[TLS] Re: Ambiguity of TLS Certificate Compression (RFC 8879)
Muhammad Usama Sardar <muhammad_usama.sardar@tu-dresden.de> Wed, 11 February 2026 16:08 UTC
Return-Path: <muhammad_usama.sardar@tu-dresden.de>
X-Original-To: tls@mail2.ietf.org
Delivered-To: tls@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id F045EB57FE21 for <tls@mail2.ietf.org>; Wed, 11 Feb 2026 08:08:42 -0800 (PST)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -4.397
X-Spam-Level:
X-Spam-Status: No, score=-4.397 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=tu-dresden.de
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 8Qh-6FKNebG2 for <tls@mail2.ietf.org>; Wed, 11 Feb 2026 08:08:42 -0800 (PST)
Received: from mailout3.zih.tu-dresden.de (mailout3.zih.tu-dresden.de [141.30.67.74]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-256) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 2F680B57FE13 for <tls@ietf.org>; Wed, 11 Feb 2026 08:08:42 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=tu-dresden.de; s=dkim2022; h=Content-Type:In-Reply-To:From:References:CC:To :Subject:MIME-Version:Date:Message-ID:Sender:Reply-To: Content-Transfer-Encoding:Content-ID:Content-Description:Resent-Date: Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID:List-Id: List-Help:List-Unsubscribe:List-Subscribe:List-Post:List-Owner:List-Archive; bh=toJFN/oXcfrUNMljejPr5NZlmZtKyZS10m86to5I9Bw=; b=bz1fZklQdgx7RYzdIgjDUw2X84 ha4NCBo7YEr6GdJXcZnozFdNlR8AysgoVWDz28cQbWVRP4cj5xlBcGUUv6VhC1CUZSl9KEaaci2pt +eJ8ZupXwOvG+ty0wRaYxN9I2K4McJWCTc+MpLQyeQEI6dzM9hIVqf/P9wS0emx0MQx319Tf9AfUL Df8wcM8OtBl12UyMOIPe5u4OudFQsvnGO/hfeEl/xANnCGnmcrssFLCU6GH/7qU6ckp+BgqVPDTnS PHxzfIzgQJzJb+kJ1F5//XSqw0POjZok8qoOsOnH4xOQ3ElM6Cx95e+shosMIjFoBG7rcEr4v52pf ZO2J8FoQ==;
Received: from msx-t422.msx.ad.zih.tu-dresden.de ([172.26.35.139] helo=msx.tu-dresden.de) by mailout3.zih.tu-dresden.de with esmtps (TLS1.2) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from <muhammad_usama.sardar@tu-dresden.de>) id 1vqClc-00Do1s-1s; Wed, 11 Feb 2026 17:08:40 +0100
Received: from [192.168.178.60] (141.76.13.149) by msx-t422.msx.ad.zih.tu-dresden.de (172.26.35.139) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.2562.35; Wed, 11 Feb 2026 17:08:33 +0100
Message-ID: <464c1d2a-9a88-4135-b50c-a33457d4523a@tu-dresden.de>
Date: Wed, 11 Feb 2026 17:08:32 +0100
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: David Benjamin <davidben@chromium.org>
References: <20260130.124640.484427558490648192.kazu@iij.ad.jp> <aYLj37WY/VbA5rkq@ubby> <CAF8qwaAfAs=tMABHs30M+FFdvkWQko3nV4RTA-kMeAOfZ5hxyQ@mail.gmail.com> <c70a361c-153c-41ee-828c-b4e74b415c37@tu-dresden.de> <CAF8qwaCqD5QKVW60muvnfKLoTODhSc40z_qxQ6bVpPVGKZ-tgw@mail.gmail.com>
Content-Language: en-US
From: Muhammad Usama Sardar <muhammad_usama.sardar@tu-dresden.de>
In-Reply-To: <CAF8qwaCqD5QKVW60muvnfKLoTODhSc40z_qxQ6bVpPVGKZ-tgw@mail.gmail.com>
Content-Type: multipart/signed; protocol="application/pkcs7-signature"; micalg="sha-512"; boundary="------------ms070709030009060407020007"
X-ClientProxiedBy: msx-t420.msx.ad.zih.tu-dresden.de (172.26.35.137) To msx-t422.msx.ad.zih.tu-dresden.de (172.26.35.139)
X-TUD-Virus-Scanned: mailout3.zih.tu-dresden.de
Message-ID-Hash: HAZX5NI4NVWIQBWNZL5RF5U23A72PLXK
X-Message-ID-Hash: HAZX5NI4NVWIQBWNZL5RF5U23A72PLXK
X-MailFrom: muhammad_usama.sardar@tu-dresden.de
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-tls.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "Kazu Yamamoto (山本和彦)" <kazu=40iij.ad.jp@dmarc.ietf.org>, tls@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [TLS] Re: Ambiguity of TLS Certificate Compression (RFC 8879)
List-Id: "This is the mailing list for the Transport Layer Security working group of the IETF." <tls.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tls/sN7tn7sxWFQ5_O0cuaTuGqoReg4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tls>
List-Help: <mailto:tls-request@ietf.org?subject=help>
List-Owner: <mailto:tls-owner@ietf.org>
List-Post: <mailto:tls@ietf.org>
List-Subscribe: <mailto:tls-join@ietf.org>
List-Unsubscribe: <mailto:tls-leave@ietf.org>
Thanks David for sharing the insights. I naturally support interpretation of what is actually sent/received by the endpoints. Changing it is an unnecessary and additional proof work to maintain my existing formal proofs. A particular challenge seems to be to ensure the thing sent/received vs. the one used links properly to avoid introducing new attack vectors. My intuition is that it may even be hard to ensure completely at /symbolic/ analysis tools, like ProVerif, and may warrant additional /computational/ (cryptographic) proofs, like CryptoVerif. As you mention, changing it seems to be significant effort for implementations too. On 11.02.26 16:01, David Benjamin wrote: > On Wed, Feb 11, 2026, 09:15 Muhammad Usama Sardar > <muhammad_usama.sardar@tu-dresden.de> wrote: > > In formal model, I always take what is actually sent/received by > the endpoints. I suspect additional lemmas will be required for > the proofs if it is not the case. > > I think everyone takes this interpretation. Let's not change it. I can't say for everyone. But I, for sure, would like it not to be changed. > > I like to think of those as addition of new message. In this case, > RFC 6066 is for TLS 1.2. I don't directly see how this is > necessarily relevant for RFC8446bis. Is there any RFC where a new > message was added to TLS 1.3 handshake? > > > The one we are talking about right now does this? It replaces a > message with a different one. From a formal analysis perspective, it seems to fall in /modification/ of existing messages category since it /replaces/ an existing message, rather than adding a completely new message in addition to the existing ones. Anyway, that doesn't matter much, since your next answer covers all the three cases. > >> When that happens, such changes are reflected in the handshake >> transcript. > Could you clarify what exactly "that" refers to: the last one (new > message) or all three above? > > > All of the above. Thanks for the clarification. > >> Indeed some handle the transcript automatically under the >> handshake layer and would /only/ be able to implement this version. > I don't quite get that "/only/". Whatever layer it is implemented, > it is still software which -- in principle -- can be changed > (hardware can be changed, too but a bit more costly). This may > need some work to re-architecture (just like you were able to) but > I don't think the reasoning is that they are /not able/ to > implement the other version. > > > Yes, I mean that it would be a significant amount of effort and break > some core assumptions to implement the other version. It sounds like > your formal models are the same. Yes, as summarized at the beginning of this email, I would expect so. > > But it does not sound like anyone wants the other version, so this is > all fine. > > If you "take literally", I couldn't follow how you came to > conclusion "unless it says otherwise", specially given that the > quoted text says "*always*", independent of whatever the > extensions define. > > > It is always the case that updating documents are allowed to override > text in the base document. Sure, but RFC8879 does not seem to update RFC8846. I still don't see how you derive this based on the statement you quoted. Perhaps you meant "unless it says otherwise and updates RFC8446(bis)". > >> That's not what we want, both by how real implementations >> work, or by the security goals of the transcript. > I can't say anything for real implementations but agree for > security goals from a formal analysis perspective. >> But in TLS we're sloppy enough about messages with and without >> the header that it's worth being explicit. > > Do the headers contain any security-relevant information? If not, > isn't it intentionally just left over as an implementation choice, > rather than being sloppy? > > > I think you misunderstand the comment. It is very, very much not > implementation choice whether the decompressed message should contain > or not contain the header. You cannot interop if you don't agree here. Sorry if I misunderstood. It's always unclear to me what exactly "TLS" entails. I interpreted "TLS" in your quoted message to mean "RFC8446(bis)". So, I was saying that from RFC8446bis (and not RFC 8879) perspective. -Usama
- [TLS] Ambiguity of TLS Certificate Compression (R… Kazu Yamamoto
- [TLS] Re: Ambiguity of TLS Certificate Compressio… David Benjamin
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Martin Thomson
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Kazu Yamamoto
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Sean Turner
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Kazu Yamamoto
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Nico Williams
- [TLS] Re: Ambiguity of TLS Certificate Compressio… David Benjamin
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Eric Rescorla
- [TLS] Re: Ambiguity of TLS Certificate Compressio… David Benjamin
- [TLS] Re: Ambiguity of TLS Certificate Compressio… David Benjamin
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Muhammad Usama Sardar
- [TLS] Re: Ambiguity of TLS Certificate Compressio… David Benjamin
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Muhammad Usama Sardar
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Nico Williams
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Muhammad Usama Sardar
- [TLS] Re: Ambiguity of TLS Certificate Compressio… David Benjamin
- [TLS] Re: Ambiguity of TLS Certificate Compressio… Muhammad Usama Sardar