[tsvwg] Re: [Int-dir] draft-ietf-tsvwg-usr-exp-12 telechat Intdir review
"touch@strayalpha.com" <touch@strayalpha.com> Sat, 13 September 2025 00:00 UTC
Return-Path: <touch@strayalpha.com>
X-Original-To: tsvwg@mail2.ietf.org
Delivered-To: tsvwg@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 0A34861F61CB; Fri, 12 Sep 2025 17:00:08 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.097
X-Spam-Level:
X-Spam-Status: No, score=-2.097 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=strayalpha.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id IzHNYiMnySZg; Fri, 12 Sep 2025 17:00:07 -0700 (PDT)
Received: from server217-3.web-hosting.com (server217-3.web-hosting.com [198.54.115.226]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 2606361F61C4; Fri, 12 Sep 2025 17:00:07 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=strayalpha.com; s=default; h=To:References:Message-Id:Cc:Date:In-Reply-To: From:Subject:Mime-Version:Content-Type:Sender:Reply-To: Content-Transfer-Encoding:Content-ID:Content-Description:Resent-Date: Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID:List-Id: List-Help:List-Unsubscribe:List-Subscribe:List-Post:List-Owner:List-Archive; bh=yUNNCDAljm+cpuOmOmRj7LZwkDxb9+DCX3vH9rFZpNA=; b=107+xl1t5DJ4nAUilRhJBwGq7o 9gWQTa21nIEXpqUOSkdzC7Yu3VmSBHDYpOYOKJIoP7k3x25TkzEytMoUMKG2mfOho/eDV22OiqLvy kjAemLcfYY//BSA1ex5y0S71olfTn6uagh0sn2yluCzq3hljoc2hI0RtDdCI2gPa0GYz0Jv0+2QBH J42egktDAs0kwC4BTYPKgk4Wxu/1pdAUMB+0hnljpnded1C59XeNGKV8PDdC7d4SA0X6p2GHAMswD EpVpPXV8U+MIwu85nhPMwIOqhhj8FWD58O98y640btPAhjyBlIrKiKyYReDKeOmvrlidJSQJBx6sE HuFyqdQw==;
Received: from [172.56.54.165] (port=34965 helo=smtpclient.apple) by server217.web-hosting.com with esmtpsa (TLS1.2) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.98.2) (envelope-from <touch@strayalpha.com>) id 1uxDgO-0000000G10D-0rph; Fri, 12 Sep 2025 20:00:00 -0400
Content-Type: multipart/alternative; boundary="Apple-Mail=_6923798D-124B-478E-B221-64ABA2963E23"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3826.700.81\))
From: "touch@strayalpha.com" <touch@strayalpha.com>
In-Reply-To: <175749089048.3618247.6296476683794153957@dt-datatracker-f7c8fdcb7-pjx77>
Date: Fri, 12 Sep 2025 16:59:44 -0700
Message-Id: <BC8DAC16-27EB-455B-A18C-851473712E02@strayalpha.com>
References: <175749089048.3618247.6296476683794153957@dt-datatracker-f7c8fdcb7-pjx77>
To: David Lou <zhe.lou@huawei.com>
X-Mailer: Apple Mail (2.3826.700.81)
X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
X-AntiAbuse: Primary Hostname - server217.web-hosting.com
X-AntiAbuse: Original Domain - ietf.org
X-AntiAbuse: Originator/Caller UID/GID - [47 12] / [47 12]
X-AntiAbuse: Sender Address Domain - strayalpha.com
X-Get-Message-Sender-Via: server217.web-hosting.com: authenticated_id: touch@strayalpha.com
X-Authenticated-Sender: server217.web-hosting.com: touch@strayalpha.com
X-Source:
X-Source-Args:
X-Source-Dir:
X-From-Rewrite: unmodified, already matched
X-Rspamd-Queue-Id: 1uxDgO-0000000G10D-0rph
Message-ID-Hash: WJI6OA6TRNAKAO4APTWZ43HTWY2LW4QF
X-Message-ID-Hash: WJI6OA6TRNAKAO4APTWZ43HTWY2LW4QF
X-MailFrom: touch@strayalpha.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-tsvwg.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: int-dir@ietf.org, draft-ietf-tsvwg-usr-exp.all@ietf.org, last-call@ietf.org, tsvwg@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [tsvwg] Re: [Int-dir] draft-ietf-tsvwg-usr-exp-12 telechat Intdir review
List-Id: Transport Area Working Group <tsvwg.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tsvwg/7RcIKwAwZmvxe4qbzp2bbApwjA4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tsvwg>
List-Help: <mailto:tsvwg-request@ietf.org?subject=help>
List-Owner: <mailto:tsvwg-owner@ietf.org>
List-Post: <mailto:tsvwg@ietf.org>
List-Subscribe: <mailto:tsvwg-join@ietf.org>
List-Unsubscribe: <mailto:tsvwg-leave@ietf.org>
Hi, David, Notes below. Joe — Dr. Joe Touch, temporal epistemologist www.strayalpha.com > On Sep 10, 2025, at 12:54 AM, David Lou via Datatracker <noreply@ietf.org> wrote: > > Document: draft-ietf-tsvwg-usr-exp > Title: User Ports for Experiments > Reviewer: David Lou > Review result: Ready with Nits > > Document: draft-ietf-tsvwg-usr-exp > Title: User Ports for Experiments > Reviewer: David Lou > > The draft proposes to reserve two user ports for experiment usages, and create > a PExID registry to differentiate shared use of these ports for concurrent > experiments. It's well written. > > Major issues: > None > > Minor issues: > 1. This draft actually touches 2 topics, the USR-EXP and the PExID. Although > they are associated with each other, the PExID could be potentially used by > other experiment ports (like 1021 and 1022). Actually, the use of PExIDs with system experimental ports 1021 and 1022 is defined by this doc. > But the title only covers the > former. Therefore, I wonder whether it would be better to reflext PExID in the > title as well. It could - here’s what I’ll submit for -13 if it seems OK: User Ports and Port Identifiers for Experiments draft-ietf-tsvwg-usr-exp-13.txt Abstract This document defines user ports for experiments using transport protocols and the use of experiment identifiers to enable shared use of these ports. It updates RFC 4727 to recommend the use of these experimental identifiers for the system ports for experiments in the same manner. And later: This document also creates a PExID registry, in addition to the IANA service names and ports registry [SP-reg], to reduce the potential that uses of PExIDs on either user or system experiment ports interfere with each other if they are tested in the same environment or in the public Internet. > 2. P2, "EXP2 -> "EXP2" Fixed. > 3. P3, "that are, that are...", duplicated twice Fixed, also changed to “PExIDs, which” (the clause should not be restrictive - the doc defines PExIDs (all of which are for experiment use), not specific ones for experiment use. > 4. P5, "network-stand byte order..." -> "networkstand byte order", to make it > consistant with other apprearance I’ve made it consistently network-standard byte order which is what the RFC Editor recommended the last time the issue came up for me (RFC5925) with the knowledge that the RFC Editor style guide will establish whether a hyphen is appropriate or not. > 5. P6, "SCTP and DCCP connections can use self-assigned Private service codes, > which provide experimental-use identification [RFC4340][RFC5595]". The 2 RFCs > only covers DCCP. It would be nice to have one reference for SCTP as well. The additional reference was provided by Gorry: SCTP and DCCP connections already have a mechanism to indicate experimental-use using a self-assigned Private Use DCCP Service Code [RFC4340][RFC5595] or a registered SCTP Payload Protocol Identifier (PPID) [RFC9260] > 6. P6, "...a single approach to indicating..." -> "...a single approach > indicating…” Clarified as follows: This document does not define a single approach as to how PExIDs are indicated within either stateful or connectionless associations. > > Regards > David > > > _______________________________________________ > Int-dir mailing list -- int-dir@ietf.org > To unsubscribe send an email to int-dir-leave@ietf.org
- [tsvwg] draft-ietf-tsvwg-usr-exp-12 telechat Intd… David Lou via Datatracker
- [tsvwg] Re: [Int-dir] draft-ietf-tsvwg-usr-exp-12… touch@strayalpha.com
- [tsvwg] 回复: [Int-dir] draft-ietf-tsvwg-usr-exp-12… Zhe Lou