[urn] Re: The URN:GLUE proposal
"Henry S. Thompson" <ht@inf.ed.ac.uk> Thu, 02 April 2026 14:25 UTC
Return-Path: <ht@inf.ed.ac.uk>
X-Original-To: urn@mail2.ietf.org
Delivered-To: urn@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 79133D5911E3; Thu, 2 Apr 2026 07:25:02 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1775139902; bh=KpFMJgJ/8UP6u+W9e3t9BBiIKJS4txFWOCh2uwOS2/I=; h=To:Cc:Subject:References:From:Date:In-Reply-To; b=hSfrhZ+WHga70aAmseV8Ja4MEJ+craOoucfWl5K8zFLzuiQIjs4On2k2pelM9x1ud iNTj/iffSYf3qCcGfLXcKpUj7teCXj5QjaGJH8VhDCynEk0IrdguGWsmw8VbaEGYgC D33BFGJoBjb343Pkpjn1/yCLiVIMl44EDAXptcC8=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.997
X-Spam-Level:
X-Spam-Status: No, score=-1.997 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_MSPIKE_H5=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=inf.ed.ac.uk
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ygWL_74Qyqut; Thu, 2 Apr 2026 07:24:58 -0700 (PDT)
Received: from seine.is.ed.ac.uk (seine.is.ed.ac.uk [129.215.17.202]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 6F4DCD5911CF; Thu, 2 Apr 2026 07:24:58 -0700 (PDT)
Received: from flakey.inf.ed.ac.uk (flakey.inf.ed.ac.uk [129.215.202.88]) by seine.is.ed.ac.uk (8.15.2/8.15.2) with ESMTPS id 632EOeFF732120 (version=TLSv1.3 cipher=TLS_AES_256_GCM_SHA384 bits=256 verify=NOT); Thu, 2 Apr 2026 15:24:40 +0100
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=inf.ed.ac.uk; s=relay2; t=1775139884; bh=zLyEUq81wXW/yh4xLgkVb+bst/wUuMgQrU8gG5G3VHQ=; h=To:Cc:Subject:References:From:Date:In-Reply-To:From; b=as2IGV1VPErg6lWJvJ+eLXrU6DdMC5sT5PGtxn9cR8XIQDbZJmGBEmq+TUanTUviu 2oBbfMDCR3bbsCzASmvkvYqdB1hxn5lcTg6DAo3v9dlPJu1GfdymwQoO249mPpByDz siKt8fEFBp+jRJopZBoL0z+e9Hqnp1vfn2k0meGTaTfEljUElSzQxCFPXFPQCSEbCj yE5GRD4jGrpumdi6teje0GZ816K6IVDOkg2Dgwy774iOvikTJNakDoLuc5QmAZl7eC WEmu/qTjvQkWRBgofdPEoZxwFlMt9n4QgGUvHbEUZy7uv/wnJViakFfy4Pg//kslJn G23vEs8sjrpaw==
Received: from lochinver.inf.ed.ac.uk (lochinver.inf.ed.ac.uk [129.215.24.150]) by flakey.inf.ed.ac.uk (8.15.2/8.15.2) with ESMTP id 632EOe60313344; Thu, 2 Apr 2026 15:24:40 +0100
Received: by lochinver.inf.ed.ac.uk (Postfix, from userid 27024) id 3687220410; Thu, 2 Apr 2026 15:24:40 +0100 (BST)
To: Peter Saint-Andre <stpeter@stpeter.im>
References: <877bqqqexh.fsf@hobgoblin.ariadne.com> <e25452e0-73a4-48a2-a284-ef3d272a2365@stpeter.im>
From: "Henry S. Thompson" <ht@inf.ed.ac.uk>
Date: Thu, 02 Apr 2026 15:24:40 +0100
In-Reply-To: <e25452e0-73a4-48a2-a284-ef3d272a2365@stpeter.im> (Peter Saint-Andre's message of "Thu\, 2 Apr 2026 06\:29\:36 -0600")
Message-ID: <f5bcy0hignr.fsf@lochinver.inf.ed.ac.uk>
User-Agent: Gnus/5.101 (Gnus v5.10.10) XEmacs/21.5-b35 (linux)
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
X-Edinburgh-Scanned: at seine.is.ed.ac.uk
Message-ID-Hash: 4EMK5RKPTPNLH4PIQTZW3TX7NWSKZYIZ
X-Message-ID-Hash: 4EMK5RKPTPNLH4PIQTZW3TX7NWSKZYIZ
X-MailFrom: ht@inf.ed.ac.uk
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-urn.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "Dale R. Worley" <worley@ariadne.com>, urn@ietf.org, draft-ietf-spice-glue-id.all@ietf.org, spice@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [urn] Re: The URN:GLUE proposal
List-Id: "Discussion about Uniform Resource Names (URNs)." <urn.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/urn/WkwQX8zaOBJ9bl7KihZK-lLOptg>
List-Archive: <https://mailarchive.ietf.org/arch/browse/urn>
List-Help: <mailto:urn-request@ietf.org?subject=help>
List-Owner: <mailto:urn-owner@ietf.org>
List-Post: <mailto:urn@ietf.org>
List-Subscribe: <mailto:urn-join@ietf.org>
List-Unsubscribe: <mailto:urn-leave@ietf.org>
Peter Saint-Andre writes:
> Focusing on only one point for now...
>
> On 4/1/26 8:22 PM, Dale R. Worley wrote:
>
>> 2. The politics of using someone else's identifier
> ...
>
> Until draft-ietf-spice-glue came along, in the entire history of URN
> namespace registrations going back 25 years or more (the earliest one
> I see is `pin` in RFC 3043, not including `ietf` in RFC 2648), I
> believe that "we" - the folks involved with the URN WG and
> subsequently the URN namespaces expert review team set up by RFC 8141
> - never imagined such a "creative" registration as GLUE. We always
> assumed that other SDOs would make requests of us to register their
> own namespaces so as to incorporate their own identifier systems, not
> that what you are calling third-party organizations (or WGs) would
> register namespaces to incorporate identifier systems defined
> elsewhere.
Apologies for flogging a dead quadruped, but that's at least somewhat
misleading. In November 2022 we approved, after lengthy argument which
I lost, 'pwid', which existed solely to give authority to 3rd parties
to wrap their URIs, which might be URNs, in a PWID, without any
engagement with the 3rd party at all.
Notwithstanding that precedent (which has not received much (any?)
use) I agree with the concern expressed by others about the GLUE
proposal.
I'm sure I yet see how offering 'glue' as a URI scheme solves the
'political' objection, but that's for another thread.
As far as the concern for the authors' frustration, yes, I sympathise,
but as far as I can see we're doing our job here, and hard cases make
bad law, as the saying goes, or, in this case, a long time to arrive
at the best resolution.
ht
--
Henry S. Thompson, School of Informatics, University of Edinburgh
10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND
e-mail: ht@inf.ed.ac.uk
URL: https://www.ltg.ed.ac.uk/~ht/
[mail from me _always_ has a .sig like this -- mail without it is forged spam]
- [urn] GS1 input for URN:GLUE Tom Roberts
- [urn] Re: GS1 input for URN:GLUE Martin Thomson
- [urn] The URN:GLUE proposal worley
- [urn] Re: The URN:GLUE proposal Peter Saint-Andre
- [urn] Re: The URN:GLUE proposal Henry S. Thompson
- [urn] Re: The URN:GLUE proposal Henry S. Thompson
- [urn] Re: The URN:GLUE proposal Peter Saint-Andre
- [urn] Re: The URN:GLUE proposal worley
- [urn] third-party registrations Peter Saint-Andre
- [urn] Re: third-party registrations Michael Jones
- [urn] Re: third-party registrations Peter Saint-Andre
- [urn] Re: third-party registrations Michael Jones
- [urn] Proposing a way forward re: GLUE and "third… worley
- [urn] Re: Proposing a way forward re: GLUE and "t… Peter Saint-Andre
- [urn] Re: Proposing a way forward re: GLUE and "t… worley
- [urn] Re: Proposing a way forward re: GLUE and "t… Peter Saint-Andre
- [urn] Re: Proposing a way forward re: GLUE and "t… Henry S. Thompson
- [urn] Re: Proposing a way forward re: GLUE and "t… Peter Saint-Andre
- [urn] Re: Proposing a way forward re: GLUE and "t… Ted Hardie
- [urn] Re: Proposing a way forward re: GLUE and "t… worley
- [urn] Re: Proposing a way forward re: GLUE and "t… Peter Saint-Andre
- [urn] Re: Proposing a way forward re: GLUE and "t… John C Klensin
- [urn] Re: Proposing a way forward re: GLUE and "t… Peter Saint-Andre
- [urn] Re: Proposing a way forward re: GLUE and "t… worley
- [urn] Re: Proposing a way forward re: GLUE and "t… John C Klensin
- [urn] "third-party" registrations and urn:pwid: worley
- [urn] Re: Proposing a way forward re: GLUE and "t… worley
- [urn] Re: Proposing a way forward re: GLUE and "t… Orie
- [urn] Re: Proposing a way forward re: GLUE and "t… Peter Saint-Andre
- [urn] Re: [EXTERNAL] Re: Re: Proposing a way forw… Pamela Dingle
- [urn] Re: [EXTERNAL] Re: Re: Proposing a way forw… Peter Saint-Andre
- [urn] Re: Proposing a way forward re: GLUE and "t… worley
- [urn] Re: third-party registrations worley
- [urn] Re: third-party registrations Peter Saint-Andre
- [urn] Re: The URN:GLUE proposal worley