[Uta] Summary of changes to draft-ietf-uta-tls13-iot-profile
Hannes Tschofenig <hannes.tschofenig@gmx.net> Tue, 07 July 2026 08:48 UTC
Return-Path: <hannes.tschofenig@gmx.net>
X-Original-To: uta@mail2.ietf.org
Delivered-To: uta@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id E6378111BC365 for <uta@mail2.ietf.org>; Tue, 7 Jul 2026 01:48:20 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1783414100; bh=aP2nTpkr8cPAvoXUhXIRR/ORX79aNg9IHebYr7e+BKc=; h=Date:From:To:Subject; b=FXugA0d7c8MGJysyIOZ8biPZRM3RBPEpj1qiCnPPPprwfgPfW9gdParsmPoEmGyEq fJaOZL6+YcgpB6dpe2MBLecdIN4M7sZZX955GANKpRW6GA5p/V1gci+3ah++OkwVI7 zSUujgHDHIQeM8UEdQ0wMsgpfzYozX/6s8IPbE2E=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.795
X-Spam-Level:
X-Spam-Status: No, score=-2.795 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_LOW=-0.7, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmx.net
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ZDbfRGhcrFia for <uta@mail2.ietf.org>; Tue, 7 Jul 2026 01:48:20 -0700 (PDT)
Received: from mout.gmx.net (mout.gmx.net [212.227.17.22]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-256) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id E654C111BC35C for <uta@ietf.org>; Tue, 7 Jul 2026 01:48:19 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmx.net; s=s31663417; t=1783414092; x=1784018892; i=hannes.tschofenig@gmx.net; bh=aP2nTpkr8cPAvoXUhXIRR/ORX79aNg9IHebYr7e+BKc=; h=X-UI-Sender-Class:Message-ID:Date:MIME-Version:From:To:Subject: Content-Type:Content-Transfer-Encoding:cc: content-transfer-encoding:content-type:date:from:message-id: mime-version:reply-to:subject:to; b=QUIyUTFwS6UupJjYESwwPaEg2y3JwmG53G3EDEIJE3CL3g20keAgBbpiL59RY2s0 mAlwFNRHs2d4jUyeAawkbu5a1SmPxS8Bcx7mnAAOIga1ZT8Df7ICvQVUgrvCeAnIw fEL5cV/z4HldlPAFEjHMYdpaJZmyzk9h02D/4OwEsY5lAdaPeaALo1DLHigCu28rB 0bYYfd3DtDglsjapO99tDLj+ii+WyQjp/zU/Yv5YVZUmfUXNSHH6UmJwYftuncuIQ 9bkAOQaKbaNlxMGNVZA5/UZna+mh40/mOD0FzfaXvTFt6xl83rox6dkHD5S2tyRCT a1FdhBUdAJWQPmUvVw==
X-UI-Sender-Class: 724b4f7f-cbec-4199-ad4e-598c01a50d3a
Received: from client.hidden.invalid by mail.gmx.net (mrgmx105 [212.227.17.168]) with ESMTPSA (Nemesis) id 1N2V0B-1x4pcp2vs7-014xjK for <uta@ietf.org>; Tue, 07 Jul 2026 10:48:12 +0200
Message-ID: <0c9302fb-14fa-461e-b49a-2378e30dec40@gmx.net>
Date: Tue, 07 Jul 2026 10:48:12 +0200
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
From: Hannes Tschofenig <hannes.tschofenig@gmx.net>
To: uta@ietf.org
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: quoted-printable
X-Provags-ID: V03:K1:MJIEhBoqLXNlCKi67RLnTzGwoX/t81dp+vgTtC7tJ9ZkLnPLCHh Vk40yT5rw0bzWlbyzLNKaOHAw5wUfSkb4MM0UK/RfjQmdwTFazzZWOnRdYg2FaQJKsBNV16 fYx7+IESm0d/dQOcrFv6mb2eBuO/98KqYzS/BV1CWBWe01PKF9Zh0cSA6kMmkJU9oYa6iXC QcXwSNNYc8gb6+6QpRU0w==
UI-OutboundReport: notjunk:1;M01:P0:AVsRyKZyq0c=;dR+20ixuASf4qvupKEGBqPLLWJ+ 8y8kUVBOBoGD0hB1dsfGOqYV75aJJF/LIbkuHOd2Z/h2FpyXslM0kOvXZ9fpU4k2ilEnkvN8b 0UcrpbmqhTioqtYCQVCYpsdp+o91vNz7LX4aIp2rDzo7cPb9nT+pq2He7GScNUJqe/dDqdcpY 6WKAtHS2ynwVbf5O6Jya7cMMmypiqNBretehKpNff1nluL35m8qVpaTHjDGYH/UjCropi4Q5C Op9coHY/2TPv0xVbZQWTBry+/cZ4f+G3zB0iRQF8hbhxk0sZNegYni3Zs6qTdpohOl8WcTVSq iRPiUXQ64Tk2cWmg5xWn1I0gVXE/mhOJzptfB9Ldb9JRlmcDaRE6kIIn9p1inpDPHscUdQRwF F5mf9s6aCDZ9MVhILFhxH+dGj+1rqDfq51ilHsupb+WQuTDROyXIINj+Th/oOyWFdHwTIZ/oa yV0gKxP/Ti2JIRhJ72q59KVP9w0K/scFeeR5Gtngax3COkqcUkTSkL34/8vCWlK/K2q45DzPC 7vJ3oK0Msk4/taUf9B0XPW24SiZ1+2IOfyGy1Sz4trdrQ+I8Ve0nMjB7/Is1738TLp5SAhqSp 9+3y3apPSm8CK/23UWgBkRcxp1+dayrP7rzeP43Mt7KKCcGAAyoj995BNB/UFQOZjuDwIKCBR H7CGbNwV+gPnUemGqklxcAKrUH4N1Yzn7nFppXPFGQl3+CeEEJ0d0ttfPPWGoCXPzWKaBY3wr jjFu1bqZy6gJqEb1F26sjHRTFA84cSY8H6ndsNTxOxWUAAA0K/ZR65Ho2rW4w2ehmPOniDB61 RAbgjlcbiQmPciiNu59j9g9Lt+9UfZmN7sfKuiz0YVLGa6bOEPDLUPYD4TXd6c9dInyoXrbly zagXtHp2+/W7G3GQXw+XTSlqMDhBh01Tqy83yfAQoGq8d4lVAucUfyzt3+MF39aUNrZT+TNzW Xxwv8Zrqo1hfqRmTDFRPR9WzGFv7XaTrgOhshsJvXJnWs12R67b5HAzzJ33wHFNViMl3a4sCI 4vIugkq/ciya59tx88LpaISSXvMMwDa/y/BwxDPN7xO2k+V4agbKtrC16PZgQjtQDN3lNeoRc fzx1VeiF/WCR8mBXPjrEMyFJTrBrDyQonfFPQkq3UuBXglXn5iTOQiyGrM9ce+XUUKfxQz+yj x6qdjV/EHc/3Q1Kk6AFPT9IOY1X5dDcARYRnaaprAJkH6FJe8pkM7GI4bYUFcvQkYWY70kXLy C3OdtvfJ46pI1c73gkUlLMLHhEqiAOGg8wQ8SBIbNKjZL3sqzrJvlOwPN67tbCQbENZqc04NL WMPrPEGQnM2Uh9EbmL/v13g0am2zpuzptT1m1RnB2LXViDp6ctvRjbogAxVlVIdFygve92yJ/ 16oOppJQ+fWX35XRo02eSVmeJmgA6Ur2HBWVBNlLSzzQ817DLZlsNvuMtDf4ZemO+qPOxVjDx 8awWjy5waES1YK6jts8+p6fDYLb+qYfcC8J1WA69SIRajCpxEd7NyjG/eDg9DD5ZrRAYdPCpJ 7t6hD9tdyu+CM0kCTINCqVEhNYyI6cnSpK/TAttwQhuroUof0bOJ4tQrkP2RKJ8g8B25frtDi 3q9G2wJOifuEZmebAK1i7DWe1Ff0SYBJNdOgAkjc2fNk/LCy8dYOpJ6xBPQNOwSxzm/inDJYU 4IB1tVn9kHu/sBB2cIxHTG8hDI8lTuXO2hWpMyjtd4Z77RhKwOEDqBSLv9TszgmznO5ca7J5v lzs1wWJUq+GJnBfosR3G0VwfN8T5rrtL4NqHq0bDFXhM37nqX5US8d9cqIdxYYTwrflUHHMQp eHaEK3ddJyion+Cqbuoa0bCuuwazp7A/OZFPsGyeCIb+8uLqWgKI/IjLfOftvTXBHkOHairhb sucdT4VKrQ7XmtcY5W0wIMijWLElPidf/IHqg4/pe4k+jItnijA2c2OSW5gxZjLQzLm2pSWro C5VBUAMPKL3+Kz08zEMsuXl+noMP/KL3akjZca3pCTzQVINphfqW3CsDVYqwo7Ze8ZpvtIdaW gYAOIUPeHKIR5qLXGJI7SdMcYlYnLsNLD+fh7kb8S23xmvJN14+rZ9WUoCsoT1VZZ4B8c4f1v 6+TJ1I3HIpwOjoVqEiEbdcaJGmzr7istCoIYLhVtYFxI+pYwo0s36gXBnTf9EI9VuayFteoiP byt4yiZJawaLq3sUA6SXGPkhqn3pMiInUzQT5mwcHUvhaWQQDMLfVjNPOdPTHHNVYGHx4GWMq PBIKQ74MBfI7wnDPHDvtaWJBbCBOFtx3peF3M2nYA+axOqSKqbgdFe4bzg1DPOoUfL92/dzsX 6fpw2QG8ErxSfBMezeZM+njtcA/YjMpOSrSS5prA/pKzr6Cl+kLLo+LZGSd2grtmi6ihWLKEn hjMUO47zRCeIl0+zBzFcwu1BPfJwmuiX3yY80oJYaDpvJPi+va3hxfb9chPplEfWmNxT872y7 5JXGMYHQB5TGXp7UvbTjJCXwCumgqnrRaNVQLKXKwPr+gm2MdG2RXraUYSwTv5iwOQ7EIxFKh KfAh4LEP6JlAJmj1EghGdxIUpPLCZCUCD35VEuGTYWIl0KB4sapdhbswpNNxKsmiE77xQC5Ax QDdEoW7uARLEt6e+mfTohZ3UAkp/VFENHKztPmInnssF0+lfPN95c5eiv2WuKWYudx9pDGdtx uvuQ2CbqpDH9aH2Hcn8sy/v7irlrMTMTr57bU/EqofVregUK6VA9Yb/jni0eycV1VbK8bhspn MXWxr8QP9wF9C8PQ/Ar6ZHoR+sA4n7aOoO4vxHZmfP0vPOlyiBtLlXPOxUZYDoJJ6ljBSGM/P VYEuzNB2RDZIZd8yzesws4BmPoJdOHyubX2wp1NlgL+ZFPlasJ3EinKlTdVgWAez4ZoOh7or9 ZSrmqOujvdvw9drC1iW5R3dyWfh9ESrU8pyGDN9zaKQJ6rtN3Knw9x2kJrWiUqg+hL0unPHJg rTUcvl6KS1dYyCZ2uo3fML6ptqAVx7z42oISq2xSsYEAhsIOc13Dz9EUodmv9J1rdLUrSPCtx hCCzDu1oguiS/6ss02wXEUfzRVB6GOGLxHuNQpmLlSHz5Nu1QWtZ2CAtmKrkmgbh0RNE2Bnhj Mhc9yPMYSaPTSkMpj6G/G+mvMPcgtza3CEcO4iDtMD/JCEwjwIoRGI+2z3HWoROynqqQVNHhG ANu6we35Jdrfoq5NKIkAXHvZRj6CPYInx8r88iq/KpXpuVC0zsrBgIBd17ywpkEVkrld0HGig Yjaf98tU1phjAN/Zacm8tT9/lnW2cHMU98MSYWjwnQ3MQ4D8Bh/71MQSB2wyILqXB3FfDXrZG MhOgNZSkem6lEfha1Rs28GSAoYOXxgHDsV0NwqYLxC4tbLKC/JQUVejFZBGKLQ0W0O43cZyL+ Px38xl74YJei/zqyjFNZvn8vhSgDRBcwQKl4cjXZ3G2w4Ob29lvnb14cFpXHxTge07gOHa4aq Ot+yo/pE44cU2+S4/K79evEySsfEcqPtZimBmcMHeeYFgoMwGf9hchYawwEhwiLbt0Clfd+ZS yr9yjeHFRJJLnC9Jqoe61BFqUD5AtSarngiPNOjd49hH6FC4qfqbpDXhWvDaXoWv65JHTrsns 7M0eolhha97dhb3uoURE3wA7faZewBvvZZ6+xPI4wDtjZjz3xVhW377mySIV/JAYZ2gndBdoa JYLJrbime6Wang/rriXoZXq5KAd1aDT/gYjH+pQ7y8boN4F6xDIRe/bwHoXirUqbNKQAWO8QM +Ygj4WEYwBq0wVNGppa+Cl3fl9VrywgviaAanIXV707qSXgl2+uctZ0blnN4XaHEBeRmpVR4x XmqblkyygmE5WiSdQrvH3FR+BbgjWgN/fGXl9vYhtsfH7vvOslaD7n3y/9Yxqv4f7Fp/TIbQ/ WcBDTEw0UdwshUFNzNCBnDpHznkn/eICb6J35EghK5F1IWm3AnHzKbxSjUB4P15i01lyFkYrK TqLKZCCK7dIoUJPtvZ8a4PK4ATm+kz7VTIIaB4qrpN7LCeK9PuT4IBYXWl35LubnoCNdtU3+e H/FQN7ybKrkUZH7EHL+2J4O60ZhQEynkz940hseAs3gK9mD5fGz6FbTuKLGvhuggG/kWlcY0D 87I9YwUiAGLQzTXCKHR2smYMGLrKx6zUWZ3G4Ho8nQN7CFtMHXfFcKgH3FFi3v1jCETJR0mJ/ rlJYwMpQ5a1JN/C0mW8jyBr2Hj4tYzxJe1YixkMgGqqTDlOP+OqBm2f4G3Re78Eg4OyBVlWeQ 1ZAlZEeaSeEhNviPg0mDgroMs+9dpRmCnx3hUzKhO4vB09gp3KyIKsl8w9qcLB5UtFJBFLdLp Vu2L/a2vUXqDt+df/y0ayjioeTuselRxeNnWAHtV/mYhxqxncv1l9VYn2l0qUsRRPOGZaGUXp j7gw9ZA74nke/7RllzUCT75kxgdP0PqSHw8KJy/vDXPlhaoXPE68oYDQOpbXtPaJJXtT3FY5q BHHc9wd+ivWsRS4nJDyjAKwhTcmRsRTnBPy7ZGyYNptXjpfhYfOLUmaMzgE3AD2otFKMG61ZR OPwB9mDVxGIc/YC09UVRE1mTqI+ZqMSU1u3wGKWIOsWj/nwoWCZuL+Hd36+ovvTXTkAOWXHYr Fxh71hy4vqnPmlAQeISWf5+/cpVdM+4HFJ3YHhwh5LJjHdoorh6CdJf+DAjAbWndeTjhKQ5/d 7m4f1ALk4/7NPBw39rQMMRJm1JSFDX0gUQFjwUs0X2z/EWYnY3YS80LD4Z/4lNJp4DTGnIM8i pv77nutiRoLvfePZW6JUt7EK2e96bAzaf/1QIT6dEipk2CSYNzYFdQPl0H3W3dOsMWuqmqw+v Ltt40X+kzUe6s0El9cVh65VZgj8Tg8MUhlNfVV1efIR+qb++cw3lMXAhKz5W8LQ0hW86n/Cww VnMSOT8o8Zk9zcvmfOPnmNGopQ7/FoL3VWuODjZhk0GC6D70w7uJk12N1kHdo2Vjgim2nTXlw 5b38S1UwXDI29yCAbFQPyax/4wFZBTgWbRu1+qsLVox0fncHFJMHsUQAhDD1OKl+A/S3s9suQ V+iQ+5giKgVFms1H/V865nxqzsHsb7o3kAz3yEPSB6a5ujILz+C4/fOuibi25gA6aCKapBlxA a9pYI/wSZNzbbfrtJzFDluHAHlzypgUCi5ArDRbvSjXnFUPVtmLkDoueUAJ11Q8bjAHG5qVhO Df5TSp6numRAJ/5W+uTxiwZtWJijU+xC2Fp4poiBHsuJG/mealy4+POYFCgqMqkfDxxnZYE3n JvoHc4z5IArAW9PTu5JFCRhjoLCfTC3spkDKcuTJ+RL6HoGdpf+k/PgWxx0g9Wk2x8Bbz8x/J 1aYAKv179ApdSzBlyFdC0dM2UTZyV14Zz+ZzUd6b4WqyGXBdejbtGWE8tcyxk1ouArYfuo/3P HvWcz1b0hdai48J8qAu6IgrDb1WD5tjsDJ0nP6ccNoRhlJi384zNIrwSy4hDnQoDotnCdhk2g kql7ihwkxGuH/DZPk3MT0neq5RpWe9XmNcBaJqQSz6P5Z/iwwSuELuSppFFLLo2j4j9v7kAVE 0E8JeYkPsrVVBEOZv2apypOEJILq+zHW+0lqeeYforM8tX8Z5SzrQHlz1mD/mxhY6FzdVA==
Message-ID-Hash: 4Z4AB6O6O6JVU3UQHYXIUVHQNXOGX4ZQ
X-Message-ID-Hash: 4Z4AB6O6O6JVU3UQHYXIUVHQNXOGX4ZQ
X-MailFrom: hannes.tschofenig@gmx.net
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-uta.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Uta] Summary of changes to draft-ietf-uta-tls13-iot-profile
List-Id: UTA working group mailing list <uta.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/uta/AKTbPHqORRhcbn0DOIrljqMbC9I>
List-Archive: <https://mailarchive.ietf.org/arch/browse/uta>
List-Help: <mailto:uta-request@ietf.org?subject=help>
List-Owner: <mailto:uta-owner@ietf.org>
List-Post: <mailto:uta@ietf.org>
List-Subscribe: <mailto:uta-join@ietf.org>
List-Unsubscribe: <mailto:uta-leave@ietf.org>
Hi all, since the last IETF meeting we have received a number of reviews from various directorates, including TSVART, Genart, Opsdir, Dnsdir, Artart. In addition, Deb has provided a detailed AD review of the document. Here are the reviews and replies: Tsvart - review: https://mailarchive.ietf.org/arch/msg/uta/70MlrCGckn37Ulm6ZQFXQqgiQWE/ - reply: https://mailarchive.ietf.org/arch/msg/uta/bongRhthUC4Ou4jPZ39bAS6z-YA/ Opsdir - review: https://mailarchive.ietf.org/arch/msg/uta/-XMAqyzVUffBkGQxnsGTIs6L4xE/ - reply: https://mailarchive.ietf.org/arch/msg/uta/wPpEEH4kg9gJpNyVFgGHWcEwQqQ/ Dnsdir - review: https://mailarchive.ietf.org/arch/msg/uta/oolwaT6cJg275rmlUnOEqcCHjuM/ - reply: https://mailarchive.ietf.org/arch/msg/uta/wPpEEH4kg9gJpNyVFgGHWcEwQqQ/ Genart - review: https://mailarchive.ietf.org/arch/msg/uta/psLblw-Smca-yAFKbgZs4-OqZxo/ - reply: https://mailarchive.ietf.org/arch/msg/uta/iGm0Z1w-v-1OZLxzhbpjEx5_Xqk/ Artart - review: https://mailarchive.ietf.org/arch/msg/uta/YgX5QNsiSh_RpL0eyrEYgZV5Gr4/ - reply: https://mailarchive.ietf.org/arch/msg/uta/y-UFnPbXGEmPB-fOYKLQXs3Z9DQ/ and https://mailarchive.ietf.org/arch/msg/uta/NuUld8NzVWu8Xiaq--BmEnji6tw/ AD - review: https://mailarchive.ietf.org/arch/msg/uta/FdGq8Ss4cKVv5j5HOwguhd-9VWs/ - reply: https://mailarchive.ietf.org/arch/msg/uta/X3aHhHAryRp9BaOZC5EfzNpMjug/ Since there was overlap in the feedback, I am using this email to summarize the changes for Martin Thomson, Martin Duke, Deb, Russ, Scott, and Menachem. As you can see from the diff, we have done our best to address the feedback: https://author-tools.ietf.org/iddiff?url1=draft-ietf-uta-tls13-iot-profile-19&url2=draft-ietf-uta-tls13-iot-profile-22&difftype=--html The main changes are: * We improved the readability and structure of the document. The introduction now gives a clearer overview of how the document is organized, and the terminology section now explicitly points to TLS, DTLS, X.509/PKIX, IoT device-class, and DevID/IDevID/LDevID terminology. Several RFC 5280 references in the certificate profile were also made more specific. * We clarified the TLS/DTLS profile guidance. This includes corrected text about TLS 1.3 PSK identities, clearer guidance to use PSK with (EC)DHE, a new table summarizing mandatory and profile-specific extensions, a separate ALPN section, updated Record Size Limit guidance, and revised keep-alive and timers/ACK text. * We reworked the SNI, ECH, DNS, and privacy-related text. The SNI section now distinguishes named services from deployments where peer identity is established by configuration, and it clarifies that authorization is based on authenticated peer credentials and local policy. The ECH discussion now also points out the need to protect DNS resolution where DNS privacy is a deployment requirement. * We updated the cryptographic guidance. The draft now raises the RFC 7925 key-strength guidance to at least 128 bits, clarifies the AES-GCM/AES-CCM recommendations, keeps CCM_8 for compatibility while discouraging it for new deployments, removes the RFC 8221 SHOULD+/MUST- terminology, and moves authentication-/integrity-only ciphersuites out of the profile scope. * We substantially revised the certificate profile. The text now talks about certification paths rather than assuming strictly hierarchical PKIs, clarifies that IEEE 802.1AR terminology is borrowed without claiming full IEEE 802.1AR conformance, distinguishes IDevID and LDevID usage, clarifies TLS 1.3 signature-certificate requirements, updates serial-number guidance, explains certificate lifetime trade-offs, and reorganizes the revocation discussion. * We addressed certificate identifier and extension comments. The end-entity certificate text now discusses manufacturer-assigned serial numbers, MACAddress otherName, EUI-48/EUI-64 considerations, DNS-ID usage, and stable-identifier privacy implications. Key Usage, Extended Key Usage, Basic Constraints, AIA, and CRL Distribution Point guidance for root, subordinate CA, and end-entity certificates was clarified. * We expanded the certificate-overhead discussion. The draft now emphasizes baseline measures such as ECC certificates, shallow certification paths, omitting trust anchors from TLS Certificate messages, session resumption, and DTLS Connection IDs. It also discusses cached info, certificate URLs, DANE-based approaches, certificate compression, alternative certificate formats, and the trade-offs these mechanisms introduce. * We updated the PQC discussion. The section is now explicitly informational, says that the profile is based on classical cryptography and is not quantum-resistant, and discusses the use of external PSKs with certificate-based authentication as a transitional confidentiality mechanism while PQC work for TLS continues. A reference to the ongoing work in draft-ietf-uta-pqc-app has been added. * We updated references and acknowledgments, including replacing RFC 4210 with RFC 9810, updating ECH to RFC 9849, adding RFC 8937, adding the IoT DNS guidelines reference, and acknowledging your reviews. We believe the document quality has improved quite a bit as a result of these changes. Please have a look and let us know whether you are OK with the current version and feel that your comments have been addressed. Greetings, Thomas, Michael, Daniel and Hannes
- [Uta] Summary of changes to draft-ietf-uta-tls13-… Hannes Tschofenig