[v6ops] Re: Éric Vyncke's Discuss on draft-ietf-v6ops-claton-13: (with DISCUSS and COMMENT)

"Eric Vyncke (evyncke)" <evyncke@cisco.com> Thu, 18 December 2025 08:24 UTC

Return-Path: <evyncke@cisco.com>
X-Original-To: v6ops@mail2.ietf.org
Delivered-To: v6ops@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 5C0A09C321C4; Thu, 18 Dec 2025 00:24:28 -0800 (PST)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -10.646
X-Spam-Level:
X-Spam-Status: No, score=-10.646 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.001, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, NORMAL_HTTP_TO_IP=0.001, NUMERIC_HTTP_ADDR=1.242, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_NONE=0.001, T_SPF_HELO_PERMERROR=0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=cisco.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id IKNh3bXjXwyM; Thu, 18 Dec 2025 00:24:21 -0800 (PST)
Received: from alln-iport-3.cisco.com (alln-iport-3.cisco.com [173.37.142.90]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 7E21E9C321AD; Thu, 18 Dec 2025 00:24:21 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=60144; q=dns/txt; s=iport01; t=1766046261; x=1767255861; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=i2VKq9RAMFhFFoAasfTO77HwdNV3fDAKq/wXhk7UhqE=; b=T48UCOPC3N/1mfhJGg4A9bN/YRMFi26SFc4nvsO3Xb/iYAMvSem4m1mm 6kkkUT+AD8h3oXwZLZzh4Ockc+vyRXy850WE/13iPDn6HIQkpIssOqKaP gj4UMUhG8WvB7IU0vfG5K7SijGreRIVs9Jr/RCWowCrq1b4SYUhf4uIFZ M4OUKmSf+L0BzLrvW4uTkKF3dwBQ/I3hZijFRXmYM1zBHHmvbx/PaDdnZ cbHZwgLlyn64zUCLikHQUdxgGdhTatzcxGN8gXqEZ0JQ5wrQkwrF5eZMr khm0oAe9LOyDjB17keeF57TCUSwiBZyAqxbb1ba4ITBtBuu4NV1cswX0K g==;
X-CSE-ConnectionGUID: xbq5ely9Sl2cL9Yk/eJNig==
X-CSE-MsgGUID: nQo42c+KTUCxwaILB7qeXA==
X-IPAS-Result: A0C+BAC6uENp/44QJK1agS6BK4E9MSooB3+BIUmEVINMA4UshliCIQOBExaBdIhHhWaMUBSBaw8BAQENAkQNBAEBhQcCFoxTAiY2Bw4BAgQBAQEBAwIDAQEBAQEBAQEBAQELAQEFAQEBAgEHBYEOE4ZPDYZaAQEBAQMSCAkoAS0QAgEIDgIBAQEBAQIhAQYDAgICHgQNFAMDAwgCBA4FCA4MgmGCHR0DNgMBAg6jXwGBQAKKK3qBMoEBgygBMQMECwMYJtkTDYJbgUuFO4J5HwEqgTQDDoNnCRAbKYQ0CB8bgUlEgRVCgWZKOD6CH0IBAQOBKAEMBgELEgYeFgiDHTqCLwSCDRV6FB2BWIQZBQYGeEeBLYhagRGHElJyIgMmMywBVRMXCwcFgSNDA4ELI0sFLR2BIyEdFxNgVECDSRgGaA8GgREZSQICAgUCQDqBaAYcBhwSAgMBAgI6VQyBdgICBIIRfYIKD4c+gQEFLnolIgIiAwttPTcUGwUEgTUFk0NDGRg2gUADDVsGAQcYAhwcCgQNFQ0MCAgHARQMAi4vEgdCBCAEAQIOAjkpA5JDJAoMgxhJi2CjBXEKhByMHocniBcEhi4XhASBV4s8hwKRa2eGIpJkgliLMYJhBoEig1RlQoxgBBiFDQIEAgQFAhABAQY2gRwdBTBpPxkRB3AVO4IzAQEBMQlJGQ+OKAIDFhx2AQlygVCFE8NeeAI6AgcBCgEBAwkBgjmPMYF8AQE
IronPort-PHdr: A9a23:NcUuzxWkxuRNY/zmEOisA0GNQUDV8K3PAWYlg6HPw5pUeailupP6M 1OaubNmjUTCWsPQ7PcXw+bVsqW1QWUb+t7Bq3ENdpVQSgUIwdsbhQ0uAcOJSAX7IffmYjZ8H ZFqX15+9Hb9Ok9QcPs=
IronPort-Data: A9a23:snwY7a0pjGxTr+hSHPbD5dxwkn2cJEfYwER7XKvMYLTBsI5bpzYAx zAYC22HPazYN2T0e9Aka42+8x4Fv5/VzNE1TgFl3Hw8FHgiRegpqji6wuYcGwvIc6UvmWo+t 512huHodZ5yFjmH4E/xbtANlFEkvYmQXL3wFeXYDS54QA5gWU8JhAlq8wIDqtYAbeORXUXX4 Lsen+WFYAX4gmQtbTpIg06+gEoHUMra6WtwUmMWPZinjHeG/1EJAZQWI72GLneQauF8Au6gS u/f+6qy92Xf8g1FIovNfmHTKxBirhb6ZGBiu1IOM0SQqkEqSh8ajs7XAMEhhXJ/0F1lqTzeJ OJl7vRcQS9xVkHFdX90vxNwS0mSNoUekFPLzOTWXcG7lyX7n3XQL/pGHEsvYIAc67dMBTtF0 a0pK3cATDaCiLfjqF67YrEEasULJc3vOsYb/3pn1zycVatgSpHYSKKM7thdtNsyrpkRRrCFO YxAN3w2ME6ojx5nYj/7DLozgvaujXryWzZZs1mS46Ew5gA/ySQvjuC2b4WPIYHiqcN9mH+f+ jjNvEfFPzoKK9W+7RDa63+cr7qa9c/8cMdIfFGizdZmmlSd2ikSBQEYEEXlpuGiz0W6Us5YL WQV9zYg668o+ySDT9TmUDW5rWKK+BkGVLJ4DbM98BrIward4hyCLmkJUjAHb8Yp3OcoGzsyz XeIks/nQzt1v9WopWm1/7OQq3a2fCMSN2JHPXJCRgoe6N6lq4Y25v7Scute/GeOpoSdMRn7w iuBq241gLB7sCLB///TEYzv6950mqX0cw==
IronPort-HdrOrdr: A9a23:UlIhQajT2+cjGrKka1AShUFSpHBQX6d23DAbv31ZSRFFG/FwyP re/8jzhCWVtN9OYhAdcIi7Sde9qBPnmaKc4eEqTNGftXrdyRqVxeBZnMTfKlLbalfDH4JmpM Ndmu1FeaLN5DtB/IjHCWuDYqsdKbC8mcjC65a9vhJQpENRGt1dBmxCe3+m+zhNNXJ77O0CZe KhD6R81l2dUEVSRP6WQlMCWO/OrcDKkpXJXT4qbiRM1CC+yRmTxPrfCRa34jcyOgkj/V4lyw f4uj28wp/mn+Cwyxfa2WOWxY9RgsHdxtxKA9HJotQJKx334zzYJLhJavmnhnQYseuv4FElnJ 3nuBE7Jfl+7HvXYyWcvQbt4Q/9yzwjgkWSimNwwEGT4/ARdghKT/aptrgpNScxLHBQ+u2U5Z g7ml5xcaAnVC8o0h6Nv+QgHCsa5nZc6UBS4tL7yUYvELf3rNRq3NYiFIQ/KuZaIAvqrI8gC+ VgF8fa+bJfdk6bdWnQui11zMWrRWlbJGbNfqEugL3c79FtpgEz82IIgMgE2nsQ/pM0TJdJo+ zCL6RzjblLCssbd7h0CusNSda+TjWle2OBDEuCZVD8UK0XMXPErJD6pL0z+eGxYZQNiJ8/go 7IXl9UvXM7P0juFcqN1ptW9Q2lehTxYR39jsVFo5RpsLz1Q7TmdSWFVVA1isOl5+4SB8XKMs zDca6+w8WTW1cGNbw5qDEWAaMiXEU2QYkQoJIhV1qFv8LMLZeCjJ2oTB/6HsuYLQoZ
X-Talos-CUID: 9a23:JC0/N2EHsZPZ+oIuqmJ3/ldJF8Q0I0bZlnz0cn67TmtLbryaHAo=
X-Talos-MUID: 9a23:PNJUeAok8kQcudLPcWcezzdbM5sy6OeNNH0mgYoPmu2uajV9Cx7I2Q==
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-l-core-05.cisco.com ([173.36.16.142]) by alln-iport-3.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 18 Dec 2025 08:24:14 +0000
Received: from rcdn-opgw-4.cisco.com (rcdn-opgw-4.cisco.com [72.163.7.165]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by alln-l-core-05.cisco.com (Postfix) with ESMTPS id B6EB11800017D; Thu, 18 Dec 2025 08:24:14 +0000 (GMT)
X-CSE-ConnectionGUID: oav7k+2nQqaDHWUkAmyNKw==
X-CSE-MsgGUID: 4Oi9gNWcRgiw489GjOM+RQ==
Authentication-Results: rcdn-opgw-4.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.21,158,1763424000"; d="scan'208,217";a="63934398"
Received: from mail-sn1pr07cu00103.outbound.protection.outlook.com (HELO SN1PR07CU001.outbound.protection.outlook.com) ([40.93.14.99]) by rcdn-opgw-4.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 18 Dec 2025 08:24:14 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=rRcmepl6UmjVpoITz0vhMxx0cR2UP/s3/q/iQ47PBvIDi0fzoZzgBsrnA4nu5E02mCIxYaTPnil2z0gQ+NLahPgBJAOgyJtWXsrSoCxwqRu/Wf4323xJSDk3Um1b1okR2m65Wug1mstkTFICZ0WvfrvSA7+wnUZ9gYshkyh5D38M1+NunfnUmf3/mdHqmwwacSWYSGd59+KUhFs39MjergfvzJR62v/qItvrG/C8EG9Ziunc2XWpInNwIxHJwwvo9KZ06v7lReOeYR9GEye2h7e9jVXhhZKi5P+5ymyr3HLoadXToes3xBpi02qVbbfr8RZJVOVFjGNV4t5tvSVyIw==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=i2VKq9RAMFhFFoAasfTO77HwdNV3fDAKq/wXhk7UhqE=; b=XAYDf0WzM37kVaXQVO6obPkbImXVBwSZG7XDqe/fo70zHoemZvhyVsWXT/NhMe/z8aeQJZg4Yil/ctKmK29U4d5pzENwze7A886AExa6wa4ftkTJC/InHp9fOHrHqnOc3sLOJRDSTslTTn23ClHe46R8zWwrKuWu0KlR8snhIuZIIVjI5s2cKY/ioae4q9A16jSGmyfu2y1t9KkeClOBmYgIKkZ07Gbg7qO+/h0PJ+mu3OIc9f5ta7J+q7no/jhSdOzVQ/0eF7cO/MnaIXIwT6pS1Ob//q6WRvE2gs2H3svsAQFmopZAUCCodtcj0Er37rvRTqaqmv1lo3Bwp1BVhA==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from PH0PR11MB4966.namprd11.prod.outlook.com (2603:10b6:510:42::21) by CH3PR11MB8186.namprd11.prod.outlook.com (2603:10b6:610:15a::12) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9434.8; Thu, 18 Dec 2025 08:24:12 +0000
Received: from PH0PR11MB4966.namprd11.prod.outlook.com ([fe80::258a:9418:efab:8cb8]) by PH0PR11MB4966.namprd11.prod.outlook.com ([fe80::258a:9418:efab:8cb8%7]) with mapi id 15.20.9434.001; Thu, 18 Dec 2025 08:24:12 +0000
From: "Eric Vyncke (evyncke)" <evyncke@cisco.com>
To: Tommy Jensen <tojens.ietf@gmail.com>
Thread-Topic: Éric Vyncke's Discuss on draft-ietf-v6ops-claton-13: (with DISCUSS and COMMENT)
Thread-Index: AQHcb/Tzqz61KXmrVUSrqf0+Na8/j7UnDtkQ
Date: Thu, 18 Dec 2025 08:24:12 +0000
Message-ID: <PH0PR11MB49664D3BD419B90672270491A9A8A@PH0PR11MB4966.namprd11.prod.outlook.com>
References: <176589705535.704674.17073535824993411286@dt-datatracker-5bd94c585b-pvtsm> <CABDV=UNjS0B-9KOqtT8zk_Tif2qTtPyE4T+ebfXKt=oH52vz9g@mail.gmail.com>
In-Reply-To: <CABDV=UNjS0B-9KOqtT8zk_Tif2qTtPyE4T+ebfXKt=oH52vz9g@mail.gmail.com>
Accept-Language: fr-BE, en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PH0PR11MB4966:EE_|CH3PR11MB8186:EE_
x-ms-office365-filtering-correlation-id: 8c952280-9d16-4255-de3a-08de3e0ed303
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|376014|366016|10070799003|1800799024|38070700021|7053199007|13003099007|8096899003;
x-microsoft-antispam-message-info: baNVEVZdQPmBrYfAuGQQdcFPIc/ro7J/6lEgpCUWzVM0/rCSUjUZ7fjfmZ8yiUH/xs4nxI8b76WP4wA1JR4zT+Lgr9HADGbwLwF6uwFYxteUvxbNprnvlP7vN9Nga9xatuVSZBL9S0o/aL1isfPKoaRfzDENHsAroO5c1W8RI7jSW5x7BUBgrvMSknMgYebBoz7dS3UF7HpnNMcrH9ELfGLMrrtIhoP4+s7lPPNQilGc7HBqYLDkaIQBx00so3bxHHW5UL5pham3FFQ/fMuZWF7yXln+lpwXucYa0ahFsN8ebeQ4W1Q0kp8XfjzazRCTRfuEKYHAw+g0jCly1s7QocnEwaVA+2NldesDMdaUbaGeeOo3PZF7M7CtXLZvrjeYzq29/YP7mXuuv02naSrmSyWgoi09oRVJSNJB27VtJfhWJngFMxBBAJD8O2xJXgNKZRO4WZTaHBI+i3uty+WvU+hP6lWcQ/kAIDaBqzfJkALvtThM0w9k5v7du93aNIM+pGPnRAt3E81JpssN+LMIGdBfcjOxc7mUKxaEhQiRxDhEAuc8rihx7tdxi7VczxmBNNTpuLhupSlz/idGS1s6eXKlQrbg8Ws3LyVs13NPwabL7gDCughtpKbusRZDcPaAu2naWG+ngxy56F7uJdigb1M2Z7RAKabyMHo0XehFpZW4ybgEjf6yi5d8RYn6MbhsXN9JAbiRxY//Pw4q2Q/+uTVDq9z91u9IZN9uyDMLMLXQERPeJNysdJEJDyWcOxsIkoEUiUWrSoD1fgA130kq5Z0B/dAGqqamg34SubYfwMAn9P5rwJAVbaUMkdyx8FUmKgc0g8ZtNbnrYjnZg7KTQZVFu2fWMAyEaXfjlq9l6Adx9i8v3wmAGEhyHv83H064jjwarpfqQVMNZv5NfQ9qlmfUtUTp6zLJ9THfOAUX+ep8Zc81lanzt5LAUYkKC1HL/SNUzbCtjcl8OAL8FHdp5RMQ07C4r5tpG22l3zw5GxHscgTXa+1aqbTrMUwsqRAGtfEaU5et53nQtWK6LsCYIoujquwwR3AMfr+JI+DCRv3J7+ZBSPp7rfpZlNzX4samp1zWgGRX6GUxjWdmAilKp6/s9dsrvbzunD68fuzIzWXSpqmfTuUiIKNc0wLcyqSOyukjLO7Yo0rB922zF7jeBid0zARdHw8WaNXmWu8ONYDVqbHl4bQSEx/YhZWMQLVf5DlI46fdoR6t+2UiidIXHk+GcECZMViAvZ+R1wUdqdKXPDA29Pbemv94+SmyrcBlXqyy9AztCvz+JKQqaM2mxQMzts0vvy+J3WAk95BXXzujahjMT0AAPUlz1hNmAWglE3vADIT2Fz3gxXNQFoylYm1vvk7aSEs1X0e3tK71eSNtRTrXASgEEmDg4bvt4nKvm8IJfBEM/9lolwPD5+xd3rXPKmS4YL+1sE2DHIZnKT08A0EAx36Rlc5Q6zpmp9tMqHcQV2DsHuPf/IW/zDFl/w==
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PH0PR11MB4966.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(376014)(366016)(10070799003)(1800799024)(38070700021)(7053199007)(13003099007)(8096899003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: nXusyhkAuJvNdh9CnxpXq+pBoNpHuysaMEMju3jI3PrJgSnAydOtN5tiOLJYGIlCjURlSAeLNsHBFA1Joo0bg1CjCx1jPkb/TJhBDruDt8hl+YoKJbM/iJ0g/Q+GG2YXrV/fclTCV74AvqwTSkGvoDxMRDkFND95U2tYRB90HeD6sC3aNthDEbByMtsp0Y8H9zM1Wcts7uACZ8fnqLsR+GAtkqEDAqimgkwLzNxo91grWVpZ0xpYs4dqynkr5+acV9wO4n//QOSbw4SbcJGNLrfvhuhGEUOVAGCMekfyX0xzZnlHlc3WhfI3mEZ4Aguh+paXxAx+GpSBIjsUWTbFDPSjWj0ZzpeCMJddVhigmBpmVlFB3WY6x+7Z2HFi1TWYzqfCjix9zO4ypOHfOVNrPyLq1JmD7M4v0VWw7DPtbhQ/TAfHNDkrts6AyLH4cBcc50m2aQNDGEJT2THic4JuLrXSkMRh4XjIpDvjvSGSKEgdPVHyGlQhLI/I7HNBkyms4S8dT7lfctCBtWKjC3Td0Q/Ua0bII8stU7wLO5RXszPwhvNTvxtYToWZgV4K04l4RLtUjelARkWYpSayLR9+0s9OToF2omoYfDhyGVgUrsxEyJs4Cn2qyR6wQ2GDcTuaiUU4oKhZrh7wB9MRYe5bV3X0108QH8jie57T7GvuipBNg0ezK4tl4QptbiN9hbggU4Llr22ocqhiMm3A1arC/MftskcENuL+DauKWuZtpolmLx8+OnUeN2DC513aP2T6v1eRWceNtOzPbeH54tiHe9TlJ7w/DU5QcVfpTcAonwuOI9YDelF8NvQhHT9J+TbgSNsQ7iuNSxLvxK09x8RUWKcLITWIGN26vEKaOkfrq2xZusvp+ela9PQag6NoyfqS5PWnmrtPpkPXelRpIw2bLDyLhX9HVuBYVXD6q76+wFEQlpGD9I1U//nUp6dofEa/NQlVTIS7njLuqJu95eDBfsDv94iUvXiLgwp2iP0PIC8wrZ5HOfwjYqStTmZtvr3RCGo1FA+sP3xWnH5jx1xEKYopS/UGLKiQLKFOrBKxzAGfCcr28Pah3gNfvErRlqIq9LjZlLik9EZ23Ad59XqoPockHx9bQTQXkNaN7DeviHeuHqT25T97n+iAZc3YV5lpQVPp/Fjz8VxP5jezMIVqDHe7TNWXWkWHxS3kdTSlQW9uQSm+auIr/FXWFue/rmrCXkDQEF6q4ggV9CivOJT4sQZcSf0kLYdxZIDqd9VsQBMazJBXu+TvUMmaij3CMXcdcyujhLmvzf2ClxlTQQLMT8ZVRVprniKB8XpM93iV1xyPEBjlbcQpoJCX9YYnwTlhgNxiCC1HosjIbFB3m4XY1mHLgXWbzhleCIp4oxFbmPm8jMpJ6I+3+9Oy2V96QVQqCvTCufX8J576OjK4GcaAVQQ0LP8juOoivr1Xj9tW8pAYdaDv+1+XgpRnBJDFyWXEjUCW8ypaLsMe0cO9ZgE3N7oVVYiwqyXiraLgkLL3kYCVYS703B4vzxxVuMbRHh7rsebOBwUgR0lIFrwEAIkKgpYOnyCb1tJUrBagAG0an6DQC38elxX9jtjVco+wfRwG3nGplbNZEz3i3Nbg5REc3fr2szkBNMjrRjeSvPVPkTJTUiIxra2BjZkaIaT8v+ujIB0Q2luzUJokNrlDNYQO/g==
Content-Type: multipart/alternative; boundary="_000_PH0PR11MB49664D3BD419B90672270491A9A8APH0PR11MB4966namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PH0PR11MB4966.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 8c952280-9d16-4255-de3a-08de3e0ed303
X-MS-Exchange-CrossTenant-originalarrivaltime: 18 Dec 2025 08:24:12.3214 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: 4A3XYKmrNRdbBoRD+PXyu8KZKzX1NqS4MIZBoiYLy9/RNYLE3GXhg7T29UURzJzuA5Ar2BYQ5K1FRCwc/hVl5w==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: CH3PR11MB8186
X-Outbound-SMTP-Client: 72.163.7.165, rcdn-opgw-4.cisco.com
X-Outbound-Node: alln-l-core-05.cisco.com
Message-ID-Hash: HIWKLPHUFH4KXOLJMR4T6XZ4CI6VRTCQ
X-Message-ID-Hash: HIWKLPHUFH4KXOLJMR4T6XZ4CI6VRTCQ
X-MailFrom: evyncke@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-v6ops.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: The IESG <iesg@ietf.org>, "draft-ietf-v6ops-claton@ietf.org" <draft-ietf-v6ops-claton@ietf.org>, "gih@apnic.net" <gih@apnic.net>, "jim@rfc1035.com" <jim@rfc1035.com>, "mcr@sandelman.ca" <mcr@sandelman.ca>, "v6ops-chairs@ietf.org" <v6ops-chairs@ietf.org>, "v6ops@ietf.org" <v6ops@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [v6ops] Re: Éric Vyncke's Discuss on draft-ietf-v6ops-claton-13: (with DISCUSS and COMMENT)
List-Id: v6ops discussion list <v6ops.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/v6ops/WFJwnQrtEpksY7DyQyqQ4M8Wa8A>
List-Archive: <https://mailarchive.ietf.org/arch/browse/v6ops>
List-Help: <mailto:v6ops-request@ietf.org?subject=help>
List-Owner: <mailto:v6ops-owner@ietf.org>
List-Post: <mailto:v6ops@ietf.org>
List-Subscribe: <mailto:v6ops-join@ietf.org>
List-Unsubscribe: <mailto:v6ops-leave@ietf.org>

Thank you, Tommy, for your message.

While I do not agree always with your reply to my non-blocking comments, there are not blocking anyway :-)

I am also curious to read the next text as it seems that it may address all my DISCUSS points.

Finally, it was a nice start of my European day to read `Our compliments to the complementary feedback`about my `s/compl*i*ments/compl*e*ments/ ;-)`

Regards, I am confident that the DISCUSS ballot will be solved quickly

-éric

From: Tommy Jensen <tojens.ietf@gmail.com>
Date: Thursday, 18 December 2025 at 09:04
To: Eric Vyncke (evyncke) <evyncke@cisco.com>
Cc: The IESG <iesg@ietf.org>, draft-ietf-v6ops-claton@ietf.org <draft-ietf-v6ops-claton@ietf.org>, gih@apnic.net <gih@apnic.net>, jim@rfc1035.com <jim@rfc1035.com>, mcr@sandelman.ca <mcr@sandelman.ca>, n.leymann@telekom.de <n.leymann@telekom.de>, v6ops-chairs@ietf.org <v6ops-chairs@ietf.org>, v6ops@ietf.org <v6ops@ietf.org>
Subject: Re: Éric Vyncke's Discuss on draft-ietf-v6ops-claton-13: (with DISCUSS and COMMENT)

Thank you for the comments, Éric. Some responses in-line. Unanswered items were left that way as a trade-off to get partial answers to you in time for the telechat review, rather than waiting for time for the editors to meet to discuss the remaining.

Thanks,
Tommy

On Tue, Dec 16, 2025 at 6:57 AM Éric Vyncke via Datatracker <noreply@ietf.org<mailto:noreply@ietf.org>> wrote:
Éric Vyncke has entered the following ballot position for
draft-ietf-v6ops-claton-13: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-v6ops-claton/



----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------


# Éric Vyncke INT AD comments for draft-ietf-v6ops-claton-13
CC @evyncke

Thank you for the work put into this document. While my current ballot is a
blocking DISCUSS, I am a big supporter of this work, so, take the length list
of the points below as a way to help the authors improving their document.

Please find below some blocking DISCUSS points, some non-blocking COMMENT
points/nits (replies would be appreciated even if only for my own education).

Special thanks to Michael Richardson for the shepherd's detailed write-up
including the WG consensus *and* the justification of the intended status.

Other thanks to Nicolai Leymann, the DNS directorate reviewer, and Nicolai
confirmed that all its comments were implemented by the authors.

I hope that this review helps to improve the document,

Regards,

-éric

Note: this ballot comments follow the Markdown syntax of
https://github.com/mnot/ietf-comments/tree/main, i.e., they can be processed by
a tool to create github issues.

## DISCUSS (blocking)

As noted in
https://datatracker.ietf.org/doc/statement-iesg-handling-ballot-positions-20220121/,
a DISCUSS ballot is a request to have a discussion on the points below; I
really think that the document would be improved with a change here, but can be
convinced otherwise.

### Section 6.1

In which case does the SHOULD not apply in `A node providing CLAT functions to
local applications SHOULD use IPv4 addresses from the dedicated 192.0.0.0/29<http://192.0.0.0/29>
range [RFC7335]` ? I.e., why not a MUST

Since the IPv4 address in question is never used on the network (in fact, it's forbidden), there's no interoperational harm from a protocol perspective to not do so, hence we felt SHOULD was better. We have updated text coming in the next revision (coming soon!) that makes this more in line with IESG guidance, explaining what harm results if an implementor doesn't use this range (i.e. apps may assume no CLAT is in place because it expects to see 192.0.0.0/29<http://192.0.0.0/29>).


### Section 6.2.2

I have also seen mcast IP over ucast layer-2, so, the text in the second bullet
should really qualify ucast and mcast by the layer.

We've attempted a rephrase here too. New text incoming.


### Section 7

Please explain why PvDs (RFC 8801) do not help in this case.

The editors didn't have time to sync before the telechat and want to discuss this further. This comment remains open.


### Section 8

Why not a MUST in `the CLAT instance SHOULD present IPv4-only applications with
an IPv4 MTU which is 28 bytes smaller` ? If SHOULD is kept, then follow the
IESG guidance at
https://datatracker.ietf.org/doc/statement-iesg-statement-on-clarifying-the-use-of-bcp-14-key-words/



We thought we had provided the needed format, but the new text restructures this to make alignment with the IESG guidance clearer.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------


## COMMENTS (non-blocking)

### Section 1

While I understand why the I-D means by `which require IPv4 would fail`, the
wording seems a little 'fuzzy', perhaps adding '(e.g., having a remote peer
hardcoded IPv4 addresses preventing the use of DNS64/NAT64)' could help (even
if the sentence is heavier) ?

I may perhaps be too strict about the use of "host" vs. "node" in `CLAT
functions are performed by the host itself` because the host can be used for
tethering 'downstream' devices, i.e., not really a 'host' anymore. I.e.,
suggest s/host/node/. Later in the I-D, "node" seems to be used more often than
"host", so, let's be consistent.

This bullet is in the context of Section 4.2 of RFC 6877, which is the use of CLAT by endpoints that do not provide downstream connectivity, for which the editors feel “host” is more accurate. The rest of the document tends to use “node” to be generic when CLAT is discussed without specifying whether it is for the node itself as a host or for devices connected to/through the node.


s/compl*i*ments/compl*e*ments/ ;-)

Thank you! Our compliments to the complementary feedback.


### Section 3

I find the definition of `IPv6-only network` a little confusing with the use of
2 similar but not identical sentences.

Agreed; these sentences have been merged in the new text to avoid duplication.


About the `native IPv4`, why not using "IPv4-only network" even if only for
symmetry with "IPv6-only network" ?

Because "native IPv4" is not defined to be the IPv4 equivalent of "IPv6-only network". The intent is to refer to the use of IPv4 "on the wire" (sorry) rather than inside of IPv6, meaning that both IPv4-only networks and dual-stack networks have "native IPv4" available.


### Section 4

Why not a "MUST" in `Therefore an IPv6-only node SHOULD enable CLAT `? Even if
the "MUST" is conditioned with "Therefore an IPv6-only node with CLAT features
MUST enable CLAT as soon as it receives a PREF64 option from the network and if
local policy allows it." or something similar. Nevertheless I appreciate the
"Discussion" as it matches
https://datatracker.ietf.org/doc/statement-iesg-statement-on-clarifying-the-use-of-bcp-14-key-words/


We felt SHOULD was most appropriate given the context (glad you like our added discussion). It needs more than one sentence, hence it isn't exactly in the format described by the IESG for SHOULDs, but our reasoning is the same as the text. It doesn't make sense to have to try and decide when this MUST needs to be SHOULD as IPv4 becomes less common whereas the conditions of the SHOULD remain the same and the reader can evaluate the conditions themselves.

About the multi-interface with CLAT on, should this specific use case be more
detailed ? E.g., by explaining how the selection of the default IPv4 route
should work ? (I note that there is text about using "ipv4only.arpa" in
multi-interface, which is good).

We tried to avoid getting too into the weeds on how address selection should work, given we don't want to change that logic for the platform.


s/the node is allowed to use other mechanisms/the node *MAY* use other
mechanisms/ ?

That makes sense (changed in next version).


I fear that `Unless configured otherwise, the node MUST enable CLAT if the node
has not already obtained a non-link-local IPv4 address by the time it discovers
the NAT64 prefix.` is probably too aggressive as DHCPv4 is typically slower (as
it relayed and requires a permanent storage write operation) than IPv6 RA by a
local router. I.e., CLAT could end up being enabled 10 msec before DHCPv4
especially with text later saying `If native IPv4 connectivity becomes
available later for a given interface, the node SHOULD disable CLAT for that
interface `. Should there be a minimum delay before enable CLAT ?

We do not think so, because this is a trade-off with waiting too long to start and unnecessarily delaying IPv4 connectivity when we know there is IPv4 connectivity available (via 464XLAT). We have guidance for allowing delay in the next sentences to address the shortcomings of RFC 7050 in that specific case, however.


`If native IPv4 connectivity becomes available later for a given interface, the
node SHOULD disable CLAT for that interface ` while the next section has a
"MUST" (although with a "unless"). This reads weird.

You are correct that it is a weird flow, but it was the best spot we could find for that guidance the last time section ordering was challenged in review. Open to suggestions.


### Section 6.1

`on the wire` in a Wi-Fi world looks strange ;-)

Fair point! Changed to "to the network"


### Section 6.2.1

Please note that RFC8415 will soon be RFC9915 (it is in AUTH48) so using the
I-D draft-ietf-dhc-rfc8415bis rather RFC 8415 will ensure that the RFC editor
picks up the right RFC for DHCPv6.

Good point, updated.


You may add that the examples are using the Well-Known Prefix for NAT64.

Should there be some text confirming that the CLAT node can obtain *two* IPv6
addresses by DHCPv6 and use one for CLAT ? Of course at the expense of checksum
recomputation (it would be nice to have an DHCPv6 option to request a checksum
neutral IPv6 address...)

Definitely possible to add. The current state reflects us trying not to iterate valid ways network administrators could handle this and rather focus on what the client needs (separate addresses/prefixes for native IPv6 and CLAT traffic).


Really unsure what is meant by `If a protocol uses the standard IP checksum,`
as there is no checksum in any IP header ;-) and is there any TCP or UDP
protocols not using the standard checksum ?

“IP checksum” is commonly used as shorthand for “Internet checksum” (and arguably easier to recognize given IP is no longer expanded usually) as defined in RFCs 1071, 1141, and 1624, which are legacy but most recently referenced by RFC 7414 which also uses the two phrases interchangeably.

The safe approach is to assume some protocols might behave differently so the current text says may rather than boldly claim it will always work because no protocols do anything but the expected IP checksum.


### Section 6.2.2

Should there be another term instead of `native IPv6 addresses`, e.g.,
"non-CLAT addresses" or simply "their other IPv6 addresses" ?

We prefer this term because it uses the same paradigm as “native IPv4” to mean something about addresses that have nothing to do with translation (see "native IPv4" discussion above).


Hummm, the 1st paragraph clearly (and rightfully) states that all IPv6
addresses (CLAT & non-CLAT) MUST have the same behavior, then the bulleted list
only specifies the CLAT behavior, e.g., allow non-DAD for some addresses as
long as CLAT addresses do DAD... This is not correct, I suggest removing the
CLAT-specific text in the bulleted list.

We want to limit specificity to CLAT because if this section provides normative behavior for the treatment of IPv6 addresses outside the context of CLAT, this document’s scope is much wider than originally intended. This document is only intended to update CLAT-related RFCs rather than define new requirements that would apply to use of IPv6 without CLAT in place.


About the DHCP registration, like written above, what if the other addresses
are not registered ?

### Section 7

A small but nice graphics would help some readers who are not aware of the
issue.

We explicitly tried to avoid architecture diagrams knowing there's no way to come close to being comprehensive here and moreso now in light of the pushback the flow diagram received in other reviews.


### Section 9.2

I was expecting a MAY rather than `SHOULD implement [RFC7050] ("Discovery of
the IPv6 Prefix Used for IPv6 Address Synthesis")` as this document clearly
prefers (rightfully) the RA method.

This was our original intention, but then it became clear that there are networks where 8781 is not feasible as raised by those with 3GPP experience. Leaving 7050 as a MAY would regress the state of interoperability. That said, we do have text in the fifth paragraph of Section 4 that addresses this by illustrating both the preference order and the heightened considerations around using 7050 versus 8781.


`The router SHOULD have a configuration knob to disable DHCP Option 108
processing.` has little to do with 464XLAT though and more about IPv6-mostly.

### Section 10

`For non-mobile environments, ... the operational considerations are documented
in [I-D.ietf-v6ops-6mops].` is rather succint as having 2 IPv6 addresses (and
the whole discussion of multi-prefixes) really belongs to this document IMHO.

### Section 11

The link to I-D.ietf-pquip-pqc-engineers does not bring a lot as the discussion
about ""Harvest Now, Decrypt Later" as it is not specific to this I-D. Consider
removing this part, else a LOT of I-D will end-up referring to this PQC draft.

That draft getting a lot of references makes sense given it’s the way the rest of us can define why it is important in a threat model to avoid exposing encrypted data to an unintended recipient. Otherwise, it is difficult for us to explain why an attacker moving traffic to their PLAT on what is supposed to be an IPv4-only network matters when most of it is encrypted anyway.