Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops Digest, Vol 52, Issue 41)
"Templin, Fred L" <Fred.L.Templin@boeing.com> Mon, 15 December 2014 22:43 UTC
Return-Path: <Fred.L.Templin@boeing.com>
X-Original-To: v6ops@ietfa.amsl.com
Delivered-To: v6ops@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id D65B51A1EED for <v6ops@ietfa.amsl.com>; Mon, 15 Dec 2014 14:43:21 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.211
X-Spam-Level:
X-Spam-Status: No, score=-4.211 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 8r48Qxyn2gW0 for <v6ops@ietfa.amsl.com>; Mon, 15 Dec 2014 14:43:20 -0800 (PST)
Received: from stl-mbsout-02.boeing.com (stl-mbsout-02.boeing.com [130.76.96.170]) (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 4E99C1A1EEA for <v6ops@ietf.org>; Mon, 15 Dec 2014 14:43:20 -0800 (PST)
Received: from localhost (localhost [127.0.0.1]) by stl-mbsout-02.boeing.com (8.14.4/8.14.4/DOWNSTREAM_MBSOUT) with SMTP id sBFMhJq1003706; Mon, 15 Dec 2014 16:43:19 -0600
Received: from XCH-PHX-413.sw.nos.boeing.com (xch-phx-413.sw.nos.boeing.com [10.57.37.45]) by stl-mbsout-02.boeing.com (8.14.4/8.14.4/UPSTREAM_MBSOUT) with ESMTP id sBFMhA0l003159 (version=TLSv1/SSLv3 cipher=AES128-SHA bits=128 verify=OK); Mon, 15 Dec 2014 16:43:11 -0600
Received: from XCH-BLV-504.nw.nos.boeing.com ([169.254.4.76]) by XCH-PHX-413.sw.nos.boeing.com ([169.254.13.86]) with mapi id 14.03.0210.002; Mon, 15 Dec 2014 14:43:09 -0800
From: "Templin, Fred L" <Fred.L.Templin@boeing.com>
To: "owens@nysernet.org" <owens@nysernet.org>
Thread-Topic: [v6ops] IPv6 multicast and tunnels (RE: v6ops Digest, Vol 52, Issue 41)
Thread-Index: AQHQGKuGG9salvinE0WXixCACR3twpyRuA4A//96RHA=
Date: Mon, 15 Dec 2014 22:43:09 +0000
Message-ID: <2134F8430051B64F815C691A62D9831832DB719B@XCH-BLV-504.nw.nos.boeing.com>
References: <2134F8430051B64F815C691A62D9831832DB6F84@XCH-BLV-504.nw.nos.boeing.com> <20141215200121.GA34418@nysernet.org> <2134F8430051B64F815C691A62D9831832DB70A4@XCH-BLV-504.nw.nos.boeing.com> <20141215215404.GR33073@nysernet.org>
In-Reply-To: <20141215215404.GR33073@nysernet.org>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-originating-ip: [130.247.104.6]
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
X-TM-AS-MML: disable
Archived-At: http://mailarchive.ietf.org/arch/msg/v6ops/ZoCDYVpyrBAl860760V0WlSY29k
Cc: "v6ops@ietf.org" <v6ops@ietf.org>
Subject: Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops Digest, Vol 52, Issue 41)
X-BeenThere: v6ops@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: v6ops discussion list <v6ops.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/v6ops>, <mailto:v6ops-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/v6ops/>
List-Post: <mailto:v6ops@ietf.org>
List-Help: <mailto:v6ops-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/v6ops>, <mailto:v6ops-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 15 Dec 2014 22:43:22 -0000
Hi Bill, > -----Original Message----- > From: Bill Owens [mailto:owens@nysernet.org] > Sent: Monday, December 15, 2014 1:54 PM > To: Templin, Fred L > Cc: v6ops@ietf.org > Subject: Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops Digest, Vol 52, Issue 41) > > On Mon, Dec 15, 2014 at 09:10:17PM +0000, Templin, Fred L wrote: > > Hi Bill, > > > > > -----Original Message----- > > > From: Bill Owens [mailto:owens@nysernet.org] > > > As of this afternoon, we see 20655 v6 unicast networks and 66 multicast, with paths that include a total of 50 ASes. We have both > > > commercial and R&E v6 paths, but there are just thirteen peers that carry multicast; all of them are R&E networks. So there is > *some* > > > wide-area IPv6 multicast, but not *much*. Certainly not enough to be worth using except in extremely limited circumstances. We > > > continue to support it simply because of inertia; it would be more work to remove it from our configurations than to keep it in. > > > > That is great data, but is a bigger picture concern for IPv6 in general and > > not for the use of tunnels inside of IPv6 sites right? > > > > Inside of the site, there may be a need for IPv6 link- and site-scoped > > multicasts, e.g., for service discovery, public bulletins, media simulcasts, > > etc. In that case, it might be good if the tunnels handled multicast. > > I suppose it might be useful to have site-scoped multicast, Two that come to mind are LLMNR and mDNS. But really, any site-scoped or link-scoped multicast application should work. > though if tunnels were needed to accomplish that I think it would be more > likely that they'd be hand-configured tunnels between routers, Automatic tunnels without explicit configurations are also possible (see AERO). > rather than some part of a transition mechanism. Tunneling is about more than just transition. Also useful for mobility, routing control, security, traffic engineering, etc. regardless of transition or not. > I honestly have > never paid any attention to the prospect of using any of the transition schemes within a site; it always seemed to me that they would > be between a site and its provider. Just to be clear, I am considering the entire ISP network as a "site" when I talk about link- and site-scoped multicast. And the tunnel provides a "link" that spans the site. > And although I used to be a strong advocate of multicast both in the wide and local networks, its > use cases have faded to the point where I no longer recommend that anyone make the effort of deploying it. Well, there are already RFC4795, RFC6762, RFC6763, etc. Thanks - Fred fred.l.templin@boeing.com > Bill.
- [v6ops] IPv6 multicast and tunnels (RE: v6ops Dig… Templin, Fred L
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Bill Owens
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Templin, Fred L
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Bill Owens
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Templin, Fred L
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Nick Hilliard
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Templin, Fred L
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Bill Owens
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Templin, Fred L
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Tim Chown
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Bill Owens
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Gert Doering
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Templin, Fred L
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Gert Doering
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Templin, Fred L
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Gert Doering
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Templin, Fred L
- Re: [v6ops] IPv6 multicast and tunnels (RE: v6ops… Nick Hilliard