[v6ops] Re: WG Last Call: draft-ietf-v6ops-6mops-04 (Ends 2025-12-05)

Goetz Goerisch <ggoerisch@gmail.com> Sat, 06 December 2025 20:44 UTC

Return-Path: <ggoerisch@gmail.com>
X-Original-To: v6ops@mail2.ietf.org
Delivered-To: v6ops@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 60AA3968B76B for <v6ops@mail2.ietf.org>; Sat, 6 Dec 2025 12:44:04 -0800 (PST)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.099
X-Spam-Level:
X-Spam-Status: No, score=-2.099 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ycfR0NiRz-Ga for <v6ops@mail2.ietf.org>; Sat, 6 Dec 2025 12:44:03 -0800 (PST)
Received: from mail-ej1-x62b.google.com (mail-ej1-x62b.google.com [IPv6:2a00:1450:4864:20::62b]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 3DAC4968B757 for <v6ops@ietf.org>; Sat, 6 Dec 2025 12:44:03 -0800 (PST)
Received: by mail-ej1-x62b.google.com with SMTP id a640c23a62f3a-b79f8f7ea43so531189666b.2 for <v6ops@ietf.org>; Sat, 06 Dec 2025 12:44:03 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1765053842; x=1765658642; darn=ietf.org; h=importance:content-transfer-encoding:mime-version:subject :references:in-reply-to:message-id:cc:to:from:date:from:to:cc :subject:date:message-id:reply-to; bh=BoCEUHCg9CpdYmdyaNFxmqa6srsUetx/KDEZvdYxHrA=; b=ZYu+uZMaTFdF4aEPVbNbe3FdsZWuEVBWvCYHN70yAnXS+ZCmjBxQ4QrR9zB8LhKk25 z2qMSffW8TKuFC6B9bCaNqXYFM8GmErRg0vbO0f4nvIPbikmQbvhMlFkShZ/pfjfe8Jg UyS/1ebDtMzCxXi6tykWL9xeOhj4b4gqUfTZAdjTzjxoEUF5pKsOW8i8KNpq3/+f7G4D oFm5cxGCDAnW4YM6f+3DWWTUJhQeHBA3MOw5bE/2ruy93FlcDzW7/LkmDrjBEdJiX2qW CqGX8lDnaFbOlAWPMp/QjiVCofQEu+PbQU6KQLmBuRN3XZNSTsFnu76RohqrWzbTjymN fTNw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1765053842; x=1765658642; h=importance:content-transfer-encoding:mime-version:subject :references:in-reply-to:message-id:cc:to:from:date:x-gm-gg :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=BoCEUHCg9CpdYmdyaNFxmqa6srsUetx/KDEZvdYxHrA=; b=BSTJXf3Uoo0VkTBUDZK9eRgNeJ6iZQXLPA25nze807MWZsAV6qUKD0Ly7xDF055v5p vDLBb513KabgF4WSz6NBGO97hkxCumJIRvzP2kXl+qicnh8kJTy8dx5xnxuDyI1tvyMn m+tFm60oXe1vm9yDgWGJLxICV53maqcqR6WS0MD8ocptahfweNNuW/ri4zW/WfljyaHb KvnfcOsudsCHAECBayEYTmoLesmZ5ZGzJJhxprjfI2EzKOlOmv+O4evJasSNO8jK9zBs BUkh3lxxF2c99wlf8oXhx5/bdN0qiKzZp7tT96wYq0f0UNJd4vKS28VDCrISxQ/aXXV5 EDBg==
X-Forwarded-Encrypted: i=1; AJvYcCX6xCgat4dQj/YxOZzjXMWFMxgmmUx7OOINTaFUS5D5HdrlMq4WJgrGCnyhpkgLs6wiejB+Mw==@ietf.org
X-Gm-Message-State: AOJu0YxBtt655+HDEjTcxpqmTQoIlT8B9vh5ur5VBDL5ZEGeICSVqj58 VcmZUr+0SlpN9ABbe5h+MahoNPuETjo6Q8y991nfz0eXhVhL81Ana1Ru
X-Gm-Gg: ASbGncuxB114YMRpEwa7XP/DfqszBa26doXUNEx6mHYxYk3aZdvagSv9nLGAT0FGta4 BsO8dff94r3fotcvTFgm8AMIu+9RjJq7mehkN626sZQE4a/Hd7WTeDBhqkQ9lBbroVQELgMvttR jFYbY8RYvv3iIKqmRKXSqwbToQECOE3aJCTUZnKbTY4pjggbasFVg7XO1giGAn0QyXRQtrbhGms o70VnrHF5EKCdZHttRWkidWBsGHKpTeJoiruDT18wbshEvX83oe9SGW89GYDIPhG0LkPot23918 nXNiDC4nCDDEpIxJlCSianZRbiEjHYc/WDQBcuSS4gCqdwRPLsEiDOcNzV6LozjI2xP+kTd8Gci nJazNgZtkYgRQWfXN8oOdZ1OBm+GaKrkYu56LcPBW+gJrS/dn+pYbaLhrhL6sY1JMyUVgoTSmK2 ZSzjSKUG/TP0jsi3AH1dhxV13hdBh3afQsYWb7esq05sTOygyABEtHVIrPtAlYD7oVWdnOBvlZ0 CfZ
X-Google-Smtp-Source: AGHT+IGLLxJsJIDR4OCGScz9lptAhMGaTlJWvrvH4mPxJi1WYou7MU2EgONQsm9PYrd6tEHugi+Qtw==
X-Received: by 2002:a17:906:d54c:b0:b74:9862:3e36 with SMTP id a640c23a62f3a-b7a24805105mr317381066b.51.1765053841790; Sat, 06 Dec 2025 12:44:01 -0800 (PST)
Received: from appsuite-core-mw-groupware-54b5d45d74-wv7kt (gate-4.heinlein-hosting.de. [80.241.60.14]) by smtp.gmail.com with ESMTPSA id a640c23a62f3a-b7a01a33379sm527407666b.62.2025.12.06.12.44.01 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Sat, 06 Dec 2025 12:44:01 -0800 (PST)
Date: Sat, 06 Dec 2025 21:44:00 +0100
From: Goetz Goerisch <ggoerisch@gmail.com>
To: Xipengxiao <xipengxiao=40huawei.com@dmarc.ietf.org>, "v6ops@ietf.org" <v6ops@ietf.org>
Message-ID: <503966793.216286.1765053840926@app.mailbox.org>
In-Reply-To: <7720e1f6b3ab4d17ba4179d4754d6836@huawei.com>
References: <176374684852.1748355.11818209162334090600@dt-datatracker-5bd94c585b-wk4l4> <9672552d42664bc09328c5c40a9cebb9@huawei.com> <7720e1f6b3ab4d17ba4179d4754d6836@huawei.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
X-Priority: 3
Importance: Normal
X-Mailer: Open-Xchange Mailer v8.43.61
X-Originating-Client: open-xchange-appsuite
Message-ID-Hash: DYTYMPRYEFS3WPLWSLTJAFNNFWUC4HXC
X-Message-ID-Hash: DYTYMPRYEFS3WPLWSLTJAFNNFWUC4HXC
X-MailFrom: ggoerisch@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-v6ops.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "draft-ietf-v6ops-6mops@ietf.org" <draft-ietf-v6ops-6mops@ietf.org>, "v6ops-chairs@ietf.org" <v6ops-chairs@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [v6ops] Re: WG Last Call: draft-ietf-v6ops-6mops-04 (Ends 2025-12-05)
List-Id: v6ops discussion list <v6ops.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/v6ops/aCfLyTE6C4x7_zJ1QkOBDDAtotU>
List-Archive: <https://mailarchive.ietf.org/arch/browse/v6ops>
List-Help: <mailto:v6ops-request@ietf.org?subject=help>
List-Owner: <mailto:v6ops-owner@ietf.org>
List-Post: <mailto:v6ops@ietf.org>
List-Subscribe: <mailto:v6ops-join@ietf.org>
List-Unsubscribe: <mailto:v6ops-leave@ietf.org>

Dear authors and WG,

I support the addoption and I already earlier sent comments for consideration.
To ease the work of the authors I submitted a PR directly to the working document.

https://github.com/furry13/v6mostly-ops/pull/35

Best regards,
Goetz

> The WGLC is supposed to end on Dec. 5, but we only got 2 reviews by Brian and Philipp.  So I will extend the WGLC for 1 more week and request more reviews.   Mine is below.  Thank you.   XiPeng 
> 
> 
> ======== review of draft-ietf-v6ops-6mops-04 =========
> 
>   Network segment: a link (VLAN, a broadcast domain etc) where hosts
>    share the same IP subnet.
> ==>
> “Network segment” is L3, “link” is L2.  So this seems a little awkward.  suggest “Network segment: an IP subnet”
> 
> 
>    However, dual-stack networks do not address the core problem driving
>    IPv6 adoption: IPv4 address exhaustion.  They still require the same
>    amount of IPv4 resources as IPv4-only networks.  Even worse, this
>    dual-stack approach has been demonstrated to be a long-term crutch,
>    frequently masking problems that would otherwise be exposed and
>    remedied as normal operational workflows.
> ==>
> Dual stack allows people to gain IPv6 experience so that they can move to IPv6-Mostly or IPv6-Only later. For many organizations, it’s a useful (middle) step.  I think it’s better not to complain about dual stack, but simply say something like:
> Dual stack consumes more network resources and requires more management effort, i.e. for both IPv4 and IPv6. Therefore, once organizations gain sufficient IPv6 experience, it is advisable to move as many devices to IPv6 as possible.
> 
> 
>    Those concerns make DNS64 is suboptimal and undesirtable solution
> ==>
> s/undesirtable/undesirable
> 
> 
> This capability potentially allows for the
>       use of IPv4 subnets that are 2 to 4 times smaller than those
>       required for dual-stack.  It is important to note that migrating a
>       dual-stack network to an IPv6-only mode does not reduce the amount
>       of public IPv4 space required for network elements such as NAT
>       pools. 
> ==>
> The first sentence says smaller IPv4 subnet size so people would think that they can reduce the amount of public IPv4 addresses needed. But the second sentence says no. It can be a surprise.  Therefore, it may be worth explaining why.
> 
> 
>    To provide IPv6-only endpoints with DNS recursive server addresses,
>    the administrator MUST configure the network to include the DNS
>    servers IPv6 addresses into RA option, as per [RFC8106].
> ==>
> Can DHCPv6 be used?  MUST or SHOULD?
> 
> 
> DNSSEC Incompatibility: DNS64 responses fail DNSSEC validation.
> ==>
> Is this sentence too strong?  Maybe: DNS64 can interfere with DNSSEC validation for validating stubs or when synthesis happens in an untrusted resolver.
> 
> 
> Simplified troubleshooting due reduced impact of Happy Eyeballs
>       [RFC8305]: 
> ==>
> s/due/due to
> 
> 
> such as translating flows from different hosts to thesame
> ==>
> s/thesame/the same
> 
> 
>    *  User-selected fallback to dual-stack
>       networks can mask issues with IPv6-only operation, hindering
>       problem reporting and resolution.  
> ==>
> I think it’s better not to say dual stack and HE are “hindering problem reporting and resolution” – they don’t - but simply say that IPv6-Mostly may expose issues masked by dual stack and HE. To draw an analogy, taking a pain killer doesn’t prevent a person from seeking medical treatment, and if he doesn’t, it may be because he is too busy on the day (good reason), or he is too lazy (bad reason). But anyhow, we should not blame the pain killer. 
> 
> 
> For recurring temporary
>    networks, for instance during a conference, it might be a good
>    practice to change the network SSID of the last resort fallback
>    network between each event.
> ==>
> Not clear.  Please consider rewording.
> 
> 
> transating from IPv4 to IPv6 can result in packets exceeding the path
>    MTU on the IPv6 side.  In that case NAT64 creates IPv6 packets with
>    the Fragment Header (see Section 4 of [RFC6145] for more details.
> ==>
> 1.	s/transating/translating
> 2.	RFC6145 has been obsoleted by RFC7915.  Please consider quoting RFC7915.
> 
> 
> Currently (2024), all implementations use SLAAC for CLAT address
> ==>
> The latest status, as of Dec 2025, should be discussed here.
> 
> 
> In that case NAT64 creates IPv6 packets with
>    the Fragment Header (see Section 4 of [RFC6145] for more details.
> ==>
> Missing “)”
> 
> 
> As IPv6-only device can not fall back to IPv4
>    if IPv6 connectivity is not available or impacted by a malicious
>    actor.  Therefore any attack affecting IPv6 connectivity would have
>    much more drastic outcome, comparing to dual-stack networks.
> ==>
> The two sentences should become one sentence.
> 
> 
> -----Original Message-----
> From: Xipengxiao <xipengxiao=40huawei.com@dmarc.ietf.org> 
> Sent: Saturday, 22 November 2025 15:16
> To: v6ops@ietf.org
> Cc: draft-ietf-v6ops-6mops@ietf.org; v6ops-chairs@ietf.org; mohamed.boucadair@orange.com
> Subject: RE: WG Last Call: draft-ietf-v6ops-6mops-04 (Ends 2025-12-05)
> 
> Hi folks,
> 
> As Nick is a co-author, I will be watching and judging consensus for this WGLC. Please review the document and indicate whether you support or object to proceeding with its publication. As a reminder, this is not an adoption call, so please avoid statements such as “I support adoption of this draft.” Thank you.
> 
> XiPeng 
> 
> -----Original Message-----
> From: Nick Buraglio via Datatracker <noreply@ietf.org> 
> Sent: Friday, 21 November 2025 18:41
> To: draft-ietf-v6ops-6mops@ietf.org; v6ops-chairs@ietf.org; v6ops@ietf.org
> Subject: WG Last Call: draft-ietf-v6ops-6mops-04 (Ends 2025-12-05)
> 
> 
> Subject: WG Last Call: draft-ietf-v6ops-6mops-04 (Ends 2025-12-05)
> 
> This message starts a 2-week WG Last Call for this document.
> 
> Abstract:
>    This document discusses a deployment scenario called "an IPv6-Mostly
>    network", when IPv6-only and IPv4-enabled endpoints coexist on the
>    same network (network segment, VLAN, SSID etc).
> 
> File can be retrieved from:
> https://datatracker.ietf.org/doc/draft-ietf-v6ops-6mops/
> 
> Please review and indicate your support or objection to proceed with the publication of this document by replying to this email keeping v6ops@ietf.org in copy. Objections should be motivated and suggestions to resolve them are highly appreciated.
> 
> Authors, and WG participants in general, are reminded again of the Intellectual Property Rights (IPR) disclosure obligations described in BCP 79 [1]. Appropriate IPR disclosures required for full conformance with the provisions of BCP 78 [1] and BCP 79 [2] must be filed, if you are aware of any. Sanctions available for application to violators of IETF IPR Policy can be found at [3].
> 
> Thank you.
> 
> [1] https://datatracker.ietf.org/doc/bcp78/
> [2] https://datatracker.ietf.org/doc/bcp79/
> [3] https://datatracker.ietf.org/doc/rfc6701/
> 
> 
> 
> _______________________________________________
> v6ops mailing list -- v6ops@ietf.org
> To unsubscribe send an email to v6ops-leave@ietf.org