Re: [apps-discuss] Fwd: I-D Action:draft-saintandre-xdash-considered-harmful-01.txt
Claudio Allocchio <Claudio.Allocchio@garr.it> Thu, 21 October 2010 06:44 UTC
Return-Path: <Claudio.Allocchio@garr.it>
X-Original-To: apps-discuss@core3.amsl.com
Delivered-To: apps-discuss@core3.amsl.com
Received: from localhost (localhost [127.0.0.1]) by core3.amsl.com (Postfix) with ESMTP id 538113A6990 for <apps-discuss@core3.amsl.com>; Wed, 20 Oct 2010 23:44:08 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.479
X-Spam-Level:
X-Spam-Status: No, score=-1.479 tagged_above=-999 required=5 tests=[AWL=1.120, BAYES_00=-2.599]
Received: from mail.ietf.org ([64.170.98.32]) by localhost (core3.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ojTf9xXG7lPp for <apps-discuss@core3.amsl.com>; Wed, 20 Oct 2010 23:44:06 -0700 (PDT)
Received: from cyrus.dir.garr.it (cyrus.dir.garr.it [IPv6:2001:760:0:158::29]) by core3.amsl.com (Postfix) with ESMTP id 541F53A691C for <apps-discuss@ietf.org>; Wed, 20 Oct 2010 23:44:06 -0700 (PDT)
Received: from webcam1-all.garrtest.units.it (webcam1-all.garrtest.units.it [140.105.201.5]) (authenticated bits=0) by cyrus.dir.garr.it (8.14.4/8.14.4) with ESMTP id o9L6jOCT026325 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO); Thu, 21 Oct 2010 08:45:26 +0200 (CEST)
X-DomainKeys: Sendmail DomainKeys Filter v1.0.2 cyrus.dir.garr.it o9L6jOCT026325
DomainKey-Signature: a=rsa-sha1; s=mail; d=garr.it; c=simple; q=dns; b=DTbbH4VY3B3T5aPm9qKxOoeQCLQ0noNjlro6r7eGZrHngI9BpAHMLYPfDiRVjI+/M wR85d1nTuWeAnum+gCMM2nOZ+gUO4r3aCRXviV3XDKsMha6tlqBETHE3CgCZA92A7SN l9VRtiL14HQNZm3m2RY8uBVX3CRSKhh3ajOiHtM=
Date: Thu, 21 Oct 2010 08:45:23 +0200
From: Claudio Allocchio <Claudio.Allocchio@garr.it>
X-X-Sender: claudio@webcam1-all.garrtest.units.it
To: dcrocker@bbiw.net
In-Reply-To: <4CBF8007.5010609@dcrocker.net>
Message-ID: <Pine.OSX.4.64.1010210822500.25214@webcam1-all.garrtest.units.it>
References: <4CBDE23C.7050904@stpeter.im> <6.2.5.6.2.20101019205927.0ae108b8@resistor.net> <4CBF8007.5010609@dcrocker.net>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset="US-ASCII"; format="flowed"
Cc: apps-discuss@ietf.org
Subject: Re: [apps-discuss] Fwd: I-D Action:draft-saintandre-xdash-considered-harmful-01.txt
X-BeenThere: apps-discuss@ietf.org
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: General discussion of application-layer protocols <apps-discuss.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/apps-discuss>, <mailto:apps-discuss-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/apps-discuss>
List-Post: <mailto:apps-discuss@ietf.org>
List-Help: <mailto:apps-discuss-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/apps-discuss>, <mailto:apps-discuss-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 21 Oct 2010 06:44:08 -0000
On Wed, 20 Oct 2010, Dave CROCKER wrote: > Disclaimer: > > I was editor for the document that introduced it, 28 years ago, but am > pretty sure the idea came from a participant on the mailing list that was > discussing RFC 822 development, rather than coming from my own brain. > > In any event, during the IETF DRUMS working group, which produced > RFC2822, I lobbied for eliminating the construct. I think it was an > excellent idea, but I think it's downside is far more significant than its > upside. And indeed, the upside has largely been eliminated. /d > > > On 10/20/2010 2:44 AM, SM wrote: >> Quoting Section 3.8.1 of RFC 2821 (3.7.1 in RFC 5321): >> >> "Other mail systems gatewayed to the Internet often use a subset of >> the RFC 822 header section ... A possible >> solution would be to create new header fields to carry the envelope >> information (e.g., "X-SMTP-MAIL:" and "X-SMTP-RCPT:");" for this one you I can blame guilty, but I share the burden with Steve Kille. It was a workaround to allow SMTP to be the intermediate carrier between 2 non-standard, or "different" standard mail systems: A-type-mail-system-->gw-->SMTP-->gw-->A-type-mail-system > Essentially, the need for some additonal header fields, for messages being > gatewaying in from another system, is merely one more source of "private" > content labeling. It does not really ahve any special characteristics. true. > There are two different issues. One is that people like to invent header > fields frequently and conveniently. I'd say that's a pretty safe assessment. > > The second is that they somehow "prefer" using X-, rather than inventing a > name that does not use X-. > > My anecdotal sense of things is that they actually believe they are > /required/ to use X-, for any non-standardized header field. Of course, this > is not the rule, but they seem to think it is. I agree. people tend to be a bit lazy... "let's use an X-... and tere will be less discussion, no need to follow standards approval procedures.." Some fields which are of general use MUST be considered for standard, thus "no X-" >> Now, does Xdash stand for Experimental or Extension? > > I don't remember that it had any specific meaning. nor do I. all the best! PS: this was the X- section of Dave's message as I received from the ML: X-Sieve: CMU Sieve 2.3 X-DKIM: Sendmail DKIM Filter v2.6.0 lx1.dir.garr.it o9KNneGD015895 X-Original-To: apps-discuss@core3.amsl.com X-Virus-Scanned: clamav-milter 0.96.1 at lx1.dir.garr.it X-Spam-Score: -6.539 X-Spam-Level: X-Spam-Status: No, score=-0.4 required=6.0 tests=AWL,BAYES_00,SPF_FAIL shortcircuit=no autolearn=no version=3.3.1 X-Greylist: Sender is SPF-compliant, not delayed by milter-greylist-3.0 (lx1.dir.garr.it [193.206.158.2]); Thu, 21 Oct 2010 01:49:42 +0200 (CEST) X-Greylist: Sender succeeded SMTP AUTH, not delayed by milter-greylist-4.0 (sbh17.songbird.com [72.52.113.17]); Wed, 20 Oct 2010 16:49:32 -0700 (PDT) X-BeenThere: apps-discuss@ietf.org X-Mailman-Version: 2.1.9 as you can see... none of them has any gateway meaning (ok we do not use gateways often anymore), and most of it is for informational purpouses to the human recipient (... and 98% of recipents will never see them). but... at least the "spam information" ones could have easily been standardised, but are we still in time now? :-) ------------------------------------------------------------------------------ Claudio Allocchio G A R R Claudio.Allocchio@garr.it Senior Technical Officer tel: +39 040 3758523 Italian Academic and G=Claudio; S=Allocchio; fax: +39 040 3758565 Research Network P=garr; A=garr; C=it; PGP Key: http://www.cert.garr.it/PGP/keys.php3#ca
- [apps-discuss] Fwd: I-D Action:draft-saintandre-x… Peter Saint-Andre
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Bill McQuillan
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Paul Hoffman
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Dave Cridland
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Paul Hoffman
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Dave Cridland
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Nicolas Williams
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Tony Finch
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Tony Hansen
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… John C Klensin
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Dave CROCKER
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Nathaniel Borenstein
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… John C Klensin
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Paul Hoffman
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Dave CROCKER
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Dave Cridland
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Dave CROCKER
- Re: [apps-discuss] Fwd:I-D Action:draft-saintandr… Al Costanzo
- Re: [apps-discuss] Fwd:I-D Action:draft-saintandr… Julian Reschke
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Graham Klyne
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… John C Klensin
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… SM
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Dave CROCKER
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Mark Nottingham
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Claudio Allocchio
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Kurt Zeilenga
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Dave CROCKER
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Claudio Allocchio
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Kurt Zeilenga
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Royer Software and Services
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Keith Moore
- Re: [apps-discuss] Fwd: I-D Action:draft-saintand… Ted Hardie