Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-nfsv4-scsi-layout-nvme-07> for your review
rfc-editor@rfc-editor.org Thu, 07 March 2024 01:27 UTC
Return-Path: <wwwrun@rfcpa.amsl.com>
X-Original-To: auth48archive@ietfa.amsl.com
Delivered-To: auth48archive@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7E6C9C14F6FB; Wed, 6 Mar 2024 17:27:37 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.657
X-Spam-Level:
X-Spam-Status: No, score=-1.657 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, CTE_8BIT_MISMATCH=0.001, HEADER_FROM_DIFFERENT_DOMAINS=0.249, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=no autolearn_force=no
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id vAAWLPIOoAPD; Wed, 6 Mar 2024 17:27:33 -0800 (PST)
Received: from rfcpa.amsl.com (rfcpa.amsl.com [50.223.129.200]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id C5C5FC14F6F6; Wed, 6 Mar 2024 17:27:33 -0800 (PST)
Received: by rfcpa.amsl.com (Postfix, from userid 499) id B76BC76356; Wed, 6 Mar 2024 17:27:33 -0800 (PST)
To: hch@lst.de, chuck.lever@oracle.com, s.faibish@opendrives.com, david.black@dell.com
From: rfc-editor@rfc-editor.org
Cc: rfc-editor@rfc-editor.org, nfsv4-ads@ietf.org, nfsv4-chairs@ietf.org, inacio@cert.org, zahed.sarker.ietf@gmail.com, auth48archive@rfc-editor.org
Content-type: text/plain; charset="UTF-8"
Message-Id: <20240307012733.B76BC76356@rfcpa.amsl.com>
Date: Wed, 06 Mar 2024 17:27:33 -0800
Archived-At: <https://mailarchive.ietf.org/arch/msg/auth48archive/-I9yB9EUEwMu39aqy3b2WDkcq6k>
Subject: Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-nfsv4-scsi-layout-nvme-07> for your review
X-BeenThere: auth48archive@rfc-editor.org
X-Mailman-Version: 2.1.39
Precedence: list
List-Id: "Archiving AUTH48 exchanges between the RFC Production Center, the authors, and other related parties" <auth48archive.rfc-editor.org>
List-Unsubscribe: <https://mailman.rfc-editor.org/mailman/options/auth48archive>, <mailto:auth48archive-request@rfc-editor.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/auth48archive/>
List-Post: <mailto:auth48archive@rfc-editor.org>
List-Help: <mailto:auth48archive-request@rfc-editor.org?subject=help>
List-Subscribe: <https://mailman.rfc-editor.org/mailman/listinfo/auth48archive>, <mailto:auth48archive-request@rfc-editor.org?subject=subscribe>
X-List-Received-Date: Thu, 07 Mar 2024 01:27:37 -0000
Authors,
While reviewing this document during AUTH48, please resolve (as necessary)
the following questions, which are also in the XML file.
1) <!-- [rfced] Please note that the title of the document has been updated
as shown below. Abbreviations have been expanded per Section 3.6 of RFC
7322 ("RFC Style Guide"). Please review.
Original:
Using the Parallel NFS (pNFS) SCSI Layout to access NVMe storage devices
Current:
Using the Parallel NFS (pNFS) SCSI Layout to Access Non-Volatile Memory Express (NVMe) Storage Devices
-->
2) <!-- [rfced] Please review whether this note should be in the <aside>
element. It is defined as "a container for content that is semantically
less important or tangential to the content that surrounds it"
(https://authors.ietf.org/en/rfcxml-vocabulary#aside)
Original:
Note: The PS_DESIGNATOR_T10 and PS_DESIGNATOR_NAME have no equivalent
in NVMe and cannot be used to identify NVMe storage devices.
-->
3) <!-- [rfced] Please confirm that the following is correct. We are
unable to find "variable length" in RFC 8154.
Original:
RFC 8154 [RFC8154] specifies the "sbv_designator" field as an XDR
variable length opaque<>.
-->
4) <!-- [rfced] We do not see "direct block" or "block" in Sections 2.4.6
or 4 of RFC 8154. However, we do see the "direct block" in Section 2.4.5;
"block" appears in many sections. Please review the text and let us know
if any updates are needed.
Original:
Refer to Sections 2.4.6 (Extents Are
Permissions) and 4 (Security Considerations) of [RFC8154] for the
Security Considerations of direct block access from NFS clients.
-->
5) <!-- [rfced] Please review the "Inclusive Language" portion of the
online Style Guide <https://www.rfc-editor.org/styleguide/part2/#inclusive_language>
and let us know if any changes are needed. Note that our script did not
flag any words in particular, but this should still be reviewed as a best
practice.
-->
Thank you.
RFC Editor
On Mar 6, 2024, at 5:25 PM, rfc-editor@rfc-editor.org wrote:
*****IMPORTANT*****
Updated 2024/03/06
RFC Author(s):
--------------
Instructions for Completing AUTH48
Your document has now entered AUTH48. Once it has been reviewed and
approved by you and all coauthors, it will be published as an RFC.
If an author is no longer available, there are several remedies
available as listed in the FAQ (https://www.rfc-editor.org/faq/)
You and you coauthors are responsible for engaging other parties
(e.g., Contributors or Working Group) as necessary before providing
your approval.
Planning your review
---------------------
Please review the following aspects of your document:
* RFC Editor questions
Please review and resolve any questions raised by the RFC Editor
that have been included in the XML file as comments marked as
follows:
<!-- [rfced] ... -->
These questions will also be sent in a subsequent email.
* Changes submitted by coauthors
Please ensure that you review any changes submitted by your
coauthors. We assume that if you do not speak up that you
agree to changes submitted by your coauthors.
* Content
Please review the full content of the document, as this cannot
change once the RFC is published. Please pay particular attention to:
- IANA considerations updates (if applicable)
- contact information
- references
* Copyright notices and legends
Please review the copyright notice and legends as defined in
RFC 5378 and the Trust Legal Provisions
(TLP – https://trustee.ietf.org/license-info/)
* Semantic markup
Please review the markup in the XML file to ensure that elements of
content are correctly tagged. For example, ensure that <sourcecode>
and <artwork> are set correctly. See details at
<https://authors.ietf.org/rfcxml-vocabulary>.
* Formatted output
Please review the PDF, HTML, and TXT files to ensure that the
formatted output, as generated from the markup in the XML file, is
reasonable. Please note that the TXT will have formatting
limitations compared to the PDF and HTML.
Submitting changes
------------------
To submit changes, please reply to this email using ‘REPLY ALL’ as all
the parties CCed on this message need to see your changes. The parties
include:
* your coauthors
* rfc-editor@rfc-editor.org (the RPC team)
* other document participants, depending on the stream (e.g.,
IETF Stream participants are your working group chairs, the
responsible ADs, and the document shepherd).
* auth48archive@rfc-editor.org, which is a new archival mailing list
to preserve AUTH48 conversations; it is not an active discussion
list:
* More info:
https://mailarchive.ietf.org/arch/msg/ietf-announce/yb6lpIGh-4Q9l2USxIAe6P8O4Zc
* The archive itself:
https://mailarchive.ietf.org/arch/browse/auth48archive/
* Note: If only absolutely necessary, you may temporarily opt out
of the archiving of messages (e.g., to discuss a sensitive matter).
If needed, please add a note at the top of the message that you
have dropped the address. When the discussion is concluded,
auth48archive@rfc-editor.org will be re-added to the CC list and
its addition will be noted at the top of the message.
You may submit your changes in one of two ways:
An update to the provided XML file
— OR —
An explicit list of changes in this format
Section # (or indicate Global)
OLD:
old text
NEW:
new text
You do not need to reply with both an updated XML file and an explicit
list of changes, as either form is sufficient.
We will ask a stream manager to review and approve any changes that seem
beyond editorial in nature, e.g., addition of new text, deletion of text,
and technical changes. Information about stream managers can be found in
the FAQ. Editorial changes do not require approval from a stream manager.
Approving for publication
--------------------------
To approve your RFC for publication, please reply to this email stating
that you approve this RFC for publication. Please use ‘REPLY ALL’,
as all the parties CCed on this message need to see your approval.
Files
-----
The files are available here:
https://www.rfc-editor.org/authors/rfc9561.xml
https://www.rfc-editor.org/authors/rfc9561.html
https://www.rfc-editor.org/authors/rfc9561.pdf
https://www.rfc-editor.org/authors/rfc9561.txt
Diff file of the text:
https://www.rfc-editor.org/authors/rfc9561-diff.html
https://www.rfc-editor.org/authors/rfc9561-rfcdiff.html (side by side)
Diff of the XML:
https://www.rfc-editor.org/authors/rfc9561-xmldiff1.html
The following files are provided to facilitate creation of your own
diff files of the XML.
Initial XMLv3 created using XMLv2 as input:
https://www.rfc-editor.org/authors/rfc9561.original.v2v3.xml
XMLv3 file that is a best effort to capture v3-related format updates
only:
https://www.rfc-editor.org/authors/rfc9561.form.xml
Tracking progress
-----------------
The details of the AUTH48 status of your document are here:
https://www.rfc-editor.org/auth48/rfc9561
Please let us know if you have any questions.
Thank you for your cooperation,
RFC Editor
--------------------------------------
RFC9561 (draft-ietf-nfsv4-scsi-layout-nvme-07)
Title : Using the Parallel NFS (pNFS) SCSI Layout to access NVMe storage devices
Author(s) : C. Hellwig, C. Lever, S. Faibish, D. Black
WG Chair(s) : Brian Pawlowski, Christopher Inacio
Area Director(s) : Martin Duke, Zaheduzzaman Sarker
- [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-nfsv4… rfc-editor
- Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-n… rfc-editor
- Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-n… Black, David
- Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-n… Black, David
- Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-n… hch@lst.de
- Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-n… Black, David
- Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-n… hch@lst.de
- Re: [auth48] AUTH48: RFC-to-be 9561 <draft-ietf-n… Black, David
- [auth48] [AD - Zahed] Re: AUTH48: RFC-to-be 9561 … Sandy Ginoza
- Re: [auth48] [AD - Zahed] Re: AUTH48: RFC-to-be 9… Black, David
- Re: [auth48] [AD - Zahed] AUTH48: RFC-to-be 9561 … Sandy Ginoza
- Re: [auth48] [AD - Zahed] Re: AUTH48: RFC-to-be 9… Sorin Faibish
- Re: [auth48] [AD - Zahed] AUTH48: RFC-to-be 9561 … Chuck Lever III
- [auth48] [AD - Zahed] AUTH48: RFC-to-be 9561 <dra… Sandy Ginoza
- [auth48] [AD - Zahed] AUTH48: RFC-to-be 9561 <dra… Sandy Ginoza
- Re: [auth48] [AD - Zahed] AUTH48: RFC-to-be 9561 … Zaheduzzaman Sarker
- Re: [auth48] [AD - Zahed] AUTH48: RFC-to-be 9561 … Sorin Faibish
- Re: [auth48] [AD - Zahed] Re: AUTH48: RFC-to-be 9… hch@lst.de