Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-spring-mpls-path-segment-22> for your review
Alanna Paloma <apaloma@amsl.com> Tue, 20 February 2024 20:34 UTC
Return-Path: <apaloma@amsl.com>
X-Original-To: auth48archive@ietfa.amsl.com
Delivered-To: auth48archive@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id D404FC137360; Tue, 20 Feb 2024 12:34:24 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.907
X-Spam-Level:
X-Spam-Status: No, score=-6.907 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_HI=-5, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=unavailable autolearn_force=no
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 0bYh1BioKxms; Tue, 20 Feb 2024 12:34:20 -0800 (PST)
Received: from c8a.amsl.com (c8a.amsl.com [4.31.198.40]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 961A4C180B7C; Tue, 20 Feb 2024 12:34:20 -0800 (PST)
Received: from localhost (localhost [127.0.0.1]) by c8a.amsl.com (Postfix) with ESMTP id 348C9424B455; Tue, 20 Feb 2024 12:34:20 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
Received: from c8a.amsl.com ([127.0.0.1]) by localhost (c8a.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 11XauEe5-mew; Tue, 20 Feb 2024 12:34:20 -0800 (PST)
Received: from smtpclient.apple (unknown [IPv6:2600:1700:65a2:2250:4002:81c2:aef0:5bee]) by c8a.amsl.com (Postfix) with ESMTPSA id A85CF424B426; Tue, 20 Feb 2024 12:34:19 -0800 (PST)
Content-Type: text/plain; charset="utf-8"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3774.400.31\))
From: Alanna Paloma <apaloma@amsl.com>
In-Reply-To: <ef5e35c1347d45e9abdc091b4194a4df@huawei.com>
Date: Tue, 20 Feb 2024 12:34:08 -0800
Cc: "Rakesh Gandhi (rgandhi)" <rgandhi@cisco.com>, "chengweiqiang@chinamobile.com" <chengweiqiang@chinamobile.com>, "lihan@chinamobile.com" <lihan@chinamobile.com>, "royi.zigler@broadcom.com" <royi.zigler@broadcom.com>, "spring-ads@ietf.org" <spring-ads@ietf.org>, "spring-chairs@ietf.org" <spring-chairs@ietf.org>, DECRAENE Bruno INNOV/NET <bruno.decraene@orange.com>, "james.n.guichard@futurewei.com" <james.n.guichard@futurewei.com>, "auth48archive@rfc-editor.org" <auth48archive@rfc-editor.org>, "rfc-editor@rfc-editor.org" <rfc-editor@rfc-editor.org>, Xipengxiao <xipengxiao@huawei.com>
Content-Transfer-Encoding: quoted-printable
Message-Id: <63884980-99A8-40B8-A09F-B5F8C260C800@amsl.com>
References: <20240216014458.AEC7011821ED@rfcpa.amsl.com> <BL3PR11MB573181C178660D63CE1E1FD8BF4C2@BL3PR11MB5731.namprd11.prod.outlook.com> <9d967a1b9848444e92fe12de4c9684ad@huawei.com> <30feff6f46fa4939aff7e45aa31492f7@huawei.com> <6215485D-89C7-4464-BD2E-73CCAA3C01B8@amsl.com> <ef5e35c1347d45e9abdc091b4194a4df@huawei.com>
To: Cheng Li <c.l@huawei.com>
X-Mailer: Apple Mail (2.3774.400.31)
Archived-At: <https://mailarchive.ietf.org/arch/msg/auth48archive/AV-swfD2wMcEuitGgnzXjR8DZB0>
Subject: Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-spring-mpls-path-segment-22> for your review
X-BeenThere: auth48archive@rfc-editor.org
X-Mailman-Version: 2.1.39
Precedence: list
List-Id: "Archiving AUTH48 exchanges between the RFC Production Center, the authors, and other related parties" <auth48archive.rfc-editor.org>
List-Unsubscribe: <https://mailman.rfc-editor.org/mailman/options/auth48archive>, <mailto:auth48archive-request@rfc-editor.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/auth48archive/>
List-Post: <mailto:auth48archive@rfc-editor.org>
List-Help: <mailto:auth48archive-request@rfc-editor.org?subject=help>
List-Subscribe: <https://mailman.rfc-editor.org/mailman/listinfo/auth48archive>, <mailto:auth48archive-request@rfc-editor.org?subject=subscribe>
X-List-Received-Date: Tue, 20 Feb 2024 20:34:24 -0000
Hi Cheng, Thank you for your reply. Your approval has been noted on the AUTH48 status page: https://www.rfc-editor.org/auth48/rfc9545 We will await approvals from Weiqiang, Han, and Royi prior to moving forward with the publication process. Best regards, RFC Editor/ap > On Feb 20, 2024, at 11:36 AM, Cheng Li <c.l@huawei.com> wrote: > > Thank you so much! I am ok with the publication 😊 > > Respect > Cheng > > -----Original Message----- > From: Alanna Paloma <apaloma@amsl.com> > Sent: Tuesday, February 20, 2024 5:55 PM > To: Cheng Li <c.l@huawei.com>; Rakesh Gandhi (rgandhi) <rgandhi@cisco.com> > Cc: chengweiqiang@chinamobile.com; lihan@chinamobile.com; royi.zigler@broadcom.com; spring-ads@ietf.org; spring-chairs@ietf.org; DECRAENE Bruno INNOV/NET <bruno.decraene@orange.com>; james.n.guichard@futurewei.com; auth48archive@rfc-editor.org; rfc-editor@rfc-editor.org; Xipengxiao <xipengxiao@huawei.com> > Subject: Re: AUTH48: RFC-to-be 9545 <draft-ietf-spring-mpls-path-segment-22> for your review > > Greetings, > > Rakesh - Thank you for your reply. We have noted your approval on the AUTH48 status page: > https://www.rfc-editor.org/auth48/rfc9545 > > Cheng - Per your request, we’ve removed the Chinese characters from your contact information and reverted it back to how it appeared originally. > > The files have been posted here (please refresh): > https://www.rfc-editor.org/authors/rfc9545.xml > https://www.rfc-editor.org/authors/rfc9545.txt > https://www.rfc-editor.org/authors/rfc9545.html > https://www.rfc-editor.org/authors/rfc9545.pdf > > The relevant diff files have been posted here: > https://www.rfc-editor.org/authors/rfc9545-diff.html (comprehensive diff) https://www.rfc-editor.org/authors/rfc9545-auth48diff.html (AUTH48 changes) > > Once we’ve received approvals from Weiqiang, Han, Cheng, and Royi, we will move this document forward in the publication process. > > Thank you, > RFC Editor/ap > >> On Feb 19, 2024, at 6:19 AM, Cheng Li <c.l=40huawei.com@dmarc.ietf.org> wrote: >> >> Dear RFC Editor, >> After discussion with authors, we decide to remove my Chinese information, because we have three Chinese authors in the RFC. Sorry for my bother. LOL. >> If possible, can you please delete my Chinese information? >> Thanks, >> Cheng >> From: Cheng Li >> Sent: Friday, February 16, 2024 5:36 PM >> To: rfc-editor@rfc-editor.org >> Subject: RE: AUTH48: RFC-to-be 9545 >> <draft-ietf-spring-mpls-path-segment-22> for your review Dear RFC >> Editor, I have a simple request of adding some non-ACSII contact >> information for myself, like the example defined in RFC7997 😊 >> Could you please help to add some additional contact info for me? Just >> like Cheng Li (editor) Huawei Technologies China >> Email: c.l@huawei.com >> Additional contact information: >> 李呈(editor) >> 华为技术有限公司 >> 中国广东东莞溪村 >> Email: c.l@huawei.com >> Where 华为技术有限公司 is the Chinese characters of Huawei Technologies. Thank you so much! >> It may show in the first page like my info in https://datatracker.ietf.org/doc/rfc9005/, correct? >> Best wishes, >> Cheng >> From: Rakesh Gandhi (rgandhi) <rgandhi@cisco.com> >> Sent: Friday, February 16, 2024 3:51 PM >> To: rfc-editor@rfc-editor.org; chengweiqiang@chinamobile.com; >> lihan@chinamobile.com; Cheng Li <c.l@huawei.com>; >> royi.zigler@broadcom.com >> Cc: rfc-editor@rfc-editor.org; spring-ads@ietf.org; >> spring-chairs@ietf.org; DECRAENE Bruno INNOV/NET >> <bruno.decraene@orange.com>; >> james.n.guichard@futurewei.com;auth48archive@rfc-editor.org >> Subject: Re: AUTH48: RFC-to-be 9545 >> <draft-ietf-spring-mpls-path-segment-22> for your review Hello, >> Thank you for the careful editing of the document. >> Please see replies inline with <RG>…. >> From: rfc-editor@rfc-editor.org <rfc-editor@rfc-editor.org> >> Date: Thursday, February 15, 2024 at 8:45 PM >> To: chengweiqiang@chinamobile.com >> <chengweiqiang@chinamobile.com>,lihan@chinamobile.com >> <lihan@chinamobile.com>, c.l@huawei.com <c.l@huawei.com>, Rakesh >> Gandhi (rgandhi) <rgandhi@cisco.com>, royi.zigler@broadcom.com >> <royi.zigler@broadcom.com> >> Cc: rfc-editor@rfc-editor.org <rfc-editor@rfc-editor.org>, >> spring-ads@ietf.org <spring-ads@ietf.org>, spring-chairs@ietf.org >> <spring-chairs@ietf.org>, DECRAENE Bruno INNOV/NET >> <bruno.decraene@orange.com>, >> james.n.guichard@futurewei.com<james.n.guichard@futurewei.com>, >> auth48archive@rfc-editor.org <auth48archive@rfc-editor.org> >> Subject: Re: AUTH48: RFC-to-be 9545 >> <draft-ietf-spring-mpls-path-segment-22> for your review Authors, >> >> While reviewing this document during AUTH48, please resolve (as necessary) the following questions, which are also in the XML file. >> >> 1) <!--[rfced] Please insert any keywords (beyond those that appear in >> the title) for use on https://www.rfc-editor.org/search. --> >> >> <RG> How about following? >> Performance Measurement >> Bidirectional SR Path >> End-to-End Path Protection >> >> 2) <!--[rfced] How may we adjust the sentence below for clarity? >> Specifically, how does "SR-MPLS" relate to the rest of the sentence? >> >> Original: >> In the MPLS data plane SR-MPLS [RFC8660] the SR header is >> instantiated through a label stack. >> >> Perhaps: >> In the SR-MPLS data plane [RFC8660], the SR header is >> instantiated through a label stack. >> --> >> <RG> How about following? >> In SR with MPLS data plane [RFC8660], the SR header is >> instantiated through a label stack. >> >> >> 3) <!--[rfced] Would you like to alphabetize the terms listed in Section 1.2? >> Or do you prefer the current order? >> --> >> >> <RG> alphabetize >> >> 4) <!--[rfced] FYI - We have updated the definition of "SR-MPLS" in >> Section 1.2 to clarify the 1:1 relationship between the abbreviation >> and its expansion. Please let us know any objections. >> >> Original: >> SR-MPLS: Instantiation of SR on the MPLS data plane. >> >> Current: >> SR-MPLS: SR over MPLS >> --> >> <RG> ok >> >> >> 5) <!--[rfced] We note some terms appear separated with a slash (/) in >> this document, but it may be unclear whether the slash stands for >> "and", "or", or "and/or". Please review the instances below and let us >> know how they may be updated for clarity. >> >> Original: >> When a PSID is used, the PSID can be inserted at the ingress node and >> MUST immediately follow the last label of the SR path, in other >> words, inserted after the routing segment (adjacency/node/prefix >> segment) pointing to the egress node of the SR path. >> ... >> A PSID in SR-MPLS is a local label similar to other labels/Segment, >> such as a VPN label, defined in MPLS and SR-MPLS. >> --> >> <RG> How about following: >> words, inserted after the routing segment (adjacency, node, or prefix >> segment) pointing to the egress node of the SR path. >> … >> A PSID in SR-MPLS is a local label similar to other labels and segments, >> such as a VPN label, defined in MPLS and SR-MPLS. >> >> 6) <!--[rfced] We note that the formatting of ellipses and commas in >> the two examples below varies. Should these be made consistent? >> >> Original: >> The SID list of a sub-path can be expressed as <SID1, SID2, >> ...SIDn, s-PSID> >> >> The SID list of the end-to-end path can be expressed as <BSID1, >> BSID2, ..., BSIDn, e-PSID> >> >> Perhaps: >> The SID list of a sub-path can be expressed as <SID1, SID2, ..., >> SIDn, s-PSID> >> >> The SID list of the end-to-end path can be expressed as <BSID1, >> BSID2, ..., BSIDn, e-PSID> >> --> >> <RG> ok. >> >> >> 7) <!--[rfced] We note that Figure 2 uses both "Sub-path" and "SubPath". >> May we update these instances to be "Sub-path" or "sub-path" to >> reflect the term's usage in the running text of this document? Please >> let us know your preference. >> --> >> <RG> sub-path >> >> >> 8) <!--[rfced] Did Alexander Vainshtein contribute to Section 3.4 or Figure 2? >> As both have the same title, may we add a citation to clarify his contribution? >> >> Original: >> The authors would like to acknowledge the contribution from Alexander >> Vainshtein on "Nesting of PSIDs". >> >> Perhaps A: >> The authors would like to acknowledge the contribution from Alexander >> Vainshtein on "Nesting of PSIDs" (Section 3.4). >> >> Perhaps B: >> The authors would like to acknowledge the contribution from Alexander >> Vainshtein on "Nesting of PSIDs" (Figure 2). >> --> >> <RG> A: >> The authors would like to acknowledge the contribution from Alexander >> Vainshtein on "Nesting of PSIDs" (Section 3.4). >> >> >> 9) <!--[rfced] In recent RFCs, we note that Greg Mirsky's organization >> appears as "Ericsson", but in this document it appears as "ZTE Corp". >> Please let us know if any updates are needed. --> <RG> From RFC 9534. >> Greg Mirsky >> Ericsson >> United States of America >> Email: gregimirsky@gmail.com >> >> 10) <!--[rfced] FYI - We have made the following updates to the >> terminology used in this document. Please review and let us know any objections. >> >> a. We have added expansions for abbreviations upon first use per >> Section 3.6 of RFC 7322 ("RFC Style Guide"). Please review each >> expansion in the document carefully to ensure correctness. >> >> Associated Channel Header (ACH) >> Label Switched Path (LSP) >> <RG> ok. >> >> b. The following terms appear inconsistently capitalized and/or >> hyphenated throughout this document. We have updated to use the term >> listed on the right for consistency within the document and/or to match previous RFCs. >> >> segment list / Segment-List / Segment List > segment list >> Performance Measurement > performance measurement (per RFC 7799) SR >> Path > SR path Egress > egress Label Stack > label stack >> --> >> <RG> ok >> >> 11) <!--[rfced] Please review the "Inclusive Language" portion of the >> online Style Guide >> <https://www.rfc-editor.org/styleguide/part2/#inclusive_language> >> and let us know if any changes are needed. >> >> Note that our script did not flag any words in particular, but this >> should still be reviewed as a best practice. --> <RG> It’s ok. >> Thanks, >> Rakesh >> >> >> Thank you. >> >> RFC Editor/kf/ap >> >> >> On Feb 15, 2024, at 5:42 PM, rfc-editor@rfc-editor.org wrote: >> >> *****IMPORTANT***** >> >> Updated 2024/02/15 >> >> RFC Author(s): >> -------------- >> >> Instructions for Completing AUTH48 >> >> Your document has now entered AUTH48. Once it has been reviewed and >> approved by you and all coauthors, it will be published as an RFC. >> If an author is no longer available, there are several remedies >> available as listed in the FAQ (https://www.rfc-editor.org/faq/) >> >> You and you coauthors are responsible for engaging other parties >> (e.g., Contributors or Working Group) as necessary before providing >> your approval. >> >> Planning your review >> --------------------- >> >> Please review the following aspects of your document: >> >> * RFC Editor questions >> >> Please review and resolve any questions raised by the RFC Editor >> that have been included in the XML file as comments marked as >> follows: >> >> <!-- [rfced] ... --> >> >> These questions will also be sent in a subsequent email. >> >> * Changes submitted by coauthors >> >> Please ensure that you review any changes submitted by your >> coauthors. We assume that if you do not speak up that you >> agree to changes submitted by your coauthors. >> >> * Content >> >> Please review the full content of the document, as this cannot >> change once the RFC is published. Please pay particular attention to: >> - IANA considerations updates (if applicable) >> - contact information >> - references >> >> * Copyright notices and legends >> >> Please review the copyright notice and legends as defined in >> RFC 5378 and the Trust Legal Provisions >> (TLP – https://trustee.ietf.org/license-info/) >> >> * Semantic markup >> >> Please review the markup in the XML file to ensure that elements of >> content are correctly tagged. For example, ensure that <sourcecode> >> and <artwork> are set correctly. See details at >> <https://authors.ietf.org/rfcxml-vocabulary>. >> >> * Formatted output >> >> Please review the PDF, HTML, and TXT files to ensure that the >> formatted output, as generated from the markup in the XML file, is >> reasonable. Please note that the TXT will have formatting >> limitations compared to the PDF and HTML. >> >> >> Submitting changes >> ------------------ >> >> To submit changes, please reply to this email using ‘REPLY ALL’ as all >> the parties CCed on this message need to see your changes. The parties >> include: >> >> * your coauthors >> >> * rfc-editor@rfc-editor.org (the RPC team) >> >> * other document participants, depending on the stream (e.g., >> IETF Stream participants are your working group chairs, the >> responsible ADs, and the document shepherd). >> >> * auth48archive@rfc-editor.org, which is a new archival mailing list >> to preserve AUTH48 conversations; it is not an active discussion >> list: >> >> * More info: >> >> https://mailarchive.ietf.org/arch/msg/ietf-announce/yb6lpIGh-4Q9l2USxI >> Ae6P8O4Zc >> >> * The archive itself: >> https://mailarchive.ietf.org/arch/browse/auth48archive/ >> >> * Note: If only absolutely necessary, you may temporarily opt out >> of the archiving of messages (e.g., to discuss a sensitive matter). >> If needed, please add a note at the top of the message that you >> have dropped the address. When the discussion is concluded, >> auth48archive@rfc-editor.org will be re-added to the CC list and >> its addition will be noted at the top of the message. >> >> You may submit your changes in one of two ways: >> >> An update to the provided XML file >> — OR — >> An explicit list of changes in this format >> >> Section # (or indicate Global) >> >> OLD: >> old text >> >> NEW: >> new text >> >> You do not need to reply with both an updated XML file and an explicit >> list of changes, as either form is sufficient. >> >> We will ask a stream manager to review and approve any changes that >> seem beyond editorial in nature, e.g., addition of new text, deletion >> of text, and technical changes. Information about stream managers can >> be found in the FAQ. Editorial changes do not require approval from a stream manager. >> >> >> Approving for publication >> -------------------------- >> >> To approve your RFC for publication, please reply to this email >> stating that you approve this RFC for publication. Please use ‘REPLY >> ALL’, as all the parties CCed on this message need to see your approval. >> >> >> Files >> ----- >> >> The files are available here: >> https://www.rfc-editor.org/authors/rfc9545.xml >> https://www.rfc-editor.org/authors/rfc9545.html >> https://www.rfc-editor.org/authors/rfc9545.pdf >> https://www.rfc-editor.org/authors/rfc9545.txt >> >> Diff file of the text: >> https://www.rfc-editor.org/authors/rfc9545-diff.html >> https://www.rfc-editor.org/authors/rfc9545-rfcdiff.html (side by >> side) >> >> Diff of the XML: >> https://www.rfc-editor.org/authors/rfc9545-xmldiff1.html >> >> >> Tracking progress >> ----------------- >> >> The details of the AUTH48 status of your document are here: >> https://www.rfc-editor.org/auth48/rfc9545 >> >> Please let us know if you have any questions. >> >> Thank you for your cooperation, >> >> RFC Editor >> >> -------------------------------------- >> RFC9545 (draft-ietf-spring-mpls-path-segment-22) >> >> Title : Path Segment Identifier in MPLS Based Segment Routing Network >> Author(s) : W. Cheng, Ed., H. Li, C. Li, Ed., R. Gandhi, R. Zigler >> WG Chair(s) : Bruno Decraene, Alvaro Retana, Joel M. Halpern >> >> Area Director(s) : Alvaro Retana, John Scudder, Andrew Alston > >
- [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-sprin… rfc-editor
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… rfc-editor
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Rakesh Gandhi (rgandhi)
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Cheng Li
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Alanna Paloma
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Rakesh Gandhi (rgandhi)
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Weiqiang Cheng
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… 李晗
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Alanna Paloma
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Royi Zigler
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Alanna Paloma
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Alanna Paloma
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Cheng Li
- Re: [auth48] AUTH48: RFC-to-be 9545 <draft-ietf-s… Alanna Paloma