[auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-pim-sr-p2mp-policy-22> for your review
Rishabh Parekh <rishabh@arrcus.com> Tue, 28 April 2026 22:41 UTC
Return-Path: <rishabh@arrcus.com>
X-Original-To: auth48archive@mail2.ietf.org
Delivered-To: auth48archive@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id B0AF0E52F6BF; Tue, 28 Apr 2026 15:41:56 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1777416116; bh=Omo4/hFwW9RialLtDiEhZ31UIuqhUccjPl5GnLP/a7M=; h=From:To:CC:Subject:Date:References:In-Reply-To; b=Qf4Gxzszwel6BPzsmKJBuspYDipQJIjF+iStst1l4NL67ysHLw2vhJV1LEbj+lxX0 pDIQmwpeiNX+jP3inp/O+LxAbhpHFroS3xh73+ovU4zKvpcmQj9cJouPZSOs4ohweY 8rLhq9hWsd7GKJ7+RlIur6Yx6Kccd1v7V9TBc7zg=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.9
X-Spam-Level:
X-Spam-Status: No, score=-1.9 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (1024-bit key) header.d=netorgft1331857.onmicrosoft.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id d7qiNnO85rDY; Tue, 28 Apr 2026 15:41:54 -0700 (PDT)
Received: from CH5PR02CU005.outbound.protection.outlook.com (mail-northcentralusazlp170120005.outbound.protection.outlook.com [IPv6:2a01:111:f403:c105::5]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-384) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 9DBE7E52F37D; Tue, 28 Apr 2026 15:41:31 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=JCqmKXONF8QRR09/Dpyf95P7nPlPGnpyTiBlQVm74W809qIp9K0VuZ0PaCcUmNTLBC2ySIWUVKI9dq1Ie5f0Xg28F5rYugfPPlKrnSuAdUKQPmjp7/oeMGpRoCjmCRdBE1XamtagzYEdW+/Efu9831LmQN0fFBsX8ggyrPfbCcJ3zPK1aQmXvlddXKYSRyEzTjaZpWkNBW0sT5t4Tp0t6Ph0xza9DzOvcETtUliDfpRntuVoyiAHXwdZDStcBa3b76Ih0eA00g0Aha4TlhoZIKmADHjmb6pLkQGFCYDlJjylMBRk78sX6OmxwGmaiUEo5r4D1OB3cMf4m+eFgp9YEw==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=Omo4/hFwW9RialLtDiEhZ31UIuqhUccjPl5GnLP/a7M=; b=WBMQL7Q8cc+Q8RL2xO7pcDa7mtJsrqn0eiOo31TaMAzzJm6qS2kIfHYZP0izqBNgduL+IjiXNXQ/Ds97P+7Z/ax4tUyEW3TXSyn6iSowYAeBuxwgxb9zfFNNVNGSo/7XT3pdNSIzEWvzTxve94XEy+znmxR6obuPOtZkwdF/awFqHTAjSjpPyYaWYbyrBin+0xZIMZ+6K7QepuAyAqbjeBTjDDxyfjCyVrmqWNbirQTdKDT4mpS7qOn8Z1W/HCxA9x3KkK4srUx6QfC5b5Ud7shaTSZE6yOcyK6Obu7dio9t+DTw2+vTyjA0n2UVi478GwkWthxwY+F395feel/kGA==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=arrcus.com; dmarc=pass action=none header.from=arrcus.com; dkim=pass header.d=arrcus.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=NETORGFT1331857.onmicrosoft.com; s=selector2-NETORGFT1331857-onmicrosoft-com; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=Omo4/hFwW9RialLtDiEhZ31UIuqhUccjPl5GnLP/a7M=; b=U9NrmpOHPezFygy/B8p7blsl0pKcOuuFL6DYrbEw9jaTeLWIQGXOAB0zvdiS/m0hzWmivk7/C0LSe/kov/PjpXLOnLrlvQptiapTeo/uc1xGL0BPdDmdUdMuTAEbZXgT6i41HIQeYjI1TTHjhuyrdNNbOrYUjMpkexxClWQbLVI=
Received: from CH0PR18MB5419.namprd18.prod.outlook.com (2603:10b6:610:187::22) by IA2PR18MB5964.namprd18.prod.outlook.com (2603:10b6:208:4ad::22) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9846.26; Tue, 28 Apr 2026 22:41:20 +0000
Received: from CH0PR18MB5419.namprd18.prod.outlook.com ([fe80::9fad:1bce:37c6:761a]) by CH0PR18MB5419.namprd18.prod.outlook.com ([fe80::9fad:1bce:37c6:761a%5]) with mapi id 15.20.9846.025; Tue, 28 Apr 2026 22:41:20 +0000
From: Rishabh Parekh <rishabh@arrcus.com>
To: "Jeffrey (Zhaohui) Zhang" <zzhang=40juniper.net@dmarc.ietf.org>, Alanna Paloma <apaloma@staff.rfc-editor.org>, "Hooman Bidgoli (Nokia)" <hooman.bidgoli@nokia.com>, "Dan Voyer (davoyer)" <davoyer@cisco.com>
Thread-Topic: AUTH48: RFC-to-be 9960 <draft-ietf-pim-sr-p2mp-policy-22> for your review
Thread-Index: AQHc1p++2qq1EZp940+2QpJ2OuhZqLX0tswAgABJ41g=
Date: Tue, 28 Apr 2026 22:41:03 +0000
Message-ID: <CH0PR18MB5419C782E1D6A01B6CEDF85DDA372@CH0PR18MB5419.namprd18.prod.outlook.com>
References: <20260417221520.5DF86C0004D7@rfcpa.rfc-editor.org> <MN6PR18MB5413A04FC61625D94EEC0481DA2F2@MN6PR18MB5413.namprd18.prod.outlook.com> <47BB5B66-D4C3-44FC-8AEC-97B0970497B6@staff.rfc-editor.org> <DM8PR11MB5575FCBB6F34064E4C043982B2362@DM8PR11MB5575.namprd11.prod.outlook.com> <CH0PR08MB73228D2F596EBF7B4621CCC791362@CH0PR08MB7322.namprd08.prod.outlook.com> <620FE7A6-AEC9-456B-A32A-D4D7087BAA45@staff.rfc-editor.org> <IA1PR05MB95503BA471A77A71ED58EFDFD4372@IA1PR05MB9550.namprd05.prod.outlook.com>
In-Reply-To: <IA1PR05MB95503BA471A77A71ED58EFDFD4372@IA1PR05MB9550.namprd05.prod.outlook.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=arrcus.com;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: CH0PR18MB5419:EE_|IA2PR18MB5964:EE_
x-ms-office365-filtering-correlation-id: b0d6453c-7447-447d-f6cc-08dea577445c
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|69100299015|3109299003|7416014|366016|7049299003|376014|38070700021|13003099007|8096899003|18002099003|22082099003|56012099003;
x-microsoft-antispam-message-info: sUor5067P2t0vBUZhZpP8/5irx0v4cIeVS2qkyaQI6J3C1xrq3+3A9rFSN1edAeWR3DO0eOq1kDOSOagISsdu+nyL7ZN4cbgXHpWw7DWU1EMogp/N7s4Ryq7X+BAhyxqvg67i114/sFzO1kN3I//+f8ARf79MpuHwBOX8nKoxfnndWoQvtuh3/bMtvMk7aIsB9dFOgNnmfjhyopT3ZU/j3+LnvJmnwokc6sgCp1CCi7ScSK1lKSrueffperCWDQn602mjk57ymccuwE0wxn/j876pTZ2/gh27uT3o58BFs7WbVCqE0zfTStqKj0dSbaqm4KJ2OxwMZNskuCJqTxG27bvjCQLOoUgpMnHdz/7+hkJQhf3aLVyeEY6nGxTcwbjEJCu6z99g+SULsXRqUKdjH12NBmG8+mKtSE97g9kAtcynImoZ2yMl6jtCvK2ZUwpfvRL3QDcNz0OyypXqRVxSFFUZ9ezfDrELmCb9JtSYCxu789chJgb4m4BJwN5nH9ZhRIxYS2AsxEjR/bdsukXOMY5HTqmrFqtbindhS6ImVa4Wv40jtqJbbOHNRAbqNko3+vDRpN/cAskmqsSfHkbaoXLAPn7hgdkSN43o7b06YZa84fWgTVnv6Mn9t5L60jMB9kHJdh+YPt4fmDl9tEQJh+Mm/ZmMSqX1vq44JZYDLNMbZJMc7mjJ9sg7geLJhMwWcOLMDIFwfSJQz/ybP+J/c0fEtQ/JAjwwxqXHxif7yE=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:CH0PR18MB5419.namprd18.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(69100299015)(3109299003)(7416014)(366016)(7049299003)(376014)(38070700021)(13003099007)(8096899003)(18002099003)(22082099003)(56012099003);DIR:OUT;SFP:1102;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: zsAcb1ji7PF9kILopswlA8xRhibPq78X3klLdFIl7rinXOgRfNSX4XK0VrtY0B2CvN85Efn1VTfqGBlfvnkLEl5zUrpuXwH4Uinqcq9LuHrb+6ir6tu8UkwlXhgXkpwGFtS03GiOE3kmvP9Byv5FzOSu5rrZMqhSRiAkemy0p5JN3mbx9XlWEUkamlubpQPrWHdn0pjEpZPpwBeyu0+adQl6GNNR7wDY7kNdNptALQyrpeYNv5DdKxuYsxNQp4IxVICRPNpeFiyOiKYsi4JRv4eqGlNRbUQTAlIMofLTCTVLxEjK+igVPGYExagBBcJso7Cf5Carpzy/G1cTjMyDBXQp6Tf6PGOIytHrVCby7mLHY02W/gr6PbGKk4J2ZDUL+TrpYrsTpiXFv65894qh6Q0VhxTtJBPtBN/rljVcDbXv2hr/nYeGAQVKCuU6g/0hZ7rhuNTTBXUwWe9GycUScsvVZ654nQzpO+dq23/9DoTYvSidgzz5w82rFW5XO98S9u4RoQz57AYoOv/3whAT3VFz34fE1L5XxA93R96P4mZbVOp3/trdC8ZVpSAPjfN/19kHAnJ/eKNFxEdpoTQpQHh5BN5gbr7ZX2zi9z2BeTnKrGVe4h0SGWAJuNKh75w1ubJYBWTy+vSdyz6hr4Hv233MbCstj0jCxHJVZt4C9mQ/+3ajlmh5i+zgHQoL2UO+FImN37sW4tl4NYtPeLAu1NnLolSDkKxzCyHRCLdGdzozIrQSClwKXREPDGLhScxU09zyhZxART/fvAhEXTBmozmckvY7/FFecNHcEWBh1lXTflEyW0xa37Y7lI6LcX9lWSuT9kbiwX3nXpdv3n5MaoG7es77R4ih0VvCz4n2Y5F+ImZfZafa1cXIl4dCGJopeclHPNK+yJHm95C3UNNPHs97Mv4ljTTvU460CxQNh5Fc0kJaadHnNuuqnQn06WygZscVVx2K73WLH/xBSg7PtQPU/2i9kqOlVlDT4s5C+DXWVw35qfDJ7mJci9fVFLAQ0Zd5+27Q7IZD3o0U2zHIj5QCk1OQpm/GofxX70ouIXAZv+8Mem3O9opxn5Ojb8xs6nydq7GygdstavrFHNT1hmpfsYXeoChc3g+frcYnE+QNpll1wSngXQXgIGLVhFp1l7IJelKsVMdAw9eVseOQ/nUM4QK4xBhxj63mN+e5G6Ikh762e5X44CNtLml2eFmtr9zXE+FY8Ak+nzxl8WY7mic/3ChE4eJrB/jAKjn/H3dXcn6EaGUt4DHUaeecioVtw3dnlL/jMwFFUkV5P1GDaFxV3xbLGUjLxERksWMdbolPS0sgtxZr8YI1iG+Or3g/UTetO+sFdOUdkE8DjiFZLPaOyIXtBnulRYtj28F7sKbdz/XVfHZo83WcxBgkpQYQ9LcaUmSiCBb6zQq6olWWjajZo9Dl1+IkrwUIHBaA0PMmjIjT4rJMegOD70UIS1Ur2eCV9//rIyXxG8/68rF1wPoTYOtbwX5WOOW96rrhPz0BNu0MJBa2O3Az9EW4zZzQ4QUaZDaj9NDdcSEIP8PCfUYfVJtiFoTF9GqHXKEQKqRsG3JjQO1KaIshn6iIdIFk7xn2SFWvlz7f/IKJn4MN9L7EYYDlxEhxgmlMiqvhnKNGlTp5eWIDC3rTbpEzuRhyddzaTnJ8IMliZ6jNSy72efG7ctYTfiDgcCdySJ12jbCn+STE1dnbwk/tALYXiGKwx7ETLi+y1Nxn2VcDG6nUcA==
Content-Type: multipart/alternative; boundary="_000_CH0PR18MB5419C782E1D6A01B6CEDF85DDA372CH0PR18MB5419namp_"
MIME-Version: 1.0
X-OriginatorOrg: arrcus.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: CH0PR18MB5419.namprd18.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: b0d6453c-7447-447d-f6cc-08dea577445c
X-MS-Exchange-CrossTenant-originalarrivaltime: 28 Apr 2026 22:41:19.9332 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 697b3529-5c2b-40cf-a019-193eb78f6820
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: 1rBY9U3wHTG1xa7dwU5025ZFse/gXk9xbaOcguZKCVRB/X4JHO+jkEbafwB/0Nyj8B5wEGoqhPgFnIJ78lly7w==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: IA2PR18MB5964
Message-ID-Hash: P7ITDQRYIBZWZ3CH5DHCERP5GO4GGN3D
X-Message-ID-Hash: P7ITDQRYIBZWZ3CH5DHCERP5GO4GGN3D
X-MailFrom: rishabh@arrcus.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "Gunter van de Velde (Nokia)" <gunter.van_de_velde@nokia.com>, "Clarence Filsfils (cfilsfil)" <cfilsfil@cisco.com>, "rfc-editor@rfc-editor.org" <rfc-editor@rfc-editor.org>, "pim-ads@ietf.org" <pim-ads@ietf.org>, "pim-chairs@ietf.org" <pim-chairs@ietf.org>, "mmcbride7@gmail.com" <mmcbride7@gmail.com>, "auth48archive@rfc-editor.org" <auth48archive@rfc-editor.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-pim-sr-p2mp-policy-22> for your review
List-Id: "Archiving AUTH48 exchanges between the RFC Production Center, the authors, and other related parties" <auth48archive.rfc-editor.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/auth48archive/AfYGUP3zUUHVNUHqE7ljBGNRAp4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/auth48archive>
List-Help: <mailto:auth48archive-request@rfc-editor.org?subject=help>
List-Owner: <mailto:auth48archive-owner@rfc-editor.org>
List-Post: <mailto:auth48archive@rfc-editor.org>
List-Subscribe: <mailto:auth48archive-join@rfc-editor.org>
List-Unsubscribe: <mailto:auth48archive-leave@rfc-editor.org>
Alanna, I agree with Jeffrey’s comment - it is easy to be confused with similar terms and concepts like Replication segment identifier, Replication-ID and Replication-SID. II propose a slightly modified text in order to make it clear that the paragraph is about the control plane identifier of a Replication segment. Section 2.3 CURR: PTIs are instantiated using Replication segments. Section 2 of [RFC9524] specifies the Replication-ID of the Replication-SID tuple as a variable length field that can be modified as required based on the use of a Replication segment. However, length is an imprecise indicator of the actual structure of the Replication-ID. This document updates the Replication-ID of a Replication-SID [RFC9524] to be the tuple: <Root, Tree-ID, Instance-ID, Node-ID>, where <Root, Tree-ID> identifies the SR P2MP Policy and Instance-ID identifies the PTI within that SR P2MP Policy. This results in the Replication segments used to instantiate a PTI being identified by the tuple: <Root, Tree-ID, Instance-ID, Node-ID>. In the simplest case, the Replication-ID of a Replication segment is a 32-bit number as per Section 2 of [RFC9524] for which the Root MUST be zero (0.0.0.0 for IPv4 and :: for IPv6), the Instance-ID MUST be zero, and the 32-bit Tree-ID to effectively make the Replication-SID <[0.0.0.0 or ::], Tree-ID, 0, Node-ID>. NEW: PTIs are instantiated using Replication segments. Section 2 of [RFC9524] specifies the Replication-ID of the Replication segment control plane identifier tuple as a variable length field that can be modified as required based on the use of a Replication segment. However, length is an imprecise indicator of the actual structure of the Replication-ID. This document updates the Replication-ID of the control plane identifier of a Replication segment [RFC9524] to be the tuple: <Root, Tree-ID, Instance-ID>, where <Root, Tree-ID> identifies the SR P2MP Policy and Instance-ID identifies the PTI within that SR P2MP Policy. The Replication segments used to instantiate a PTI are thus identified in the control plane by the tuple: <Root, Tree-ID, Instance-ID, Node-ID>. As per Section 2 of [RFC9524], for a simple use case, the Replication-ID is a 32-bit number. To map this use case to the tuple for the control plane identifier of a Replication segment as defined in this document, the Root MUST be zero (0.0.0.0 for IPv4 and :: for IPv6), the Instance-ID MUST be zero, and the 32-bit Tree-ID to effectively make the tuple <[0.0.0.0 or ::], Tree-ID, 0, Node-ID>. The last sentence of the following paragraph also needs a minor change to make it clear that Replication-SID in the text refers to the data plane. Section 2.3 CURR: Therefore, each PTI has its own Replication segment and a unique Replication-SID at a given node in the SR domain. NEW: Therefore, each PTI has its own Replication segment and a unique Replication-SID in the data plane at a given node in the SR domain. With the above changes, I approve the document. Thank you, Rishabh. From: Jeffrey (Zhaohui) Zhang <zzhang=40juniper.net@dmarc.ietf.org> Date: Tuesday, April 28, 2026 at 10:11 AM To: Alanna Paloma <apaloma@staff.rfc-editor.org>, Hooman Bidgoli (Nokia) <hooman.bidgoli@nokia.com>, Dan Voyer (davoyer) <davoyer@cisco.com> Cc: Gunter van de Velde (Nokia) <gunter.van_de_velde@nokia.com>, Rishabh Parekh <rishabh@arrcus.com>, Clarence Filsfils (cfilsfil) <cfilsfil@cisco.com>, rfc-editor@rfc-editor.org <rfc-editor@rfc-editor.org>, pim-ads@ietf.org <pim-ads@ietf.org>, pim-chairs@ietf.org <pim-chairs@ietf.org>, mmcbride7@gmail.com <mmcbride7@gmail.com>, auth48archive@rfc-editor.org <auth48archive@rfc-editor.org> Subject: RE: AUTH48: RFC-to-be 9960 <draft-ietf-pim-sr-p2mp-policy-22> for your review [https://members.ironscales.com/static/webapp/images/iron_icon_color_7_2021.png] IRONSCALES couldn't recognize this email as this is the first time you received an email from this sender zzhang=40juniper.net @ dmarc.ietf.org Hi Alanna, In the following paragraph, PTIs are instantiated using Replication segments. Section 2 of [RFC9524] specifies the Replication-ID of the Replication segment identifier Replication-SID tuple as a variable length field that can be modified as required based on the use of a Replication segment. However, length is an imprecise indicator of the actual structure of the Replication- ID. Replication-ID. This document updates the Replication-ID of a Replication segment identifier Replication-SID [RFC9524] to be the tuple: <Root, Tree-ID, Instance-ID, Node-ID>, where <Root, Tree-ID> identifies the SR P2MP Policy and Instance-ID identifies the PTI within that SR P2MP Policy. This results in the Replication segments used to instantiate a PTI being identified by the tuple: <Root, Tree-ID, Instance-ID, Node-ID>. In the simplest case, the Replication-ID of a Replication segment is a 32-bit number as per Section 2 of [RFC9524]. For this use case, [RFC9524] for which the Root MUST be zero (0.0.0.0 for IPv4 and :: for IPv6) and IPv6), the Instance-ID MUST be zero zero, and the 32-bit Tree-ID to effectively make the Replication segment identifier Replication-SID <[0.0.0.0 or ::], Tree-ID, 0, Node- ID>. Node-ID>. I don’t think we should change Replication Segment Identifier to Replication-SID. The reason is that Replication Segment Identifier is a control plane identifier, and it is a tuple. Replication-SID, on the other hand, typically refers to a forwarding plane identifier, e.g., a label, an IPv6 address, or an SRv6 uSID. Using Replication-SID is misleading here. Other than that, I approve the document. Thanks. Jeffrey -----Original Message----- From: Alanna Paloma <apaloma@staff.rfc-editor.org<mailto:apaloma@staff.rfc-editor.org>> Sent: Monday, April 27, 2026 7:44 PM To: Hooman Bidgoli (Nokia) <hooman.bidgoli@nokia.com<mailto:hooman.bidgoli@nokia.com>>; Dan Voyer (davoyer) <davoyer@cisco.com<mailto:davoyer@cisco.com>> Cc: Gunter van de Velde (Nokia) <gunter.van_de_velde@nokia.com<mailto:gunter.van_de_velde@nokia.com>>; Rishabh Parekh <rishabh=40arrcus.com@dmarc.ietf.org<mailto:rishabh=40arrcus.com@dmarc.ietf.org>>; Clarence Filsfils (cfilsfil) <cfilsfil@cisco.com<mailto:cfilsfil@cisco.com>>; Jeffrey (Zhaohui) Zhang <zzhang@juniper.net<mailto:zzhang@juniper.net>>; rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org>; pim-ads@ietf.org<mailto:pim-ads@ietf.org>; pim-chairs@ietf.org<mailto:pim-chairs@ietf.org>; mmcbride7@gmail.com<mailto:mmcbride7@gmail.com>; auth48archive@rfc-editor.org<mailto:auth48archive@rfc-editor.org> Subject: Re: AUTH48: RFC-to-be 9960 <draft-ietf-pim-sr-p2mp-policy-22> for your review Hi Dan and Hooman, Thank you for your approvals. They have been noted here: https://urldefense.com/v3/__https://www.rfc-editor.org/auth48/rfc9960__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdEaIgI4A$<https://urldefense.com/v3/__https:/www.rfc-editor.org/auth48/rfc9960__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdEaIgI4A$> We will await approvals from Rishabh, Clarence, and Zhaohui prior to moving this document forward in the publication process. Best regards, Alanna Paloma RFC Production Center > On Apr 27, 2026, at 1:46 PM, Hooman Bidgoli (Nokia) <hooman.bidgoli@nokia.com<mailto:hooman.bidgoli@nokia.com>> wrote: > > Approved > From: Dan Voyer (davoyer) <davoyer@cisco.com<mailto:davoyer@cisco.com>> > Sent: Monday, April 27, 2026 2:19 PM > To: Alanna Paloma <apaloma@staff.rfc-editor.org<mailto:apaloma@staff.rfc-editor.org>>; Gunter van de Velde > (Nokia) <gunter.van_de_velde@nokia.com<mailto:gunter.van_de_velde@nokia.com>>; Rishabh Parekh > <rishabh=40arrcus.com@dmarc.ietf.org<mailto:rishabh=40arrcus.com@dmarc.ietf.org>>; Clarence Filsfils (cfilsfil) > <cfilsfil@cisco.com<mailto:cfilsfil@cisco.com>>; Hooman Bidgoli (Nokia) > <hooman.bidgoli@nokia.com<mailto:hooman.bidgoli@nokia.com>>;zzhang@juniper.net > Cc: rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org>; pim-ads@ietf.org<mailto:pim-ads@ietf.org>; pim-chairs@ietf.org<mailto:pim-chairs@ietf.org>; > mmcbride7@gmail.com<mailto:mmcbride7@gmail.com>; auth48archive@rfc-editor.org<mailto:auth48archive@rfc-editor.org> > Subject: Re: [AD] AUTH48: RFC-to-be 9960 <draft-ietf-pim-sr-p2mp-policy-22> for your review > CAUTION: This is an external email. Please be very careful when clicking links or opening attachments. See the URL nok.it/ext for additional information. > yes, approved ! > Dan > From: Alanna Paloma <apaloma@staff.rfc-editor.org<mailto:apaloma@staff.rfc-editor.org>> > Date: Friday, April 24, 2026 at 1:49 PM > To: gunter.van_de_velde@nokia.com<gunter.van_de_velde@nokia.com<mailto:gunter.van_de_velde@nokia.com%3cgunter.van_de_velde@nokia.com>>; > Rishabh Parekh <rishabh=40arrcus.com@dmarc.ietf.org<mailto:rishabh=40arrcus.com@dmarc.ietf.org>>; Dan Voyer > (davoyer) <davoyer@cisco.com<mailto:davoyer@cisco.com>>; Clarence Filsfils (cfilsfil) > <cfilsfil@cisco.com<mailto:cfilsfil@cisco.com>>;hooman.bidgoli@nokia.com > <hooman.bidgoli@nokia.com<mailto:hooman.bidgoli@nokia.com>>;zzhang@juniper.net <zzhang@juniper.net<mailto:zzhang@juniper.net>> > Cc: rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org> <rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org>>; > pim-ads@ietf.org<pim-ads@ietf.org<mailto:pim-ads@ietf.org%3cpim-ads@ietf.org>>; pim-chairs@ietf.org<mailto:pim-chairs@ietf.org> > <pim-chairs@ietf.org<mailto:pim-chairs@ietf.org>>;mmcbride7@gmail.com <mmcbride7@gmail.com<mailto:mmcbride7@gmail.com>>; > auth48archive@rfc-editor.org<mailto:auth48archive@rfc-editor.org> <auth48archive@rfc-editor.org<mailto:auth48archive@rfc-editor.org>> > Subject: Re: [AD] AUTH48: RFC-to-be 9960 > <draft-ietf-pim-sr-p2mp-policy-22> for your review Hi Authors and > Gunter (AD)*, > > *Gunter - As the AD, please review and approve of the updated and added text in Section 4.2 in the diff file below: > > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960> > -auth48diff.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pK > SinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzfnQx7WmA$ > > > Authors - Thank you for your reply. We have updated as requested. > > The files have been posted here (please refresh): > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960> > .txt__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1 > SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIze7VnIi0g$ > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960> > .pdf__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1 > SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzeTAg4lGQ$ > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960> > .html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC > 1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdenc1RLA$ > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960> > .xml__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1 > SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdk8XdyGQ$ > > The relevant diff files are posted here: > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960> > -diff.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyL > OwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzeaiXWREw$ (comprehensive diff) > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960> > -auth48diff.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pK > SinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzfnQx7WmA$ (all AUTH48 > changes) > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960> > -auth48rfcdiff.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk3 > 3pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcunGg8ow$ (AUTH48 > changes side by side) > > Please review the document carefully as documents do not change once published as RFCs. > > We will await any further changes you may have and approvals from each author and *Gunter prior to moving forward in the publication process. > > Please see the AUTH48 status page for this document here: > https://urldefense.com/v3/__https://www.rfc-editor.org/auth48/rfc9960_<https://urldefense.com/v3/__https:/www.rfc-editor.org/auth48/rfc9960_> > _;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG- > oYt6UrDz7ZS9HjIXg6mnKp_yokIzdEaIgI4A$ > > Thank you, > Alanna Paloma > RFC Production Center > > > On Apr 20, 2026, at 7:57 PM, Rishabh Parekh <rishabh=40arrcus.com@dmarc.ietf.org<mailto:rishabh=40arrcus.com@dmarc.ietf.org>> wrote: > > > > Please fine the response inline @ [RP]. > > > > Thanks, > > Rishabh > > > > From: rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org> <rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org>> > > Date: Friday, April 17, 2026 at 3:15 PM > > To: Rishabh Parekh <rishabh@arrcus.com<mailto:rishabh@arrcus.com>>, > > davoyer@cisco.com<davoyer@cisco.com<mailto:davoyer@cisco.com%3cdavoyer@cisco.com>>, cfilsfil@cisco.com<mailto:cfilsfil@cisco.com> > > <cfilsfil@cisco.com<mailto:cfilsfil@cisco.com>>,hooman.bidgoli@nokia.com > > <hooman.bidgoli@nokia.com<mailto:hooman.bidgoli@nokia.com>>, zzhang@juniper.net<zzhang@juniper.net<mailto:zzhang@juniper.net%3czzhang@juniper.net>> > > Cc: rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org> <rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org>>, > > pim-ads@ietf.org<pim-ads@ietf.org<mailto:pim-ads@ietf.org%3cpim-ads@ietf.org>>, pim-chairs@ietf.org<mailto:pim-chairs@ietf.org> > > <pim-chairs@ietf.org<mailto:pim-chairs@ietf.org>>,mmcbride7@gmail.com > > <mmcbride7@gmail.com<mailto:mmcbride7@gmail.com>>,gunter.van_de_velde@nokia.com > > <gunter.van_de_velde@nokia.com<mailto:gunter.van_de_velde@nokia.com>>,auth48archive@rfc-editor.org > > <auth48archive@rfc-editor.org<mailto:auth48archive@rfc-editor.org>> > > Subject: Re: AUTH48: RFC-to-be 9960 > > <draft-ietf-pim-sr-p2mp-policy-22> for your review > > > > Authors, > > > > While reviewing this document during AUTH48, please resolve (as necessary) the following questions, which are also in the source file. > > > > 1) <!--[rfced] Should "(SR)" and "(P2MP)" be added to this > > document's title for consistency with the title in RFC-to-be 9961, > > or do you prefer the current form? > > > > Original: > > Segment Routing Point-to-Multipoint Policy > > > > Perhaps: > > Segment Routing (SR) Point-to-Multipoint (P2MP) Policy —> > > > > [RP] I prefer the current form because abbreviations in the title seem odd to me and both the abbreviations are introduced in the first sentence of the Abstract of the document. Maybe the same can be suggested to authors of RFC-to-be-9961. > > > > 2) <!-- [rfced] Please insert any keywords (beyond those that appear > > in the title) for use on https://urldefense.com/v3/__https://www.rfc-editor.org/search__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdUXBBb1Q$<https://urldefense.com/v3/__https:/www.rfc-editor.org/search__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdUXBBb1Q$> . > > —> > > > > [RP] SR Multicast, SRv6 Multicast > > > > > > 3) <!--[rfced] Please let us know how we may clarify this sentence. > > Does "stitched to one or more Replication segments..." refer to the > > "Root node" (option A) or to the "Replication segment" (option B)? > > Does "at" the Leaf nodes and intermediate Replication nodes mean > > "between"? > > > > Original: > > It consists of a Replication segment at the Root node, stitched to one > > or more Replication segments at Leaf nodes and intermediate > > Replication nodes. > > > > Perhaps A: > > It consists of a Replication segment at the Root node, which is stitched > > to one or more Replication segments between the Leaf nodes and intermediate > > Replication nodes. > > > > Perhaps B: > > It consists of a Replication segment at the Root node, and that > > Replication segment is stitched to one or more Replication segments > > between the Leaf nodes and intermediate Replication nodes. > > —> > > > > [RP] Option B is more clear. > > > > The sentence in the document is trying to describe the following in a concise manner: > > > > Replication segment at the Root node is stitched to one or more replication segments at intermediate Replication nodes, and these intermediate Replication segments are stitched to either the Replication segments of subsequent intermediate Replication nodes or the Replication segments at the Leaf nodes. Note that there can be arbitrary number of intermediate Replication nodes (and associated Replication segments) in the path from the Root node to a specific Leaf node. In the simplest case, the Replication segment at the Root node is stitched to the Replication segments at the Leaf nodes i.e. there are no intermediate Replication nodes. > > > > > > 4) <!--[rfced] We are having difficulty parsing the listed items in > > this sentence. To clarify, may we update as follows? > > > > Original: > > For this use case, the Root MUST be zero (0.0.0.0 for IPv4 and :: > > for IPv6) and the Instance-ID MUST be zero and the 32-bit Tree-ID > > effectively make the Replication segment identifier <[0.0.0.0 or > > ::], Tree-ID, 0, Node-ID>. > > > > Perhaps: > > For this use case, the Root MUST be zero (0.0.0.0 for IPv4 and :: > > for IPv6), the Instance-ID MUST be zero, and the 32-bit Tree-ID > > effectively makes the Replication segment identifier <[0.0.0.0 or > > ::], Tree-ID, 0, Node-ID>. > > —> > > > > [RP] I think the suggested change is clear, but I have another suggestion since “For this use case, …” is referring to the previous sentence and maybe these two sentences can be combined to further clarify the text. > > > > Section 2.3 > > > > OLD: > > In the simplest case, the Replication-ID of a Replication segment is a 32-bit number as per Section 2 of [RFC9524]. For this use case, the Root MUST be zero (0.0.0.0 for IPv4 and :: for IPv6) and the Instance-ID MUST be zero and the 32-bit Tree-ID effectively make the Replication segment identifier <[0.0.0.0 or ::], Tree-ID, 0, Node-ID>. > > > > NEW: > > In the simplest case, the Replication-ID of a Replication segment is a 32-bit number as per Section 2 of [RFC9524] for which the Root MUST be zero (0.0.0.0 for IPv4 and :: for IPv6), the Instance-ID MUST be zero, and the 32-bit Tree-ID to effectively make the Replication segment identifier <[0.0.0.0 or ::], Tree-ID, 0, Node-ID>. > > > > > > 5) <!--[rfced] FYI - To improve readability and avoid awkward > > hyphenation of the expansion "PHP" when followed by "like", we > > updated this text as shown below. > > > > Original: > > In SRv6 deployments, Replication segments of a PTI MUST be > > instantiated on Leaf nodes of the tree since PHP like behavior is not > > feasible because the Tree-SID is carried in IPv6 Destination Address > > field of outer IPv6 header. > > > > Current: > > In SRv6 deployments, Replication segments of a PTI MUST be > > instantiated on Leaf nodes of the tree since behavior like Penultimate > > Hop Popping (PHP) is not feasible because the Tree-SID is carried in IPv6 > > Destination Address field of outer IPv6 header. > > —> > > > > [RP] This change is fine. > > > > > > 6) <!--[rfced] We are having difficulty understanding how "to the > > common downstream node of these Replication segments" fits into this sentence. > > Please review and let us know what updates may be made for clarity. > > > > Original: > > A shared Replication segment can protect > > Replication segments of different PTIs against an adjacency or path > > failure to the common downstream node of these Replication segments. > > —> > > > > [RP] I think changing “.. the common downstream node ..” to “.. a common downstream node ..” should make this clear, but I have a more verbose suggestion below for clarity, but this does change the text. > > > > Section 4.2 > > > > OLD: > > A shared Replication segment can protect > > Replication segments of different PTIs against an adjacency or path > > failure to the common downstream node of these Replication segments. > > > > NEW: > > Assume a Replication node, say node X, with multiple PTIs. Assume the Replications segments of these PTIs replicate to a downstream node, say node Y, amongst other downstream nodes. This node Y is a common downstream node of these Replication segments at node X. A Replication segment is established to protect the adjacency or path between node X and node Y; this Replication segment can be shared across all the Replication segments of the PTIs replicating from node X to node Y. > > > > > > > > 7) <!--[rfced] Is SRv6 replication intended for one downstream node > > or multiple downstream nodes? > > > > Original: > > For details of SRv6 replication to non-adjacent downstream node and IPv6 > > Hop Limit considerations, refer to Section 2.2 of [RFC9524]. > > > > Perhaps A (singular): > > For details of SRv6 replication to a non-adjacent downstream node and IPv6 > > Hop Limit considerations, refer to Section 2.2 of [RFC9524]. > > > > Perhaps B (plural): > > For details of SRv6 replication to non-adjacent downstream nodes and IPv6 > > Hop Limit considerations, refer to Section 2.2 of [RFC9524]. > > —> > > > > [RP] Option A (singular) is appropriate here since the whole paragraph is about a single replication between a pair of nodes. > > > > > > 8) <!--[rfced] We note 80 instances of "SR P2MP Policy" but only two > > instances of "SR P2MP". Are the two instances of "SR P2MP" okay as > > is, or is an update needed for consistency? > > > > Current: > > * Capability Exchange: A controller discovers a node's capability to > > participate in SR P2MP as well as advertise its capability to > > support SR P2MP. > > > > Perhaps: > > * Capability Exchange: A controller discovers a node's capability to > > participate in an SR P2MP Policy as well as advertise its capability > > to support the SR P2MP Policy. > > —> > > > > [RP] The suggested change is fine. > > > > > > 9) <!--[rfced] We are having difficulty parsing "globally > > significant the SR domain any it may get depleted if significant > > number of PTIs" in the sentence below. Please review and let us know > > how this text may be updated for clarity. > > > > Original: > > It is NOT RECOMMENDED to allocate a Replication-SID from the SRBG > > since this block is globally significant the SR domain any it may > > get depleted if significant number of PTIs are instantiated in the > > SR domain. > > > > Perhaps: > > It is NOT RECOMMENDED to allocate a Replication-SID from the SRGB > > since this block is globally significant to the SR domain and it > > may get depleted if a significant number of PTIs are instantiated > > in the SR domain. > > —> > > > > [RP] I think “in” is better than “to” above, so the updated text should be: > > > > NEW: > > It is NOT RECOMMENDED to allocate a Replication-SID from the SRGB > > since this block is globally significant in the SR domain and it > > may get depleted if a significant number of PTIs are instantiated > > in the SR domain. > > > > BTW, the “Original” text snippet above has “SRBG” which is NOT in the original text. I hope this is a type since the original text has SRGB (which is the correct abbreviation). > > > > > > > > 10) <!--[rfced] To improve readability, may we update the second sentence as follows? > > > > Original: > > Some security > > considerations for Replication segments outlined in [RFC9524] are > > also applicable to this document. Following is a brief reminder of > > the same. > > > > Perhaps: > > Some security > > considerations for Replication segments outlined in [RFC9524] are > > also applicable to this document. Following is a brief reminder of > > those security considerations. > > —> > > > > [RP] Yes, this is fine. > > > > > > 11) <!--[rfced] FYI - We have updated "to implement BCP 38 > > [RFC2827]" as shown below for clarity. Please review and let us know > > of any objections. > > > > Original: > > Failure to protect the SRv6 domain with inbound Infrastructure Access > > Control Lists (IACLs) on external interfaces, combined with failure > > to implement BCP 38 [RFC2827] or apply IACLs on nodes provisioning > > SIDs, permits attackers from outside the SR domain to send packets to > > the receivers of Multi-point services that use the SR P2MP Policies > > provisioned within the domain. > > > > Current: > > Failure to protect the SRv6 domain with inbound Infrastructure Access > > Control Lists (IACLs) on external interfaces, combined with failure > > to implement the method described in RFC2827 [BCP38] or apply IACLs on > > nodes provisioning SIDs, permits attackers from outside the SR domain to > > send packets to the receivers of multipoint services that use the SR P2MP > > Policies provisioned within the domain. > > —> > > > > [RP] Yes, this change is fine. > > > > > > 12) <!--[rfced] To reflect the text in RFC 9524, may we update this > > sentence as follows? > > > > Original: > > For SRv6, [RFC9524] describes an exception for Parameter Problem > > Message, code 2 ICMPv6 Error messages. > > > > Perhaps: > > For SRv6, [RFC9524] describes an exception for the ICMPv6 Parameter Problem > > message with Code 2. > > —> > > > > [RP] This change is fine. > > > > > > 13) <!--[rfced] We are having difficulty understanding "one of IGP > > ECMP nexthops towards R7". How should this text be clarified? > > > > Original: > > For replication to R7, R2 performs a PUSH operation of N-SID7, to > > send <N-SID7,T-SID1> label stack to R4, one of IGP ECMP nexthops > > towards R7. > > > > Perhaps: > > For replication to R7, R2 performs a PUSH operation of N-SID7 to > > send the <N-SID7,T-SID1> label stack to R4, which is an IGP ECMP > > next hop towards R7. > > —> > > > > [RP] I have a slightly different suggestion > > > > NEW: > > For replication to R7, R2 performs a PUSH operation of N-SID7 to > > send the <N-SID7,T-SID1> label stack to R4, which is one of the IGP ECMP > > next hops (R5 is other) towards R7. > > > > > > > > 14) <!-- [rfced] Throughout the text, the following terminology > > appears to be used inconsistently. Please review these occurrences > > and let us know if/how they may be made consistent. > > > > a) SR domain (26) vs. SR MPLS domain (1) > > > > Note: is "SR MPLS domain" different than "SR domain"? > > If not, should "MPLS" be removed for consistency? > > > > Current: > > Failure to protect the SR MPLS domain by correctly provisioning MPLS > > support per interface permits attackers from outside the domain to > > send packets to receivers of the multipoint services that use the SR > > P2MP Policies provisioned within the domain. > > > > b) SR P2MP Policy (72) vs. SR Policy (4) —> > > > > [RP] > > > > • SR-MPLS is specialized deployment of SR with MPLS data plane. SR domain is a more general (covering both SR-MPLS and SRv6). To fix this, please change the singular occurrence of “SR MPLS domain” to “SR-MPLS domain" > > > > NEW: > > Failure to protect the SR-MPLS domain by correctly provisioning MPLS > > support per interface permits attackers from outside the domain to > > send packets to receivers of the multipoint services that use the SR > > P2MP Policies provisioned within the domain. > > > > b) SR Policy [RFC 9256] is distinct from SR P2MP Policy described in this document. I have reviewed occurrences of “SR Policy” (exact case) and all are correct and must be retained EXCEPT one occurrence below. > > > > Section 3 > > > > OLD: > > The BSID is used to steer traffic into an SR Policy, as described below, when the Root > > node is not the ingress node of the SR domain where the traffic arrives. > > > > NEW: > > The BSID is used to steer traffic into an SR P2MP Policy, as described below, when the Root > > node is not the ingress node of the SR domain where the traffic arrives. > > > > > > 15) <!-- [rfced] Abbreviations > > a) FYI - We have added expansions for the following abbreviations > > per Section 3.6 of RFC 7322 ("RFC Style Guide"). Please review each > > expansion in the document carefully to ensure correctness. > > locator (LOC) > > Path Computation Element Communication Protocol (PCEP) Penultimate > > Hop Popping (PHP) Regional Internet Registry (RIR) Replication > > segment identifier (Replication-SID) Topology Independent Loop-Free > > Alternate (TI-LFA) > > b) As recommended in the Web Portion of the Style Guide > > <https://urldefense.com/v3/__https://www.rfc-editor.org/styleguide/p > > art2/*exp_abbrev__;Iw!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk > > 33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIze_ItQisA$ >, once > > an abbreviation is introduced, the abbreviated form should be used thereafter. Please consider if you would like to apply this style for the following terms: > > Binding SID (BSID) > > candidate path (CP) > > P2MP tree instance (PTI) > > Penultimate Hop Popping (PHP) > > Replication segment identifier (Replication-SID) Segment Routing > > (SR) —> > > > > [RP] > > • The expansion of the abbreviations are correct. However, when reviewing expansion of PCEP in below text, I see the reference abbreviation [SR-P2MP-PING] in text below: > > > > Section 5.5 > > > > NEW: > > After computing P2MP trees, the controller instantiates the > > Replication segments that compose the PTIs in the SR domain using > > signaling protocols such as the Path Computation Element > > Communication Protocol (PCEP) [SR-P2MP-PING], BGP [P2MP-BGP], or > > other mechanisms such as NETCONF/YANG [SR-P2MP-YANG], etc. > > > > The abbreviation should be [SR-P2MP-PCEP]. > > > > I think this is most likely due to below comment in the modified XML source of this document. > > > > <!-- [I-D.ietf-pce-sr-p2mp-policy] > > draft-ietf-pce-sr-p2mp-policy-14 > > IESG State: I-D Exists as of 04/16/26 > > * Note this draft is also part of C556 * —> > > > > The above comment is incorrect since draft-ietf-pce-sr-p2mp-policy is a PCE WG document which has NOT been reviewed by IESG yet and it NOT part of cluster C556. draft-ietf-pim-p2mp-policy-ping is the IESG reviewed document (I guess soon to be RFC 9661) in cluster C556, but this document does NOT have a reference to it. Please fix this. > > > > b) The abbreviations in the list can be used in the documented as per the style guide. > > > > 16) <!-- [rfced] Please review the "Inclusive Language" portion of > > the online Style Guide > > <https://urldefense.com/v3/__https://www.rfc-editor.org/styleguide/p > > art2/*inclusive_language__;Iw!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcheSipfg$ > and let us know if any changes are needed. Updates of this nature typically result in more precise language, which is helpful for readers. > > Note that our script did not flag any words in particular, but this > > should still be reviewed as a best practice. > > —> > > > > [RP] I reviewed the inclusive language style guidelines and I don't see any changes required. > > > > Thank you. > > Alanna Paloma and Karen Moore > > RFC Production Center > > > > > > On Apr 17, 2026, at 3:12 PM, rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org> wrote: > > *****IMPORTANT***** > > Updated 2026/04/17 > > RFC Author(s): > > -------------- > > Instructions for Completing AUTH48 > > Your document has now entered AUTH48. Once it has been reviewed and > > approved by you and all coauthors, it will be published as an RFC. > > If an author is no longer available, there are several remedies > > available as listed in the FAQ (https://urldefense.com/v3/__https://www.rfc-editor.org/faq/__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcoipPoeA$<https://urldefense.com/v3/__https:/www.rfc-editor.org/faq/__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcoipPoeA$> ). > > You and you coauthors are responsible for engaging other parties > > (e.g., Contributors or Working Group) as necessary before providing > > your approval. > > Planning your review > > --------------------- > > Please review the following aspects of your document: > > * RFC Editor questions > > Please review and resolve any questions raised by the RFC Editor > > that have been included in the XML file as comments marked as > > follows: > > <!-- [rfced] ... --> > > These questions will also be sent in a subsequent email. > > * Changes submitted by coauthors > > Please ensure that you review any changes submitted by your > > coauthors. We assume that if you do not speak up that you > > agree to changes submitted by your coauthors. > > * Content > > Please review the full content of the document, as this cannot > > change once the RFC is published. Please pay particular attention to: > > - IANA considerations updates (if applicable) > > - contact information > > - references > > * Copyright notices and legends > > Please review the copyright notice and legends as defined in > > RFC 5378 and the Trust Legal Provisions > > (TLP – https://urldefense.com/v3/__https://trustee.ietf.org/license-info__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcOzEAO0Q$<https://urldefense.com/v3/__https:/trustee.ietf.org/license-info__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcOzEAO0Q$> ). > > * Semantic markup > > Please review the markup in the XML file to ensure that elements of > > content are correctly tagged. For example, ensure that <sourcecode> > > and <artwork> are set correctly. See details at > > <https://urldefense.com/v3/__https://authors.ietf.org/rfcxml-vocabulary__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzfVYzmhKQ$ <https://urldefense.com/v3/__https:/authors.ietf.org/rfcxml-vocabulary__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzfVYzmhKQ$%20> >. > > * Formatted output > > Please review the PDF, HTML, and TXT files to ensure that the > > formatted output, as generated from the markup in the XML file, is > > reasonable. Please note that the TXT will have formatting > > limitations compared to the PDF and HTML. > > Submitting changes > > ------------------ > > To submit changes, please reply to this email using ‘REPLY ALL’ as > > all the parties CCed on this message need to see your changes. The > > parties > > include: > > * your coauthors > > * rfc-editor@rfc-editor.org<mailto:rfc-editor@rfc-editor.org> (the RPC team) > > * other document participants, depending on the stream (e.g., > > IETF Stream participants are your working group chairs, the > > responsible ADs, and the document shepherd). > > * auth48archive@rfc-editor.org<mailto:auth48archive@rfc-editor.org>, which is a new archival mailing list > > to preserve AUTH48 conversations; it is not an active discussion > > list: > > * More info: > > https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/ietf-announce/yb6lpIGh-4Q9l2USxIAe6P8O4Zc__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcQkPiuuQ$<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/ietf-announce/yb6lpIGh-4Q9l2USxIAe6P8O4Zc__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcQkPiuuQ$> > > * The archive itself: > > https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/browse/auth48archive/__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzeXNWV9Jw$<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/browse/auth48archive/__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzeXNWV9Jw$> > > * Note: If only absolutely necessary, you may temporarily opt out > > of the archiving of messages (e.g., to discuss a sensitive matter). > > If needed, please add a note at the top of the message that you > > have dropped the address. When the discussion is concluded, > > auth48archive@rfc-editor.org<mailto:auth48archive@rfc-editor.org> will be re-added to the CC list and > > its addition will be noted at the top of the message. > > You may submit your changes in one of two ways: > > An update to the provided XML file > > — OR — > > An explicit list of changes in this format Section # (or indicate > > Global) > > OLD: > > old text > > NEW: > > new text > > You do not need to reply with both an updated XML file and an > > explicit list of changes, as either form is sufficient. > > We will ask a stream manager to review and approve any changes that > > seem beyond editorial in nature, e.g., addition of new text, > > deletion of text, and technical changes. Information about stream > > managers can be found in the FAQ. Editorial changes do not require approval from a stream manager. > > Approving for publication > > -------------------------- > > To approve your RFC for publication, please reply to this email > > stating that you approve this RFC for publication. Please use > > ‘REPLY ALL’, as all the parties CCed on this message need to see your approval. > > Files > > ----- > > The files are available here: > > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960.xml__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdk8XdyGQ$<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960.xml__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdk8XdyGQ$> > > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdenc1RLA$<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdenc1RLA$> > > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960.pdf__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzeTAg4lGQ$<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960.pdf__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzeTAg4lGQ$> > > > > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc99<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc99> > > 60.txt__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOw > > LbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIze7VnIi0g$ > > Diff file of the text: > > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960-diff.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzeaiXWREw$<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960-diff.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzeaiXWREw$> > > > > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc9960-rfcdiff.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzfOKDjxSw$<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc9960-rfcdiff.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzfOKDjxSw$> (side by side) Diff of the XML: > > > > https://urldefense.com/v3/__https://www.rfc-editor.org/authors/rfc99<https://urldefense.com/v3/__https:/www.rfc-editor.org/authors/rfc99> > > 60-xmldiff1.html__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33 > > pKSinEyLOwLbC1SoiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzcQMrMLvQ$ > > Tracking progress > > ----------------- > > The details of the AUTH48 status of your document are here: > > > > https://urldefense.com/v3/__https://www.rfc-editor.org/auth48/rfc996<https://urldefense.com/v3/__https:/www.rfc-editor.org/auth48/rfc996> > > 0__;!!NEt6yMaO-gk!Esg0UtguSyeXdpf7Kqm5lUskN3Fb0SZtk33pKSinEyLOwLbC1S > > oiG-oYt6UrDz7ZS9HjIXg6mnKp_yokIzdEaIgI4A$ > > Please let us know if you have any questions. > > Thank you for your cooperation, > > RFC Editor > > -------------------------------------- > > RFC9960 (draft-ietf-pim-sr-p2mp-policy-22) > > Title : Segment Routing Point-to-Multipoint Policy > > Author(s) : R. Parekh, Ed., D. Voyer, Ed., C. Filsfils, H. Bidgoli, Z. Zhang > > WG Chair(s) : Stig Venaas, Mike McBride > > Area Director(s) : Jim Guichard, Ketan Talaulikar, Gunter Van de > > Velde [EXTERNAL] [EXTERNAL]
- [auth48] AUTH48: RFC-to-be 9960 <draft-ietf-pim-s… rfc-editor
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… rfc-editor
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Rishabh Parekh
- [auth48] Re: [AD] AUTH48: RFC-to-be 9960 <draft-i… Alanna Paloma
- [auth48] Re: [AD] AUTH48: RFC-to-be 9960 <draft-i… Gunter van de Velde (Nokia)
- [auth48] Re: [AD] AUTH48: RFC-to-be 9960 <draft-i… Alanna Paloma
- [auth48] Re: [AD] AUTH48: RFC-to-be 9960 <draft-i… Dan Voyer (davoyer)
- [auth48] Re: [AD] AUTH48: RFC-to-be 9960 <draft-i… Hooman Bidgoli (Nokia)
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Alanna Paloma
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Dan Voyer (davoyer)
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Jeffrey (Zhaohui) Zhang
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Rishabh Parekh
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Alanna Paloma
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Rishabh Parekh
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Alanna Paloma
- [auth48] Re: AUTH48: RFC-to-be 9960 <draft-ietf-p… Rishabh Parekh
- [auth48] Re: [AD] AUTH48: RFC-to-be 9960 <draft-i… Clarence Filsfils (cfilsfil)