[auth48] Re: Document intake questions about draft-ietf-teas-ietf-network-slice-nbi-yang

Sarah Tarrant <starrant@staff.rfc-editor.org> Tue, 26 May 2026 15:38 UTC

Return-Path: <starrant@staff.rfc-editor.org>
X-Original-To: auth48archive@mail2.ietf.org
Delivered-To: auth48archive@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 58F82F54BBDD for <auth48archive@mail2.ietf.org>; Tue, 26 May 2026 08:38:57 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1779809937; bh=zH9q5xnmT5jfQ9WAjaatjo60bk691gOVTpSpiTK0qtk=; h=Subject:From:In-Reply-To:Date:Cc:References:To; b=QKJG+7gpWtYKnBh2S8MOwDUUMdhtkVDCKWXFZfwlMpQG8S3K/gjSMPPGuJpUg4eUh 8sEo1aHSmdjb4RaYVSO3zz/dVxNYKNtn8YcEMRiS4NMQQP1KOwBR3vz0Cc7tQeD1uB oV3ehkm5CNowRG3GkLuqhmhXW1G9MkXW7sbYk834=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.9
X-Spam-Level:
X-Spam-Status: No, score=-1.9 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=staff-rfc-editor-org.20251104.gappssmtp.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Tnskb6Dld7pF for <auth48archive@mail2.ietf.org>; Tue, 26 May 2026 08:38:56 -0700 (PDT)
Received: from mail-ot1-x32b.google.com (mail-ot1-x32b.google.com [IPv6:2607:f8b0:4864:20::32b]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id C285EF54B94F for <auth48archive@rfc-editor.org>; Tue, 26 May 2026 08:36:29 -0700 (PDT)
Received: by mail-ot1-x32b.google.com with SMTP id 46e09a7af769-7de4a9cb8eeso9771813a34.0 for <auth48archive@rfc-editor.org>; Tue, 26 May 2026 08:36:29 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=staff-rfc-editor-org.20251104.gappssmtp.com; s=20251104; t=1779809789; x=1780414589; darn=rfc-editor.org; h=to:references:message-id:content-transfer-encoding:cc:date :in-reply-to:from:subject:mime-version:from:to:cc:subject:date :message-id:reply-to; bh=tyy9TNG8O/Fq7TXhqz4MjTdbukUhHBb37NOtkidVqRI=; b=H8DDvJPYnj0c0W4OhtMMKMw7E5Czw3pcTnP8ZzYxWqylPvDB8hIQvMSkuJdwfE4U0x QkZbB1wbTY5h0Wh6Q3haZD9avu+Bmf1VYs0ZFbz32aA+s12xt5Zi20hok0aOneAaOtQd PUMFeGcbZodTmFh69sSjVuoDy0KkiqT8gZxaA1ugV8QlDzNhlcC37gZUAkzX0uzT9oTX tYFWIDUolu5wrWZJ9m4hPqDI9dnVCpwPx1+0W6IBcuFa97gDbFxUFvxyYNUsAjAgJXxd wfGo8IalvBQ6D7OMSCLXUMpckq8S//xEVAXpmW8FVq8RQdDSaILtABbOlygG5xtrngyz W03g==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1779809789; x=1780414589; h=to:references:message-id:content-transfer-encoding:cc:date :in-reply-to:from:subject:mime-version:x-gm-gg:x-gm-message-state :from:to:cc:subject:date:message-id:reply-to; bh=tyy9TNG8O/Fq7TXhqz4MjTdbukUhHBb37NOtkidVqRI=; b=fjHMAeNwn/EgUoZKqKwwnFNc23l3YXoOQ1G5oxIWRtzcSOIhYGsOU/KSifNbS6H64S yI+qqhO5f91gjwnQ3y915uT/P3FW95XBwT23LMSRnwRFT6/QOWQaWvUPZtkpUPXRNgAW JfyZyBpD+aVWE9kWfqOtCP+y9Sd0SH1BUHpCr0U8irrCfvO9yW7ZIHaNFTJoaDIYPkYH UzHJ3wRXU6h/ypA8ESXOnj+sg2eQashZsDZqYDR8Tc0KxUW12gnOt0MBwRtxG4CadCTR 2Mwz48kCu45HmxArpxkFSPLxrE++tHIw7bmEhAgDdj63XIzd2Vn0N5Uml13GaCOwkJrK ZCyg==
X-Forwarded-Encrypted: i=1; AFNElJ+mS96YZS63UH7Y7u2wrmohypB0NJ8rdtt9PNfUS66t5rr2N1LznDLov087+o7am/g1UQij85uFpOVkuZof@rfc-editor.org
X-Gm-Message-State: AOJu0YzVi9XwYHhY6eI5PanujvdvSv54wjRHmfrYvt4Qs0NFsjGL3s7w dp/WK9d19oeTS26rQCJm0BfHoEtD4ZY4NYXVSWoR9/BbXOYC8xX3iSgHhiQZlfhFPU9o6Q==
X-Gm-Gg: Acq92OHp40jLljnUaFDvuYgFmWADZ2X7HSqiZIybZvMTgYRdV0j48g/DFdD+cNO6Xe+ yV4fvnyOhkZJ9DOTVcFrJHrQcNtPPKDMMWkKQyoWhYoZsi1XZopCXfAr2BGHe9jDpp6Qix/lq0E I61eOv+RyBO3iJVDvIuzYgO3/NEoSg23g5bdHNNdTcPvFPadoT24GvkYe4zYATbqN26iHx3h9p2 VHz96WtqmiNWPYHxKZHxF14414U5L472nRXLTucydAxyJSGD3ghLmkQxY707hzNbQ/ia1jwEFri 525ExPUIduOvpG22g4ZE0wC+VIWqOwUtuQxtHkbgmwh3rpNOieCcGNFO5DZ7HlLTbRTwcEFizg7 6l2JFohtssOhKY+EYJXZRhnhatSn7g9FmVqSiZZ29PqOPzGGblag4SAYNUEhi8qVp3FbZITPuV+ Z/DEChVwUNtS99vpo9Z3a0dXiW77VKCT9+fPq0Adpe6gmbUfpGVpfVq5bt
X-Received: by 2002:a05:6830:673a:b0:7dc:df37:844b with SMTP id 46e09a7af769-7e5fec68eb5mr12395347a34.4.1779809789112; Tue, 26 May 2026 08:36:29 -0700 (PDT)
Received: from smtpclient.apple ([47.214.52.136]) by smtp.gmail.com with ESMTPSA id 46e09a7af769-7e6065e7cb6sm9666510a34.16.2026.05.26.08.36.27 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Tue, 26 May 2026 08:36:28 -0700 (PDT)
Content-Type: text/plain; charset="utf-8"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3864.400.21\))
From: Sarah Tarrant <starrant@staff.rfc-editor.org>
In-Reply-To: <476f1032f39b4ed2bfe0b60b1fe461e2@huawei.com>
Date: Tue, 26 May 2026 10:36:17 -0500
Content-Transfer-Encoding: quoted-printable
Message-Id: <2E66C4D6-97D9-4112-BB9E-A706B2FEE1A0@staff.rfc-editor.org>
References: <177948224397.17.10942712238693796264@rfc-editor.org> <476f1032f39b4ed2bfe0b60b1fe461e2@huawei.com>
To: "Wubo (lana)" <lana.wubo=40huawei.com@dmarc.ietf.org>
X-Mailer: Apple Mail (2.3864.400.21)
Message-ID-Hash: 4M4KKGVDWV3QWQAAMDJPZHAJ54WFAI4Z
X-Message-ID-Hash: 4M4KKGVDWV3QWQAAMDJPZHAJ54WFAI4Z
X-MailFrom: starrant@staff.rfc-editor.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "rfc-editor@rfc-editor.org" <rfc-editor@rfc-editor.org>, "dd@dhruvdhody.com" <dd@dhruvdhody.com>, "rrokui@ciena.com" <rrokui@ciena.com>, "tsaad.net@gmail.com" <tsaad.net@gmail.com>, "jmullool@cisco.com" <jmullool@cisco.com>, "ketant.ietf@gmail.com" <ketant.ietf@gmail.com>, "vishnupavan.ietf@gmail.com" <vishnupavan.ietf@gmail.com>, "james.n.guichard@futurewei.com" <james.n.guichard@futurewei.com>, "gunter.van_de_velde@nokia.com" <gunter.van_de_velde@nokia.com>, "auth48archive@rfc-editor.org" <auth48archive@rfc-editor.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [auth48] Re: Document intake questions about draft-ietf-teas-ietf-network-slice-nbi-yang
List-Id: "Archiving AUTH48 exchanges between the RFC Production Center, the authors, and other related parties" <auth48archive.rfc-editor.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/auth48archive/UaCLizLaurFVFXFg_gS-RinIDi0>
List-Archive: <https://mailarchive.ietf.org/arch/browse/auth48archive>
List-Help: <mailto:auth48archive-request@rfc-editor.org?subject=help>
List-Owner: <mailto:auth48archive-owner@rfc-editor.org>
List-Post: <mailto:auth48archive@rfc-editor.org>
List-Subscribe: <mailto:auth48archive-join@rfc-editor.org>
List-Unsubscribe: <mailto:auth48archive-leave@rfc-editor.org>

Hi Bo,

Thank you for your reply.

Please go ahead and update the references and nits as you would like and upload the files to the datatracker as usual. However, there is no need to update the placeholder values at this time -- we will resolve those on our end.

Sincerely,
Sarah Tarrant
RFC Production Center

> On May 26, 2026, at 3:16 AM, Wubo (lana) <lana.wubo=40huawei.com@dmarc.ietf.org> wrote:
> 
> Dear RPC team,
> 
> Thank you for adding our draft to the RFC Editor queue. 
> On behalf of the authors, please find our response inline to the questions.
> We have reviewed the current version (–25) and confirm some references need updates to RFC publication and some minor nits (e.g. stale copyright ) need to be fixed. Should we update now or later in the further stage?
> 
> Thanks,
> Bo (On behalf of the authors)
> 
> -----Original Message-----
> From: rfc-editor@rfc-editor.org <rfc-editor@rfc-editor.org> 
> Sent: Saturday, May 23, 2026 4:37 AM
> To: Wubo (lana) <lana.wubo@huawei.com>; dd@dhruvdhody.com; rrokui@ciena.com; tsaad.net@gmail.com; jmullool@cisco.com
> Cc: ketant.ietf@gmail.com; vishnupavan.ietf@gmail.com; james.n.guichard@futurewei.com; gunter.van_de_velde@nokia.com; rfc-editor@rfc-editor.org; auth48archive@rfc-editor.org
> Subject: Document intake questions about draft-ietf-teas-ietf-network-slice-nbi-yang
> 
> Author(s), 
> 
> Congratulations, your document has been successfully added to the RFC Editor queue!  
> The team at the RFC Production Center (RPC) is looking forward to working with you as your document moves forward toward publication. To help reduce processing time and improve editing accuracy, please respond to the questions below. Please confer with your coauthors (or authors of other documents if your document is in a
> cluster) as necessary prior to taking action in order to streamline communication. 
> If your document has multiple authors, only one author needs to reply to this message.
> 
> As you read through the rest of this email:
> 
> * If you need/want to make updates to your document, we encourage you to make those changes and resubmit to the Datatracker. This allows for the easy creation of diffs, which facilitates review by interested parties (e.g., authors, ADs, doc shepherds).
> * If you feel no updates to the document are necessary, please reply with any applicable rationale/comments.
> 
> 
> Please note that the RPC team will not work on your document until we hear from you (that is, your document will remain in AUTH state until we receive a reply). Even if you don't have guidance or don't feel that you need to make any updates to the document, you need to let us know. After we hear from you, your document will start moving through the queue. You will be able to review and approve our updates during AUTH48.
> 
> Please feel free to contact us with any questions you may have at rfc-editor@rfc-editor.org.
> 
> Thank you!
> The RPC Team
> 
> --
> 
> 1) As there may have been multiple updates made to the document during Last Call, please review the current version of the document: 
> 
> * Is the text in the Abstract still accurate?
> * Are the Authors' Addresses, Contributors, and Acknowledgments sections current?
> [Bo Wu] The Abstract remains correct and consistent with the document body. The draft defines the ietf-network-slice-service YANG module, which is a customer-service model for the RFC 9543 Network Slice Service interface, as intended.
> And I confirmed Authors' Addresses, Contributors, and Acknowledgments sections current and complete.
> 
> 
> 2) Please share any style information that could help us with editing your 
> document. For example:
> 
> * Is your document's format or its terminology based on another document, 
> WG style guide, etc.? If so, please provide a pointer to that information 
> (e.g., "This document's terminology should match DNS terminology in 
> RFC 9499." or "This document uses the style info at 
> <https://httpwg.org/admin/editors/style-guide>.").
> * Is there a general pattern of capitalization or formatting of terms that 
> editors can follow (e.g., "Field names should have initial capitalization." 
> or  "Parameter names should be in double quotes." or "<tt/> should be used 
> for token names." etc.)?
> [Bo Wu] This document's terminology should match Network Slice terminology in 
> RFC 9543. Specifically, terms such as Network Slice Service, Service Demarcation Point (SDP), Connectivity Construct (CC), Service Level Objective (SLO), and Service Level Expectation (SLE) are defined in Section 3.2 and Section 5.1 of RFC 9543. This document uses "Network Slice Service" (without the "IETF" prefix) for brevity, as noted in Section 1.
> 
> 3) Please carefully review the entries and their URLs in the
> References section with the following in mind. Note that we will 
> update as follows unless we hear otherwise at this time:
> 
> * References to obsoleted RFCs will be updated to point to the current 
> RFC on the topic in accordance with Section 4.8.6 of RFC 7322 
> (RFC Style Guide).
> 
> * References to I-Ds that have been replaced by another I-D will be 
> updated to point to the replacement I-D.
> [Bo Wu] RFC 6991 is obsolete and has been replaced by: RFCRFC9911. We will update.
> * References to documents from other organizations that have been 
> superseded will be updated to their superseding version.
> 
> Note: To check for outdated RFC and I-D references, you can use 
> idnits <https://author-tools.ietf.org/idnits>. You can also help the
> IETF Tools Team by testing idnits3 <https://author-tools.ietf.org/idnits3/>
> with your document and reporting any issues to them.
> [Bo Wu] We have carefully reviewed the References section and confirm the following:
> The draft reference draft-ietf-opsawg-teas-attachment-circuit (version 20) is stale. It was replaced by rfc9834 (version rfc9834).
> The draft reference draft-ietf-opsawg-teas-common-ac (version 15) is stale. It was replaced by rfc9833 (version rfc9833).
> The draft reference draft-ietf-netmod-rfc8407bis (version 24) is stale. It was replaced by draft-ietf-netmod-rfc8407bis (version 28) and rfc9907 (version rfc9907).
> The copyright year in the IETF Trust and authors Copyright Line does not match the current year
> The YANG module contains a stale license declaration.
> Domain "foo.com" is not an allowed reserved domain. Use ".example.(com|org|net)" instead.
> BCP14->BCP 14
> 
> 4) Is there any text that requires special handling? For example:
> * Are there any sections that were contentious when the document was drafted?
> [Bo Wu] There are no contentious sections remaining. The document has completed WG Last Call, multiple directorate reviews (rtgdir, opsdir, secdir, tsvdir, genart), and IESG review without outstanding objections. All previous issues were resolved during the review process.
> * Are any sections that need to be removed before publication marked as such 
> (e.g., Implementation Status sections (per RFC 7942)).
> [Bo Wu] Section 1 (Introduction) contains an "Editorial Note: (To be removed by RFC Editor)" that explicitly lists the placeholder substitutions (AAAA → RFC number, BBBB → RFC number, etc.) and the YANG module revision date update. This section must be removed before publication.
> There is no Implementation Status section in this document. Per RFC 7942, this is not required.
> 
> * Are there any instances of repeated text/sections that should be edited 
> the same way?
> [Bo Wu] Except the Security Consideration, YANG module header, Placeholder patterns, we confirm that no other special handling is required.
> 
> 5) This document contains sourcecode: 
> 
> * Does the sourcecode validate?
> [Bo Wu] Yes, the YANG module validates successfully.
> The document contains one primary YANG module: ietf-network-slice-service@2025-05-09.yang. 
> This module has been validated using standard YANG validation tools (e.g., pyang, yanglint) during WG Last Call and directorate reviews and no validation errors are present in the final version.
> 
> * Some sourcecode types (e.g., YANG) require certain references and/or text 
> in the Security Considerations section. Is this information correct?
> [Bo Wu] The module uses placeholder values (AAAA, BBBB, CCCC, DDDD) for RFC numbers of documents that are part of the same cluster or completed publication. 
> These are addressed in the Editorial Note. Can we resolve this now or later during AUTH48? 
> AAAA --> the assigned RFC value for this draft both in this draft
>      and in the YANG models under the revision statement
> BBBB --> the assigned RFC value for
>      [I-D.ietf-opsawg-teas-common-ac] -> Published as RFC 9833
> CCCC --> the assigned RFC value for
>      [I-D.ietf-opsawg-teas-attachment-circuit] -> Published as RFC 9834
> DDDD --> the assigned RFC value for [I-D.ietf-teas-rfc8776-update]
> 
> For YANG-specific Security Considerations references, we confirmed correct and complete.
> But we need to update draft-ietf-netmod-rfc8407bis to published RFC 9907.
> 
> * Is the sourcecode type indicated in the XML? (See information about 
> types: https://www.rfc-editor.org/rpc/wiki/doku.php?id=sourcecode-types.)
> [Bo Wu] Yes. The YANG module is properly enclosed in <CODE BEGINS> and <CODE ENDS>.
> 
> 
> 6) This document is part of Cluster 517:
> https://queue.rfc-editor.org/clusters/517/ 
> 
> * To help the reader understand the content of the cluster, is there a 
> document in the cluster that should be read first? Next? If so, please provide 
> the order and we will provide RFC numbers for the documents accordingly. 
> If order is not important, please let us know. 
> 
> [Bo Wu] We recommend the following sequence for readers to understand the cluster:
> First: draft-ietf-opsawg-teas-common-ac (A Common YANG Data Model for Attachment Circuits) - RFC 9833
> This provides the foundational common AC types and groupings used by all other documents in the cluster.
> Second: draft-ietf-opsawg-teas-attachment-circuit (YANG Data Models for Bearers and 'Attachment Circuits'-as-a-Service) - RFC 9834
> This defines the AC service model, which is referenced by the Network Slice Service model for SDP attachment circuit bindings.
> Third: draft-ietf-teas-rfc8776-update (Common YANG Data Types for Traffic Engineering)
> This provides updated TE common types used by this document (e.g., te-types:te-path-disjointness for path diversity constraints).
> Fourth: draft-ietf-teas-ietf-network-slice-nbi-yang (this document)
> This document builds upon the models above and defines the Network Slice Service YANG model.
> 
> 
> * Is there any text that has been repeated within the cluster document that 
> should be edited in the same way (for instance, parallel introductory text or 
> Security Considerations)?
> [Bo Wu] Yes, there are parallel structures that should be edited consistently:
> Security Considerations boilerplate: RFC 9907 (Guidelines for Authors and Reviewers of Documents Containing YANG Data Models)
> YANG module header/footer: All modules in the cluster contain similar copyright notices, revision statements, and RFC Editor notes as guided also by RFC 9907.
> Editorial Notes: These should be removed consistently at publication time.
> 
> * For more information about clusters, see: 
> https://authors.ietf.org/en/rfc-publication-process#clusters
> * For a list of all current clusters, see: 
> https://queue.rfc-editor.org/clusters/
> 
> 
> 7) Is there anything else that the RPC should be aware of while editing this 
> document?
> [Bo Wu] 
> a)This document uses four placeholder patterns that must be replaced consistently:
> AAAA → RFC number assigned to this document
> BBBB → RFC number for draft-ietf-opsawg-teas-common-ac -> published as RFC 9833
> CCCC → RFC number for draft-ietf-opsawg-teas-attachment-circuit -> published as RFC 9834
> DDDD → RFC number for draft-ietf-teas-rfc8776-update
> The YANG module's revision statement date (2025-05-09) and the reference text in the module description must also be updated to the final publication date
> b)And also I-D.ietf-netmod-rfc8407bis we referenced is published as RFC9907.
> YANG module filename:
> c)The <CODE BEGINS> tag includes the revision date in the filename (ietf-network-slice-service@2025-05-09.yang) If the publication date differs significantly, the filename in the code tag should be updated to match the final revision date in the module.
> d) JSON examples:Appendix B contains multiple JSON examples that use RFC 8792 line wrapping (indicated by \ line continuation). These are properly formatted and should render correctly in the final RFC