[calsify] Re: Short re-WGLC for draft-ietf-calext-ical-tasks
Michael Douglass <mikeadouglass@gmail.com> Wed, 23 October 2024 21:12 UTC
Return-Path: <mikeadouglass@gmail.com>
X-Original-To: calsify@ietfa.amsl.com
Delivered-To: calsify@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 2969BC14CF15 for <calsify@ietfa.amsl.com>; Wed, 23 Oct 2024 14:12:38 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.103
X-Spam-Level:
X-Spam-Status: No, score=-2.103 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_BLOCKED=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id bl9esYe5j1N1 for <calsify@ietfa.amsl.com>; Wed, 23 Oct 2024 14:12:34 -0700 (PDT)
Received: from mail-yw1-x1132.google.com (mail-yw1-x1132.google.com [IPv6:2607:f8b0:4864:20::1132]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 7F9CFC14F6EE for <calsify@ietf.org>; Wed, 23 Oct 2024 14:12:29 -0700 (PDT)
Received: by mail-yw1-x1132.google.com with SMTP id 00721157ae682-6e5e5c43497so1793967b3.3 for <calsify@ietf.org>; Wed, 23 Oct 2024 14:12:29 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1729717948; x=1730322748; darn=ietf.org; h=in-reply-to:from:content-language:references:to:subject:user-agent :mime-version:date:message-id:from:to:cc:subject:date:message-id :reply-to; bh=kEAYyRgkpopJ9TrLJ6SCrNtW+MC4OA05OajDE/1DCXs=; b=CpZ0ao4ix6OVCctqWwe8e/YD8Gkdka5GeugyLA6ZKI1K2sqB0ijVvGnXl+ZyG04cFV 1iua/eeiV6pXEEWW+t0eVoKIcV94v3L3TixbKeb/sHK8pOv6IsmcokXYify3F00VIFRR MT+CMadckLyJW/a1LHaTuASYooIHLBX9nXMNOWfwbv6/8dKM+dMnNIksNnjjRoRQjQj9 5ZRIezzh5RfksayFVii+QJw04lebsLng9ZQJPFj4PlRYrzepzyCQTFinIACmn7p5zVND QrocOCSSMf8uYWKeLFAbFOP3oeeGBBtwcesOUqT7sBMZvGo6pcUuybEwjv81s5yx5fxI W7vg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1729717948; x=1730322748; h=in-reply-to:from:content-language:references:to:subject:user-agent :mime-version:date:message-id:x-gm-message-state:from:to:cc:subject :date:message-id:reply-to; bh=kEAYyRgkpopJ9TrLJ6SCrNtW+MC4OA05OajDE/1DCXs=; b=XPnBGGN+twNJ329dnSB5b0rDxAbx/jrgn6rIkK2E3m3sjm9bApMhxSkuRuWqAX3ha6 lpWsL+1NrrfNMZPYnnTrGWVsdECyJWPtX4B7pfs9I02NK79YnC+bLw+3pWev1iz9HgA7 kIvg2KbOmGoMGULQmUKhoAe0asLk0HAUWO22uDmwdJp+LoNpnK+Tt84cUNj+jIWWNUJh YzmbNWevw68UMPB7iGvBUvwXkLgNNFo/fAI/2I0q+TRsYI5V7542pofYv1AFjY2NXPlz IWxOcNNBujCzS37hCtrZZtz7s+fvohx9a4947olvwFz/ecrn1IT9uxvdsqWMdMagA9aj Bnpg==
X-Forwarded-Encrypted: i=1; AJvYcCX1jkv3WN9LZxwMezHxHV6aB8Mry15XVxrcsrjgcMqADaBJaGlYqCIdDW2FBlRfE8Dg6SWigfoz@ietf.org
X-Gm-Message-State: AOJu0YxnUZASFTlS9rvxZGXi2X4n4zSeucuxAiO0e8g3u+gX5mFrnury Ga2s3+y113eS+0lpXw01wd65eSEVftL0Tuq+3s6cs9ZFu5GTvTRV
X-Google-Smtp-Source: AGHT+IEsYzJi/Onej1povaUZc1fjysdCSpVw+Z8V2lvUovHRel+Da9Lkz9/PBZ2X1+5SHagMk7GmQQ==
X-Received: by 2002:a05:690c:f09:b0:6e2:1467:17b4 with SMTP id 00721157ae682-6e7f0dbbf21mr44378937b3.9.1729717948176; Wed, 23 Oct 2024 14:12:28 -0700 (PDT)
Received: from [192.168.1.23] (syn-074-070-070-237.res.spectrum.com. [74.70.70.237]) by smtp.googlemail.com with ESMTPSA id d75a77b69052e-460d3cb62cbsm44716591cf.46.2024.10.23.14.12.27 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Wed, 23 Oct 2024 14:12:27 -0700 (PDT)
Content-Type: multipart/alternative; boundary="------------RUZzNnON0Yp82y6R1O0AP3W3"
Message-ID: <f336c38a-a549-4c22-92e6-7ad87aaa8a02@gmail.com>
Date: Wed, 23 Oct 2024 17:12:26 -0400
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: Bron Gondwana <brong@fastmailteam.com>, Robert Stepanek <rsto=40fastmailteam.com@dmarc.ietf.org>, calsify@ietf.org, Apthorp Adrian <adrian@apthorpia.com>
References: <60042a9f-1df2-4494-80f0-0f0605dfd0e0@app.fastmail.com> <e1b90618-794c-42ac-896f-2b5537441358@app.fastmail.com> <99e5c57d-bd91-4f96-8375-52eb7b5af29e@gmail.com> <01dd476a-f87a-4475-9a52-6e104d184933@app.fastmail.com> <6d26b205-6113-450f-aca9-0fd9c10be946@app.fastmail.com> <5ca7d64a-5d2c-4312-a114-6ff84d8f150e@app.fastmail.com>
Content-Language: en-US
From: Michael Douglass <mikeadouglass@gmail.com>
In-Reply-To: <5ca7d64a-5d2c-4312-a114-6ff84d8f150e@app.fastmail.com>
Message-ID-Hash: 5MLLULDN7H4XLHFJQICYPXESIE5UAQDJ
X-Message-ID-Hash: 5MLLULDN7H4XLHFJQICYPXESIE5UAQDJ
X-MailFrom: mikeadouglass@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-calsify.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [calsify] Re: Short re-WGLC for draft-ietf-calext-ical-tasks
List-Id: Calendaring and Scheduling Standards Simplification <calsify.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/calsify/lNigkMbGTw6G-ugTqJyzE4RVtbw>
List-Archive: <https://mailarchive.ietf.org/arch/browse/calsify>
List-Help: <mailto:calsify-request@ietf.org?subject=help>
List-Owner: <mailto:calsify-owner@ietf.org>
List-Post: <mailto:calsify@ietf.org>
List-Subscribe: <mailto:calsify-join@ietf.org>
List-Unsubscribe: <mailto:calsify-leave@ietf.org>
On 10/23/24 16:19, Bron Gondwana wrote:
> Thankfully I haven't submitted this yet! Should we add it on the
> agenda for CALEXT at IETF in 2 weeks' time?
>
> Mike - if you can merge in this and any other suggestions you've seen,
> we can hopefully get this thing done this year!
I shall do that.
Also we had a chat this morning and came up with some agenda items:
1. the iTip with participants spec
2a. Vpoll
2b. jsCalendar <-> iCalendar
The second 2 can be any order but it seemed to make sense to do #1 first
as the other 2 now depend on it to some extent.
>
> Bron.
>
> On Wed, Oct 23, 2024, at 08:40, Robert Stepanek wrote:
>> If there is still a chance, I would prefer for this RFC to update its
>> modification of the PARTICIPANT property in section 10:
>>
>> Currently, the PARTICIPANT component definition in RFC 9073, section
>> 7.1. does not explicitly mention the PERCENT-COMPLETE property (RFC
>> 5545, 3.8.1.8). As a consequence, a PARTICIPANT component may include
>> multiple PERCENT-COMPLETE properties. I think this is an oversight.
>> Just as the PARTICIPANT already is restricted to only have at most
>> one DTSTAMP property, it should also just allow one PERCENT-COMPLETE
>> property.
>>
>> As draft-ietf-calext-ical-tasks updates the VTODO-related semantics
>> of iCalendar and already includes a section that updates the
>> PARTICIPANT component definition, it looks to be the best place to
>> also add this requirement.
>>
>> On Thu, Oct 3, 2024, at 12:44 PM, Robert Stepanek wrote:
>>> The IANA registry item in section 17.1.6.
>>> <https://www.ietf.org/archive/id/draft-ietf-calext-ical-tasks-10.html#name-properties-registry>
>>> for the ESTIMATED-DURATION property is wrong:
>>>
>>> It registers "ESTIMATED_DURATION" but the name is
>>> "ESTIMATED-DURATION" (underscore vs hyphen).
>>>
>>> Cheers,
>>> Robert
>>>
>>> On Wed, Jul 31, 2024, at 5:07 AM, Michael Douglass wrote:
>>>>
>>>> Finally got round to this. Individual responses below and I've just
>>>> posted version 10
>>>>
>>>> Thank you.
>>>>
>>>> On 6/20/24 03:35, Robert Stepanek wrote:
>>>>> Overall critique:
>>>>>
>>>>> I stand by my critique that I also raised in my review of version
>>>>> 05
>>>>> <https://mailarchive.ietf.org/arch/msg/calsify/c48tM54VQvY5sOh-DToregJ01gk/>:
>>>>> I not only find the Architecture sections 2. to 4. unnecessary but
>>>>> even detrimental for this specification. The functional
>>>>> architecture for task management systems might better be defined
>>>>> in a separate document.
>>>>>
>>>>> I think that this specification would be simpler to read if it
>>>>> gets condensed to the actual changes it brings to iCalendar. It
>>>>> would benefit from being more in line with other RFCs that define
>>>>> iCalendar extensions, such as RFC 9073
>>>>> <https://www.rfc-editor.org/info/rfc9073>, RFC 9253
>>>>> <https://www.rfc-editor.org/info/rfc9253> or RFC 7953
>>>>> <https://www.rfc-editor.org/info/rfc7953> (all by the same authors
>>>>> as draft-ietf-calext-ical-tasks). These RFCs all define their
>>>>> content in terms of iCalendar, rather than introducing a new
>>>>> document structure, terminology and process model.
>>>>>
>>>>> This critique is not a veto, but rather a call for caution.
>>>>
>>>> Obviously I disagree. For newcomers to these specifications or to
>>>> those who view VTODO as only useful for reminders etc, these
>>>> sections show how the tasks component can be used.
>>>>
>>>>>
>>>>> -- Details and Nits:
>>>>>
>>>>> Abstract
>>>>>
>>>>> "Task" is used in the Abstract and Introduction before it is
>>>>> introduced as 'A "task" is a representation of an item of work
>>>>> assigned to an individual or organization'. The Abstract would be
>>>>> clearer if it already defines what kind of "tasks" this
>>>>> specification is all about.
>>>>
>>>> I sort of agree but I'm not sure I can get away without using the
>>>> word "task"
>>>>
>>>> I've replaced this:
>>>>
>>>> ----------------------- OLD
>>>>
>>>> This document updates and defines extensions to the Internet
>>>> Calendaring and Scheduling Core Object Specification (iCalendar)
>>>> (RFC5545) to provide improved status tracking, scheduling and
>>>> specification of tasks.
>>>>
>>>>
>>>> ----------------------------
>>>>
>>>> with this
>>>>
>>>> ----------------------- NEW
>>>>
>>>> The Internet Calendaring and Scheduling Core Object Specification
>>>> (iCalendar) (RFC5545) VTODO calendar component has been seen as the
>>>> poor relation of VEVENT - useful only for personal reminders and
>>>> to-do lists.
>>>>
>>>> This document updates and defines extensions to VTODO to provide
>>>> improved status tracking, scheduling and specification of tasks to
>>>> allow its use in pther contexts, such as process control and
>>>> project management.
>>>>
>>>>
>>>> -----------------------------
>>>>
>>>>
>>>>>
>>>>> Introduction
>>>>> Make "ad-hoc tasks in personal to-do- lists" also a bullet?
>>>>
>>>> I don't think so - the text reads
>>>>
>>>> Tasks can be identified in a number of situations, either informally as ad-hoc tasks in personal "to-do" lists or more formally in:
>>>>
>>>>
>>>> I think the point here is that ad-hoc tasks is th einformal
>>>> accepted usage and the others are example sof what we'd like to see.
>>>>
>>>>>
>>>>> 1.1 Terms and Definitions
>>>>> "All calendar components start with the letter "V"." Disputable,
>>>>> because the "PARTICIPANT" component of RFC 9073 does not start
>>>>> with "V".
>>>> True - we also have the AVAILABLE component. I made a significant
>>>> number of changes to try to make naming more consistent
>>>>>
>>>>> Properties defined by [RFC5545]: nit - this doesn't like look a
>>>>> properly formatted reference.
>>>> It wasn't - fixed
>>>>>
>>>>> "Resources can be of "Location", "Equipment", or "Role" type."
>>>>> Where is this enumeration defined? If it isn't defined in this
>>>>> specification, then restricting it to these three values might be
>>>>> incorrect now or in the future.
>>>> This was intended to point out that a resource may be of many
>>>> different types. Genrealised and removed some quotes.
>>>>>
>>>>> Section 9.1 and 9.2:
>>>>> Could the VSTATUS example be moved to section 9.1? Are both
>>>>> VSTATUS and PARTICIPANT/ATTENDEE necessary to be in the same
>>>>> example in section 9.2?
>>>> Split them up - was not intentional
>>>>>
>>>>> Section 9.1:
>>>>> "Note that while VSTATUS is intended to allow multiple
>>>>> date-stamped status changes to be stored it is not intended to be
>>>>> used as a history of changes to a tasks properties".
>>>>>
>>>>> I had to pause when I read this and its meaning only become more
>>>>> clear to me after having read section 9.2 to 9.3 and their
>>>>> examples. Maybe something like "instead, the purpose of VSTATUS is
>>>>> to document changes related to fulfilling the tasks" could help?
>>>>
>>>> I moved 9.2 to after the following subsection which I think helps
>>>> and moved the above modified text to the end of the "Comments
>>>> associated to reasons and status changes" section.
>>>>
>>>> ----------------------- OLD
>>>>
>>>> Note that while VSTATUS is intended to allow multiple date-stamped
>>>> status changes to be stored it is not intended to be used as a
>>>> history of changes to a tasks properties.
>>>>
>>>> ----------------------------
>>>>
>>>> ----------------------- NEW
>>>>
>>>>
>>>> Note that the "VSTATUS" calendar component not intended to be used
>>>> as a history of changes to a tasks properties. The purpose of
>>>> "VSTATUS" calendar component is only to document changes related to
>>>> fulfilling the tasks
>>>> ---------------------------
>>>>
>>>>
>>>>>
>>>>> Section 9.4:
>>>>> This section feels out of place, as it seems to be more related to
>>>>> the architecture than actual iCalendar changes. If I read this
>>>>> section correctly, it seems to say: "Everything that's required
>>>>> from iCalendar implementations already is supported (alarms,
>>>>> notifications) and the rest is out of scope (escalations)."
>>>> I'm not sure. Notifications and escalations are tightly related to
>>>> status changes and this section points out that some calendar
>>>> constructs (e.g. alarms) may not work as expected.
>>>>>
>>>>> Section 10:
>>>>> Maybe also mention RFC 9073 here, as it had added the
>>>>> "participantc *locationc *resourcec" components?
>>>> Done
>>>>>
>>>>> Section 12.1:
>>>>> Maybe explicitly require in Description that the duration MUST be
>>>>> zero or positive.
>>>>
>>>> We already have this:
>>>>
>>>> Purpose This property specifies the estimated positive duration of
>>>> time the corresponding task will take to complete.
>>>>
>>>>
>>>>>
>>>>> Section 12.3:
>>>>> Does SUBSTATE require a STATUS property to be present in the same
>>>>> component? I guess it should?
>>>> The VSTATUS definition in section 14.1 requires STATUS
>>>>>
>>>>> Section 12.4.:
>>>>> The line ";if all attendees have completed" in the ABNF seems out
>>>>> of place? Is it actually supposed to visually separate
>>>>> AUTOMATIC-COMPLETION from the rest of enumeration values?
>>>> Fixed
>>>>>
>>>>> The Examples section should go at the end of this section, not
>>>>> separate the paragraph introducing the enumeration values from
>>>>> their definitions.
>>>> Fixed
>>>>>
>>>>> What's supposed to happen if TASK-MODE is "CLIENT,SERVER"? Also,
>>>>> does "SERVER" have precedence over the "AUTOMATIC" values?
>>>>
>>>> Changed this. Property can only appear zero or once in VTODO. Only
>>>> a single value allowed. Added an extra value of "AUTOMATIC" which
>>>> does both completion and failure. Completion and failure imply CLIENT.
>>>>
>>>>
>>>> ----------------------- OLD
>>>>
>>>> Conformance This property can be specified zero or more times in a
>>>> "VTODO" calendar component.
>>>>
>>>> Format Definition This property is defined by the following
>>>> notation:
>>>>
>>>> task-mode = "TASK-MODE taskmodeparam ":" taskvalue
>>>> *("," taskvalue) CRLF
>>>>
>>>> taskvalue = "AUTOMATIC-COMPLETION" ; set STATUS completed
>>>> ;if all attendees have completed
>>>> / "AUTOMATIC-FAILURE"
>>>> / "SERVER"
>>>> / "CLIENT"
>>>> / iana-token
>>>> / x-name
>>>>
>>>> taskmodeparam = *(";" other-param)
>>>>
>>>>
>>>> -----------------------
>>>>
>>>> ----------------------- NEW
>>>>
>>>>
>>>> -----------------------
>>>>
>>>> Additionally this text has been removed
>>>>
>>>> -----------------------
>>>>
>>>> The server can add this property to a "VTODO" calendar component to indicate to
>>>> the client that it will be managing the status.
>>>>
>>>>
>>>> -----------------------
>>>>
>>>> and a statement that the default mode is "CLIENT" added. This
>>>> preserves the current state.
>>>>
>>>>
>>>>
>>>>
>>>>>
>>>>> Section 13.1:
>>>>> The first sentence and probably also the title should make clear
>>>>> this change only relates to VTODO.
>>>> Done
>>>>>
>>>>> _______________________________________________
>>>>> calsify mailing list --calsify@ietf.org <mailto:calsify@ietf.org>
>>>>> To unsubscribe send an email tocalsify-leave@ietf.org <mailto:calsify-leave@ietf.org>
>>>>>
>>>
>>> _______________________________________________
>>> calsify mailing list -- calsify@ietf.org
>>> To unsubscribe send an email to calsify-leave@ietf.org
>>>
>>
>> _______________________________________________
>> calsify mailing list -- calsify@ietf.org
>> To unsubscribe send an email to calsify-leave@ietf.org
>>
>
> --
> Bron Gondwana, CEO, Fastmail Pty Ltd
> brong@fastmailteam.com
>
>
- [calsify] Short re-WGLC for draft-ietf-calext-ica… Bron Gondwana
- [calsify] Re: Short re-WGLC for draft-ietf-calext… Robert Stepanek
- [calsify] Re: Short re-WGLC for draft-ietf-calext… Michael Douglass
- [calsify] Re: Short re-WGLC for draft-ietf-calext… Robert Stepanek
- [calsify] Re: Short re-WGLC for draft-ietf-calext… Robert Stepanek
- [calsify] Re: Short re-WGLC for draft-ietf-calext… Bron Gondwana
- [calsify] Re: Short re-WGLC for draft-ietf-calext… Michael Douglass
- [calsify] Re: Short re-WGLC for draft-ietf-calext… Bron Gondwana
- [calsify] Re: Short re-WGLC for draft-ietf-calext… Bron Gondwana