[CFRG] Re: [EXT] Re: Adoption Call: Sigma Protocols

Cathie Yun <cathieyun@gmail.com> Thu, 01 May 2025 00:39 UTC

Return-Path: <cathieyun@gmail.com>
X-Original-To: cfrg@mail2.ietf.org
Delivered-To: cfrg@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id DCCA3236A1E1 for <cfrg@mail2.ietf.org>; Wed, 30 Apr 2025 17:39:05 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id WH8v0IlM5HUA for <cfrg@mail2.ietf.org>; Wed, 30 Apr 2025 17:39:04 -0700 (PDT)
Received: from mail-lj1-x22f.google.com (mail-lj1-x22f.google.com [IPv6:2a00:1450:4864:20::22f]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 38A91236A1CE for <cfrg@irtf.org>; Wed, 30 Apr 2025 17:39:04 -0700 (PDT)
Received: by mail-lj1-x22f.google.com with SMTP id 38308e7fff4ca-30bef9b04adso3630171fa.1 for <cfrg@irtf.org>; Wed, 30 Apr 2025 17:39:04 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1746059943; x=1746664743; darn=irtf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=XSB81MWUU0vQQwChp2LB3jjbewLw/nK9t6bLJgecQ3A=; b=IaKz3IefQuPrVu0ysYqon7D1Imh1tE6NAqsGqct0uKg+LgD4hYc97rR8T7QipVjAKc tMvkvpHOPxc3Ioza+DT9qoEEMCiuN6yuiul+AzkzPen6h6OWfFtqxREV21dnX1R1cPAM 4UdHupuUU/F71HarEswxCW3Fw7NtvaZIN/NpTzYM6P6z4u8LS1PxHfc2opuYb2O9EVWr UEok0SEEWwxBUXocOfPYu7oBZHgxiWujExq9UbUEzjOyeob/zaH6mI9RDzL4RZdjdsvK 6aT7VZqgLFM5P2b9LU+dAgWx0WU5rDgfEaib2zukG3fciEoGbMJv0CH3jogxQr8e+oXk 1r9g==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1746059943; x=1746664743; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=XSB81MWUU0vQQwChp2LB3jjbewLw/nK9t6bLJgecQ3A=; b=HptEW0tVEIBOO4FbhX93JwlvFhM2sHqf+Tc1ybG0Ynomb+ihS4SUPW4T+/6HffzVEM eWA8bHfXB3HFYfhxWuz1xyI/oTrlIdaSMSiHuwB6FRc2qqgn+GH9UdQ46hYBwfhqn5hi GfSdGg6ehHCNKsneuUrC6MIbrJqe1tBju+d4X48aSLSxf94hekEnRau2u7FVaPPUaAfe 9dC/12po0b94giZeZHPs5hHkwWLdpbrNLMvgHDcnqWBaYObeVNLIxp8v7MHP0j4oeu3B fp0vObtQxNEBLUCZ5rNuI8cfiR8ndD7CK1HTIGtx/ptIsyO0u4F2i0lOeYfWf1mHVEBI u6iQ==
X-Forwarded-Encrypted: i=1; AJvYcCXvF7i+9SDyS3XBEPI4KXZBFGidIpkxZlcZmfbS5qwAVyQYPKoTrwRs4L1wDLADnCOmEpC2@irtf.org
X-Gm-Message-State: AOJu0YwFUuv/B/GtyHtNxOuZtzDfIME0cUcUR4Fbtr+CjaQ9t57W/u4c MaLidXOBoBmZEHto8dXTat/2xTR8AvR4jSRd02fIpz5kdDgCcfHJfl9y+G9E61sPGhz3vjGyRjF U2sVGtxA5O2PuLV8isD5BRphwURNLrDX5m/g=
X-Gm-Gg: ASbGncvFiS6K13nZu+mbLzPv7jgMR0QXYLSErqa8FjsioFhy2p1D7X9lgldp9lvpNJa D3kUR8jhVwSSW5vJoTacBsaRSOuet/QNrv7Qeu2b9ch3vb6ZBrw7tFvxgPcec3NVHsb0FZsBkAp 4w41lDST7wSoECajDrVgsDvJI=
X-Google-Smtp-Source: AGHT+IFil0Vhm8pSaYoXb0ECXka4J9SeEWmuhvKFUWpJDQfYu47oUEkglrGJuh0njsPhzTOPl6u0ETmJEv1ScVpbN0E=
X-Received: by 2002:a2e:a00e:0:20b0:31a:1e23:a46e with SMTP id 38308e7fff4ca-31e6a221be6mr10433251fa.14.1746059942431; Wed, 30 Apr 2025 17:39:02 -0700 (PDT)
MIME-Version: 1.0
References: <CAMr0u6mtvLBNnurVjw3rq5PmSF6okisAg5OVRzoqVvzpR7+r=A@mail.gmail.com> <CAG2Zi22Jx+-2LWgqezxs-=H+3nz8OOMJ1QDir7q0ToYk=8-AMQ@mail.gmail.com> <BN0P110MB14191EEB6F53C0B7D8D4E5719083A@BN0P110MB1419.NAMP110.PROD.OUTLOOK.COM>
In-Reply-To: <BN0P110MB14191EEB6F53C0B7D8D4E5719083A@BN0P110MB1419.NAMP110.PROD.OUTLOOK.COM>
From: Cathie Yun <cathieyun@gmail.com>
Date: Wed, 30 Apr 2025 17:38:50 -0700
X-Gm-Features: ATxdqUGSjMi1BHLkKZuHuYbB09OZe73nmHNzPb45xlKeIfib7O0xIN-OYPjdoe4
Message-ID: <CAExNBoAro5oj7DjuToZVt3VYzeCc8w2hiBouvHSrGdwXgkczQQ@mail.gmail.com>
To: "Blumenthal, Uri - 0553 - MITLL" <uri@ll.mit.edu>
Content-Type: multipart/alternative; boundary="000000000000a0133206340842f3"
Message-ID-Hash: PRHQEUZKPGKTY22YZEMMF443FURCJ2JZ
X-Message-ID-Hash: PRHQEUZKPGKTY22YZEMMF443FURCJ2JZ
X-MailFrom: cathieyun@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-cfrg.irtf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Christopher Patton <cpatton=40cloudflare.com@dmarc.ietf.org>, CFRG <cfrg@irtf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [CFRG] Re: [EXT] Re: Adoption Call: Sigma Protocols
List-Id: Crypto Forum Research Group <cfrg.irtf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/cfrg/i7aikxH28_HtpmWNhkVzZbEBUOk>
List-Archive: <https://mailarchive.ietf.org/arch/browse/cfrg>
List-Help: <mailto:cfrg-request@irtf.org?subject=help>
List-Owner: <mailto:cfrg-owner@irtf.org>
List-Post: <mailto:cfrg@irtf.org>
List-Subscribe: <mailto:cfrg-join@irtf.org>
List-Unsubscribe: <mailto:cfrg-leave@irtf.org>

It's awesome to see all this support and interest, thanks for the responses!

The sigma proofs construction maps almost exactly to the proof
constructions in existing drafts[1], where the proofs in those drafts are
wire-incompatible with the sigma spec not because of use case specific
optimizations, but mostly due to arbitrary decisions such as serialization
order.

To Bas and Christopher’s questions about adoption, the ARC draft
(draft-yun-cfrg-arc) plans to adopt the sigma protocol spec - Chris shared
this at the IETF122 meeting. The draft currently has its own schnorr
compiler[2] for creating the credential proofs, which is redundant with the
sigma spec. I think specs like this are a great example of where we can
promote reusability of cryptographic building blocks, in the same way we
have elliptic curve specs and not every cfrg draft has to define their own
elliptic curve within the draft.

Regarding the curve choice, we chose P384 out of an abundance of caution
(similar to Uri's reasoning), but are happy to support P256 if there is a
strong need / argument for it.

[1] 6 drafts (draft-yun-cfrg-arc, draft-irtf-cfrg-bbs-signatures,
draft-kalos-bbs-blind-signatures,
draft-irtf-cfrg-bbs-per-verifier-linkability, draft-ladd-privacypass-bbs)
and 2 RFCs (RFC8235, RFC9497) relying on Σ-protocols, all specified in
different ways.
[2]
https://chris-wood.github.io/draft-arc/draft-yun-cfrg-arc.html#name-schnorr-compiler

Thanks,
Cathie Yun


On Wed, Apr 30, 2025 at 12:02 PM Blumenthal, Uri - 0553 - MITLL <
uri@ll.mit.edu> wrote:

> That said, the draft itself is short and well-scoped. I support adoption
> on the basis that it will at the very least be an excellent informative
> reference for others.
>
>
>
> +1
>
>
>
> A quick question for the authors: Why start with P-384? Would P-256 have
> too low of a security margin? If so, what attack are we worried about?
>
>
>
> I personally would prefer implementing as few (different) hash-functions
> as practically possible. At least some applications/deployments/customers
> *require* SHA384 or SHA512. While there are applications for which SHA256
> is sufficient – including it would imply the need to implement *both*:
> SHA256 *and* SHA384. While requiring *only* SHA384 (or only SHA512) would
> ensure that all the needs are addressed.
>
>
>
> What do you think about starting with the recently published decaf448 doc
> (RFC 9496)?
>
>
>
> See above. 😉
>
>
>
> Thanks
>
>
>
>
>
> On Thu, Apr 17, 2025 at 11:31 PM Stanislav V. Smyshlyaev <
> smyshsv@gmail.com> wrote:
>
> Dear CFRG participants,
>
> This message is starting a 4-week adoption call on "Sigma Protocols"
> draft, draft-orru-zkproof-sigma-protocols (
> https://datatracker.ietf.org/doc/draft-orru-zkproof-sigma-protocols/) that
> will end on April 16th 2025.
>
> More information about the draft:
> https://mailarchive.ietf.org/arch/msg/cfrg/TkvxLDfjUZvFvh4DcbyLiraa4wM/
>
> Please send your feedback in reply to this email or directly to CFRG
> chairs <cfrg-chairs@ietf.org> <cfrg-chairs@ietf.org>.
>
> Best regards,
>
> Stanislav (for CFRG chairs)
>
>
>
>
>
>
>
> _______________________________________________
> CFRG mailing list -- cfrg@irtf.org
> To unsubscribe send an email to cfrg-leave@irtf.org
>
> _______________________________________________
> CFRG mailing list -- cfrg@irtf.org
> To unsubscribe send an email to cfrg-leave@irtf.org
>