Counters for Multicast Blocks and Bytes Sent

saperia@tcpjon.ogo.dec.com Tue, 09 June 1992 15:00 UTC

Received: from nri.nri.reston.va.us by ietf.NRI.Reston.VA.US id aa08371; 9 Jun 92 11:00 EDT
Received: from nri.reston.va.us by NRI.Reston.VA.US id aa12328; 9 Jun 92 10:59 EDT
Received: from inet-gw-2.pa.dec.com by NRI.Reston.VA.US id aa12324; 9 Jun 92 10:59 EDT
Received: by inet-gw-2.pa.dec.com; id AA12393; Tue, 9 Jun 92 07:55:27 -0700
Received: by nsl.pa.dec.com; id AA23477; Tue, 9 Jun 92 07:05:49 -0700
Received: by nsl.pa.dec.com; id AA23473; Tue, 9 Jun 92 07:05:48 -0700
Received: by inet-gw-2.pa.dec.com; id AA09328; Tue, 9 Jun 92 07:05:46 -0700
Received: by tcpjon.ogo.dec.com (5.57/ULTRIX-fma-071891); id AA03006; Tue, 9 Jun 92 10:08:22 -0400
Message-Id: <9206091408.AA03006@tcpjon.ogo.dec.com>
To: phiv-mib@pa.dec.com
Cc: saperia@tcpjon.ogo.dec.com
Subject: Counters for Multicast Blocks and Bytes Sent
Date: Tue, 09 Jun 92 10:08:21 -0400
From: saperia@tcpjon.ogo.dec.com
X-Mts: smtp

Hi,

I have now had several different people ask about Multicast Bytes sent, and
why there is not such counter in the MIB.  I posted some information
previously but the short answer is that it was not in the original phase iv
specification.  I have confirmed this with the current architect.  Given that
there seems to be a desire to have a more thorough accounting of phase iv
multicast traffic, I am reposting a proposed solution by one of the people who
is currently implementing the phiv MIB.

They also have some additions/corrections they would like posted as well.  I
would like to have some response from this list if there are objections or
alternate solutions.  If there are none, then I will add these to the very short
list of edits I am saving up for when we think we are ready to move to draft
(which is probably not soon).

I have assumed that we are not yet ready for interoperability testing, but would
be willing to try to help put something together in the fall if people are
interested.  Please let me know.

/jon




--------------------------------Forwared Note---------------------------------


     Hi Jon,

        Thanks for your mail message. As we discussed over the phone,

     1) The phivCountersCountEntry has two typos.

	phivCountersCountDataBlksRecd { phivCountersCountEntry 8 } is the same
	as phivCountersCountDataBlocksRecd { phivCountersCountEntry 4 }.

	Similarly, phivCountersCountDataBlksSent { phivCountersCountEntry 9 }
	is the same as phivCountersCountDataBlocksSent { phivCountersCountEntry 5 }.

	Because phivCountersCountEntry does not have any entries for

	phivCountersCountMcastBytesSent : Number of multicast bytes sent,

	 and

        phivCountersCountMcastBlksSent : Number of multicast messages sent,

       it would be helpful if we could rename the variables

       phivCountersCountDataBlksRecd to phivCountersCountMcastBytesSent.
	
       and

       phivCountersCountDataBlksSent to phivCountersCountMcastBlksSent.

   2)  Also, since now DECnet-Phiv is also supported over token ring,
       it would be helpful if there is an enumeration for token ring in

	phivCircuitCommonType { phivCircuitParametersEntry 7 }

        and

	phivLineProtocol { phivLineEntry 8 }

   3)   In phivCircuitCountEntry, we have the following counters,

	       phivCircuitCountBytesRecd
	           PhivCounter,
	       phivCircuitCountBytesSent
	           PhivCounter,
	       phivCircuitCountDataBlocksRecd
	           PhivCounter (0..65535),
	       phivCircuitCountDataBlocksSent
	           PhivCounter,

	Because phivCircuitCountBytesRecd is actually the count of data
	bytes received, it would clarify the semantics better, if we could
	rename phivCircuitCountBytesRecd to phivCircuitCountDataBytesRecd

	Similary since phivCircuitCountBytesSent is actually the count of
	data bytes sent, it would clarify the semantics better, if we could
	rename phivCircuitCountBytesSent to phivCircuitCountDataBytesSent.

   4)   Similarly, phivCountersCountEntry has the following counters,

	       phivCountersCountBytesRecd
	           PhivCounter,
	       phivCountersCountBytesSent
	           PhivCounter,
	       phivCountersCountDataBlocksRecd
	           PhivCounter,
	       phivCountersCountDataBlocksSent
	           PhivCounter,

	Because phivCountersCountBytesRecd is actually the count of data
	bytes ( datalink data) received, it would clarify the semantices better,
	if we could rename phivCountersCountBytesRecd to
	phivCountersCountDataBytesRecd.

	Because phivCountersCountBytesSent is actually the count of data
	bytes ( datalink data) received, it would clarify the semantices better,
	if we could rename phivCountersCountBytesSent to
	phivCountersCountDataBytesSent.

     Please acknowledge the receipt of this message.
	
     Jim Hill and Apurva Mehta





------- End of Forwarded Message