[DNSOP] AD review of draft-ietf-dnsop-structured-dns-error

"Eric Vyncke (evyncke)" <evyncke@cisco.com> Fri, 04 April 2025 11:57 UTC

Return-Path: <evyncke@cisco.com>
X-Original-To: dnsop@mail2.ietf.org
Delivered-To: dnsop@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 87A5F177CC10 for <dnsop@mail2.ietf.org>; Fri, 4 Apr 2025 04:57:22 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -11.886
X-Spam-Level:
X-Spam-Status: No, score=-11.886 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.001, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_NONE=0.001, T_SPF_HELO_PERMERROR=0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=cisco.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id jBgtCFril6AF for <dnsop@mail2.ietf.org>; Fri, 4 Apr 2025 04:57:21 -0700 (PDT)
Received: from rcdn-iport-8.cisco.com (rcdn-iport-8.cisco.com [173.37.86.79]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id A3568177CC09 for <dnsop@ietf.org>; Fri, 4 Apr 2025 04:57:21 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=24472; q=dns/txt; s=iport01; t=1743767841; x=1744977441; h=from:to:cc:subject:date:message-id:mime-version; bh=CACg8Jlbjoc187EVwzW3COWRFX8TESDFwEodKcJ8juI=; b=WCVaDXilcUw0xUwRIKBzSkJUIJf9q0ITvPZ5bbanvG+7WgwoJ+FEJmAD MQiXIDWiwSzvw4WueeOcAMZC/CcKlvL0xceVk6stpJPWCAi+kg6r6HIa6 F7L+tlxfNHQ5dIkIikzyjnYlIW1/0epVkO3xxeDzI29dQtmLocI2mKx8V 0OstxG5t4ljHFKqPlEmmWRGpUz38iCxePSpsIGnLgRn6qum71mjjUuVj5 2g80pbOU0qfFcdP6wRQZk8F2fQBTtxm30MavKmdf1wZPK4PqpFSXkiG6y kaFwJ2K5RgqrFHTg528NRr6B1ISKCcGNqGKZJfMIptektuWAinZafVXrM w==;
X-CSE-ConnectionGUID: rnOseg1XQe2rVQyBYxA4Vw==
X-CSE-MsgGUID: Zqep5DLYSjy7Hnizf9JnxA==
X-IPAS-Result: A0ANAADqx+9n/5T/Ja1aGwEBAQEBAQEBBQEBARIBAQEDAwEBAUAlgRoGAQEBCwGBQDFSB3aBHIhoA4ROX4h2kUqGM4E6hF8UgWoPAQEBDQI7CQQBAYUHAosoAiY0CQ4BAgQBAQEBAwIDAQEBAQEBAQEBAQELAQEFAQEBAgEHBYEOE4V7AQyGXRAGWQgGEgFAPycEDg0agmGCHEgDARCiLAGBQAKKK3iBNIEBO4MxQdtvBoFIAYUCg00BKoEzhEeCDIIzJxuBSUSBFUKGBwEBAgGBIwUBEgEJGoQTgi8EghYXgQUWH0qCUIQlhEqBI4QOgnGEF3yHPIFHIgMmMywBVRMXCwcFgWwDKjQVHHg4HYF8g3mFOoIRiyGEWy1Pg30dQAMLbT0UIxQbBQSBNQWWFB4iGoN3GQYrOQQUDgURAwgOAheBATUfBw8CDwMyAjCSQDiDGAGMG0ejJgqEG4wYlWYXhAONCZhlZph+Io1jlSoCSgiFBgIEAgQFAg8BAQaBZzxpcHAVO4JoURkPji0WiGvEDoE0AgcBCgEBAwmPai2BTgEB
IronPort-PHdr: A9a23:xD/erRN8POdHvgt+G64l6nc2WUAX0o4cdiYc7p4hzrVWfbvmpNLpP VfU4rNmi1qaFYnY6vcRk+PNqOigQm0P55+drWoPOIJBTR4LiMga3kQgDceJBFe9LavCZC0hF 8MEX1hgl0w=
IronPort-Data: A9a23:Cta1Sqti2KdJRoIswq1sstlukOfnVBBfMUV32f8akzHdYApBsoF/q tZmKWzUbKmKZzD9L9pxOo+/oUoC65fWmN9nSFY9qHs1RC9AgMeUXt7xwmUckM+xwmwvaGo9s q3yv/GZdJhcokf0/0nrav656yEhjclkf5KkYMbcICd9WAR4fykojBNnioYRj5Vh6TSDK1vlV eja/YuGZTdJ5xYuajhJs/7b9Es11BjPkGpwUmIWNKgjUGD2zxH5PLpHTYmtIn3xRJVjH+LSb 47r0LGj82rFyAwmA9Wjn6yTWhVirmn6ZFXmZtJ+AsBOszAazsAA+v9T2Mk0NS+7vw60c+VZk 72hg3AfpTABZcUgkMxFO/VR/roX0aduoNcrKlDn2SCfItGvn3bEm51T4E8K0YIw4OBQGmxBr MwhJWoXUCmSrdOm6e6FVbw57igjBJGD0II3oHpsy3TdSP0hW52GGvyM7t5D1zB2jcdLdRrcT 5NGMnw0M1KaPkAJYwtHYH49tL/Aan3XfiNJrlmWqII84nPYy0p6172F3N/9IYfbHZQKxBfAz o7A11bgDwlHGPiu8jiUrVKqh/3BzAH9SKtHQdVU8dYv2jV/3Fc7BBsNUkOToPSlhAi5Qd03F qAP0jAloa538AmgScPwGkTh5nWFpRUbHdFXFoXW9T2w90Yd2C7AbkAsRT9aY9tgv8gzLQHGH HfQ9z81LVSDaIGodE8=
IronPort-HdrOrdr: A9a23:yPycIquOoH5nlSy/30moXbvs7skCN4Aji2hC6mlwRA09TyXGrb HMoB1L73/JYWgqOU3IwerwRJVoIUmxyXZ0ibNhW4tKLzOWx1dATbsSoLcKrAeQYREWmtQtsZ uIEJIOROEYb2IK8PoSiTPQe71Psbv3lZxA7t2utkuFODsaEJ2ImD0JcjpzfHcGIzVuNN4SLr bZzMxBoDarZHQQaeqGJlRtZYL+juyOvqjLJTodCTAayCTmt16VAbjBfCSw71M7aXdi0L0i+W /Kn0jS/aO4qcy2zRfayiv684lWsMGJ8KoMOOW8zuwubhn8gAehY4psH5eYuioune2p4FE21P HRvhYbOdhp4X+5RBD1nfKt4Xih7N8d0Q6h9baquwqnnSU/fkN/NyN1v/MbTvIe0TtmgDgz6t MM44vTjesoMfqJplWN2zGPbWAkqqJxykBSydL6SBdkINIjQa4UoooF8ExPFpAcWCr89YA8Ce FrSNrR/fBMbDqhHjjkV0RUsaqRt04Ib167a1lHvtbQ3yldnXh/wUddzMsDnm0Y/JZ4T5Vf/e zLPqlhibkLF6YtHOhALfZERdHyBn3GQBrKPm7XKVP7FLsfM3aIr5Ls+r066OyjZZRNxpovn5 bKVk9eqAcJCgnTINzL2IcO/gHGQW27UziowsZC54Jhsrm5X7bvOT3rciFYryJhmYRqPiT2YY fHBHsNOY6REUL+XYJSmxbzU5NOKX8YSqQuy6YGsnq107D2FrE=
X-Talos-CUID: 9a23:/T+3MWoXq1ygJkwJfwwfjJrmUdojVWbQwy7gGkLiE1hQWZekWXbMxrwxxg==
X-Talos-MUID: 9a23:xvC3/w+g/JyUhJ3EYr9ovVCQf/Vx7rzzJGQ8qpcX5OmCND5+ahWbnB3iFw==
X-IronPort-Anti-Spam-Filtered: true
Received: from rcdn-l-core-11.cisco.com ([173.37.255.148]) by rcdn-iport-8.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 04 Apr 2025 11:57:21 +0000
Received: from alln-opgw-3.cisco.com (alln-opgw-3.cisco.com [173.37.147.251]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by rcdn-l-core-11.cisco.com (Postfix) with ESMTPS id A8C8218000159 for <dnsop@ietf.org>; Fri, 4 Apr 2025 11:57:20 +0000 (GMT)
X-CSE-ConnectionGUID: jpoFkHoyR3CtL49OD+oP1g==
X-CSE-MsgGUID: HHLs3HRSQPWOsEPt0sTn6g==
Authentication-Results: alln-opgw-3.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.15,188,1739836800"; d="scan'208,217";a="23745131"
Received: from mail-dm6nam12lp2177.outbound.protection.outlook.com (HELO NAM12-DM6-obe.outbound.protection.outlook.com) ([104.47.59.177]) by alln-opgw-3.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 04 Apr 2025 11:57:20 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=vnQ7htJXPlEUzgfSU0/JiF4+h4CA4PfyHRgS1aSIjc37CYK2tvNXVM0p5YJ/x8K6W0DaK+Q1Fo1pBIH9TTkSpdm8ryza6oAHc18zrtgpMiL8/cOBL/j4Tt1+pgcjVX485OXpt2lSF++Xgp4L0TquToNEBpmevnKPbo543hq+HV/exYiNoIshv+We08XUskETeg1TJjLCRHLDJt9l10Q+LyRgXKtfI+qcAiGIcBg1+Mb7jMSIlbr+2bemm7WM/4D7PqUtgBvVgUyKAtJi4AB2847JmpgN7Oou57O9KYbWtx8DUXo2uVDPCe2KLe+03qBVLVcRSqsrxIE85oSVmilJoA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=CACg8Jlbjoc187EVwzW3COWRFX8TESDFwEodKcJ8juI=; b=thLJMCELp+IaPDtTH4Z+eCXiEK+SvYV5BHO3C7uHAw2XHTOytiZQQqdiocaHe3errWsgm71oikdZjJ8zgCKbYsJnu8D4KnQND79JGin1Cfcv9JKgfnSkPr+bU1OR9xY/O4tFUINNI7ufAbtGBBofczmkDKuDykxtDownrFaBdlvdPpyF5/WVBl8A/Xl7SVp7gemLUkh9Eubi/XjoXEA5z5fhd2Iz0KKxy2kjjt0K79A8rMxgfznLlz7A9US27hcpE9T1cQluKlzrHq2xzFVm6bZFYkPuJuk88fNVR3E3M+p17MEldJGqgdeubJn67I66hT4zUILTCZP9AhIDjQdatQ==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from PH0PR11MB4966.namprd11.prod.outlook.com (2603:10b6:510:42::21) by SA2PR11MB4923.namprd11.prod.outlook.com (2603:10b6:806:fa::10) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.8534.44; Fri, 4 Apr 2025 11:57:18 +0000
Received: from PH0PR11MB4966.namprd11.prod.outlook.com ([fe80::dad6:3d43:4561:3c11]) by PH0PR11MB4966.namprd11.prod.outlook.com ([fe80::dad6:3d43:4561:3c11%3]) with mapi id 15.20.8534.043; Fri, 4 Apr 2025 11:57:18 +0000
From: "Eric Vyncke (evyncke)" <evyncke@cisco.com>
To: "dnsop@ietf.org" <dnsop@ietf.org>
Thread-Topic: AD review of draft-ietf-dnsop-structured-dns-error
Thread-Index: AQHbpVBiuz5jGyb9gkS5MUAqEgmHlA==
Date: Fri, 04 Apr 2025 11:57:18 +0000
Message-ID: <PH0PR11MB4966F72BAF1F83E3F80D7C0EA9A92@PH0PR11MB4966.namprd11.prod.outlook.com>
Accept-Language: fr-BE, en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PH0PR11MB4966:EE_|SA2PR11MB4923:EE_
x-ms-office365-filtering-correlation-id: 53daea20-0658-4f35-03cc-08dd736fd984
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|10070799003|376014|1800799024|366016|38070700018|8096899003|13003099007;
x-microsoft-antispam-message-info: MmJx53STlbqza8rK9c0FsBlRWw2H5J8XdmFeq5r/HjGhwG+NclINy4bc6QQMGI4KikDEXJE7paMKl4ZN6fcQu/KXC+EMybkYUcpOZyMrdgzvL7MckKg+xmUwf9+JhH//ix/YOFMPu7eTpWJRMqjJdLD+zAix+4vFkcH/D3hp1527uP5aSq9z09NOPtPK9KJoB+CGcUtJg9lNNIlwOc9HZNjQ384VPMCe+FGhY8JR7zYKA2dm75ddq7E3W9vwDqa27ynbUm4gP1pawqCRAvNMnsOI5pHZ4fP4MSo5ifV19RzKgWalAZ5wgRs4oFdtu3vJG+6A1aFaP9zL+WUHzaTd11GAsYO5nlKpA01KT+aaHJCR3insV/eFUOcTQ7YDDJQen2Dk4TjnrV8sAP1XZhdkD9dCnLn/ud2h97optp4th/lhdMrMghc1GzOT4bbDl00OzkD8gtAWzhFOb8N8pkqkYhUQURqulFvG6qUt5ao1JAN0dw0qu5F2eM1X7Hx9NmFq7MfOUG/AXjftVLOgy/F3/TRYgI0J1DXlAjatVu00BbxkPI3I0mQ6OK+QDVJBt1O8OuX2wBYnMYiuf2XeRKRl3PEXDdtbJAT5eH8dJ7ER63Od3BrrgyiHchWSUbHuKKKZxwnPNzsE/CgNnM4MFpyDMZYZbx2yZDOkT/Sbk63/tZRO1N8DwlTrZibof8pQkCOFe+027V9oIHZ9VgtWpG7eU5swXtX5GRHzk2/MCDI4we3XVBuLcJPS6v5YsUTi+mGFEoeCNVTaSx7OSUmdP5bLQTqO7cCbK0zFcu356EpcL2LvHXp5Sw5uLy4JtE/zTNCWh9nI6SeYDOkOd7wBzLt/UjFnjBs/xF9B/UZv3lYYZ1+bnoBcVYX2dtQze3YPN7wL2+tGm/rOQpymF9GPX0nE+72F/4N1m5cwezcRHq8lCL89rCsDTnRDetltI+lWZfb4oM5CL4DPwrdO17ELjhRJchBoSKSqjCDVimg7J+eW5ealzcCuM8Zy66PkFfZ+1UU64gBtQZEuyFyMQEj2ImNVpPeaCxxk0LFq37spc7ZoZf1Rj6/JLYiVe5aj3WNqemFvKIHpyS8xzzwGdwQ3NvIZM029I1D2l6w0tX3mR7E+2saVQIQ/bKfgpuJgeqP7CrfVqmwlkgRX8V/c7rykW2kTRsWZoqfDk6BC6E+/HNQt87jNSR3nAXOz6nN7pIDk3JKDhJ+2h2oKGD4jW52scMv5V3OzPLoLu4vxUs7TQrszgv0n8pHlhzf9+NI52RMZERsX+yJShF9fS32GT858VPJAEfJ572s9fPfY6ZlTHaU8YfwBt13KB1HmvfvXQ+Ig0bunl3JQbRPxdS8+0rLGMTdVOcliJ829DbPpLFuVApUJJEWne8QpKATre4xGfjO8yz8HNqu+XnZupnDUofOyI7ADrX37IlTc+80jh1rNFjWWfplAPk+0fiGddfxbVAUf08WC5voiQKkgnMcJXGErS/Bs8pgAsDe5cQMGqPs/R+4GX/g=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PH0PR11MB4966.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(10070799003)(376014)(1800799024)(366016)(38070700018)(8096899003)(13003099007);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: lcev0gmW+wKhoozYXJSQkw/SvUgbodML0oCqkTFmCrfmaS2tkBiNLl1nfzaHJ7gR/CXQZoITOAK/ZeCcnzbgVtdJaSKy4UiCtVi0vGRrC1HRRXD/pkl7oG7olHYAa5KQag2hJKWqM85lIQQeFZhYuiWmhzD1O5MUvOwt7zIIPhZTZcH0BbfmRuCag6bSbRWRY3qLg+cj2fnIBf1nCZ4kVfcySEhnSwJ4yNOSddYlJkz1Bj7qyt5k9HBu4LeMuJ/cBqXJ6xqaJnYhi1/m8fv73/KDOjMl6WTyOYO4bYtcM5P5N+HYFXI2hWPFgNjuRyJuFNbz3vhxccy6mddCcU+94gDpVM8RFPmr9Jdz1TvqQmlHUgeQUlOltWTQ3rEP2uBeiJdWXz2urS+77waMqI8ichiQwctMIPHd3jqX4OKYfFL9r0OJyuhS0n1ccUY1oNJjT5N4ArpOyE0H5LgqBTDTElePbDWjmpk7eH+zvXFQibgODYa+4SHShRsgj4iOIpRZjr7dL4gLpuPF4iYP1xvcdw74wvaLADncJ0jGRjjoSVnL7tKHJSTT+eskTgwduySmCBEy23xZ7BXCETsUCG+bIWXEvIwCQ97EQJaK9aR94Cer61QHSt3d0sYxzN+yQMiMFGFz0MSJfTvOU3599KwPSmqi1K6A+shyWubL91XBfN67Mj1QvnPVcEPbFXz60HfFu+lXezqykYoG4zowJndJs/dFKNSNz966sF4BKF5YandcgrCVZJm+v04AP8tOL6vbLOqIFvOAoRd6tzHMCwuy49n4rwTqeuTA8muZ51IQsAOaDObLp3NbhHK2/I/TmaBtvRX7zF45oWOYCCcFdogDPiPz+ceLLaOvb6td8rfc/AYP1VyZBBBENeua97GTlneQsiGLBdPMx71xK9xGYTUBJ6IXbPW8nR1cpDYWAQYFb6Yu3mRA5PleemqCKlBZAYieFYjXaQOY9f15hgCpMWbZsuLvoCiDdTXNh0lTz3HHIE+CWivqzvq5h5MYSgbNmYVQyMMsSDtZVL/whoZmEb479RbhEtFSzDBRG7fLl+UzMC7UdDX33OFZUPJ/A6kgIXjmxXAdd26/N/SPgaDFGGI2zQbsr8MktYBVVgeqNvAWDQMMzkO+mW9NoPGxSktZQgU7dKbl1aGDENxAXX9H7PMjkZSNSW+k7wnZDNzr2z6ybi2li5140PUPJU6LQYJylDJTc2rz5rsq5uPYjmFDu5GNFsx23NlNNPLtkfnSN2uQzbnl0+Qp6j5I3eSsI0S2veSJsc4cl0BixxmEcLgAiq5rV0aDgvIBMJnTfpuOld+46jQWpmHzsKJ/TV0uwrTbVGd1SYSMcbykv1Quv3yFUagoj0i6Rt9hSs7ZzWWMR8JA3EZYbKPeYFMl4SJ4LqQDsvYHRls8JiroIjplIqYBz5dHWUszPaeU4lr+1sH73QIaUFQvZAr7RGeScVHxH5/RAFdm0AtKb/cebU7WgxjTwcjVSPqsZ6t1mc1pUPbC+Km/7Q+2vgjK3xpaE2/ohtm/FWq4aeuYUtJC7E3zHGVJVeZ3O3W+2zzX9Y4tF3ARBS/1VbFE3uot0bgM/cNYaRyg+zwfrr/jkdymagRw/vfzlEECvNOQ0EKn/KWhv+Qev6fguNo+3e+rT8BdT03YjFYsz6AWsmmdQdtEqpQhyT21vTkCUg==
Content-Type: multipart/alternative; boundary="_000_PH0PR11MB4966F72BAF1F83E3F80D7C0EA9A92PH0PR11MB4966namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PH0PR11MB4966.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 53daea20-0658-4f35-03cc-08dd736fd984
X-MS-Exchange-CrossTenant-originalarrivaltime: 04 Apr 2025 11:57:18.3951 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: t94Y4vpNz4AqySUguQiMZElYBAiHT1hqNGjX+D6UAcFLqJhkrcdNYTQSn+JFCEU8la8BLIzNcS3oFGqEySRhsg==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: SA2PR11MB4923
X-Outbound-SMTP-Client: 173.37.147.251, alln-opgw-3.cisco.com
X-Outbound-Node: rcdn-l-core-11.cisco.com
Message-ID-Hash: 662P4AKUDACTF5EDH7FLKUONF5L36WWC
X-Message-ID-Hash: 662P4AKUDACTF5EDH7FLKUONF5L36WWC
X-MailFrom: evyncke@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-dnsop.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "danwing@gmail.com" <danwing@gmail.com>, tirumal reddy <kondtir@gmail.com>, "neil.cook@noware.co.uk" <neil.cook@noware.co.uk>, Mohamed Boucadair <mohamed.boucadair@orange.com>, "benno@NLnetLabs.nl" <benno@NLnetLabs.nl>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [DNSOP] AD review of draft-ietf-dnsop-structured-dns-error
List-Id: IETF DNSOP WG mailing list <dnsop.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dnsop/6OUPPDpFTuOPqVRCvHAgXwXK3bk>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dnsop>
List-Help: <mailto:dnsop-request@ietf.org?subject=help>
List-Owner: <mailto:dnsop-owner@ietf.org>
List-Post: <mailto:dnsop@ietf.org>
List-Subscribe: <mailto:dnsop-join@ietf.org>
List-Unsubscribe: <mailto:dnsop-leave@ietf.org>

Dear authors, dear shepherd, DNSOP WG,

As Mohamed ‘Med’ Boucadair is now the responsible AD for DNSOP, he passed me the role of responsible AD for this I-D :-) Therefore, here is my own AD review. Before proceeding with the publication process (IETF Last Call and the IESG evaluation), I request to have all points below addressed, i.e., by changing the text, by replying by email wit explanations, ... (Feel free to reject my comments as long as you explain why).

Benno, the shepherd’s write-up needs to be revised:

  1.  In point 1), there is an unfinished sentence “The status of Proposed Standard will”
  2.  Change the responsible AD to a guy name “Éric Vyncke” ;-)

### Section 1

I am unsure whether firewalls and IPS do use DNS filtering rather than content inspection.

Is it worth defining “Users of DNS service”, is it the app or the user using the app ? The text also uses “end user”, is the same human being ?

` the DNS server`is a little ambiguous here, should it rather be “recursive DNS resolver“ ?

### Section 3

` In order to return a block page over HTTPS, man in the middle (MITM)` should “without triggering an invalid TLS server authentication” be added ? Please refrain from using “MITM”, favor “on path attack” or simply “interception” in this case.

` The HTTPS server will have access` unsure which HTTPS server is referred to... is it the expected or the spoofed reply servers ?

s/Enterprise networks do not assume/Enterprise networks do not always assume/

Should there be text in the DNSSEC bullet that if the filtering DNS server is also the DNSSEC validator, then all is good ?

Should bullet (4) be merged in bullet (3) ?

### Section 4

Does this text add any value ` Note that [RFC7493<https://www.rfc-editor.org/rfc/rfc7493>] was based on [RFC7159<https://www.rfc-editor.org/rfc/rfc7159>] but [RFC7159<https://www.rfc-editor.org/rfc/rfc7159>] was replaced by [RFC8259<https://www.rfc-editor.org/rfc/rfc8259>].`?

s/ This field is structured as an array of contact URIs, using/ This field is structured as an array of contact URIs that MUST use/ ?

Can the “l” name occur in the absence of “j” or “o” names ?
As I live in a country with 3 (+ English) languages, I sincerely regret that only one language can be used... IMHO, “j” should be an array of <language, text> especially when the end user is residential.

Did the WG consider using a single URI pointing to a possibly larger JSON file ?

Did the WG consider using CBOR for encoding ? It may be useful to justify in the I-D why JSON was preferred to CBOR.

### Section 5.2

S/ A or AAAA record query/ A or AAAA resource record query/

The 2 seconds for TTL seems very short to me. I would avoid using this value even as an example.

### Section 5.3

As the I-D states `following ordered actions`, please use a numbered list.

Also, I wonder about the actual order as the channel considerations should probably be first, before the JSON syntax.

In ` If the "c" field contains any URI scheme not registered in the Section 10.3<https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-structured-dns-error-10#IANA-Contact> registry, it MUST be discarded` it is unclear what the “it” refers to.

s/ In such a case, the content of the "c" attribute can be ignored/ In such a case, the content of the "c" attribute MAY be ignored/

The last two bullets (DNS forwarder and app) are not really part of this list but should probably appear as stand alone.

### Section 6

Is worth explaining why value = 0 is there and why there are no values for 1 to 4 ?

### Section 7

It is unclear whether the original reply is forwarded as it is received, i.e., is the information specified in this document also forwarded ?

### Section 10.1

I am not an application expert, but is this registration required ?

### References

draft-ietf-add-ddr-10 is now RFC 9642

draft-ietf-add-resolver-info-13 is now RFC 9606 (the authors should know ;-) )

DNS terminology is no more RFC 8499 but RFC 9499