[DNSOP] Re: AD review of draft-ietf-dnsop-structured-dns-error
"Eric Vyncke (evyncke)" <evyncke@cisco.com> Sat, 12 April 2025 05:34 UTC
Return-Path: <evyncke@cisco.com>
X-Original-To: dnsop@mail2.ietf.org
Delivered-To: dnsop@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 0D5E41B06B74 for <dnsop@mail2.ietf.org>; Fri, 11 Apr 2025 22:34:11 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -11.888
X-Spam-Level:
X-Spam-Status: No, score=-11.888 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.001, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_NONE=0.001, T_SPF_HELO_PERMERROR=0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=cisco.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id eNN5BRoqtltz for <dnsop@mail2.ietf.org>; Fri, 11 Apr 2025 22:34:10 -0700 (PDT)
Received: from alln-iport-7.cisco.com (alln-iport-7.cisco.com [173.37.142.94]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id C02751B06B6D for <dnsop@ietf.org>; Fri, 11 Apr 2025 22:34:09 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=47165; q=dns/txt; s=iport01; t=1744436049; x=1745645649; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=kE5GjhVk8nOasVaZ7BTF68O99XwB+Bz4IKvsT1m9u6Q=; b=caVv8OOLM4LEU65iopyAIq9w/jh0MIe4mJRysdT3pP8J01m58ZwW8oZy JWzKb+RA+WA0Hcpj4QO9NAHD4pwvfpPmniy408iDh4or7vfQ85EnWVUdN F/OHSpybtTTOzoS17xcitsGLtvL+BxaDDlAqJMjnqP7Fnpl6FwXt0Uu3u eAz8Mqox6Uc1N10Qa7XozN6plLXkRery2nRpwy0a35w9PGLY3NfPdSUmb 5qCPMoTwnGsmBIdf5n6QuZCKrqJMi8FhNNur6UIKM14fSJvCaGA33FwsN qvFfYrQPK+rQA9uDrazg+EQiRUTpZoH4xWW4sRzEws+Ryjk/p9h+OuTlr w==;
X-CSE-ConnectionGUID: qRSIprncSSCuNR4Xrs7L8Q==
X-CSE-MsgGUID: tE+9Zp9aQ2a4UJ/A/u9nOQ==
X-IPAS-Result: A0AOAAAv+vln/4oQJK1aGwEBAQEBAQEBBQEBARIBAQEDAwEBAUAlgRoGAQEBCwGBQDFSB3aBHEiIIAOETl+IdgOLY4VkhjOBOoRfFIERA1YPAQEBDQI7CQQBAYUHAosoAiY0CQ4BAgQBAQEBAwIDAQEBAQEBAQEBAQELAQEFAQEBAgEHBYEOE4V7DYZaAQEBAQMMBhs+CAYQAgEIEQMBAh4DAQYHIBEUCQgCBA4FCAwOgmGCHBQDMQMBEKNTAYFAAooreIE0gQE7gzFB2Q4NglQGgUgBiDEeASqBM4QqgimCMycbgUlEgRVCgmg+gh9CAQECAYEjBQESAQcCGh4Wg1+CLwSCFhdFPhQfSYJGgSWCfoQ/gSSDOFeCb4F7ghV8h3FSdSIDJjMsAVUTFwsHBYEpQwOBDyNQBTAdgXyDcoU2ghGBXAMDI4MVdxyEcIRVLU+DM4FGHUADC209FCMUGwUEgTUFljseIhqDdBkGKzkEFA4FEQMICAYBARcJeAgtHwcPAg8DFhELAgQsgRCRMDiDGAGMG0eOFJQhcQqEG4wZjziGLheEA40JmGVmmH6OBYQHkSMCSgiFBgIEAgQFAg8BAQaBZzxpcHAVO4JnUhkPi0iCZRaDWIUTwxd4PAIHAQoBAQMJj2otcV0BAQ
IronPort-PHdr: A9a23:z+5rMRzt0zAuqXnXCzPsngc9DxPP853uNQITr50/hK0LLuKo/o/pO wrU4vA+xFPKXICO8/tfkKKWqKHvX2Uc/IyM+G4Pap1CVhIJyI0WkgUsDdTDCBjTJ//xZCt8F 8NHPGI=
IronPort-Data: A9a23:UOzQXqgSbXneGvzEyW59vMS5X161JxEKZh0ujC45NGQN5FlHY01je htvXzzVa6vbMGSgft9yaou/8UoAscTcm4c3Twdqr3swEC9jpJueD7x1DKtf0wB+jyHnZBg6h ynLQoCYdKjYdleF+FH1dOCn9SQkvU2xbuKUIPbePSxsThNTRi4kiBZy88Y0mYcAbeKRW2thg vus5ZSCULOZ82QsaD9Mt/vZ8EoHUMna4Vv0gHRvPZing3eG/5UlJMp3Db28KXL+Xr5VEoaSL 87fzKu093/u5BwkDNWoiN7TKiXmlZaLYGBiIlIPM0STqkAqSh4ai87XB9JAAatjsAhlqvgqo Dl7WTNcfi9yVkHEsLx1vxC1iEiSN4UekFPMCSDXXcB+UyQqflO0q8iCAn3aMqUBwN1WGXtI/ scjAy0rVEyznfnp5OKCH7wEasQLdKEHPasWvnVmiDWcBvE8TNWbGuPB5MRT23E7gcUm8fT2P pVCL2ExKk2eJUQUaj/7C7pm9AusrnThYjtTq1+9rqss6G+Vxwt0uFToGIaIJobaH54Ezi50o Era0ieoMAlLPeXFwGa40DWFwfKemwTCDdd6+LqQs6QCbEeo7mAVExoOfVq2vff/jVSxM++zM GQd/i4o6Kx3/0uxQ5ylBluzoWWPuVgXXN84//AG1TxhA5H8um6xLmMFVTVGLtchsacLqfYCj zdlQ/uB6eRTjYCo
IronPort-HdrOrdr: A9a23:zfXTca687jr57Tf4GwPXwbWCI+orL9Y04lQ7vn2ZFiYlEfBwxv rPoB1E737JYW4qKQ8dcLC7VJVpQRvnhPhICPoqTMaftWjdySSVxe5ZnPHfKlHbaknDH6tmpN hdmstFeZPN5DpB/LvHCWCDer5KrqjkgcWVbKXlvgtQpGpRGthdBnJCe32m+zpNNXF77PQCZf 2hz/sCjQCNPV4QacO2DGQEWe/sm/3n/aiNXTc2QzQcxE2rlz2H1J7WeiL04v4ZaVxy6IZn1V KAvx3y562lvf3+4ATbzXXv45Nfn8ak4sdfBeSX4/JlagnEu0KNXsBMSreCtDc6rKWE81Axiu TBpB8mIoBa927RRGeouhHgsjOQkwrGqkWSi2Nws0GT5fARdwhKTPapQrgpNCcx3nBQ+e2UFp g7hl5x+aAnVS8o1x6Nl+QgHysa5XZc50BS0NL6SxdkINEjgHg7l/1FwGpFVJgHBy7084YhDa 1nC9zd/u9fdReAY2nepXQH+q3nYp0fJGbPfqE5gL3f7xFG2HRii0cIzs0WmXkNsJo7Vplf/u zBdqBljqtHQMMaZb90QL5pe7r6NkXdBRbXdG6CK1XuE68Kf3rLtp7s+b0woOWnYoYBwpc+kI nIFFlYqWkxcUTzDtDm5uwHzjndBGGmGTj9wMBX4JZ0/rX6WbrwKCWGDEsjlsOxys9vS/Ezm8 zDTq6+L8WTWlcGQ7w5qjHWSt1XMz0EXMUep9Y8XEjmmLO4FmTDjJ2uTMru
X-Talos-CUID: 9a23:7TrwaW659I2VqIEoKdss7XQvO9g/dHbm91zNBXXkOXxyF5nFcArF
X-Talos-MUID: 9a23:eDqv/Q1xD6fW6X6HI/whJKnZHzUj/4ntWXIVwJw/4cDYCA43EnCA3TKQe9py
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-l-core-01.cisco.com ([173.36.16.138]) by alln-iport-7.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 12 Apr 2025 05:34:08 +0000
Received: from rcdn-opgw-4.cisco.com (rcdn-opgw-4.cisco.com [72.163.7.165]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by alln-l-core-01.cisco.com (Postfix) with ESMTPS id D7E9F18000198 for <dnsop@ietf.org>; Sat, 12 Apr 2025 05:34:08 +0000 (GMT)
X-CSE-ConnectionGUID: kNzHF6pQTXWsaPlE2QH8WQ==
X-CSE-MsgGUID: ivhlZFvgQFGZ/3ZwHsIXpQ==
Authentication-Results: rcdn-opgw-4.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.15,207,1739836800"; d="scan'208,217";a="50663478"
Received: from mail-bn8nam12lp2174.outbound.protection.outlook.com (HELO NAM12-BN8-obe.outbound.protection.outlook.com) ([104.47.55.174]) by rcdn-opgw-4.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 12 Apr 2025 05:34:07 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=PrJgQLxclFWUAgtA7W09Ha8lxHp2GAPfn3GAqM/BnkuFZEiqEnffAeWVcwhVx/EN3Nb/3LTDR3SrtPjS09H/NjwHAoLS9Y15quHmIYoH3/+JJmp3hbb+jmy07aDmoebUwP7NXvIvWPAbQY+qZxBWBNIvUHBXo6UitPtDhhjKKMjX6Pc8WRM+Vpp7HhZ0Hgq7ukAvcs3OiQGD29I5NPMuw4heVxcl6fRs/DeJ20b/8YE/CcZNW59ZGhRQIQOsPupS08OYiuXPRn/WD1hwoemFq3SjAtS4SV5nQ0V59pjflP2zEFY15JQjpO2WAfBZ3vSmD21XWlu3pNqWIWLp7ZNOZg==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=kE5GjhVk8nOasVaZ7BTF68O99XwB+Bz4IKvsT1m9u6Q=; b=QE9IelGPrSPMLepxDWUQTzkf1rBWSiTZe2L/EmvJgVUXyrB8p99L25V+Ahhs1O7R/ck3mnp6duMVob6sKZYVT0C/V4Ii6PtBH9dF4tSn5G8X8IZ0a6n+sdDZQf3Yq/4uD+O3aboYekB3MiOzkmkES2Pza0urzOG4i0aqsBCKQbeNc9c8hNtQZNIZBeqEMUcHFb0zWJrTk8ouhg2mh3CX8oGeMh7jlA2OkcnCnxwSHYAW4GKBNryV9PmcY51J/1kYA7ihkRqFei+B8RAfMPTUYSrwt2Z14jeObLoFUOjKqjRsfW83Yrf/OaU/iuQ2HCcDRZyxEc1QI0nZclSIM72iTw==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from PH0PR11MB4966.namprd11.prod.outlook.com (2603:10b6:510:42::21) by CY8PR11MB6988.namprd11.prod.outlook.com (2603:10b6:930:54::18) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.8632.27; Sat, 12 Apr 2025 05:34:05 +0000
Received: from PH0PR11MB4966.namprd11.prod.outlook.com ([fe80::dad6:3d43:4561:3c11]) by PH0PR11MB4966.namprd11.prod.outlook.com ([fe80::dad6:3d43:4561:3c11%3]) with mapi id 15.20.8606.028; Sat, 12 Apr 2025 05:34:05 +0000
From: "Eric Vyncke (evyncke)" <evyncke@cisco.com>
To: tirumal reddy <kondtir@gmail.com>
Thread-Topic: AD review of draft-ietf-dnsop-structured-dns-error
Thread-Index: AQHbpVBiuz5jGyb9gkS5MUAqEgmHlLOYRwMAgAdErhA=
Date: Sat, 12 Apr 2025 05:34:05 +0000
Message-ID: <PH0PR11MB49667337AF2C5A63D2080C40A9B12@PH0PR11MB4966.namprd11.prod.outlook.com>
References: <PH0PR11MB4966F72BAF1F83E3F80D7C0EA9A92@PH0PR11MB4966.namprd11.prod.outlook.com> <CAFpG3gc2sojMQb+joC82nLxjU-4daJzDoJgdyub8h0NXC6G7jg@mail.gmail.com>
In-Reply-To: <CAFpG3gc2sojMQb+joC82nLxjU-4daJzDoJgdyub8h0NXC6G7jg@mail.gmail.com>
Accept-Language: fr-BE, en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PH0PR11MB4966:EE_|CY8PR11MB6988:EE_
x-ms-office365-filtering-correlation-id: ad1d3d0a-f71c-45ea-0cd5-08dd7983a3db
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|376014|366016|1800799024|10070799003|7053199007|8096899003|13003099007|38070700018;
x-microsoft-antispam-message-info: +9TUUxhfI6ei5hL7OUxxrjz1jn3+ninh5UoaIOGjZsTvSP6DPvfEqB24B3Ehi1tS0PwUi4YpAXKFSIsAs8YV/l25hwjOHeokLl4CKb1F61nvkQvzVQKl0p9tWvrKwf+F6CrrVKQDnoi3MInCecYh1Nhm0XZM8SoxeWB6OgSJAbUWiBmDwpT75WC6LtbJ+UYIa1mBZOtra5SK8MA0dyv7XvNw2YMWu2bVAGcFIKtp5TlApTpgYGPcxL4ylaO/QdV6fItDBHZAskpWxpOYdeK2C2moDxHOkfcSpufndlsOwKW1NddTqCfYakikc6Z8oWz2bUosLeiHkHDo9XYwAaImWZjyZGUBo7ggYIU9aaCSf+4cI6D88oJDuN+PHN/1/+3MOSzup1DSmoZ0rDi0gmW2dcLElaufMyOUn3OX/1eBwxBK+OPp+zwfKExE91b1ZaWdRNLmeXq+U86jihoKggCpKuZkSHJCybXI9weq2N1DWLk85c48necN7yLkHzvjwxvH5mRtG6h3MUJXEMJ8EVVBNdxR+la3E0C/AINwdC4uAOGj4GDCWYjWFB9QhBe14bG7+Qxt6grs/O78oF+kOFsadzSkI0gnl4m5QaRfLbEyy+UAq8Frxm9d1tDVgfJ8szbDlhsM7Eja8JciHmCdojD22toXln/5NhyfIFoj5jAXLX1kjwzmgBEkMv4JzGwGUJENRGQep3guE7xqxizh9uI2zrPZtkYzqUkyAA1Rgh5h32KU6RcP0ZKh4TH01Lolitnj8wVYfmf5lKXQrm7YHavTCc/nXqnZXXVMpKWbxgrLMJKWqph/b5jBsfHdU6S4ZD2KrqPWGOcxHaorOwNbcv51WiPmah4DjoQmvbjc0FRGp8eURjJo8xBh7r9g5eYovIDyUQEDcSTbqYTg5eE4Ex9Ywd0A2mneuOO67HkuVfM/JJiu6yrJBUaGly1aMoxVtmun4l6SQwe0sE1cqLXrtg4UusKCAEUHpYqCH81VaD7Y429tSraeQAP8UUJV30TSZcKliy1qY0ItFFSaXjjWMXOrhOAcYM/z7uzJP+yJmZk5VGuowDMgM4jUr5fusqD7dHZFSqq4w0hXbEWLchyMZyUrOyUvAGfbDLFYmDIt9TVKWZsuKO71aNHvfetgzrC+h3FFaMTxyf5/bpw0HrCL/pz7LpIcKB7QMVGWNlWk+JbrFU/FoStNs14nGjVlGgiAUu5tTw6Xq5/EJpq+8Y3mbJowe0kEEm1r2k6rsSX3ZiqrYCSMtM5o7HG5AKuxvVQwmNSq3xqcZdkqHomSU0orLbnVexlU9GKAAiLJgOZZojzzpAT+N+7Nr+vFU8qlunJB7KxUO8k5LrOnzJ9R2jP7wNZSCdcLOgP9iyjyAQbtc1YV0XOpJ8uBPKiY5m75j8HNxtWKlQtPglWuxv/ma1nv8OqrkGZkpqicAkKUmmYJa2aimXEcQ3NQd1spR594bmtXUU8NwX4YbkKnGNjyNq7pXF9SeFvZDE3sY/7raW6v7LkLckY=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PH0PR11MB4966.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(376014)(366016)(1800799024)(10070799003)(7053199007)(8096899003)(13003099007)(38070700018);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: v43zUk8DIwdgoye8gS7sHPt+0Uw5OS7XQ3HyVHXaHzkyY7bQI0hNXsPXvSnNC2yWbBT8YlsheJAjZ9QZzvJCbIGLfG0/Fv/kJ8qVQehgBt4cGUjiaI+MfBuN4WMpn7JHwaF2Vwqt4rsSRUYJ5Q75qK/q2rwuPpl/tjYkCUKiqTuRWj7BAeuavwKClPivY+O33RLIP7Ja0bBowUHt5Ip1FEnYwNdCEEl3dnvGkwpSXceO3O4mn/XQGE5fEMQP8k38rBgjfAqyh/nwvW6mVr001NT/Jfq6dEKdadoUICa69W3k6mmOe841h5vV381Og1EItdPK5e4KXH9sOrHS/V/8l7bd4FmecYZyb1tRGgGmjc1Wo9NLlOg6cDtSvABbAAHtwigiBZkOeuV0nJsNWbqdAZs9BR9LxZMEVMzdSGXwYnh9RB+QBuAiZfnedOq7bX3uGblstOcFEvRhyCMq1yXoLvvUuU3Yek8uytwruqL72M7fWLU8KjeTkYmELfPJmbpdFuHCslydmNC4BaveXonNnDYHGPh28LGZuWqhP2ir538ACHrJKpTbAYpcv4/wcVsJU8pd1V1pUR6Vk41+1XAuFUwduzy6oBHjCLU26df6rDpUIZ5Wis+yK2L4h67EW8kT6GAGlwyuuwDM68A4Fk2GuVqd/6ZnonPaPfCPjcM68nfWNH7MQv+/e7GxYQStaAXcEXKfJQnqPGo7fNkPmiPQuYfBeW9fK0XI6uV5hcz+WfrtnoNd1sGtKod44z/6TytlX0zTZJSWxcOlQcMv8TojSZ+d1aLFcDdlSPe+IvJ5PiC/E47jgsIwQiIqN7cePGq/HzseqsNAeb3zl/zBUEEuI1tQR0tYO7vfd1xGuthpBUlmQqm1iRSyaUjLWTBz32eZew2N7Vgvasq1uJSln1aD6LiVGfDmWX37WWsHfmD7QnP001eNcPUlcdCbX4nt0CvXzXJkIVGIEs4KkXaRzN3B+Aj7dSCaTxB5ZyHoEpeiG0SKI/AGs7PHCJ4Ma6AFffk+/BKH6Wc0sJOc6+HenIoLu91zSPbXbG77EMqiXiqj9Krf4Oe7TIYamxC9OW7GS7d7hq0Tumspfmmnl+0/m7zpUS50RZGpjuy4r4MCweyCvVs2K9nzTOrEodyg1IoJzbt0GlTQX8AO44a5hkQjw7uzXMRepGiBuEF4B7WXa+BRtTVNDVVTbaz7MFHWEEOkSlfHMSahfPSI057iIpCqDKnGuK4tqlyfbO280JDbCD3Vjbbh/9OSXTFOYeeYDDl+x7sAxABngVhR3up96VQ8z0SmTHdeTtQYyUf0t6UeHiPZvPVLS7Wg17emVb/cORg1on8AWeXlMJpU2CqrAu24pG4I8EQDyNkzAlEtTrexDoi3nC0ok4VZoBBkDVkTnEPVf0gbSntcxypvIG2UQVKEgkSArB50jjIDRj5UW7BRWfnHm33gYtwC69pUOLoeHq8lwv5YoA3LC0nufoQdrPU0dhYBschL09C7wiZtUWbtOggvfiHUrqFx8gHz2CT7mAiWOEL0zgSfjj1GO3gD+WwwHNZnCTunoCcAJ3JlarmcubmLXxr/MOwvdY1O/FOALpp7Zc5xD62179Ns8CNJPMyZ5B1XA61y+jWDqlT2Ja7kcPHJNp4H4d2TUabDTWaUEWg4cUEWl/jiIDmBPCJ9L9x24BLQLg==
Content-Type: multipart/alternative; boundary="_000_PH0PR11MB49667337AF2C5A63D2080C40A9B12PH0PR11MB4966namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PH0PR11MB4966.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: ad1d3d0a-f71c-45ea-0cd5-08dd7983a3db
X-MS-Exchange-CrossTenant-originalarrivaltime: 12 Apr 2025 05:34:05.2757 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: OGb6qtAtp2omAtP6S9OgJGR4dgJTQ+i6U76XFdhCxYpCnZhBelO1/3M++O43CJXhmB8JGJ0rVdFOA08iWnJK6g==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: CY8PR11MB6988
X-Outbound-SMTP-Client: 72.163.7.165, rcdn-opgw-4.cisco.com
X-Outbound-Node: alln-l-core-01.cisco.com
Message-ID-Hash: KWFP6DXUJ5VJBMVYQER2EDEJZVBAWMSZ
X-Message-ID-Hash: KWFP6DXUJ5VJBMVYQER2EDEJZVBAWMSZ
X-MailFrom: evyncke@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-dnsop.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "dnsop@ietf.org" <dnsop@ietf.org>, "danwing@gmail.com" <danwing@gmail.com>, "neil.cook@noware.co.uk" <neil.cook@noware.co.uk>, Mohamed Boucadair <mohamed.boucadair@orange.com>, "benno@NLnetLabs.nl" <benno@nlnetlabs.nl>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [DNSOP] Re: AD review of draft-ietf-dnsop-structured-dns-error
List-Id: IETF DNSOP WG mailing list <dnsop.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dnsop/TdHi2qfJvxi76EVlUGRp6TIJVI8>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dnsop>
List-Help: <mailto:dnsop-request@ietf.org?subject=help>
List-Owner: <mailto:dnsop-owner@ietf.org>
List-Post: <mailto:dnsop@ietf.org>
List-Subscribe: <mailto:dnsop-join@ietf.org>
List-Unsubscribe: <mailto:dnsop-leave@ietf.org>
Tiru and other authors, Thanks for your reply and for the revised I-D. As noted below, some points of the AD review were either not addressed at all or I still have suggestions. Nevertheless, I am proceeding with the IETF Last Call, i.e., you may consider my AD review comments as a community review during the IETF Last Call. Regards -éric From: tirumal reddy <kondtir@gmail.com> Date: Monday, 7 April 2025 at 16:25 To: Eric Vyncke (evyncke) <evyncke@cisco.com> Cc: dnsop@ietf.org <dnsop@ietf.org>, danwing@gmail.com <danwing@gmail.com>, neil.cook@noware.co.uk <neil.cook@noware.co.uk>, Mohamed Boucadair <mohamed.boucadair@orange.com>, benno@NLnetLabs.nl <benno@nlnetlabs.nl> Subject: Re: AD review of draft-ietf-dnsop-structured-dns-error Hi Eric, Thanks for the review. Please see inline On Fri, 4 Apr 2025 at 17:27, Eric Vyncke (evyncke) <evyncke@cisco.com<mailto:evyncke@cisco.com>> wrote: Dear authors, dear shepherd, DNSOP WG, As Mohamed ‘Med’ Boucadair is now the responsible AD for DNSOP, he passed me the role of responsible AD for this I-D :-) Therefore, here is my own AD review. Before proceeding with the publication process (IETF Last Call and the IESG evaluation), I request to have all points below addressed, i.e., by changing the text, by replying by email wit explanations, ... (Feel free to reject my comments as long as you explain why). Benno, the shepherd’s write-up needs to be revised: 1. In point 1), there is an unfinished sentence “The status of Proposed Standard will” 2. Change the responsible AD to a guy name “Éric Vyncke” ;-) ### Section 1 I am unsure whether firewalls and IPS do use DNS filtering rather than content inspection. DNS filtering is also done by firewalls and IPS. For instance, by-pass content inspection for domains with low security risk score. Is it worth defining “Users of DNS service”, is it the app or the user using the app ? The text also uses “end user”, is the same human being ? Fixed text, please see https://github.com/ietf-wg-dnsop/draft-ietf-dnsop-structured-dns-error/pull/59 ` the DNS server`is a little ambiguous here, should it rather be “recursive DNS resolver“ ? It could be either a DNS resolver or DNS forwarder. EVY> suggest to explicitly write so in the I-D ### Section 3 ` In order to return a block page over HTTPS, man in the middle (MITM)` should “without triggering an invalid TLS server authentication” be added ? Please refrain from using “MITM”, favor “on path attack” or simply “interception” in this case. Fixed text, please see https://github.com/ietf-wg-dnsop/draft-ietf-dnsop-structured-dns-error/pull/59 ` The HTTPS server will have access` unsure which HTTPS server is referred to... is it the expected or the spoofed reply servers ? The HTTP server hosted on the network security device, fixed text. s/Enterprise networks do not assume/Enterprise networks do not always assume/ Should there be text in the DNSSEC bullet that if the filtering DNS server is also the DNSSEC validator, then all is good ? Good point, updated text. Should bullet (4) be merged in bullet (3) ? Yes, merged. ### Section 4 Does this text add any value ` Note that [RFC7493<https://www.rfc-editor.org/rfc/rfc7493>] was based on [RFC7159<https://www.rfc-editor.org/rfc/rfc7159>] but [RFC7159<https://www.rfc-editor.org/rfc/rfc7159>] was replaced by [RFC8259<https://www.rfc-editor.org/rfc/rfc8259>].`? Yes, it helps when going through RFC7493 to refer to RFC8259 instead of RFC7159 (RFC7493 refers to RFC7159) . s/ This field is structured as an array of contact URIs, using/ This field is structured as an array of contact URIs that MUST use/ ? Fixed. Can the “l” name occur in the absence of “j” or “o” names ? "j" is a mandatory field, so "l" cannot occur without it. As I live in a country with 3 (+ English) languages, I sincerely regret that only one language can be used... IMHO, “j” should be an array of <language, text> especially when the end user is residential. The idea is if the language is known, it could be translated by the client to the end-user's native language. (My country has 22 national languages :)) EVY> Oh man... you beat me flat there ;-) EVY> suggest adding some text around it even if I still would prefer an array of languages. Did the WG consider using a single URI pointing to a possibly larger JSON file ? Did the WG consider using CBOR for encoding ? It may be useful to justify in the I-D why JSON was preferred to CBOR. JSON is already used by DNS (see RFC8427) and the spec mandates DoT, DoH or DoQ, fragmentation is not an issue over these transports. EVY> OK, the justification is good ### Section 5.2 S/ A or AAAA record query/ A or AAAA resource record query/ Fixed. EVY> actually not fixed... The 2 seconds for TTL seems very short to me. I would avoid using this value even as an example. Okay, replaced with 10 seconds. ### Section 5.3 As the I-D states `following ordered actions`, please use a numbered list. Thanks, updated. Also, I wonder about the actual order as the channel considerations should probably be first, before the JSON syntax. #1 discusses implementations that both support and do not support this specification. If the input is not valid JSON, subsequent steps will be skipped. In ` If the "c" field contains any URI scheme not registered in the Section 10.3<https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-structured-dns-error-10#IANA-Contact> registry, it MUST be discarded` it is unclear what the “it” refers to. Fixed. s/ In such a case, the content of the "c" attribute can be ignored/ In such a case, the content of the "c" attribute MAY be ignored/ Fixed. The last two bullets (DNS forwarder and app) are not really part of this list but should probably appear as stand alone. Yes, added a new section (see https://github.com/ietf-wg-dnsop/draft-ietf-dnsop-structured-dns-error/pull/62) ### Section 6 Is worth explaining why value = 0 is there and why there are no values for 1 to 4 ? 1 to 4 are reserved for other error codes, please see Section 10.4 ### Section 7 It is unclear whether the original reply is forwarded as it is received, i.e., is the information specified in this document also forwarded ? Yes, the EXTRA-TEXT field is forwarded to the DNS client. Updated text for clarity. ### Section 10.1 I am not an application expert, but is this registration required ? Good catch, it is not required, removed the section. ### References draft-ietf-add-ddr-10 is now RFC 9642 draft-ietf-add-resolver-info-13 is now RFC 9606 (the authors should know ;-) ) Yes, fixed all above :) DNS terminology is no more RFC 8499 but RFC 9499 Fixed. Cheers, -Tiru
- [DNSOP] AD review of draft-ietf-dnsop-structured-… Eric Vyncke (evyncke)
- [DNSOP] Re: AD review of draft-ietf-dnsop-structu… tirumal reddy
- [DNSOP] Re: AD review of draft-ietf-dnsop-structu… Eric Vyncke (evyncke)
- [DNSOP] Re: AD review of draft-ietf-dnsop-structu… tirumal reddy
- [DNSOP] Re: AD review of draft-ietf-dnsop-structu… Eric Vyncke (evyncke)
- [DNSOP] Re: AD review of draft-ietf-dnsop-structu… Benno Overeinder