[Emailcore] Re: Christopher Inacio's Discuss on draft-ietf-emailcore-as-29: (with DISCUSS and COMMENT)

Viktor Dukhovni <ietf-dane@dukhovni.org> Mon, 14 September 2026 03:13 UTC

Received: from chardros.imrryr.org (chardros.imrryr.org [144.6.86.210]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id C826342 for <emailcore@ietf.org>; Mon, 14 Sep 2026 03:13:37 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=dukhovni.org header.s=f8320d6e header.b=VaSrI5jL; dmarc=pass (policy=none) header.from=dukhovni.org; spf=pass (mx.ietf.org: domain of ietf-dane@dukhovni.org designates 144.6.86.210 as permitted sender) smtp.mailfrom=ietf-dane@dukhovni.org
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=dukhovni.org; i=@dukhovni.org; q=dns/txt; s=f8320d6e; t=1789355608; h=date : from : to : subject : message-id : reply-to : references : mime-version : content-type : in-reply-to : content-transfer-encoding : from; bh=XH5ILviHKbZgs61MyvHSiXh//EBt3sI4rawCj1Y8564=; b=VaSrI5jLEZDrM/1FrRfvofDSC60O+0HaZZR8Qfv//up7HzhWjTu6XWkyaJ0a59QNOIHhs UI8WpWZGwwSIvzOkgAqx70ZuehdwDcrxqGZT/8aXfvqN/Uc5+qfV/0nd89fulfqBZc6A3se HfYNTUI4j/JwR+rosvUSoPyj+JCKN4g=
Received: by chardros.imrryr.org (Postfix, from userid 1000) id B643493559C; Mon, 14 Sep 2026 13:13:28 +1000 (AEST)
Date: Mon, 14 Sep 2026 13:13:28 +1000
From: Viktor Dukhovni <ietf-dane@dukhovni.org>
To: emailcore@ietf.org
Message-ID: <aqdmWIdXp2WegBV-@chardros.imrryr.org>
References: <178294085544.2270182.5306958569288595552@dt-datatracker-f9b87776f-xzl65> <94bfd85d-5210-ac01-5496-5ba0d10994a2@isode.com> <63942c7e-d3e6-4335-9979-b51eef5d1768@Canary> <6906820F7AE997CEB5B78119@PSB>
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Disposition: inline
In-Reply-To: <6906820F7AE997CEB5B78119@PSB>
Mail-Followup-To: <emailcore@ietf.org>
Content-Transfer-Encoding: quoted-printable
X-Spam-Level: **
X-Spamd-Bar: ++
Message-ID-Hash: L3JQAZSE2TORKN5N4RSEL5QZB6LVHHR3
X-Message-ID-Hash: L3JQAZSE2TORKN5N4RSEL5QZB6LVHHR3
X-MailFrom: ietf-dane@dukhovni.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.10
Precedence: list
Reply-To: emailcore@ietf.org
Subject: [Emailcore] Re: Christopher Inacio's Discuss on draft-ietf-emailcore-as-29: (with DISCUSS and COMMENT)
List-Id: EMAILCORE proposed working group list <emailcore.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/emailcore/HD6k_W3nJRPz-UpJH9dC3CKGAks>
List-Archive: <https://mailarchive.ietf.org/arch/browse/emailcore>
List-Help: <mailto:emailcore-request@ietf.org?subject=help>
List-Owner: <mailto:emailcore-owner@ietf.org>
List-Post: <mailto:emailcore@ietf.org>
List-Subscribe: <mailto:emailcore-join@ietf.org>
List-Unsubscribe: <mailto:emailcore-leave@ietf.org>

On Sun, Sep 13, 2026 at 05:36:01PM -0400, John C Klensin wrote:

> (i) Unlike the clear requirement for a scope statement for TS
> document in the second paragraph of Section 3.1 of RFC 2026 (a
> requirement the IESG has sometimes ignored), there is no equivalent
> requirement for TS documents in Section 3.2.  It is my belief that
> the requirements of Section 3.2 are met by the Introduction.

There we find:

   [...]         An AS also specifies the circumstances in which the use
   of a particular TS is required, recommended, or elective (see section
   3.3).

which then expanded to include:

   The broadest type of AS is a comprehensive conformance specification,
   commonly called a "requirements document", for a particular class of
   Internet systems, such as Internet routers or Internet hosts.

With that in mind, FWIW the scope of AS is in my view systems that perform
relaying of email messages, especially across ADministrative Management
Domains (ADMDs, Section 2.3 of RFC5598).

The transport of email messages within an ADMD may be highly specialised
to a single vendor's techology stack, or a uniform set of practices that
depart materially from those seen on the public Internet.  Authenticated
TLS between internal email relays may be required in some deployments,
with perhaps GSSAPI authentication of client (almost never seen in
cross-ADMD scenarios).  Routing of email to the appropriate nexthop
may not be MX based, ...

> If it would move things along to change the title of Section 1 to
> "Introduction and Scope Statement", I don't imagine there would be any
> objection but doubt that the best interests of the IETF or the
> Internet community would be particularly well-served by holding the
> document up for that change.

If cross-ADMD email handling is the principal scope of the AS, then
the introduction's:

    In order to promote interoperability amongst senders, receivers, and
    intermediaries, it includes discussions and recommendations about
    selected features of SMTP, IMF, and certain extensions to them that
    are required, recommended, or to be avoided except in special cases.

could be somewhat more explicit, but it is also unclear to me that such
clarification warrants another round of discussion and edits.

> (ii) If this is really about making a statement about the public
> versus private Internet(s), as some earlier comments suggested, I
> think that would be a mistake.  I, and others, have tried to explain
> the problem before, but can't remember the distribution lists, so let
> me try to summarize.  Because of its history and the large variety of
> arrangements for originating and receiving messages, email is a
> strange creature.  For example, on the origination and submission
> end, constructing and sending a message over a web interface will
> typically be on the public Internet but a user of a traditional Mail
> User Agent (MUA) will often be operating on a private network with
> the boundary between that private network and the public one
> occurring either between the MUA and the client side of a Submission
> Server or between the Submission Server and the next hop.  That is
> further complicated by the common use of SSH (or SSH-like) tunnels
> between the MUA and whatever comes next and, for this document, by
> the fact that the WG Charter fairly explicitly put Message Submission
> (RFC 6409, etc.) out of scope.

Leaving submission out of scope (and any use of SSH, Web UIs, ...) is
entirely consistent with a primary focus on cross-ADMD message delivery.

> Certainly, if the IESG insisted and
> the WG was agreeable, we could write text to explain those issues,
> but it would probably be long, not help reduce any confusion that
> existed among actual email implementers or those trying to make
> decisions about choices of systems, and raise issues about the limits
> of the WG charter.
> 
> If you believe more is needed, can you be a little bit more specific
> about what you are looking for?

I am not opposed to adding context, but don't see a glaring need.

-- 
    Viktor.  🇺🇦 Слава Україні!