[Emailcore] Re: Posting draft-ietf-emailcore-as-30

Viktor Dukhovni <ietf-dane@dukhovni.org> Tue, 15 September 2026 06:54 UTC

Received: from chardros.imrryr.org (chardros.imrryr.org [144.6.86.210]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id B51C052 for <emailcore@ietf.org>; Tue, 15 Sep 2026 06:54:23 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=dukhovni.org header.s=f8320d6e header.b="u4zN/mOL"; dmarc=pass (policy=none) header.from=dukhovni.org; spf=pass (mx.ietf.org: domain of ietf-dane@dukhovni.org designates 144.6.86.210 as permitted sender) smtp.mailfrom=ietf-dane@dukhovni.org
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=dukhovni.org; i=@dukhovni.org; q=dns/txt; s=f8320d6e; t=1789455253; h=date : from : to : subject : message-id : reply-to : references : mime-version : content-type : in-reply-to : content-transfer-encoding : from; bh=Fnn9w+CshuZzaBzg5oC3Q1jJ/ykkMcionkHePOfzG1U=; b=u4zN/mOLGNCtk4h+zn7XvSCBR2dJAq8dUavaLadpM/w7C+GcCgPt1ql1xAstqfBDg1r7O IlVd+316TwodFg3fWseZpjFd225ot/13Fax7LTOXPHW2nOjqnu56fX0PQs4hzpyMXieJZqQ 6+rcSUyaWTcSXxqeucoU8TkKGkoUm+Y=
Received: by chardros.imrryr.org (Postfix, from userid 1000) id 237A393559C; Tue, 15 Sep 2026 16:54:13 +1000 (AEST)
Date: Tue, 15 Sep 2026 16:54:13 +1000
From: Viktor Dukhovni <ietf-dane@dukhovni.org>
To: emailcore@ietf.org
Message-ID: <aqjrldOdOtHYow-L@chardros.imrryr.org>
References: <42918255DBF0FD8A1CF0851B@PSB> <20260907151744.zZRESCnL@steffen%sdaoden.eu>
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Disposition: inline
In-Reply-To: <20260907151744.zZRESCnL@steffen%sdaoden.eu>
Mail-Followup-To: <emailcore@ietf.org>
Content-Transfer-Encoding: quoted-printable
X-Spam-Level: **
X-Spamd-Bar: ++
Message-ID-Hash: N7Z2YUFM5ZLT76MVXHE2YK3ILDKYQPLZ
X-Message-ID-Hash: N7Z2YUFM5ZLT76MVXHE2YK3ILDKYQPLZ
X-MailFrom: ietf-dane@dukhovni.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.10
Precedence: list
Reply-To: emailcore@ietf.org
Subject: [Emailcore] Re: Posting draft-ietf-emailcore-as-30
List-Id: EMAILCORE proposed working group list <emailcore.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/emailcore/zdWBwrC9WSduu_iG7nsiLiK5mwM>
List-Archive: <https://mailarchive.ietf.org/arch/browse/emailcore>
List-Help: <mailto:emailcore-request@ietf.org?subject=help>
List-Owner: <mailto:emailcore-owner@ietf.org>
List-Post: <mailto:emailcore@ietf.org>
List-Subscribe: <mailto:emailcore-join@ietf.org>
List-Unsubscribe: <mailto:emailcore-leave@ietf.org>

On Mon, Sep 07, 2026 at 05:17:44PM +0200, Steffen Nurpmeso wrote:

>   *  Internationalized Email [SMTPUTF8]
>   ...
>   Internationalized email is similarly ubiquitous, to the extent that
>   its non-use degrades the basic user experience in modern Internet
>   messaging, hence support for it in MTAs is encouraged.
> 
> I do not know how anyone can come to this conclusion, really.

Well ubiquitous does not mean either universal or even most common, and,
while perhaps other adjectives might be closer, this editorial nit does
not really seem to be your real issue (which remains unclear in the
below).

> If it was "detected" by doing these unbelievable large-scale scans
> that anyone believes has a right to perform, then hopefully also
> reaching out behind STARTTLS (surely), then no.

No specific measurements are reported or implied.  The "ubiquity" of EAI
is perhaps more of a consensus impression shared by the working group,
but the substance of the quoted text is a recommendation to support EAI
( at least to the extent of not getting in the way).  Whether it is or
is not "ubiquitous" is secondary.

> I only comment on that no further context on message/global etc.

The message/global (non-transparent MIME encoding) design error should
be corrected, but that's out of scope for this I-D.

> The point is that, aside those giants which the western world
> currently still uses the way it does, which possibly support
> SMTPUTF8.  The point is that massively used "everybodies'"
> software started enabling this by default, for example postfix:
> 
>   smtputf8_enable (default: yes)
>    Enable preliminary SMTPUTF8 support for the protocols described
>    in  RFC 6531,  RFC  6532,  and  RFC 6533. This requires that
>    Postfix is built to support these protocols.
> 
> This means that whenever you upgrade an existing installation of
> this software, you get this thing enabled, so that these monstrous
> scans will turn the "does it use SMTPUTF8" green.

No scans were employed in the of developing this draft.  If you object
to academic or other active deployment surveys, this is not the right
forum for those objections.

> But this does *NOT* mean that the MUAs, or any other software
> behind that MTA which does use these in parts broken protocol
> extensions, actually can deal with such messages, shall they enter
> the system.

Yes, EAI support is spotty, and a number of ubiquitous software stacks
don't handle at all EAI gracefully.  This is why a plea for broader
support is needed.  By way of anecdotal evidence in support of both the
I-D and your observations:

  - My own Postfix server and "mutt" MUA support EAI well enough to
    allow correct delivery of <cyrillic-local-part@cyrillic-label.org>
    in both directions between my server and Gmail.

        F311693559C: from=<EAI-was-here>, size=764, nrcpt=1 (queue active)
        F311693559C: to=<non-eai@gmail.com>, relay=gmail-smtp-in.l.google.com[172.217.221.26]:25, delay=3.9, delays=0.02/0.01/2.6/1.2, tls=encrypt, dsn=2.0.0, status=sent (250 2.0.0 OK  1789445239 d2e1a72fcca58-86b262bb91esi24702246b3a.7 - gsmtp)

        433A793559C: from=<non-eai@gmail.com>, size=6048, nrcpt=1 (queue active)
        433A793559C: to=<internal-address>, orig_to=<EAI-was-here>, relay=virtual, delay=1.1, delays=1.1/0/0/0, dsn=2.0.0, status=sent (delivered to maildir)

  - My up-to-date MacOS laptop's Mail.app on the other hand butchered
    the the EAI address beyond recognition:

        NOQUEUE: reject: RCPT from [...]: 550 5.1.1 <=?utf-8?B?base64?=@a-label.org>: Recipient address rejected: User unknown in virtual alias table; from=<viktor@a-label.org> to=<=?utf-8?B?base64?=@a-label.org> proto=ESMTP helo=<smtpclient.apple> sasl_method=GSSAPI sasl_username=viktor

    How the maintainers of Mail.app decided that the local part of an
    SMTP envelope address is subject to RFC2047 display name encoding is
    a mystery to me.  Also replacing the recipient domain's U-label with
    the corresponding A-label is not expected behaviour.

> [ Gripes about EAI friction ]

Well, this is why it is important to advocate for the problem
software to be fixed.

> So .. "no" regarding the above statement.  And understandably so.
> I mean, you do not even need to respond, just let it in.
> But it is utter nonsense.

Even if you feel that "ubiquitous" is the wrong adjective, it is
then even more apparent that advocacy to improve support is apt.

> Having said that, i hate the way the RFC 822 References: field has
> been insensitively and unnecessarily and blinders-wearing
> mutilated in RFC 2822. [...]

I don't think this gripe is relevant to the AS draft.  If you
have improvements in mind perhaps the "mainmaint" list is a
more appropriate forum, if there's room in the charter for such
concerns.

-- 
    Viktor.  🇺🇦 Слава Україні!