[Mod-discuss] Re: Last call review of draft-ietf-modpod-group-processes-10

David Schinazi <dschinazi.ietf@gmail.com> Fri, 12 September 2025 22:12 UTC

Return-Path: <dschinazi.ietf@gmail.com>
X-Original-To: mod-discuss@mail2.ietf.org
Delivered-To: mod-discuss@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 711B661E8121 for <mod-discuss@mail2.ietf.org>; Fri, 12 Sep 2025 15:12:05 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 3FxTvaSkYmHd for <mod-discuss@mail2.ietf.org>; Fri, 12 Sep 2025 15:12:04 -0700 (PDT)
Received: from mail-il1-x12b.google.com (mail-il1-x12b.google.com [IPv6:2607:f8b0:4864:20::12b]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id A883061E8119 for <mod-discuss@ietf.org>; Fri, 12 Sep 2025 15:12:04 -0700 (PDT)
Received: by mail-il1-x12b.google.com with SMTP id e9e14a558f8ab-403a893fb4bso12900265ab.0 for <mod-discuss@ietf.org>; Fri, 12 Sep 2025 15:12:04 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1757715118; x=1758319918; darn=ietf.org; h=to:subject:message-id:date:from:in-reply-to:references:mime-version :from:to:cc:subject:date:message-id:reply-to; bh=dMdmEWK06i1p7a6SbLhC5yU29mEkDRP+P/xlWAelrHI=; b=nRAd8SUNUmNlDhy0/ZptBMtNKFGCuhYJ3r7usf8WtOeJ+Q++oUMJ7BKHKYSCrdgmo6 2Dwy3JAHk91ZtPgRnUM4n1PKUmS5eYf5BhoqBX3yYtqWsGzShiasQbyG0h13iBZJJbmK wtEKVvgpN+WuWkD4rGEm74rjn0HdDJM6f4pobd+8lwioB0MrwpQ7PZSzqXsMsiTN5uyR btlDTx8dV7DmkUNeXuAGR/1n6QOl+Xk0aeW6YFvEMgsn2jKHcfwG/nIScfxkO7Ay5VNL WFHalwwTYRdnGbiDGk0qBxoFXucadRpHhUSBsIMVTR3trHNZMyXWkCe6U/rfkdojmHfy 9VfA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1757715118; x=1758319918; h=to:subject:message-id:date:from:in-reply-to:references:mime-version :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=dMdmEWK06i1p7a6SbLhC5yU29mEkDRP+P/xlWAelrHI=; b=tcyGNj0QfxYkZ6he1X1iDGakVyVAsw9dOtrTDnF3RzS55JSK3elqKLMjyRXLuQA4VN TsZAN++vVhHyZnoRlyT8pg1RqSoyEmzo124tRkPMMLjHJlA0MVG7d+6Iy/abKsNwSYQo 8JQjYqoeprhwyC0+cBQqgZCixrTC0+5FvXo743T4Pppe7mqAK57qznLw8+Cu2biboag0 ns9BpPZqaHn0jqrrfFi4iO1XBxqHkwLCGrc2dUERPe8NSVjk1kw1LBNYwBdqZSJQTAR2 hlzUljd2s6rdaMjIix6YLGI91Av9Vl9lkp3JI/2py2oPGdQhiID8FU6D5YvGf1icr5X7 Swvg==
X-Gm-Message-State: AOJu0YxuMCeniK2I1I0V3bfcvnfGGg4XHvSdURC7SKnDEnMytVNGVsXi 0wUE+SEOUVOM5EXLo2Smvh/oKCHWQzAl+rwKZmSiHgzkv6vOsj2sjuKYyKqHeRsQECYPJCDLXZX jxj5dsGjBSbbC5koOcDERCVodoEs9wGIYcelN
X-Gm-Gg: ASbGncvwhEJwRUU1fwlEh/saI7eOsqrYQjh6+PtWxwm2XwbYGDLWwWu6ZV5B9h4OeGa khtM66HdFlkrkf0V77asC7IhaL/17oopVYBZjdmMk6QyAlbOBLu9VRtUBtFoGFVFN/HMOVtljGt D1WYDpqsRnw/hW8mKytYF6F9u5TdTq9iYIXImpJl5SIBDPGwlzGyh8WfZbVmTtf7TqozRaLEVl+ bZw8sF9HqGgc9H9TFgmxZBFnLVqeGpstxktsyvDJEDyfkhzw4lZ1eE2WgtuXgW3FBV3pQR3FdUO G6RSd84hGTzDsI96Rg==
X-Google-Smtp-Source: AGHT+IEh9d8kA2ka39Sjd69+82Q+khkJ6uWQySdRgQT/u+tdjfuMtG3k3JXZeZIdontrYCcElkyw80QkiX1BqHwt9Wc=
X-Received: by 2002:a05:6e02:230a:b0:423:4ff6:aad3 with SMTP id e9e14a558f8ab-4234ff6b16dmr29209565ab.7.1757715117628; Fri, 12 Sep 2025 15:11:57 -0700 (PDT)
MIME-Version: 1.0
References: <CAPDSy+595bZjjFHVnvhFcYNUbk2h=jU8Uu-kpB7DeGe7dbaurw@mail.gmail.com> <E2C3382A-5291-49CA-8591-B33B3C9714D7@csperkins.org> <CAPDSy+4UU5yv=GpAnpzrR_AR6S93k+GXASB+Z+TK5LK4FQkMxA@mail.gmail.com> <823EB97A-C87A-4F42-A967-5097818C5163@csperkins.org> <ba763aa9-ec4f-46a1-81a2-09e8a5baed68@gmail.com>
In-Reply-To: <ba763aa9-ec4f-46a1-81a2-09e8a5baed68@gmail.com>
From: David Schinazi <dschinazi.ietf@gmail.com>
Date: Fri, 12 Sep 2025 15:11:46 -0700
X-Gm-Features: Ac12FXytvMtgpwuxb4Xzus9n3G5O0X1B8rcnweqW4H4s1R1-2EbXyHT0iexMBj4
Message-ID: <CAPDSy+5CWRFof7SWq7kqu-9mJKkaqPcFmBQsQA2p2_14uW307Q@mail.gmail.com>
To: mod-discuss@ietf.org
Content-Type: multipart/alternative; boundary="00000000000033e2b4063ea1f1f9"
Message-ID-Hash: HGJCLH23TLQKAONQ6PT6PJ6G76ME6Q27
X-Message-ID-Hash: HGJCLH23TLQKAONQ6PT6PJ6G76ME6Q27
X-MailFrom: dschinazi.ietf@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-mod-discuss.ietf.org-0; header-match-mod-discuss.ietf.org-1; header-match-mod-discuss.ietf.org-2; header-match-mod-discuss.ietf.org-3; header-match-mod-discuss.ietf.org-4; header-match-mod-discuss.ietf.org-5; header-match-mod-discuss.ietf.org-6; header-match-mod-discuss.ietf.org-7; header-match-mod-discuss.ietf.org-8; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Mod-discuss] Re: Last call review of draft-ietf-modpod-group-processes-10
List-Id: Discussion list for IETF moderation policies and practices <mod-discuss.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/mod-discuss/5vkrl4frp5NIDhd62DKr1APvqK8>
List-Archive: <https://mailarchive.ietf.org/arch/browse/mod-discuss>
List-Help: <mailto:mod-discuss-request@ietf.org?subject=help>
List-Owner: <mailto:mod-discuss-owner@ietf.org>
List-Post: <mailto:mod-discuss@ietf.org>
List-Subscribe: <mailto:mod-discuss-join@ietf.org>
List-Unsubscribe: <mailto:mod-discuss-leave@ietf.org>

Fair enough. If folks don't want to expand the scope to the IRTF, then that
works for me. I've written up this clarification and my other points as
GitHub PRs:

https://github.com/larseggert/draft-ietf-modpod-group-processes/pull/222
https://github.com/larseggert/draft-ietf-modpod-group-processes/pull/223
https://github.com/larseggert/draft-ietf-modpod-group-processes/pull/224

Cheers,
David

On Fri, Sep 12, 2025 at 2:03 PM Brian E Carpenter <
brian.e.carpenter@gmail.com> wrote:

> I agree with Colin. This is an IETF WG so let's limit its scope to the
> IETF.
>
> Regards/Ngā mihi
>     Brian Carpenter
>
> On 13-Sep-25 07:07, Colin Perkins wrote:
> > Hi David,
> >
> > I would argue that the right approach to moderating mailing lists
> relating to a standards development organisation differs from that of a
> research organisation.
> >
> > The IETF has process requirements for openness that the IRTF dos not
> have. The IETF has requirements for consensus that the IRTF does not have.
> As a result, moderators might put the bar for what is considered disruptive
> in a different place in the IETF than in the IRTF – the goals of the two
> organisations differ, so might the goals of their moderation policies.
> >
> > RFC 3683 (PR-Action) and RFC 3934, which are the main drivers for
> MODPOD, have never applied to IRTF.
> >
> > This WG should define a moderation process for the IETF lists, following
> its charter. The IRTF can define its own processes.
> >
> > Colin
> >
> >
> >
> >
> > On 12 Sep 2025, at 19:23, David Schinazi wrote:
> >
> >     Hi Colin,
> >
> >     You're absolutely right, IETF consensus isn't enough to change IRTF
> policies. But we can solve that by getting this document approved by the
> IRSG in addition to IETF consensus. The "Problems with the Previous
> Approach" appendix does a great job of explaining why it's helpful to have
> moderators in addition to WG chairs, and that logic applies just as well to
> RG chairs. Additionally, this would be in line with how the IRTF follows
> the IETF anti-harassment policy.
> >
> >     David
> >
> >     On Fri, Sep 12, 2025 at 12:32 AM Colin Perkins <csp@csperkins.org
> <mailto:csp@csperkins.org>> wrote:
> >
> >         HI,
> >
> >         [one comment inline]
> >
> >         On 12 Sep 2025, at 2:48, David Schinazi wrote:
> >
> >             Hi moderation enthusiasts,
> >
> >             I just did a full read through of
> draft-ietf-modpod-group-processes-10. I
> >             think the document is incredibly thorough, well-written, and
> is ready to be
> >             advanced towards publication.
> >
> >             I have a few suggestions that I don't consider to be
> blocking:
> >
> >               * Section 2.1 (Composition) states <<The moderator team
> consists of no less
> >
> >             than five individuals>> but doesn't explain what happens if
> that number
> >             were ever to drop to four due to unfortunately timed
> resignations. I'd
> >             recommend using text similar to Section 3.1 of RFC 7776 to
> avoid ambiguity.
> >
> >               * In section 5.1 (Relation to the Ombudsteam), I think we
> do a good job of
> >
> >             covering communications from the administrators to the
> Ombudsteam, but I
> >             would suggest adding text about the converse direction.
> Perhaps something
> >             like this: <<If the Ombudsteam is confidentially notified of
> unacceptable
> >             behavior on a public forum, they may notify the appropriate
> administrator
> >             about the concern and suggest a course of action.
> Administrators are
> >             encouraged to take Ombudsteam concerns into consideration.
> The Ombudsteam
> >             will clearly communicate whether their proposal is a
> non-binding suggestion
> >             or a formal Remedy as defined in Section 5 of RFC 7776.>>
> >
> >               * Section 5.3 (Relation to the IRTF) was unclear to me.
> The IRTF has its
> >
> >             own code of conduct but it still requires mailing list
> communication to be
> >             respectful and professional. Is the intent of this section
> to say that IRTF
> >             lists are out of scope for the moderation team? I think that
> would be a
> >             mistake. The IRSG is primarily responsible for enforcing the
> IRTF code of
> >             conduct, but I think the moderation team should be able to
> intervene in the
> >             same way that they can for IETF WGs.
> >
> >         That’s a possible option, but the IRSG would have to decide to
> opt into the policy. As an IETF working group, MODPOD can’t make that
> decision for the IRTF.
> >
> >         (The IETF and IRTF have historically had different mailing list
> moderation policies)
> >
> >         Colin
> >
> >             I fully support advancing the document, even if we don't end
> up reaching
> >             consensus on my suggestions above.
> >
> >             Thanks,
> >             David (writing as an individual)
> >
> >
>  ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> >
> >             Mod-discuss mailing list -- mod-discuss@ietf.org <mailto:
> mod-discuss@ietf.org>
> >             To unsubscribe send an email to mod-discuss-leave@ietf.org
> <mailto:mod-discuss-leave@ietf.org>
> >
> >
> > _______________________________________________
> > Mod-discuss mailing list -- mod-discuss@ietf.org
> > To unsubscribe send an email to mod-discuss-leave@ietf.org
> _______________________________________________
> Mod-discuss mailing list -- mod-discuss@ietf.org
> To unsubscribe send an email to mod-discuss-leave@ietf.org
>