[Mod-discuss] Re: Last call review of draft-ietf-modpod-group-processes-10

Brian E Carpenter <brian.e.carpenter@gmail.com> Fri, 12 September 2025 21:02 UTC

Return-Path: <brian.e.carpenter@gmail.com>
X-Original-To: mod-discuss@mail2.ietf.org
Delivered-To: mod-discuss@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 9AD2D61DE968 for <mod-discuss@mail2.ietf.org>; Fri, 12 Sep 2025 14:02:58 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.099
X-Spam-Level:
X-Spam-Status: No, score=-2.099 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id HJyL1jz3XDiS for <mod-discuss@mail2.ietf.org>; Fri, 12 Sep 2025 14:02:58 -0700 (PDT)
Received: from mail-pf1-x430.google.com (mail-pf1-x430.google.com [IPv6:2607:f8b0:4864:20::430]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 1955361DE8BF for <mod-discuss@ietf.org>; Fri, 12 Sep 2025 14:02:54 -0700 (PDT)
Received: by mail-pf1-x430.google.com with SMTP id d2e1a72fcca58-7761e1fc3faso574149b3a.1 for <mod-discuss@ietf.org>; Fri, 12 Sep 2025 14:02:54 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1757710967; x=1758315767; darn=ietf.org; h=content-transfer-encoding:in-reply-to:from:references:to :content-language:subject:user-agent:mime-version:date:message-id :from:to:cc:subject:date:message-id:reply-to; bh=OGOQNboBNg2NH1JXL5YygTMMxasBySSwrr3bZLMXnFQ=; b=PwfssyqnMmEI9K7AEDToGMOPTyyT7OGvLbo/yOfoipmQTfgYTio0MazjH0SpMewENv 4pg8Fi8Ok+st/qX+NeQFxvnSc8yt/eFVxn26ImsScZNVuWyG2CELm6hQAk9BmHa7PlkV trIOgF+5BQ7LDDr0uNKKhmob3yaMfLYPZKTCA8NwwqbH0QUZKiveQ7kbYfDceEt6Cqyt yvt6+71meqFEFI71sbdIqoGMdbhBrVrbgQlNxH8UB+vTVF8w9+ycIa4jAkEC4Nkc0B/G 0yEGag4MQSX3rLI45t8qYrudUewqRDkgRrzAGPdvwytEm4kRrp83fX/O1gx0lRICqs+u Zd6w==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1757710967; x=1758315767; h=content-transfer-encoding:in-reply-to:from:references:to :content-language:subject:user-agent:mime-version:date:message-id :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=OGOQNboBNg2NH1JXL5YygTMMxasBySSwrr3bZLMXnFQ=; b=Ihis/u523zhLcyEKtB9OpFFED52OCJvjaNLJXLJwR4lCq/LheKEvZEiONYdZigesUF PlewPH2yrFuq0Z6Y8OEuKY1klz6HXiVmUCWtCP6QVo4J0pL+JGgvsR6+M5TeCJoDrwg5 ffg+KdDDRGlKf7i37HvOgIe7HJtNPK48KFMuD7jxPH/Jbq/vDD1RgxxmIGSWfHQCMPdL r9tafyUw99s3nm1yx+pONWLB+VDo+4fD3fHNZUglNIJYfS5O5TM/2toph+9Yp2xkhZns EapcpPARI1ckCQ9+ZW4f5RZM2aqjl1VKO/Ii49ohq7BIhcaRC1UHf/cEWxBkBd0Nf1Db +H7A==
X-Gm-Message-State: AOJu0Yy9djttSRoSoCHj5TjxsD9xlHH0/eK1cVCc9stUVYJ21UHLjCIg vnBR/0QJIl3zha5APUBGOs7U97Gz5lkS7quN3p5UVvwTqaXITxvZHC5zAjHcCQ==
X-Gm-Gg: ASbGncuyYMiPt7bXua98lgRgoZqeu+7UBsHmQJC8xAn5k+HNViYAHSqvuu92oXXNVmY D1OoAmGUhC9HhvvihLTo8l2+UFJH7mUJh4U36jsVKwHhBFi0/f3A0IWX7KJEMotclt6LjC+9nQR 5f/XzkqtYV61cz63EbZN8+dmZx2hi9c3bAvDp6IJ60vgaEH149FPteyr9ZaDcO3vq0wi9fKwsie PQsfgABFeZfcS22jZxkj2Gr9qTLF4GSl02bEwyvQivpIrSw6LJZDZIXkqV3GXrgjnOshkJYnQ39 VdzHR/oDyMc5KbnL1F9kORnyqwqbw5dipGPiojYrsKrlmRDnrunC/Ck+hE4jLF0iITkbNMTWbiJ MCxMhz8ZN/Ng8Jlasc04IQPnt7hs5HegMe0Z8ewzE9ZsvIpBqEjaLvdL4FPLkTXJ+/hXQwo89iu Ym8CPTQ6JlO9SNOzqziCDgHQ==
X-Google-Smtp-Source: AGHT+IHHtegEZF1P0ojtyLT3gNOLQUSEmbGfVdJbIRvAuumXHxQlxL0x02orvtzDd6mSRLuUSsoTnA==
X-Received: by 2002:a05:6a00:1743:b0:73c:b86:b47f with SMTP id d2e1a72fcca58-77612064075mr5260664b3a.4.1757710966891; Fri, 12 Sep 2025 14:02:46 -0700 (PDT)
Received: from ?IPV6:2404:4400:540a:800:8bdd:3b5f:46ae:fd4c? ([2404:4400:540a:800:8bdd:3b5f:46ae:fd4c]) by smtp.gmail.com with ESMTPSA id d2e1a72fcca58-77607a48c19sm6380348b3a.36.2025.09.12.14.02.45 for <mod-discuss@ietf.org> (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Fri, 12 Sep 2025 14:02:46 -0700 (PDT)
Message-ID: <ba763aa9-ec4f-46a1-81a2-09e8a5baed68@gmail.com>
Date: Sat, 13 Sep 2025 09:02:43 +1200
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
Content-Language: en-US
To: mod-discuss@ietf.org
References: <CAPDSy+595bZjjFHVnvhFcYNUbk2h=jU8Uu-kpB7DeGe7dbaurw@mail.gmail.com> <E2C3382A-5291-49CA-8591-B33B3C9714D7@csperkins.org> <CAPDSy+4UU5yv=GpAnpzrR_AR6S93k+GXASB+Z+TK5LK4FQkMxA@mail.gmail.com> <823EB97A-C87A-4F42-A967-5097818C5163@csperkins.org>
From: Brian E Carpenter <brian.e.carpenter@gmail.com>
In-Reply-To: <823EB97A-C87A-4F42-A967-5097818C5163@csperkins.org>
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: base64
Message-ID-Hash: M3BJPGNKXZUABFPMT3HSPDXUFFNCJYEB
X-Message-ID-Hash: M3BJPGNKXZUABFPMT3HSPDXUFFNCJYEB
X-MailFrom: brian.e.carpenter@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-mod-discuss.ietf.org-0; header-match-mod-discuss.ietf.org-1; header-match-mod-discuss.ietf.org-2; header-match-mod-discuss.ietf.org-3; header-match-mod-discuss.ietf.org-4; header-match-mod-discuss.ietf.org-5; header-match-mod-discuss.ietf.org-6; header-match-mod-discuss.ietf.org-7; header-match-mod-discuss.ietf.org-8; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Mod-discuss] Re: Last call review of draft-ietf-modpod-group-processes-10
List-Id: Discussion list for IETF moderation policies and practices <mod-discuss.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/mod-discuss/DwGwGt0W-2FZ7pKX-WIKBjm42wY>
List-Archive: <https://mailarchive.ietf.org/arch/browse/mod-discuss>
List-Help: <mailto:mod-discuss-request@ietf.org?subject=help>
List-Owner: <mailto:mod-discuss-owner@ietf.org>
List-Post: <mailto:mod-discuss@ietf.org>
List-Subscribe: <mailto:mod-discuss-join@ietf.org>
List-Unsubscribe: <mailto:mod-discuss-leave@ietf.org>

I agree with Colin. This is an IETF WG so let's limit its scope to the IETF.

Regards/Ngā mihi
    Brian Carpenter

On 13-Sep-25 07:07, Colin Perkins wrote:
> Hi David,
> 
> I would argue that the right approach to moderating mailing lists relating to a standards development organisation differs from that of a research organisation.
> 
> The IETF has process requirements for openness that the IRTF dos not have. The IETF has requirements for consensus that the IRTF does not have. As a result, moderators might put the bar for what is considered disruptive in a different place in the IETF than in the IRTF – the goals of the two organisations differ, so might the goals of their moderation policies.
> 
> RFC 3683 (PR-Action) and RFC 3934, which are the main drivers for MODPOD, have never applied to IRTF.
> 
> This WG should define a moderation process for the IETF lists, following its charter. The IRTF can define its own processes.
> 
> Colin
> 
> 
> 
> 
> On 12 Sep 2025, at 19:23, David Schinazi wrote:
> 
>     Hi Colin,
> 
>     You're absolutely right, IETF consensus isn't enough to change IRTF policies. But we can solve that by getting this document approved by the IRSG in addition to IETF consensus. The "Problems with the Previous Approach" appendix does a great job of explaining why it's helpful to have moderators in addition to WG chairs, and that logic applies just as well to RG chairs. Additionally, this would be in line with how the IRTF follows the IETF anti-harassment policy.
> 
>     David
> 
>     On Fri, Sep 12, 2025 at 12:32 AM Colin Perkins <csp@csperkins.org <mailto:csp@csperkins.org>> wrote:
> 
>         HI,
> 
>         [one comment inline]
> 
>         On 12 Sep 2025, at 2:48, David Schinazi wrote:
> 
>             Hi moderation enthusiasts,
> 
>             I just did a full read through of draft-ietf-modpod-group-processes-10. I
>             think the document is incredibly thorough, well-written, and is ready to be
>             advanced towards publication.
> 
>             I have a few suggestions that I don't consider to be blocking:
> 
>               * Section 2.1 (Composition) states <<The moderator team consists of no less
> 
>             than five individuals>> but doesn't explain what happens if that number
>             were ever to drop to four due to unfortunately timed resignations. I'd
>             recommend using text similar to Section 3.1 of RFC 7776 to avoid ambiguity.
> 
>               * In section 5.1 (Relation to the Ombudsteam), I think we do a good job of
> 
>             covering communications from the administrators to the Ombudsteam, but I
>             would suggest adding text about the converse direction. Perhaps something
>             like this: <<If the Ombudsteam is confidentially notified of unacceptable
>             behavior on a public forum, they may notify the appropriate administrator
>             about the concern and suggest a course of action. Administrators are
>             encouraged to take Ombudsteam concerns into consideration. The Ombudsteam
>             will clearly communicate whether their proposal is a non-binding suggestion
>             or a formal Remedy as defined in Section 5 of RFC 7776.>>
> 
>               * Section 5.3 (Relation to the IRTF) was unclear to me. The IRTF has its
> 
>             own code of conduct but it still requires mailing list communication to be
>             respectful and professional. Is the intent of this section to say that IRTF
>             lists are out of scope for the moderation team? I think that would be a
>             mistake. The IRSG is primarily responsible for enforcing the IRTF code of
>             conduct, but I think the moderation team should be able to intervene in the
>             same way that they can for IETF WGs.
> 
>         That’s a possible option, but the IRSG would have to decide to opt into the policy. As an IETF working group, MODPOD can’t make that decision for the IRTF.
> 
>         (The IETF and IRTF have historically had different mailing list moderation policies)
> 
>         Colin
> 
>             I fully support advancing the document, even if we don't end up reaching
>             consensus on my suggestions above.
> 
>             Thanks,
>             David (writing as an individual)
> 
>             ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> 
>             Mod-discuss mailing list -- mod-discuss@ietf.org <mailto:mod-discuss@ietf.org>
>             To unsubscribe send an email to mod-discuss-leave@ietf.org <mailto:mod-discuss-leave@ietf.org>
> 
> 
> _______________________________________________
> Mod-discuss mailing list -- mod-discuss@ietf.org
> To unsubscribe send an email to mod-discuss-leave@ietf.org