[netmod] Re: AD - Re: AUTH48: RFC-to-be 9644 <draft-ietf-netconf-ssh-client-server-40> for your review

Kent Watsen <kent+ietf@watsen.net> Thu, 12 September 2024 11:04 UTC

Return-Path: <01000191e5e7bd22-2999d337-8925-470f-abb4-890ca32884aa-000000@amazonses.watsen.net>
X-Original-To: netmod@ietfa.amsl.com
Delivered-To: netmod@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C03DBC151071 for <netmod@ietfa.amsl.com>; Thu, 12 Sep 2024 04:04:17 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.017
X-Spam-Level:
X-Spam-Status: No, score=-6.017 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, HTML_MESSAGE=0.001, MIME_HTML_ONLY=0.1, MIME_HTML_ONLY_MULTI=0.001, MIME_QP_LONG_LINE=0.001, MPART_ALT_DIFF=0.79, RCVD_IN_DNSWL_HI=-5, RCVD_IN_MSPIKE_H2=-0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=amazonses.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id i-vggZgBuCrb for <netmod@ietfa.amsl.com>; Thu, 12 Sep 2024 04:04:17 -0700 (PDT)
Received: from a8-88.smtp-out.amazonses.com (a8-88.smtp-out.amazonses.com [54.240.8.88]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 14386C15106E for <netmod@ietf.org>; Thu, 12 Sep 2024 04:04:16 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/simple; s=ug7nbtf4gccmlpwj322ax3p6ow6yfsug; d=amazonses.com; t=1726139055; h=Content-Type:Content-Transfer-Encoding:From:Mime-Version:Subject:Date:Message-Id:References:Cc:In-Reply-To:To:Feedback-ID; bh=fLBIu8coUOasHi40jp9chVLsbGKey7QpH31RDo3QSew=; b=LUzd6/E6bbDGeWZhpCJ/nkFe8T1Hgi9k2MSBDRvVYT6zSUtQuPWdE0apWoLy0WP6 y1jzTk2YI/G/MRUlkM4JXrfHPlSjGhzdVDiRidn+iS9Ru0LxE+ZaBLyrkmY4Lf2HO7v fs5Pcm+iWGX/oZnf2Ste9lKQD6AyX0Q0x8e9BE3o=
Content-Type: multipart/alternative; boundary="Apple-Mail-1F69FF6E-B6C0-4406-B772-7938A9D499EC"
Content-Transfer-Encoding: 7bit
From: Kent Watsen <kent+ietf@watsen.net>
Mime-Version: 1.0 (1.0)
Date: Thu, 12 Sep 2024 11:04:15 +0000
Message-ID: <01000191e5e7bd22-2999d337-8925-470f-abb4-890ca32884aa-000000@email.amazonses.com>
References: <DU2PR02MB10160B7C5E0C210F82B774BD788642@DU2PR02MB10160.eurprd02.prod.outlook.com>
In-Reply-To: <DU2PR02MB10160B7C5E0C210F82B774BD788642@DU2PR02MB10160.eurprd02.prod.outlook.com>
To: mohamed.boucadair@orange.com
X-Mailer: iPhone Mail (21F90)
Feedback-ID: ::1.us-east-1.DKmIRZFhhsBhtmFMNikgwZUWVrODEw9qVcPhqJEI2DA=:AmazonSES
X-SES-Outgoing: 2024.09.12-54.240.8.88
Message-ID-Hash: SANSNK2MFFNFAG62BEXHKFRXO4GSUVWZ
X-Message-ID-Hash: SANSNK2MFFNFAG62BEXHKFRXO4GSUVWZ
X-MailFrom: 01000191e5e7bd22-2999d337-8925-470f-abb4-890ca32884aa-000000@amazonses.watsen.net
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-netmod.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: netmod@ietf.org
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [netmod] Re: AD - Re: AUTH48: RFC-to-be 9644 <draft-ietf-netconf-ssh-client-server-40> for your review
List-Id: NETMOD WG list <netmod.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/netmod/2Uwu_z0-ZfY6rQbC_A8b7aSqXBQ>
List-Archive: <https://mailarchive.ietf.org/arch/browse/netmod>
List-Help: <mailto:netmod-request@ietf.org?subject=help>
List-Owner: <mailto:netmod-owner@ietf.org>
List-Post: <mailto:netmod@ietf.org>
List-Subscribe: <mailto:netmod-join@ietf.org>
List-Unsubscribe: <mailto:netmod-leave@ietf.org>

Hi Med,


On Sep 12, 2024, at 3:14 AM, mohamed.boucadair@orange.com wrote:



Hi Mahesh,

 

Please see inline.

 

Cheers,

Med

 

De : Mahesh Jethanandani <mjethanandani@gmail.com>
Envoyé : jeudi 12 septembre 2024 00:49
À : BOUCADAIR Mohamed INNOV/NET <mohamed.boucadair@orange.com>
Cc : Kent Watsen <kent+ietf@watsen.net>; netmod@ietf.org
Objet : Re: [netmod] AD - Re: AUTH48: RFC-to-be 9644 <draft-ietf-netconf-ssh-client-server-40> for your review

 



Hi Med,

 

The reference of QUIC is to the protocol, RFC 9000, not NETCONF over QUIC, an I-D as you note; just as the reference is to SSH protocol, RFC 4252, not NETCONF over SSH, RFC 6242.

[Med] I understand the intent is to cite the transport themselves, but the text refers to MTI of these “YANG-based management protocols”. I don’t think we can make any claim about QUIC here as we don’t have an authoritative spec for that. If we want to cite QUIC, some further tweaking to the text is needed, IMO.


RESTCONF already supports QUIC. 

No transport-binding document will be written to enable QUIC for RC. 


On Sep 11, 2024, at 2:57 AM, mohamed.boucadair@orange.com wrote:

 

Hi Kent,

 

I like the NEWER better compared to the initial NEW you shared, however I think some more tweaking is needed.

 

I understand why you cited QUIC as well, but we don’t have formally a spec for mapping with QUIC (I know there is an individual I-D). We actually don’t need to be exhaustive here and cite every transport option.

 

The proposed NEWER changes a little bit the approach from the **recommending the use of MTI** to simply listing available MTI.  

 

[mj] Why do you say that? The statement says the protocols have mandatory-to-implement …

[Med] Having an MTI does not mean that MTI is actually used/enabled.


Touché  :)

One could process “implement” to be at the runtime-level or code-level.  I meant the former, and see that you’re interpreting the later, which is fair. 

First, I wonder if there isn’t a formal definition for MTI that disambiguates the two cases.  Looking, I see MTI used in the context of algorithms, which lends itself to the “code level” interpretation.  Fine. 

Then either s/implement/use/  or  s/-to-implement// ? 


Separately, I see your update is different in a couple ways.  Please see below for details…

 

Cheers,

Med

 

De : Kent Watsen <kent+ietf@watsen.net> 
Envoyé : mercredi 11 septembre 2024 00:10
À : BOUCADAIR Mohamed INNOV/NET <mohamed.boucadair@orange.com>
Cc : netmod@ietf.org
Objet : Re: [netmod] AD - Re: AUTH48: RFC-to-be 9644 <draft-ietf-netconf-ssh-client-server-40> for your review

 

Hi Med,

 

NEWER (this is what I’m asking RFC Editor to do for the suite of client-server drafts)

 

This section is modeled after the template described in Section 3.7 of [RFCAAAA].


This first line wasn’t picked up.  Note that the word “modeled” gives an authors a little flexibility, as is needed sometimes.  

To point, the RFC Editor takes the words literally and raise issues when things aren’t exactly same…until this word was changed. 

Honestly, the same should be done to all of the templates defined in the document.  


 

The "<module-name>" YANG module defines a data model that is designed to be accessed via YANG-


IIRC, you use different words than “data model”.   I’m trying to use sufficiently ambiguous language that includes also modules that only define identities, or only enumerations, or only typedefs, etc.  

I was going to write “data model, or parts of data models,” but it seemed unnecessary wordy and obscures the main point of the sentence. 

I don’t deny that my text could be improved, but your take didn’t seem right either. 

FWIW, I only know about your changes to my text because I received GitHub notifications.  Was a link for the PR sent?  In any case, it would’ve been nice if you’d stated that changes had been made, rather than me having to discover them on my own. 

Kent // contributor