[regext] AD Evaluation: draft-ietf-regext-epp-delete-bcp-08

Orie Steele <orie@transmute.industries> Thu, 14 November 2024 14:37 UTC

Return-Path: <orie@transmute.industries>
X-Original-To: regext@ietfa.amsl.com
Delivered-To: regext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 94E86C157927 for <regext@ietfa.amsl.com>; Thu, 14 Nov 2024 06:37:11 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.105
X-Spam-Level:
X-Spam-Status: No, score=-2.105 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_BLOCKED=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=transmute.industries
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id TxpiL0tBGY-v for <regext@ietfa.amsl.com>; Thu, 14 Nov 2024 06:37:07 -0800 (PST)
Received: from mail-pj1-x1030.google.com (mail-pj1-x1030.google.com [IPv6:2607:f8b0:4864:20::1030]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 7A4AFC151991 for <regext@ietf.org>; Thu, 14 Nov 2024 06:37:07 -0800 (PST)
Received: by mail-pj1-x1030.google.com with SMTP id 98e67ed59e1d1-2e2eba31d3aso573700a91.2 for <regext@ietf.org>; Thu, 14 Nov 2024 06:37:07 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=transmute.industries; s=google; t=1731595026; x=1732199826; darn=ietf.org; h=to:subject:message-id:date:from:mime-version:from:to:cc:subject :date:message-id:reply-to; bh=Qh/Hgog91i9/9/QAv0MGc9lvR4SvZIlQL2boXIHyK60=; b=kaMKpYyk32IIXdo7E1Ue4N0hK0aIhmBD5T3uj1PzS1Qk9m0+ENRTJA0gkshADcEPXF EOpEE3AY7qzxglnU4TiN7/J6sVh/gf7reMPRtMefThal/ui3Lej54OyiEfJ7ZAN8Ku9t UOCbMsqWvXGp355qJho9Wy6rt/lAxMUDQ7bbT+QUayGgGl5OC/tP7gh74TBH5mOiC+Xo /2/wxNFCfISLQLtivchjIxZLuFOBp/OFegTihP6qPYRCqD3ut8vZ2MumOK60kY+/f/Ki gyUkdh9HsxCaifBzcRjxlPAWygMz7Z0bnKaGZrGHv0IQdSputmHJVmJ/n0zSrXa98Z4y s2hg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1731595026; x=1732199826; h=to:subject:message-id:date:from:mime-version:x-gm-message-state :from:to:cc:subject:date:message-id:reply-to; bh=Qh/Hgog91i9/9/QAv0MGc9lvR4SvZIlQL2boXIHyK60=; b=I/iSuTEHnuz6DAHD+Gz3EIIFAAnoaadV5OtDd7mk0gXTir+DEXqDa5woHwzwGKQUJk RN74IYhTJZx0e+AtqxPuj510vgSPkW2a1btaiPkxTVntcTILypiXgjU+nzvNJir1/tx7 4bLxwbMCyF4VkQwoidH7cAu4MD8/e5IoDA2T/y42RWCya4tb+lcKEidSfCLGUfemeeqC gu/oHye3t45Xe3hmuFpahRAo3gBX1eS7G34+AbFacj4Fn3e2zlVRpayTDUymohQr9AjH AsZdjFoInLtjaDRDBG8oRDc3R3c66elzGHJ+BWgX8X87dCmutW3M9saIOZt5HjJb2VAP A25Q==
X-Gm-Message-State: AOJu0Ywz4OY01DkN3EaWdcoaiWQTwURYDHpSdWczOZPv4U3ApFt1ozpc MeVMOJwr9EEO8tzkBpodKDhfL3tQw91DcGuB/YJKBmxnhLYXIRx2etmioXS3Pd5DO17IGoaxICD avTvWBIvDjjHPM89C+PvF2rqOuF9Po4XkvxKM4KxBpsOkWN+uIDDjSw==
X-Google-Smtp-Source: AGHT+IFPOf5ue95nLnA+Qdw7RKRuNZv9t9Ra/E7zQsnqNl6qISDCHV3SU/56AIrQHy1A751yrr4Ok1LhjH2kqljZwCM=
X-Received: by 2002:a17:90b:4c06:b0:2e2:cd11:c9b with SMTP id 98e67ed59e1d1-2e9b16eb849mr30543184a91.3.1731595026088; Thu, 14 Nov 2024 06:37:06 -0800 (PST)
MIME-Version: 1.0
From: Orie Steele <orie@transmute.industries>
Date: Thu, 14 Nov 2024 08:36:55 -0600
Message-ID: <CAN8C-_J5J=mudPeAjuj0B7y2ejHHj=Cv+K_Xarjxsz43s-kvvw@mail.gmail.com>
To: Registration Protocols Extensions <regext@ietf.org>
Content-Type: multipart/alternative; boundary="0000000000006ced830626e0624e"
Message-ID-Hash: WS7QIQGG4AWE4VIL7OSCFDJRORJHLP34
X-Message-ID-Hash: WS7QIQGG4AWE4VIL7OSCFDJRORJHLP34
X-MailFrom: orie@transmute.industries
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-regext.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [regext] AD Evaluation: draft-ietf-regext-epp-delete-bcp-08
List-Id: Registration Protocols Extensions Working Group <regext.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/regext/z1ME3uuQa9UGpJiZuf1omaAcG60>
List-Archive: <https://mailarchive.ietf.org/arch/browse/regext>
List-Help: <mailto:regext-request@ietf.org?subject=help>
List-Owner: <mailto:regext-owner@ietf.org>
List-Post: <mailto:regext@ietf.org>
List-Subscribe: <mailto:regext-join@ietf.org>
List-Unsubscribe: <mailto:regext-leave@ietf.org>

# Orie Steele, ART AD, comments for draft-ietf-regext-epp-delete-bcp-08
CC @OR13

* line numbers:
  -
https://author-tools.ietf.org/api/idnits?url=https://www.ietf.org/archive/id/draft-ietf-regext-epp-delete-bcp-08.txt&submitcheck=True

* comment syntax:
  - https://github.com/mnot/ietf-comments/blob/main/format.md

I have only minor comments, and I believe this document is ready for IETF
Last Call.

## Comments

Thanks to Andy Newton for the shepherd writeup.

Highlighting a comment from the writeup:

```
Additionally, there were discussion regarding the use of BCPs to suggest
practices that are not know to be practiced. In other words, how can a BCP
normatively
require a practice that has not been observed because it is not a "current"
practice.
It was noted that RFC 2026 permits BCPs to describe what is believed to be
the best
way to perform some operations or IETF process functions.
```

Indeed the document highlights several patterns which would "not be best",
and provides recommendations for what is believed to be best at this time.

### Why not MUST?

```
414   The service SHOULD provide responses that indicate problems with a
415   domain's delegation, such as non-existence or include controlled
416   interruption IP addresses [RFC8023].  This practice has been observed
417   in use.
```

Under which circumstances can this should be safely ignored?

### Use of .invalid recommended?

.alt is clearly forbidden:

```
440   Clients may rename host objects to use ".alt" or another non-DNS
441   pseudo-TLD as suggested in [risky-bizness-irtf].  This practice has
442   not been observed in use.  This practice MUST NOT be used.
```

So I wonder if there should be clear guidance on treatment of .invalid.

```
471   Clients may rename host objects to use ".invalid" or another reserved
472   special-use ([RFC6761]) TLD as suggested in [risky-bizness].
```

Because the comments on .alt come before the comments on .invalid, I get
the feeling that use of .invalid is encouraged... even though there is no
explicit guidance.

Later:

```
748      use domain issues described in [RFC8244].  Use of
749      "sacrificial.invalid" (see 5.1.4.3) as the parent domain for the
750      host objects is RECOMMENDED to avoid the overhead of creating a
751      new TLD using either IETF or ICANN processes that offers no
752      additional operational benefit.
```

Perhaps add a brief comment and a pointer to this recommendation when the
concept is introduced.

-- 


OS, ART AD