Re: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

Linda Dunbar <linda.dunbar@futurewei.com> Mon, 11 October 2021 20:55 UTC

Return-Path: <linda.dunbar@futurewei.com>
X-Original-To: spring@ietfa.amsl.com
Delivered-To: spring@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B8B1E3A0C39; Mon, 11 Oct 2021 13:55:14 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.989
X-Spam-Level:
X-Spam-Status: No, score=-1.989 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, HTTPS_HTTP_MISMATCH=0.1, RCVD_IN_MSPIKE_H2=-0.001, T_SPF_PERMERROR=0.01, URIBL_BLOCKED=0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=futurewei.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id TlV0hDftdT7C; Mon, 11 Oct 2021 13:55:10 -0700 (PDT)
Received: from NAM10-BN7-obe.outbound.protection.outlook.com (mail-bn7nam10on2129.outbound.protection.outlook.com [40.107.92.129]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 051703A0BCB; Mon, 11 Oct 2021 13:55:09 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; s=arcselector9901; d=microsoft.com; cv=none; b=lugA9QJEblNE0dc6vD2UPccSy9NhHFhB/xks8t8FKx6IKbvzEsZVTwvxjM0+LHRG2yjPeVBjf+av9Dj+xJB+LmgqzmH5C8oFi4RmZFofZpmsONfmiJCHIzMunUYvotFeUdghtGJiX6YiNWoFJLlPVTNm2M/asNkFijhAR0kHQgoo08Rfp9GUTA0JO26C/AA41cL722HuHia/YdAS/XJyJzVvM1rS0O0DeLuSxH29WVEDm2QMmUTJN+h9nKK5ClT9LlTjIUZ01jJ0yj69IIr8XJpMqyj5G8NeAyp9QLb1pvn1DA3IrvBrxoSjKjQO5rTmh/p6xAa5VfEVSrooco8DHw==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=iKG1W0xO+y9ezFA4vp6CCnz+3hj/Z9EtBKkifjm4NZc=; b=ZZwKD7Oyf0UrdFNIb8mdOYyxa3zOScORIUiDF3Gy2l0VYTEAiDCxTmJseQ81fWg+UgP+HfUawEys1nVDGYomOxqgXww9kv/fkZdZUTsBhXJEmTVjexlE1LIHLCxcKGK26YaGkm6rUx0DefQM4MYY7A1plBSpMJ/Mf515eneUmpqmYMBhcWWFDCffZWtVvF0SXPrWOJZ113IkYvFfBgZKE29HyZ1iMZF52ePBVk14Pw2hVwSssV2GXMwNeu06nYMAVZV6rTEYX4VrswENQ4v5+3jkwWxU07R40GGKyQIu/uTrYq0JqOJoyiDMFRAXzrFmub1tr99EIYXIUDr63vvP0A==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=futurewei.com; dmarc=pass action=none header.from=futurewei.com; dkim=pass header.d=futurewei.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=Futurewei.com; s=selector2; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=iKG1W0xO+y9ezFA4vp6CCnz+3hj/Z9EtBKkifjm4NZc=; b=khepq9tdH5U8e4xfezom+Pum7KfzPrbNQjto7N2kA/ZrlC5h+b1o/Fsl3hyCTY0DUjT3R11Ns962Dms1RAgih7hdOIV2nCoEF3Ov1L0YT9UGGBZkjZNQVRQdiGIbgQpxQY78AaYXDUD9u5q/zBJYH9t4uy65na2BXSLQdcvtoBM=
Received: from CO1PR13MB4920.namprd13.prod.outlook.com (2603:10b6:303:f7::17) by MW3PR13MB3962.namprd13.prod.outlook.com (2603:10b6:303:54::15) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.4608.12; Mon, 11 Oct 2021 20:55:01 +0000
Received: from CO1PR13MB4920.namprd13.prod.outlook.com ([fe80::7cf9:4e05:b9cb:1a69]) by CO1PR13MB4920.namprd13.prod.outlook.com ([fe80::7cf9:4e05:b9cb:1a69%6]) with mapi id 15.20.4608.014; Mon, 11 Oct 2021 20:55:01 +0000
From: Linda Dunbar <linda.dunbar@futurewei.com>
To: Keyur Patel <keyur@arrcus.com>, "Zafar Ali (zali)" <zali=40cisco.com@dmarc.ietf.org>, James Guichard <james.n.guichard@futurewei.com>, SPRING WG <spring@ietf.org>
CC: "spring-chairs@ietf.org" <spring-chairs@ietf.org>, "Zafar Ali (zali)" <zali@cisco.com>
Thread-Topic: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/
Thread-Index: AQHXuTd9ijIiTOMLDkGipCqWUcImCKvM3z2AgAFylZA=
Date: Mon, 11 Oct 2021 20:55:01 +0000
Message-ID: <CO1PR13MB4920383271BF3F1477A9001D85B59@CO1PR13MB4920.namprd13.prod.outlook.com>
References: <BA3D1F1F-DF91-4463-BFEE-ECCCF9C79E22@cisco.com> <E29516CF-BF7E-457E-9EBB-0D072C758CCB@arrcus.com>
In-Reply-To: <E29516CF-BF7E-457E-9EBB-0D072C758CCB@arrcus.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
authentication-results: arrcus.com; dkim=none (message not signed) header.d=none;arrcus.com; dmarc=none action=none header.from=futurewei.com;
x-ms-publictraffictype: Email
x-ms-office365-filtering-correlation-id: 75200287-19aa-4d8b-784c-08d98cf964a2
x-ms-traffictypediagnostic: MW3PR13MB3962:
x-ms-exchange-transport-forked: True
x-microsoft-antispam-prvs: <MW3PR13MB396250828726C936212F586C85B59@MW3PR13MB3962.namprd13.prod.outlook.com>
x-ms-oob-tlc-oobclassifiers: OLM:8882;
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;
x-microsoft-antispam-message-info: sbWiCWlgUCzZSMN4ZOWjuZsZwM/4JSaSq3JgiBc5kwHeyR43L4+6XSLY1++QwPdFs6pqVYONju7Xc45YpzhpRgiAe2hzmFzPM8mdmC4g1n8T+goCF4s3HoWrcwVlHGEH05qYZ7t8zvJlxVDF5Q0TH6NgeLKvRt6L3Nk1Uf3DkYZcVxaCbsX6H7W2sEFkWsQjnyNu8vxEsoM97I4rc8NUhTx1Sw0wgkVGcPNS67azEc6lI90CpfA1KJ58L0RlurItkjXVITFJVN6iUQ9Tx0z664VD6JxxvfnZgHyDhozF5ULqgp6twEzTYGmVGHp9oQkalHvkxrN3TEJTCTKgkijCoOPPX4iQ9GUbqHT79OaJtnRmHJJR5b46VYzl9KaSJ72bhXVNAx1A+Jlx1TA5Jbn/nv9UY3Ugql8QsjAeWYRkvklqbVlEoTNJjEHW7aGceFtmaFwdZgOcn3lt2lqOyljzujlCiRhRk8dlq/7BYIdwiWsSURNBZGgxyypjUTrdNkLvXlHYV4ZTytLjMkABS3acHy064Y8spMiWXIJFwMIiv+/58CKrs+a4BupPo/dWxMYL2HY3js6FCFJ1bP1EpM3VBh1SaOQfBnRFNmSocSKO/0l5QJQcP3+MauAZLtuGElEYWKOO2dck6Eg9d1J6QGaXqzbt4wXM5dg7BnJJqg5yTwNGQ+5wDZs/n5qnDT0PwPsd90M79rB8FH2D3VMmdP5nGA0S7lL4EXXjr+Cs+uCZn/Sl9YQJZINBT8LMkeyYBTLDV5uMEU3l+7yRQcZMgSQLpfdfEG2gqfvlRWwP/QNyNd8=
x-forefront-antispam-report: CIP:255.255.255.255; CTRY:; LANG:en; SCL:1; SRV:; IPV:NLI; SFV:NSPM; H:CO1PR13MB4920.namprd13.prod.outlook.com; PTR:; CAT:NONE; SFS:(4636009)(366004)(71200400001)(7696005)(110136005)(26005)(55016002)(9686003)(54906003)(966005)(6506007)(316002)(53546011)(76116006)(186003)(8936002)(8676002)(508600001)(44832011)(33656002)(86362001)(66476007)(38100700002)(166002)(2906002)(52536014)(5660300002)(83380400001)(66946007)(122000001)(66556008)(4326008)(64756008)(66446008)(38070700005); DIR:OUT; SFP:1102;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: blXPbe/78ol9SxDiC1k8MiTrnJzlQoebuQKBC954R5821qeSU48cWPT4NtkXikCT14yloOxsqI8Q4rNzd5W+xsIJ1z3YaE++8f4hyrtdyoQVHDTQ6PET1wXH8sKbP8sctx8errSa1SQdQyhnYf2oMCeJMpqCOmKC7KNXCT2NBaXZm1x8bvqI4BlfGJGAoxU1B8dqhDqTv1zuFZmKAmivD+r3OjwC3D8YXFwHs1ATxkeD7sLSUzKfAIElsUhTrzzB8h+75qT6o/bk0GhtncsWsDbgBmJRd0ivWsbBLQ80xECzS8jH54OhmJPUVeEY/Sm8Lc8nrKocecd8DEYQhLTmN9H6FDvTb3pYnDSwSfanffyJOsOzm/1baD7slN7tH0kjlF51Lj24AhPvR+wVwp00ID+aCgB07OWNDxqlguHbc05l8S2AtYFMKIF27tG5uCfjtfYCqhI6/Uv1gNkACjb7TcgWMyqPNcbVn/9lEmyJm3pJHTQv53N8xGh+unWaVDNerKFQOs7TN6gzslTRtJ0kiue6KTP5207zx5BSgHPYxegSEy7si2RItdK5AliPt0e6vJbwaXd+p30AWhLlF2Zx95sLXeaUz9+5J9ff8sgyBPiaXZac5pxa/tD+YAo5ySL0CVjf9AttIGm6A2RUi1r9XxzG95kLZHcqNpPs3L9JDachXN2qJbDdxTFbXM65hwXCe4Q1tRp8gdTJx2DGaZP86+ASyFB5WddBWOjoexppuG/mdJUbBA2HXjCDXCxS7tDseuMAjIgu7Mh+yqPGwdLU0vlkwSIPybVvy0jTtS48V97+xPHT1R4JsKPUn9E/n6eDzS4KRuB1UDVkihZShuodfR07t5wDs883Hunacjy7GywTBWfD3DeEPkOfnx03bZgrhxzu4rUEVO5csRfLjC3BDkVJDKSwcRudh/6HpQjFx27BoX0ScU5BabU2GyHgkWnjKG0tsSidpAeIa2IOUui1Al3qhWPLeSw9gMzgqJHMk7fVMI4XcC0UBZX6TyqD6Vp3yk7slhlIYH8rLnGBqfv/Qe7fjkm/0OgO9SepAn4xeT15p+V3RDEb59JvuDBW35onGjNllqOqZQFHhS9fVYvLQQg89VTIawzb8OV7labYzhrrQfgHmofeubg8IBZyWvOVVcqw1rFx4VJ7Xp/xId9Ky7frE3nD1YrlcmWDAq4Dhk+JMDRwkp6St2crM+nVZf46xiTI1PROKW1Jg9GtB1KYkjsuTp8aUWMOLZN7z+bDRi54hXR5ERYmZtPgNRiw8sWLN3RW+KhowttxCaADjRMVDIRTF55XYF+E+Z/Y7c2Wyq5u7ssMn4yI00j20nLKas6I
Content-Type: multipart/alternative; boundary="_000_CO1PR13MB4920383271BF3F1477A9001D85B59CO1PR13MB4920namp_"
MIME-Version: 1.0
X-OriginatorOrg: Futurewei.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: CO1PR13MB4920.namprd13.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 75200287-19aa-4d8b-784c-08d98cf964a2
X-MS-Exchange-CrossTenant-originalarrivaltime: 11 Oct 2021 20:55:01.0958 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 0fee8ff2-a3b2-4018-9c75-3a1d5591fedc
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: 4qYxdQs2Tt1v5YzTkN7qjEAHH+BMWYOq7JLbBfWGqwL0kSINjbirAp7wKIqYcNZWjKpmJkPvR9XGEFbaBctxdA==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: MW3PR13MB3962
Archived-At: <https://mailarchive.ietf.org/arch/msg/spring/quBaYinf6J6W5mQeMPpbCD-hdVg>
Subject: Re: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/
X-BeenThere: spring@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: "Source Packet Routing in NetworkinG \(SPRING\)" <spring.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/spring>, <mailto:spring-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spring/>
List-Post: <mailto:spring@ietf.org>
List-Help: <mailto:spring-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/spring>, <mailto:spring-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 11 Oct 2021 20:55:24 -0000

With multiple vendors having implemented the solution, I strongly support the adoption of draft-filsfilscheng-spring-srv6-srh-compression.

Linda Dunbar

From: spring <spring-bounces@ietf.org> On Behalf Of Keyur Patel
Sent: Monday, October 11, 2021 12:48 AM
To: Zafar Ali (zali) <zali=40cisco.com@dmarc.ietf.org>; James Guichard <james.n.guichard@futurewei.com>; SPRING WG <spring@ietf.org>
Cc: spring-chairs@ietf.org; Zafar Ali (zali) <zali@cisco.com>
Subject: Re: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

Dear WG and the WG Chairs,

Network programming model (RFC8986) defines multiple flavors for End, End.X, and End.T SIDs. CSID draft builds on it with next and replace flavors for these SIDs, optimized for 16 bit and 32 bit SID sizes, respectively. This is just like PSP, USP and USD flavors defined in RFC8986 to cover different deployment scenarios.

We at Arrcus have implemented CSID solution and also have participated in multivendor interop for the solution.

I strongly support the adoption.

Best Regards,
Keyur


From: spring <spring-bounces@ietf.org<mailto:spring-bounces@ietf.org>> on behalf of "Zafar Ali (zali)" <zali=40cisco.com@dmarc.ietf.org<mailto:zali=40cisco.com@dmarc.ietf.org>>
Date: Monday, October 4, 2021 at 8:50 AM
To: James Guichard <james.n.guichard@futurewei.com<mailto:james.n.guichard@futurewei.com>>, SPRING WG <spring@ietf.org<mailto:spring@ietf.org>>
Cc: "Zafar Ali (zali)" <zali@cisco.com<mailto:zali@cisco.com>>, "spring-chairs@ietf.org<mailto:spring-chairs@ietf.org>" <spring-chairs@ietf.org<mailto:spring-chairs@ietf.org>>
Subject: Re: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

Dear WG and the chairs,

I strongly support the adoption call

About the matter in the email, the WG has defined a single data plane solution, i.e., SRv6 (RFC8402, RFC8754, and RFC8986).
SRv6 as per the inherent nature of the network programming model (RFC8996) already defines multiple standardized behaviors.
Clearly, CSID is a single solution based on the SRv6 data plane.

Thanks

Regards ... Zafar


From: spring <spring-bounces@ietf.org<mailto:spring-bounces@ietf.org>> on behalf of James Guichard <james.n.guichard@futurewei.com<mailto:james.n.guichard@futurewei.com>>
Date: Friday, October 1, 2021 at 10:05 AM
To: SPRING WG <spring@ietf.org<mailto:spring@ietf.org>>
Cc: "spring-chairs@ietf.org<mailto:spring-chairs@ietf.org>" <spring-chairs@ietf.org<mailto:spring-chairs@ietf.org>>
Subject: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

Dear WG:

The chairs would like to express their appreciation for all the responses received to our emails with reference to how the working group wishes to move forward with respect to a solution for SRv6 compression.

The apparent inclination of the working group is to use https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-filsfilscheng-spring-srv6-srh-compression%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8de269e773ca4459499408d98c7ab2cf%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637695280917116632%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=0GGK8CBENHCpOS2TdHfbxp9ph9k8R9dXMDmJTQWyBUI%3D&reserved=0> as the basis for its compression standardization work. That is part of what this email attempts to confirm.

Because of the above the chairs would like to issue a 2-week WG call for adoption ending October 15th for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-filsfilscheng-spring-srv6-srh-compression%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C8de269e773ca4459499408d98c7ab2cf%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637695280917116632%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=0GGK8CBENHCpOS2TdHfbxp9ph9k8R9dXMDmJTQWyBUI%3D&reserved=0> but with some clear guidelines as follows. By expressing support for adoption of this document you are fully aware of and are acknowledging that:


1.       The SPRING working group is adopting a document that has multiple SRv6 Endpoint behaviors.

2.       The document is a "living" document; it may change as it goes through review and analysis by the SPRING working group.

3.       All open discussion points raised on our mailing list MUST be addressed BEFORE said document is allowed to progress from the working group to publication. A list of these discussion points will be documented in the WG document and maintained by the document editor in conjunction with the chairs.

4.       If this document is adopted by the working group, the chairs specify as part of the adoption call that the following text describing an open issue be added to the document in the above-described open issues section:

*         "Given that the working group has said that it wants to standardize one data plane solution, and given that the document contains multiple SRv6 EndPoint behaviors that some WG members have stated are multiple data plane solutions, the working group will address whether this is valid and coherent with its one data plane solution objective.".

Please consider the above guidelines as you decide on whether to support or not this WG adoption. Please express clearly your reasoning for support/non-support as well as any open discussion points you would like addressed should the document be adopted into the working group.

Thanks!

Jim, Bruno & Joel