Re: [yaco-wgchair-tracker] Testdrive comments

"Emilio A. Sánchez" <> Wed, 30 March 2011 19:36 UTC

Return-Path: <>
Received: from localhost (localhost []) by (Postfix) with ESMTP id A96BD3A6BBE for <>; Wed, 30 Mar 2011 12:36:26 -0700 (PDT)
X-Virus-Scanned: amavisd-new at
X-Spam-Flag: NO
X-Spam-Score: -0.326
X-Spam-Status: No, score=-0.326 tagged_above=-999 required=5 tests=[AWL=1.491, BAYES_00=-2.599, DNS_FROM_RFC_BOGUSMX=1.482, MIME_8BIT_HEADER=0.3, RCVD_IN_DNSWL_LOW=-1]
Received: from ([]) by localhost ( []) (amavisd-new, port 10024) with ESMTP id jTvbK0Y8GD9S for <>; Wed, 30 Mar 2011 12:36:25 -0700 (PDT)
Received: from ( []) by (Postfix) with ESMTP id 490313A68E0 for <>; Wed, 30 Mar 2011 12:36:25 -0700 (PDT)
Received: by wwa36 with SMTP id 36so1363802wwa.13 for <>; Wed, 30 Mar 2011 12:38:03 -0700 (PDT)
Received: by with SMTP id m26mr1694905wbc.216.1301513883254; Wed, 30 Mar 2011 12:38:03 -0700 (PDT)
Received: from [] ( []) by with ESMTPS id o23sm237690wbc.10.2011. (version=SSLv3 cipher=OTHER); Wed, 30 Mar 2011 12:38:02 -0700 (PDT)
Message-ID: <>
Date: Wed, 30 Mar 2011 21:38:05 +0200
From: =?ISO-8859-1?Q?=22Emilio_A=2E_S=E1nchez=22?= <>
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110223 Thunderbird/3.1.8
MIME-Version: 1.0
References: <>
In-Reply-To: <>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
Subject: Re: [yaco-wgchair-tracker] Testdrive comments
X-Mailman-Version: 2.1.9
Precedence: list
List-Id: Discussion of the Yaco / WG Chairs' and Authors' Tracker Project <>
List-Unsubscribe: <>, <>
List-Archive: <>
List-Post: <>
List-Help: <>
List-Subscribe: <>, <>
X-List-Received-Date: Wed, 30 Mar 2011 19:36:26 -0000

El 27/03/11 09:56, Magnus Westerlund escribió:
> Hi,
> I have tried out the alto chair credentials and have the following comments.
> On page:
> The drop down list in 3. has RG state related actions, despite of it
> being an IETF stream document. That doesn't make a lot of sense. I
> expect to only see IETF stream WG choices.

    This one is very strange. This draft is in the correct stream (IETF) 
and group (alto) but is using the workflow of the IRTF Stream.

    alto group is the one I always use for testing from the beginning of 
the project so probably I mess something doing tests. I have fixed it by 

> This also leads to the question of how the stream is set. Automatically
> or can it be changed by the WG chair?

    The tool tries to set the stream automatically for drafts on the 
IETF stream but the only users allowed to change a draft from one stream 
to another are secretariat user.

    The only stream change that could do a WG chair is in a draft that 
does not belong to any stream. Then you could take it to the IETF stream 
and into your group with a call for adoption.

> Also, the state change button is not clear from a glance that it will
> save also the comment and the annotation.

    I'll add a help message like the one in the update tags button.

> If one forgets a comment it refuses to go on, that is fine. However, I
> see that the state drop down has forgotten my previous input, when
> highlighting the comment field.

    Good point. This need to be fixed.

> I also don't see how I can set the intended status field. As a WG chair
> I might want to override what the document currently says for capturing
> consensus decisions to go for some other state.

    You don't see the intended status field cause in the IRTF workflow 
there are no transitions defined.

    Now that I fix the draft workflow you can see buttons to perform 
state transitions.

> I also got the following error when going back using the "Return to
> document view":
> Error; cannot read (draft-ietf-alto-protocol,05,html)

    This error is cause in the beta server we don't have the draft 
contents (neither txt, neither html). Nothing to be worried about in our 

> Having gone back to
> I am missing an easily accessible link to go back to the WG list.
> Following the left side WG menu seems a bit complex. I guess the
> question is why the WG datatracker meny isn't avaiable on this page.
> I also wonder why the tasks of the shepherd isn't connected to the
> document, rather as part of managing shepherding. The write up is
> clearly a task related to a document, not the one of assigning the a
> shepherd to a document.

    This is fixed by adding the manage shepherd and manage writeup links 
in the document view.

> If I bring up:
> Why can't I enter state on this document? As a WG chair I need to enter
> notes on individual ones.

    This was an important bug [1]. First the access requirements to edit 
a draft state were to strict. You can not edit the state of this draft 
cause it doesn't belong to your WG. This is fixed and a 'first time' 
form have been introduced so you can get a draft raising a call for 

> Cheers
> Magnus Westerlund