[dmarc-ietf] Review of draft-ietf-dmarc-arc-to-historic

Tero Kivinen <kivinen@iki.fi> Wed, 01 July 2026 13:07 UTC

Return-Path: <kivinen@iki.fi>
X-Original-To: dmarc@mail2.ietf.org
Delivered-To: dmarc@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 7780A10B97594 for <dmarc@mail2.ietf.org>; Wed, 1 Jul 2026 06:07:34 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1782911254; bh=DQcdGRqJdp+zWl+ulZNW7oO3L3kNp5shu+6LQpmhN4o=; h=Date:From:To:Subject; b=BlOHU+HTwrnBvgw/hKjfwLReTccaAVwj08YnYqF2GFfe/Hj06Ua0TBN+2514FTY4y VQN/7qg1mlc7T+XOYAahtm+zval4mg0cTTfThuDtmgfvYLNxmSsK7dbNjufUgwRcu3 2vQZBFf+FXknxrVaY+kQNlrqUC64oK95iihQLZ+8=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.1
X-Spam-Level:
X-Spam-Status: No, score=-2.1 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (1024-bit key) header.d=iki.fi
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id rRRU0fyIW7gm for <dmarc@mail2.ietf.org>; Wed, 1 Jul 2026 06:07:33 -0700 (PDT)
Received: from meesny.iki.fi (meesny.iki.fi [IPv6:2001:67c:2b0:1c1::201]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 1170510B96B54 for <dmarc@ietf.org>; Wed, 1 Jul 2026 06:04:27 -0700 (PDT)
Received: from fireball.acr.fi (fireball.acr.fi [83.145.195.1]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) (Authenticated sender: kivinen@iki.fi) by meesny.iki.fi (Postfix) with ESMTPSA id 4gr0ZS16QDzyQv for <dmarc@ietf.org>; Wed, 01 Jul 2026 16:03:44 +0300 (EEST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=iki.fi; s=meesny; t=1782911025; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:mime-version:mime-version:content-type:content-type: content-transfer-encoding:content-transfer-encoding; bh=G8O6mteKdYjUnYYhFKJbldIRsVlL41xI8mhityaOeNA=; b=Dr7oFadTJLPpWXxBDSxTW2NNt6Z8pyN5GX8FOzgu1qx4ADxPlY5rcx6/T2TeaQ9aWxgNt0 +h9BLJBYZIykDB7HvfKsK+Dpboi9ZJHuKrNIgLduqUgIXM3pGcMl40YGXUNemPQ0EFd+i/ 9oSVo5jI5HNvhBCW4zLfQul9K5xYMuQ=
ARC-Seal: i=1; a=rsa-sha256; d=iki.fi; s=meesny; cv=none; t=1782911025; b=kAJNOJ8BCUjXZ8tgdbPMVsXtdhY+ti1q45g5Q2NN7m7A9fZO+630ssVzVSls8ewUecS22H 7+bFXKKD8nPuHZvM5v4me86yU6vklqbwn8C3T45dVuQTxv9xoL0zOav2L64iRn1QLLQUhR 8dW7m9I5ws3VFYAmbKJFOsSnqnUsa7c=
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=iki.fi; s=meesny; t=1782911025; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:mime-version:mime-version:content-type:content-type: content-transfer-encoding:content-transfer-encoding; bh=G8O6mteKdYjUnYYhFKJbldIRsVlL41xI8mhityaOeNA=; b=tlYaxSHWZluCBkayJ/hJGXuWV6LNvMuS43Qz+XO2mxSh200UYS7aFjNoODqevFNhlQ8mNa DAlq1fjlq/Qn3cBQDnTYNt1LYUekkg8t2WevZmGl5tstd+CmpE/JcP0pG5NfaBaGbcJCBu woOh+XaOyNK4xFjtRHUjQE9iIX40wmA=
ARC-Authentication-Results: i=1; ORIGINATING; auth=pass smtp.auth=kivinen@iki.fi smtp.mailfrom=kivinen@iki.fi
Received: by fireball.acr.fi (Postfix, from userid 15204) id C356025C11A3; Wed, 01 Jul 2026 16:03:40 +0300 (EEST)
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <27205.4140.707940.589907@fireball.acr.fi>
Date: Wed, 01 Jul 2026 16:03:40 +0300
From: Tero Kivinen <kivinen@iki.fi>
To: dmarc@ietf.org
X-Mailer: VM 8.2.0b under 26.3 (x86_64--netbsd)
X-Edit-Time: 65 min
X-Total-Time: 112 min
Message-ID-Hash: BAMVRP3WWIAAV6YM2MAYNH47YKW3GTSA
X-Message-ID-Hash: BAMVRP3WWIAAV6YM2MAYNH47YKW3GTSA
X-MailFrom: kivinen@iki.fi
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-dmarc.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [dmarc-ietf] Review of draft-ietf-dmarc-arc-to-historic
List-Id: "Domain-based Message Authentication, Reporting, and Compliance (DMARC)" <dmarc.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dmarc/vvl0VLkDeFxm8CiD8SYidOR9c3s>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dmarc>
List-Help: <mailto:dmarc-request@ietf.org?subject=help>
List-Owner: <mailto:dmarc-owner@ietf.org>
List-Post: <mailto:dmarc@ietf.org>
List-Subscribe: <mailto:dmarc-join@ietf.org>
List-Unsubscribe: <mailto:dmarc-leave@ietf.org>

Most of the text in the draft-ietf-dmarc-arc-to-historic is wrong.

First of all, it does not cover any of the topics listed in the ARC
RFC 8617 when considering whether the experiment was successfull.

If we are trying to see whether experiment is successfull, we should
first use the original goals to.

Section 11 of ARC RFC 8617 starts:
----------------------------------------------------------------------
11.  Experimental Considerations

   The ARC protocol is designed to address common interoperability
   issues introduced by intermediate message handlers.  Interoperability
   issues are described in [RFC6377] and [RFC7960].

   As the ARC protocol is implemented by Internet Mail Handlers over
   time, the following should be evaluated in order to determine the
   success of the protocol in accomplishing the intended benefits.
----------------------------------------------------------------------

I.e., this section 11 should be considered when thinking whether ARC
experiment succeeded or not.

Then it lists success considerations:
----------------------------------------------------------------------
11.1.  Success Consideration

   In an attempt to deliver legitimate messages that users desire, many
   receivers use heuristic-based methods to identify messages that
   arrive via indirect delivery paths.

   ARC will be a success if the presence of Authenticated Received
   Chains allows for improved decision making when processing legitimate
   messages, specifically resulting in equal or better delivery rates
   than achieved through the use of heuristic approaches.
----------------------------------------------------------------------

I think it succeeded in that. Almost all emails I receive have been
forwardered to me by some forwarders. I know those forwarders (iki.fi,
netbsd.org, ietf.org mailing lists, some other mailing lists).

Email forwarding does not happen without the user interaction, i.e. I
myself set up all of those forwardings and specified that those
domains should forward those emails to me.

When I receive email in my final mailbox I can use the ARC records
from iki.fi to see whether DKIM, SPF and/or DMARC succeeded when it
got the email. I do trust iki.fi so much that I allow it to forwarded
emails to me, thus I trust that iki.fi will do those checks properly.

The only interesting thing for the Chain is those machines that I
trust. I do not care if someone else forwarded email before iki.fi got
it, as I do not trust those. I only care about ARC headers that I know
I can trust.

Meaning the ARC was success as the precense of the ARC-records allowes
me for improved decision making when processing legitimate messages,
and checking those signatures is much better than heuristics using
Received headers or something like that.

Then next section of the section 11 of ARC RFC 8617 lists failure
considerations:

----------------------------------------------------------------------
11.2.  Failure Considerations

   ARC should function without introducing significant new vectors for
   abuse (see Section 9).  If unforeseen vectors are enabled by ARC,
   this protocol will be a failure.  Note that the weaknesses inherent
   in the mail protocols ARC is built upon (such as DKIM replay attacks
   and other known issues) are not new vectors that can be attributed to
   this specification.
----------------------------------------------------------------------

The draft does not list any significant new vectors for abuse caused
by ARC, and I do not know any of such things, so I assume there are
none.

(note that DKIM replay attacks are explictly listed as known attacks).

Section 11.3 then goes to Open questions, i.e., what we should have
learned from the experiment, but this draft does not answer those
either.


--

So the summary is the current draft does NOT at all use the original
sucecss / failure criteria to check whether experiment failed.

--

More detailed comments follow:

--

Abstract

I disagree that the experiment failed, and I do not think ARC should
be reclassified as Historic. I still think it has value and the
experment actually succeeded. It does provide better than heuristic
methods for the final recipient to validate the (known from outside
sources) ARC signer headers and use that information when processing
the email.

--

In the section 1 2nd paragraph there is text saying:


       	       	     	       	     	ARC's premise
   was that each handler could record its view of upstream
   authentication and then sign that record, enabling downstream
   evaluators to see what happened along the path.

I do not think the 2nd part was part of ARC's permise, i.e., "enabling
downstream evaluators to see what happened along the path". That might
be DKIM2's premise, but as ARC does not provide any such information,
ARC only allows downstream evaluators to validate
ARC-Authentication-Results headers generated by some hosts.

--

Section 1:

   This document reports the experiment's results and explains why, with
   the emergence of the proposed successor to DKIM, currently known as
   DKIM2, the community should retire ARC and incorporate the useful
   pieces directly into the successor to DKIM.

This is mostly wrong, as I explained earlier this document does NOT
report experiment's results.

I think DKIM2 will also fail, as it requires it to be implemented in
every single host that will be processing emails, and that is
unfeaseable on the internet scale. 

--

In section 2.1 the text does list forwarding party and author's domain
control, but it does not explain that the actual recipient of the
email did set up that forwarding or mailing list for himself, meaning
final recipient and forwarder do have relationship to each other, and
have some level of trust between.

--

Section 2.2 is ok, but section 2.3 again leaves out the fact that
final recipient do have trust relationship with the forwarder (if that
forwarding is something he/she actually wants). Meaning the text:


	      As such, without a robust reputation system, ARC in-
   and-of itself cannot convey trust in an email that fails DMARC.

there is no need for reputation system for ARC. There is NO global
reputation system that can work. I do not trust same forwarders that
someone else trusts. I can only list those trusted forwarders I myself
trust, I can't do that for anybody else.

--

Also in section 2.2:

   Another limitation of the design was that the ARC signature only
   indicated the intermediaries handling the message, but was silent
   about any changes the intermediaries made to the message.  As such, a
   fully validated ARC chain might include a modified message without
   the final evaluator knowing what changes were made.

I do not think that as a limitation of the ARC. It was not a goal of
ARC and I myself do not really think that it is important. When I get
email forwarded to me by ietf.org mailing list, I do not really care
what kind of changes they did before forwarding that to me. The fact
that ietf.org mailing list received the email, would have done SPF,
DKIM, and DMARC checks for the incoming email and would have in
ARC-Authentication-Results header should be enough for me to trust
that ARC-Authentication-Results (I say would here a ietf.org mailing
lists do not add ARC headers).

I think that paragraph should be removed.

--

In section 3.1 there is bullet:

   *  Internet-scale dependency on reputation: For broad
      interoperability, ARC required evaluators to run a reputation
      system for ARC signers.  Verifying the cryptography was necessary
      but insufficient; evaluators needed to decide whether to trust
      each signer in the chain before using their assertions to override
      DMARC outcomes.  This created a parallel trust infrastructure,
      separate from (but interacting with) existing domain or IP
      reputation.

The reputation system for ARC is very simple, when I set up the
forwarding from iki.fi or netbsd.org to forward email to my final
destination I add those domains to my trusted forwarders list.

Nothing else is needed.

--

In section 3.1 there is bullet:

   *  Limited reputation deployment:Even early deployers that validated
      ARC chains did not deploy robust, dynamic reputation.  Instead,
      they implemented 'allow lists' of intermediaries whose ARC
      assertions were always (or mostly) accepted.  This provided
      utility in specific bilateral or consortium relationships but did
      not scale to the open Internet.

This was correct way to implement reputation for ARC, it was not
limited reputation deployment. Only the final recipient can provide
the list of trusted forwarders. And note, this means final recipient
not the final mailbox provider. For two users in the same mailbox
providers the list of trusted forwarders is going to be different.
They might be subscribed to different set of mailing lists, meaning
one of them will trust some ARC signers that the other does not.

There is no per site, or global reputation possible with ARC.

--

In section 3.1 there is bullet:

   *  Complex evaluator policy: Receivers faced policy questions: how
      many hops of ARC to honor, how to treat partial or broken chains,
      how to reconcile conflicting assessments across chain links, and
      under what conditions ARC could influence DMARC enforcement.  The
      resulting diversity limited predictable interoperation across
      receivers.

I agree that the validation rules in the ARC RFC 8617 are bit complex,
but luckily the final recipient does NOT really care about the chain
properties of the ARC at all. The final recipient only cares whether
the trusted forwarder is in the list and what that hosts
ARC-Authentication-Results were.

--

In section 3.1 there is bullet:

   *  .....
		This reinforces that any
      intermediary authentication or chaining mechanism (such as ARC)
      must address the uncontrolled nature of forwarding, which spans
      countless unknown and dynamic systems, rather than only known
      mailing lists or enterprise relays.

Forwarding is never uncontrolled. If someone starts forwarding emails
to me I most likely do not want them, and they can end up in spam or
dropped. When I set up forwarding I do that for myself. When I join a
mailing list I need to do some actions to add myself to the mailing
list. When someone else adds me to some mailing list, I might agree or
disagree of being added to that mailing list, and if I agree that I do
want to get emails from that mailing list I can configure my trusted
forwarders accordingly, and if I disagree I will block those emails.

Remove that sentence.

--

In section 3.2 there is again talking about this "reputition system"
and there seems to be a feel that there should be one global list,
which is impossible as different people do trust different forwarders.

It is same as you complain that there should be global list of trusted
newspapers, that everybody can trust. There is no such thing. Trust is
not global it is from the forwarder to the final recipient (user).

Remove this:

						However,
   verifiable history without reputation does not enable safe override
   of DMARC or other enforcement policies.  Any Internet-wide solution
   must pair verifiable signals with a scalable, abuse-resistant trust
   model; ad hoc allow lists are not sufficient.


--

In section 3.3 I am not sure whether indication of modifications will
ever help. I do not think DKIM2 way of listing all modifications is
going to be helpful or harmful. They add lots of stuff to headers, and
for end users it is impossible to parse what was changed, and even if
you have user visible thing that shows what was changed, I am not sure
anybody is ever going to look those. But as those things are outside
the scope of ARC I thnk they do not need to be in this document
either.

I.e., remove 3.3.

--

In section 3.4 it would indicate that every node would be doing ARC
validation, but there is no need for that as the only machine that can
do ARC validation is the final end recipient machine, because he is
only one who has valid list of trusted forwarders, thus there is no
point of doing validations anywhere else than there.

I.e., remove 3.4.

--

As DKIM2 will be failing and DKIM replay was not part of ARCs goals,
listing DKIM2 as favored option is not needed, so remove section 3.5.

--

And of course my conclusions of the ARC experiment are very different.
I think it succeeded, and provided a better than heuristic way to make
decisions in the final recipient against the trust forwarders list of
the final recipient.
-- 
kivinen@iki.fi