[RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review

Tony Li <tony.li@tony.li> Wed, 21 October 2026 16:52 UTC

Received: from mail-dl1-x1232.google.com (mail-dl1-x1232.google.com [IPv6:2607:f8b0:4864:20::1232]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id AAB224B for <rtg-dir@ietf.org>; Wed, 21 Oct 2026 16:52:53 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=gmail.com header.s=20251104 header.b="f8RN/3qu"; spf=pass (mx.ietf.org: domain of tony1athome@gmail.com designates 2607:f8b0:4864:20::1232 as permitted sender) smtp.mailfrom=tony1athome@gmail.com; dmarc=none
Received: by mail-dl1-x1232.google.com with SMTP id a92af1059eb24-157fe9d771bso1226757c88.0 for <rtg-dir@ietf.org>; Wed, 21 Oct 2026 09:52:53 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1792601567; x=1793206367; darn=ietf.org; h=references:to:cc:in-reply-to:date:subject:mime-version:content-type :message-id:from:sender:from:to:cc:subject:date:message-id:reply-to :content-type; bh=lMoSNdTMWt/G7bfB45iZE+KCwcXGDLAyPWh1WwFYDfc=; b=f8RN/3qu7eySGci3F5rchgchQJktrx0sDbOfimcpZdR+W+xz7yo1PgzlWudNgFC4io fCQ2NT9jxxAxd51TVhVCUR8vdkKZq/BAEd35kJk+1ReTG+BXU7r2zqxt6twOX22neTtH I/aglpK79lPfpzOwAQXiO9fC8r04a/bHL69GvaBSl8+Ddt+/81cK0zb2omMYjtAJRSzc HDTjAW38KgzDL43p7YTP1JU6v0Vv11SwU3MbFuCvBrpoQx7Wla1Pg6y33DZeDGo1KB+1 NjHrzXYdkG7ko0S+/esqSXxtCIIX0T3dFpVI8K8Cs/nMR+tyIOBm6wmbfEokecOkMj+Y BrrQ==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20260707; t=1792601567; x=1793206367; h=references:to:cc:in-reply-to:date:subject:mime-version:content-type :message-id:from:sender:x-gm-gg:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to:content-type; bh=lMoSNdTMWt/G7bfB45iZE+KCwcXGDLAyPWh1WwFYDfc=; b=mmf0Cy3vHkWlT4kNrDcPr79fkH54FytxkCH4x//OtDf5bS4GkkzWbJ9AjIzTlrMAUL COP4GWcsWxER48+xIiLSLMGMCdpzIEKaZ7HSX9LpPgad/rz7OdCBL8A6iOb8rvEFVqKv gHdmnfVKIZ//kfWQIwSiauFDPsjXeb+ihrB3va4iIF1mm2BIFHSTt1vA+scxfZjf9N5O KjvxGmtmykhqN2emgdKMnHP8rcjYX0n7o++cXsbruxQ4p7tkK0VT4MfiTXmns5tjqD/6 heEU5MsYKggWzHjuQ2jSBRdNVv7whlVtcDdjjtn00M6L+6G5Jr5jwRyxaoQzV9KrAkdd 3sqg==
X-Gm-Message-State: AFq9FYISku76MWa8JekSw/utm349Hu43a/NBEJqoROsi6Afas7W1YaNN PGc6acbfuljdzGfEDqqwu4nQXQhIkjtvvLnqfNHuUURjp6IEL+VWPscO
X-Gm-Gg: AYBFou2kNkL0EeD1Mn52Mr9nox7jX2QkM5lIJD14WkrFq6Ri5VA9JzKYOaj08vH5wIY dgI0cRK5t23ixYfNZ1B5VWC13hjokSwmTr10PuJdp6hlX8c8vw2irTffiKQRSqMrF2CjgRamlPR Hi15OxhZbksMuHvspgtw8p+9TKDFCGJn+jgDntI0mbPj57IkvpuadNldAN0BELbquglRKOGJQjs 7WyBCrYfKgYHQZ+qvlCHdjA30R/Y9P91tLe3gBCxMqxxeCP2L/1rjgKocnKOZIY3Xs95sdsGTM5 g8qMGrHVYbVJZZfVDIw1BEOyRgmbcW92WDyfAkrd5a5TRGGouxz2dVcDVG+mJVQgiih4vql+0Wb c4VFmixBjQymN7LfZYZIy+9egXwN50HgNVAEwkaWmO0HONQZOhm31gjrVfuuLCigYq1/SDXJt3C UYhAPJ7lnJWNuhs1FDYjioDdGd43X0CGv+zLfNjHXl6Cgh/zps49u4Y6ip1CP+1w1RKlKUf78ef fCWhPOF/ndDkcEf902SmVsSpCJCz2gqarH5bZlJJ5mAtFrRF1EBdLMHZJuXVmjFn0ewn+dzwLlG OwY/t0EGQRh6jHAgcKbeR6z/yq6gEc7v3dTKhBBm6JArQ6BQhA==
X-Received: by 2002:a05:701a:ca01:b0:181:5cac:8f27 with SMTP id a92af1059eb24-190a6dbd80amr3570549c88.35.1792601566971; Wed, 21 Oct 2026 09:52:46 -0700 (PDT)
Received: from smtpclient.apple (c-73-93-167-4.hsd1.ca.comcast.net. [73.93.167.4]) by smtp.gmail.com with ESMTPSA id a92af1059eb24-19035c0c9a6sm6986091c88.3.2026.10.21.09.52.46 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Wed, 21 Oct 2026 09:52:46 -0700 (PDT)
Sender: Tony Li <tony1athome@gmail.com>
From: Tony Li <tony.li@tony.li>
Message-Id: <B961B036-94BF-47D5-BF84-9D3256F44FCF@tony.li>
Content-Type: multipart/alternative; boundary="Apple-Mail=_D9024A14-91A0-47B1-BE2A-474B2319C01C"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3864.700.51.1.1\))
Date: Wed, 21 Oct 2026 09:52:35 -0700
In-Reply-To: <179252066153.475324.4732023697329916276@dt-datatracker-7457c9c988-pqlqx>
To: Carlos Pignataro <cpignata@gmail.com>
References: <179252066153.475324.4732023697329916276@dt-datatracker-7457c9c988-pqlqx>
X-Mailer: Apple Mail (2.3864.700.51.1.1)
X-Spamd-Bar: ------------
Message-ID-Hash: WOKRLH66XAITTRERKLW7LXZFHN6U4YP2
X-Message-ID-Hash: WOKRLH66XAITTRERKLW7LXZFHN6U4YP2
X-MailFrom: tony1athome@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-rtg-dir.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: rtg-dir@ietf.org, draft-ietf-teas-rsvp-auth-v2.all@ietf.org, "TEAS WG (teas@ietf.org)" <teas@ietf.org>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review
List-Id: Routing Area Directorate <rtg-dir.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/rtg-dir/0sMLMpyt52nTwOYQJ5z45phivkk>
List-Archive: <https://mailarchive.ietf.org/arch/browse/rtg-dir>
List-Help: <mailto:rtg-dir-request@ietf.org?subject=help>
List-Owner: <mailto:rtg-dir-owner@ietf.org>
List-Post: <mailto:rtg-dir@ietf.org>
List-Subscribe: <mailto:rtg-dir-join@ietf.org>
List-Unsubscribe: <mailto:rtg-dir-leave@ietf.org>

Hi Carlos,

Please see inline.


> From: "Carlos Pignataro via Datatracker - noreply at ietf.org <http://ietf.org/>" <mailforwards@cloudmails.net <mailto:mailforwards@cloudmails.net>>
> Subject: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review
> 
> 1. Section 7 (IANA) uses RFC 2747 as the reference for HMAC-MD5, with a SHOULD,
> but this RFC obsoletes RFC 2747. This looks self-contradicting, particularly
> without MTI algo.


I believe that Joel Halpern has already addressed this comment.


> 2. Also, the column "Implementation Status" seems to be a misnomer, or a
> conflict with RFC 7942. Is that Requirement Level?


No, that was intentional. It has no relationship to RFC 7942, which does not have a trademark on “Implementation Status”.  We infer that you’re unhappy with the terminology.  Would you be happier with “Implementation Recommendation”?


> 3. Section 2 says the HF flag is a SHOULD. Section 4.3 says MUST.


Thank you, we will amend section 2.


> 4. In S4.1.1, is "computed over the message" enough clarity?


Given that this is the high level overview, we believe so.


> 5. Security association selection is based on the egress interface -- are there
> issues with RSVP with unnumbered, or budnle links?


Not that we know of.  Bundled links (i.e., LAGs) are an abstraction of multiple links into a single link.  RSVP operates at the level of the abstraction.  Similarly, the security association for an unnumbered link is specific to the link that the message arrived on.  Thus, numbering is not relevant, and unnumbered links are not an issue.


> 6. What is the length of the Challenge Cookie?


The challenge is variable length.  Its length for a given object is easily derived from the RSVP Object Header [RFC 2205, section 3.1.1], which defines a 16 bit length field for the object.  There are two reserved octets and then key identifier, of 48 bits, so the object length minus 8 octets gives the challenge length in octets.

Cheers,
Ran & Tony