[RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review
Ran Atkinson <ran.atkinson@gmail.com> Thu, 22 October 2026 20:34 UTC
Received: from mail-qk1-x72a.google.com (mail-qk1-x72a.google.com [IPv6:2607:f8b0:4864:20::72a]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id 1FB6750 for <rtg-dir@ietf.org>; Thu, 22 Oct 2026 20:34:27 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=gmail.com header.s=20251104 header.b="hUaAl7b/"; spf=pass (mx.ietf.org: domain of ran.atkinson@gmail.com designates 2607:f8b0:4864:20::72a as permitted sender) smtp.mailfrom=ran.atkinson@gmail.com; dmarc=pass (policy=none) header.from=gmail.com
Received: by mail-qk1-x72a.google.com with SMTP id af79cd13be357-93efc0452b5so14181685a.0 for <rtg-dir@ietf.org>; Thu, 22 Oct 2026 13:34:27 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1792701266; x=1793306066; darn=ietf.org; h=to:references:message-id:content-transfer-encoding:cc:date :in-reply-to:from:subject:mime-version:content-type:from:to:cc :subject:date:message-id:reply-to:content-type; bh=aMof1YHSV/xDvplowZpNpwnzvayh7Onk2rLdAngiF1U=; b=hUaAl7b/12rVYkv1DF/hx5OkZqCanyWKfHnAsRXmddBoESGaF3oocjERZ/dmEwNciA Cq5ooix+Z7hLFMxedWFOdKkhBTxVYfvot0xlf9t4PmXpbPN/IRzhdNov/qOrnCMgtBQq ii0rCpBQcoOwN0f1JrcDaDkPYiig7SSbD6LujrV4JZLAmeQvoFdY/KExKnoO4SoFair2 MLrLbKCB2sua2764MZjMOGM6Q2rePQBgaQAGuO+47wCKDDkOrvwQDaDsAGZXKN1m+wWY z0zvZSf8cfaVVyI99nQ/3LIJGMXW2S76do6Zz63UfNfKw8J5PLO/DzgJHWXWV+EiI71k Vd0g==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20260707; t=1792701266; x=1793306066; h=to:references:message-id:content-transfer-encoding:cc:date :in-reply-to:from:subject:mime-version:content-type:x-gm-gg :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to :content-type; bh=aMof1YHSV/xDvplowZpNpwnzvayh7Onk2rLdAngiF1U=; b=TT3Wt4tt+Rt/7siu3lbUhPjVEm28RvTxmldWAVbBDP7/XgGjNJg5nwLVUFwyolywaQ jIHosJX8ZeIhxwFVSdSB+Z6MxqVaX0ig3uSX67ssC0jVzU/XWjvvx3KgXXNmRT1Uowgl zt1ajmzEhSw+2ckzRUcSigm8e8mUMktzSHDR+RIU/UsBSNVBwY9R3bMA36NkVdXgoRIv DmVDgRBloxha1zhTIS787uwnrugIKfvRhe2cEc8utPgzwc8iilBz4SvEhRQLhuNKNCrq HPjX0Hh8/UNGO7+5DJKBf9l+yOtDka7Ow2IPuAVuE+4m/eaNnXnKGicxI6i7e0iWVxsy fSYA==
X-Forwarded-Encrypted: i=1; AKwUvByE7SeVy1K+F1kyDxxOLkTFXjvpCq8DW2HL0hpirlJ/4qkozgaQj2ETEuIHcqzL2w/dIeVQsoXm@ietf.org
X-Gm-Message-State: AFq9FYLgltuzmE11C9zicSSaZMPVXxgRS0lLSIXM4PPmCb8K8E3osXY7 LE6BuUJzrK2RkQAzTugG4dZ9dqaDjS0DdGGp5TAOCWQR2Nr3vjIu6Ag=
X-Gm-Gg: AYBFou2/9ZmZqJsJZae6oxGY5/RE/NaTyMhwzh/vpvITW3WdDbD7XgBqAEHGp9F0zu2 KiuaE3yB3JRZjn+xZ/kp5e+MKuzOfjtXKyW8AVMngMcKijsNtatlz75h1P4WoOY8ZAu6wqKExqW cvXtMu5Bm3qRyP6RLAm1XkUtSrCI6i783MCCMCdLPc9fUqset0t4sEwmsiN8JrWuElPwcYtcT0Y Dgi5J7ERxoJMyEVwZXX/LpDqJISEdoVwvaX0ehDPEp0jo6VRXXIAFODNHhVh14MXrnvJEuljcR9 WpRg6OBZ7W+ECuNJIL+iy92YDiBiUnbTyG7SsWsIIFYGtM/rcnohoIvKb5IYnY53D/a11UpvuCi rfGXvzA+j5XehYJoV6eTPAE6P3D2VuoeFfYU5DW7OcKQ373JAp5qPj8bWDxdcSaEhjxHVKL7Pwl D/U4W4YJAVLQEgBcgmozC0oycvzfhcQmnkOgiGt5+yag7IDcTtaIYi1GeTnC1f0LBb94tQi/YkS 7XsNBeCmF9AZ5FGzU83Owch1Qq9oa6+glBUFJpDoiCEt96H56qZfpK/z7t2WD8+NGtMTrhMSYdZ hTrkhRmJ39Qyb+AgLPeEWt21Br16TXoVs3M+smCJJacUGQfYImIp1u6tL6CJohhNWzl2MTtY
X-Received: by 2002:a05:620a:6403:b0:93e:a71a:5de0 with SMTP id af79cd13be357-93f6f908691mr107005785a.26.1792701266508; Thu, 22 Oct 2026 13:34:26 -0700 (PDT)
Received: from smtpclient.apple (pool-108-28-83-185.washdc.fios.verizon.net. [108.28.83.185]) by smtp.gmail.com with ESMTPSA id af79cd13be357-93f70fa1412sm5078785a.37.2026.10.22.13.34.25 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Thu, 22 Oct 2026 13:34:26 -0700 (PDT)
Content-Type: text/plain; charset="utf-8"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3864.700.51.1.3\))
From: Ran Atkinson <ran.atkinson@gmail.com>
In-Reply-To: <D7A60B9B-C0A6-4EF3-812C-D50F6FE5895D@gmail.com>
Date: Thu, 22 Oct 2026 16:34:15 -0400
Content-Transfer-Encoding: quoted-printable
Message-Id: <ACCD00FC-3500-4413-B04F-932B656FED4D@gmail.com>
References: <179252066153.475324.4732023697329916276@dt-datatracker-7457c9c988-pqlqx> <B961B036-94BF-47D5-BF84-9D3256F44FCF@tony.li> <D7A60B9B-C0A6-4EF3-812C-D50F6FE5895D@gmail.com>
To: Carlos Pignataro <cpignata@gmail.com>
X-Mailer: Apple Mail (2.3864.700.51.1.3)
X-Spamd-Bar: ------------
Message-ID-Hash: VYFKR737PG55HLLNRYYWCLYXNE2CWKI2
X-Message-ID-Hash: VYFKR737PG55HLLNRYYWCLYXNE2CWKI2
X-MailFrom: ran.atkinson@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-rtg-dir.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Ran Atkinson <ran.atkinson@gmail.com>, Tony Li <tony.li@tony.li>, rtg-dir@ietf.org, draft-ietf-teas-rsvp-auth-v2.all@ietf.org, "TEAS WG (teas@ietf.org)" <teas@ietf.org>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review
List-Id: Routing Area Directorate <rtg-dir.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/rtg-dir/bCqKHJlBLCvImH-DNLaAx_E0s7M>
List-Archive: <https://mailarchive.ietf.org/arch/browse/rtg-dir>
List-Help: <mailto:rtg-dir-request@ietf.org?subject=help>
List-Owner: <mailto:rtg-dir-owner@ietf.org>
List-Post: <mailto:rtg-dir@ietf.org>
List-Subscribe: <mailto:rtg-dir-join@ietf.org>
List-Unsubscribe: <mailto:rtg-dir-leave@ietf.org>
Hi, For consistency, I think RSVP ought to use the same words that IPsec uses for its security transforms in the IANA Registry. Please see RFC-8221, Section 5, page 7, which uses “Status” rather than “Implementation Status”. My apologies for the tardy response to this thread. Yours, Ran > On Oct 21, 2026, at 20:40, Carlos Pignataro <cpignata@gmail.com> wrote: > > Hi, Tony, > > Thanks for the responses — please find one follow-up inline. > >> On Oct 21, 2026, at 6:52 PM, Tony Li <tony.li@tony.li> wrote: >> >> Hi Carlos, >> >> Please see inline. >> >> >>> From: "Carlos Pignataro via Datatracker - noreply at ietf.org" <mailforwards@cloudmails.net> >>> Subject: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review >>> >>> 1. Section 7 (IANA) uses RFC 2747 as the reference for HMAC-MD5, with a SHOULD, >>> but this RFC obsoletes RFC 2747. This looks self-contradicting, particularly >>> without MTI algo. >> >> >> I believe that Joel Halpern has already addressed this comment. >> >> >>> 2. Also, the column "Implementation Status" seems to be a misnomer, or a >>> conflict with RFC 7942. Is that Requirement Level? >> >> >> No, that was intentional. It has no relationship to RFC 7942, which does not have a trademark on “Implementation Status”. We infer that you’re unhappy with the terminology. Would you be happier with “Implementation Recommendation”? > > > Frankly, the choice of words would have no influence on my happiness level — that said, I believe "Implementation Recommendation” is more accurate and less conflicting/distracting. > > Best, > > Carlos. > >> >> >>> 3. Section 2 says the HF flag is a SHOULD. Section 4.3 says MUST. >> >> >> Thank you, we will amend section 2. >> >> >>> 4. In S4.1.1, is "computed over the message" enough clarity? >> >> >> Given that this is the high level overview, we believe so. >> >> >>> 5. Security association selection is based on the egress interface -- are there >>> issues with RSVP with unnumbered, or budnle links? >> >> >> Not that we know of. Bundled links (i.e., LAGs) are an abstraction of multiple links into a single link. RSVP operates at the level of the abstraction. Similarly, the security association for an unnumbered link is specific to the link that the message arrived on. Thus, numbering is not relevant, and unnumbered links are not an issue. >> >> >>> 6. What is the length of the Challenge Cookie? >> >> >> The challenge is variable length. Its length for a given object is easily derived from the RSVP Object Header [RFC 2205, section 3.1.1], which defines a 16 bit length field for the object. There are two reserved octets and then key identifier, of 48 bits, so the object length minus 8 octets gives the challenge length in octets. >> >> Cheers, >> Ran & Tony >> >
- [RTG-DIR]draft-ietf-teas-rsvp-auth-v2-02 early Rt… Carlos Pignataro via Datatracker
- [RTG-DIR]Re: [Teas] draft-ietf-teas-rsvp-auth-v2-… Joel Halpern
- [RTG-DIR]Re: [Teas] draft-ietf-teas-rsvp-auth-v2-… Carlos Pignataro
- [RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 earl… Tony Li
- [RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 earl… Carlos Pignataro
- [RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 earl… Ran Atkinson
- [RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 earl… Carlos Pignataro