[RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review

Carlos Pignataro <cpignata@gmail.com> Sat, 24 October 2026 11:51 UTC

Received: from mail-ed1-x531.google.com (mail-ed1-x531.google.com [IPv6:2a00:1450:4864:20::531]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id C676F46 for <rtg-dir@ietf.org>; Sat, 24 Oct 2026 11:51:53 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=gmail.com header.s=20251104 header.b="ZQhAGJ/Y"; dmarc=pass (policy=none) header.from=gmail.com; spf=pass (mx.ietf.org: domain of cpignata@gmail.com designates 2a00:1450:4864:20::531 as permitted sender) smtp.mailfrom=cpignata@gmail.com; arc=pass ("google.com:s=arc-20260327:i=1")
Received: by mail-ed1-x531.google.com with SMTP id 4fb4d7f45d1cf-6ac76a02368so2154678a12.2 for <rtg-dir@ietf.org>; Sat, 24 Oct 2026 04:51:53 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; t=1792842707; cv=none; d=google.com; s=arc-20260327; b=gVZ0q+5LKHFw5w5adPlZ+4tr6+pEk7c5oSu9RUMiE9FSSA3l48avs88ZXR02rVot95 ylm1KyN/IAkZ1+rAa5fQi61D7Q+Q2jZejSGVCGLiWdw2bf9cMPy8DysXqBht4yWnsoND tRXHIyZ1/Bbu6uFuDLUxTLbqcNI5at7YKxPJi+2F1K36TCam2+04hNB3wGsIc25CP/NH cDI1JpR/xFfsBaZimD+B13VxpaJ7YqNPioaDHDmdac9yo7TFkz2IHvCfh8Lh0H41jIAF ZiI+bjcmVlG/rRHRR7CX7EHVpuKTAPYSvQwuTVCbZ5gyfEkgHoTU+u3GpCmqoNVxEEy7 IVgA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20260327; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:dkim-signature; bh=d5Yk3yCzBaDBe7rawezS3xn5v3oQ8UGpwZETM3qbjBk=; fh=KTOHiAw6aEe2IHnYzqx62v6h3XmIeo7lu3SKLlr9Ctg=; b=lT+cuWSWDr0C4LC1/kRQfthXhWBGG248tWlwI8R5amRvyacFFopr2lyiN99CuDBxB8 efk+tdH/HffaZ+LgGjmS8D7wtc1eF+3awOh52szdjnq8AItceEghnHdZ9+K8UUOXZosz t7iMqMiy7VCOwoc9CJmaaYVRQro4ezlL2TScXc6mdQp8L4jY/6wC5SwLtqSJmGWt3DJd 13xyhRp6I0EUw689IPqtN30RdbE9BH2V93QuxEYj/gAs0KJBbhCQ/o5v0yrHiqsMHsEn PcYW68FIlgVQwZmr3XYj5MLviLyAFSfcD8I25hp2dtNfMo6XKnoR2A7Rm5GmVqvM0B1N gd5A==; darn=ietf.org
ARC-Authentication-Results: i=1; mx.google.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1792842707; x=1793447507; darn=ietf.org; h=content-type:cc:to:subject:message-id:date:from:in-reply-to :references:mime-version:from:to:cc:subject:date:message-id:reply-to :content-type; bh=d5Yk3yCzBaDBe7rawezS3xn5v3oQ8UGpwZETM3qbjBk=; b=ZQhAGJ/YRnjnTgocJNQkFSwqqIqno7oMJ0i2bPiw6/WGmeRC7Ssn5ibz5TEK2S90Cu 9wnhpM9Faj0h95A1BkxKN5r7Yh8EvJWXxkd6Xs5rLVcmYJ6UdfsQYwzJaGcfQkkK9nY0 Vn9yceQQGh+mB6vFlxIl+m+8Z2j/njV9TNSlbJiw2+xxlf8cZeTHSR4y+fCCCbGG3Wag L5rBwvo71Z7KOehhl4240NyC/nUYduOBlvWddIoVSj0vg2uac9gClSKgY8D96vGJHT7Z PHjlu4iVUUCzsp7kGNEy56PL48QQJOBS8yZvbGWAHhg0zolhhKUPkqzw2+mW50Fh9shU eGHA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20260707; t=1792842707; x=1793447507; h=content-type:cc:to:subject:message-id:date:from:in-reply-to :references:mime-version:x-gm-gg:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to:content-type; bh=d5Yk3yCzBaDBe7rawezS3xn5v3oQ8UGpwZETM3qbjBk=; b=bb16RLhEApQN4RyPmlFozly3TgVmVBsel5ujWmnUz4yirMW9lda5qh5w+3RA5FpuVD uzQtL3EiH2h4lSj684DmJW9mj4gPo3QiQ+AtQA09tTttXxMKz5i2l/ccHryPro98AE0A OYZPcNqqIDpZR2R3pGD+8qvolRcyYH77RSQq9XPt6Xti1dVJRNYHgoQj1FgZ1rLQhamb hqoCfKU+33atjjY+nJPPQnixH7n8mi94JZHs6XFCIMgKqr2eWKgsw0RUEhNcfxz4yaJU YI+HToPYqVQC1z0+gv0Oq4WoxSV5rI/VeKEC68sMKfFnnLcEH/20cv6Q4TnKoIRj+oL/ 85ow==
X-Forwarded-Encrypted: i=1; AKwUvBwXITxdV0RHeYpx4z2/nAj5/IFry0Uf1BunAMt/pxM/zNt/Zw8VtHGo7HnqZuvGlp2yvtBboXhW@ietf.org
X-Gm-Message-State: AFq9FYK+VxPbSOPhcJnJTmWEJQn5UuWrfsUR6qvC/kf85Qg+hedIVHyS b74TwDJRgqbYqVtTiQ/fXLrjokCz3LHG93kaORICO9UHkHOnLxVJTlZ7e5Fin7+j8UM0gnAfxS2 X5TAaUJLBMStqRT9M3l9Xc1ae/rpqa/gEOUFTRqClqG8SRd/NIB3bACpUNStv4TdpNacEWVY=
X-Gm-Gg: AYBFou03ClwY0q2zTa4dgNIEtaAbxZ6RZZidF36vzqgPqKkwzvoNQtEiNrpL/fsCz7R 4SUo4XvHpd000h0fxPHUY+M6ae7oKBglYMZAQyevybGuUo8H0BASnBIx/fw9yj2NPSru4YPlb/L C0+c+Z87Lo01MRDf8uC6oBePnRL+Q+ayAhUNp/3scx1J/W2WbfxiYIwypu53gzGAEvxzjl5KN5z CG5viRiu/KraQmmpiP2gFnLZc2JYpDDQFXghTyS8lZI2F3t758ZAEDGY0srLIJZNTt/Q7C5G7rX +RezNN636g9VJwCfvpyBRHjod6WHm2oci7XMm/6/dgcwFGm54By/jThk0SzmNR3TLqBDR5j7INH WD093y+TTciVSvT3tB7VJQ2CxvW3mIn4jraMGOMQT4GGTdQ6AxttDokiDzTSxSEqzoQnJutY=
X-Received: by 2002:a05:6402:51d2:b0:6b4:1db6:9cab with SMTP id 4fb4d7f45d1cf-6b442fffefemr2178249a12.24.1792842707069; Sat, 24 Oct 2026 04:51:47 -0700 (PDT)
MIME-Version: 1.0
References: <179252066153.475324.4732023697329916276@dt-datatracker-7457c9c988-pqlqx> <B961B036-94BF-47D5-BF84-9D3256F44FCF@tony.li> <D7A60B9B-C0A6-4EF3-812C-D50F6FE5895D@gmail.com> <ACCD00FC-3500-4413-B04F-932B656FED4D@gmail.com>
In-Reply-To: <ACCD00FC-3500-4413-B04F-932B656FED4D@gmail.com>
From: Carlos Pignataro <cpignata@gmail.com>
Date: Sat, 24 Oct 2026 13:51:36 +0200
X-Gm-Features: AclHuK-sLn4e2HUpFPM-BFMme79G5dreQMcsw_4gOgD2r9E5rM51RBnfd_6XPok
Message-ID: <CACe62M=mnXfzsZfBo4PxrT=e5sMEgEpXNLs3O5sh0edWisQDTA@mail.gmail.com>
To: Ran Atkinson <ran.atkinson@gmail.com>
Content-Type: multipart/alternative; boundary="000000000000b17362065e94b8d1"
X-Spamd-Bar: -------------------------
Message-ID-Hash: 5ZHQYTI3GDTWQPDDUM5MEODQB2O35NLI
X-Message-ID-Hash: 5ZHQYTI3GDTWQPDDUM5MEODQB2O35NLI
X-MailFrom: cpignata@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-rtg-dir.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Tony Li <tony.li@tony.li>, rtg-dir@ietf.org, draft-ietf-teas-rsvp-auth-v2.all@ietf.org, "TEAS WG (teas@ietf.org)" <teas@ietf.org>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [RTG-DIR]Re: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review
List-Id: Routing Area Directorate <rtg-dir.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/rtg-dir/8dsJUZyqaA2G8LoTSJ8iFG46SsA>
List-Archive: <https://mailarchive.ietf.org/arch/browse/rtg-dir>
List-Help: <mailto:rtg-dir-request@ietf.org?subject=help>
List-Owner: <mailto:rtg-dir-owner@ietf.org>
List-Post: <mailto:rtg-dir@ietf.org>
List-Subscribe: <mailto:rtg-dir-join@ietf.org>
List-Unsubscribe: <mailto:rtg-dir-leave@ietf.org>

👍🏼

Carlos Pignataro reacted via Gmail
<https://www.google.com/gmail/about/?utm_source=gmail-in-product&utm_medium=et&utm_campaign=emojireactionemail#app>

On Thu, Oct 22, 2026 at 10:34 PM Ran Atkinson <ran.atkinson@gmail.com>
wrote:

> Hi,
>
> For consistency, I think RSVP ought to use the same words that IPsec uses
> for its security transforms in the IANA Registry.
>
> Please see RFC-8221, Section 5, page 7, which uses “Status” rather than
> “Implementation Status”.
>
> My apologies for the tardy response to this thread.
>
> Yours,
>
> Ran
>
> > On Oct 21, 2026, at 20:40, Carlos Pignataro <cpignata@gmail.com> wrote:
> >
> > Hi, Tony,
> >
> > Thanks for the responses — please find one follow-up inline.
> >
> >> On Oct 21, 2026, at 6:52 PM, Tony Li <tony.li@tony.li> wrote:
> >>
> >> Hi Carlos,
> >>
> >> Please see inline.
> >>
> >>
> >>> From: "Carlos Pignataro via Datatracker - noreply at ietf.org" <
> mailforwards@cloudmails.net>
> >>> Subject: draft-ietf-teas-rsvp-auth-v2-02 early Rtgdir review
> >>>
> >>> 1. Section 7 (IANA) uses RFC 2747 as the reference for HMAC-MD5, with
> a SHOULD,
> >>> but this RFC obsoletes RFC 2747. This looks self-contradicting,
> particularly
> >>> without MTI algo.
> >>
> >>
> >> I believe that Joel Halpern has already addressed this comment.
> >>
> >>
> >>> 2. Also, the column "Implementation Status" seems to be a misnomer, or
> a
> >>> conflict with RFC 7942. Is that Requirement Level?
> >>
> >>
> >> No, that was intentional. It has no relationship to RFC 7942, which
> does not have a trademark on “Implementation Status”.  We infer that you’re
> unhappy with the terminology.  Would you be happier with “Implementation
> Recommendation”?
> >
> >
> > Frankly, the choice of words would have no influence on my happiness
> level — that said, I believe "Implementation Recommendation” is more
> accurate and less conflicting/distracting.
> >
> > Best,
> >
> > Carlos.
> >
> >>
> >>
> >>> 3. Section 2 says the HF flag is a SHOULD. Section 4.3 says MUST.
> >>
> >>
> >> Thank you, we will amend section 2.
> >>
> >>
> >>> 4. In S4.1.1, is "computed over the message" enough clarity?
> >>
> >>
> >> Given that this is the high level overview, we believe so.
> >>
> >>
> >>> 5. Security association selection is based on the egress interface --
> are there
> >>> issues with RSVP with unnumbered, or budnle links?
> >>
> >>
> >> Not that we know of.  Bundled links (i.e., LAGs) are an abstraction of
> multiple links into a single link.  RSVP operates at the level of the
> abstraction.  Similarly, the security association for an unnumbered link is
> specific to the link that the message arrived on.  Thus, numbering is not
> relevant, and unnumbered links are not an issue.
> >>
> >>
> >>> 6. What is the length of the Challenge Cookie?
> >>
> >>
> >> The challenge is variable length.  Its length for a given object is
> easily derived from the RSVP Object Header [RFC 2205, section 3.1.1], which
> defines a 16 bit length field for the object.  There are two reserved
> octets and then key identifier, of 48 bits, so the object length minus 8
> octets gives the challenge length in octets.
> >>
> >> Cheers,
> >> Ran & Tony
> >>
> >
>
>