[spring] Re: [EXTERNAL] Re: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS
Luc André Burdet <laburdet.ietf@gmail.com> Mon, 05 October 2026 20:34 UTC
Received: from mail-pj2-x16.google.com (mail-pj2-x16.google.com [IPv6:2607:f8b0:4864:39::16]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id 67E0042 for <spring@ietf.org>; Mon, 05 Oct 2026 20:34:09 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=gmail.com header.s=20251104 header.b=jRePgp06; spf=pass (mx.ietf.org: domain of laburdet.ietf@gmail.com designates 2607:f8b0:4864:39::16 as permitted sender) smtp.mailfrom=laburdet.ietf@gmail.com; dmarc=pass (policy=none) header.from=gmail.com
Received: by mail-pj2-x16.google.com with SMTP id 98e67ed59e1d1-3a4c276e1c7so925407a91.0 for <spring@ietf.org>; Mon, 05 Oct 2026 13:34:09 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1791232442; x=1791837242; darn=ietf.org; h=mime-version:content-type:content-language:accept-language :in-reply-to:references:message-id:date:thread-index:thread-topic :subject:cc:to:from:from:to:cc:subject:date:message-id:reply-to :content-type; bh=vMO6qisr0ly6k8twWDubUTeoOlaHAIjcQhbEM9FNYo8=; b=jRePgp06xefgaZsVZqrFWcPN5dLaz+ptNdxsWUp2r63ADkFcFuynBIu2c8YBpdDKt9 nqoUjfoJ2u84WcSG+ORLTnqO35u0SUVzNPtHWSmIIgbqr/jQFSsgaBZHMBxbaPK6xbeY Lc8RLZ82oz4ELjtfS8T2RmYbcSbFetlXO9dsmORYrlPbi/OTHoZnITAKFe3tSwzl/FST 7fbiWg5HQR7B/v1cCj3XpdcEwK91FKAODklvW9JoYQANtxViqnt7ZMVR0IfMx4H/A1t+ CGsekrlm+Q2QvroP7csDbgRrkdgF2vUq5NOJXI1GKNBjiYJkvQu+SGayVn9Lys8QXMUq HmXQ==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20260707; t=1791232442; x=1791837242; h=mime-version:content-type:content-language:accept-language :in-reply-to:references:message-id:date:thread-index:thread-topic :subject:cc:to:from:x-gm-gg:x-gm-message-state:from:to:cc:subject :date:message-id:reply-to:content-type; bh=vMO6qisr0ly6k8twWDubUTeoOlaHAIjcQhbEM9FNYo8=; b=16w8PdonbUvJ8WmJeVQD6+k61qat41O7JajU7dvxSgoxBiW/Xxqm0DSFIsVowHhD66 oWNQGF8SVAU5sw3IGMMC7z+fXYtFOeJDnzFdgKhih8606YXsC3ouYrKA8w0ngjH04N8C JYUmMvxF7u+hohsX3p9Ldvdk+5F6EwUaAZksYHhlW6FJJiPhLv5fkYjAwWkkZuAH8Njg uRsVWT0wK4NRKTEvEi6jOBTlW6/ZrafiXwIdzjRKG1gM3MXVJi2YHP4xphVwN8G2G7G7 AggMeOtQyX4wu0s4M3IY4rRo/HL3p7eqddp9ASOm1hGOQSMntttZKwJC7Nrw8Qz/j751 gx4A==
X-Gm-Message-State: AFq9FYIPX7yW+T948cZvzlhhhV/EVjTDzZ7tvU9mfKnlVgeF/iSWy+6W ueNAbn8dSJcKtAKn3xl/NVBVLqAh6RwCLUjLOpZt20iS0H7CFYHXQo8O
X-Gm-Gg: AYBFou3Aq+Da/diKSM8TXrRJ816Un7CalXdGjSHZORTtVa6T9mZvb/16pr4FKEQyoDO lO+7qyZchYFKqcdmHVpnl4qAhzjLzqOTckwOE0XxpVRcts5vEF/J80aTmLaDCwmWlYLolnjoMOZ LV2XvgfUNdXjPI3Qo22bcJjP9MOCTQCLPgedvK6/62Xnmti0DxOwehcTfiuB7OlBEiCG0rEi5mR sYu+rl0JEF2dQzVr6E6FdkL9SVYwwJxigcpWY612/Imds4gqQ/OV3kqEsrkIX5V7EPLc/LpTmkT RbzhMUQIMchOPFM5QYbl2OdHBXgGCMuwCOtyhgkU1RbOsbst0R89pirICgC8S9MbHCTi4Oh/gDI 6QYq8hZVdwGCLnisTShX+xFCBF+mFV/VkKhyAb04smZr5iTsRXkDuymU4zcFcy/l/UboIgPkLlX ZTul9lZeNmIMsU/4KozNGcgJikJQyZca9xxhS/vl3P8ndBEPtynmZ3awMvUZamQRBoxTark3tnj vPe7N7ybOx0f22LxeKYJ5nzDwRmXJT35S6+d0vOiw4y0TddBIv3/psepBPE9C0f8Q==
X-Received: by 2002:a17:90b:5748:b0:3a4:b8fd:9662 with SMTP id 98e67ed59e1d1-3a6ce959351mr5684098a91.54.1791232440498; Mon, 05 Oct 2026 13:34:00 -0700 (PDT)
Received: from BL3PR19MB6444.namprd19.prod.outlook.com ([2603:1036:207:1b::5]) by smtp.gmail.com with ESMTPSA id 98e67ed59e1d1-3a853c9c5adsm1111395a91.8.2026.10.05.13.33.59 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Mon, 05 Oct 2026 13:34:00 -0700 (PDT)
From: Luc André Burdet <laburdet.ietf@gmail.com>
To: "Jorge Rabadan (Nokia)" <jorge.rabadan@nokia.com>, Alexander Vainshtein <Alexander.Vainshtein@rbbn.com>, Gyan Mishra <hayabusagsm@gmail.com>
Thread-Topic: [EXTERNAL] Re: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS
Thread-Index: AQHdUPSblCWnK2Z1lkKfqxGYphrOhrbm7rGAgAFnhgCABxaoNw==
X-MS-Exchange-MessageSentRepresentingType: 1
Date: Mon, 05 Oct 2026 20:33:58 +0000
Message-ID: <BL3PR19MB64449C3DA287729F2B602D3FAF962@BL3PR19MB6444.namprd19.prod.outlook.com>
References: <PH0PR03MB63003C7B2328118DE034A087F61B2@PH0PR03MB6300.namprd03.prod.outlook.com> <PH0PR03MB630089DBBA00EF47AD6D9215F6BB2@PH0PR03MB6300.namprd03.prod.outlook.com> <DM8PR11MB5719B52E2804FF4CF38FB6A1C98C2@DM8PR11MB5719.namprd11.prod.outlook.com> <CABNhwV0mSbz3uCkjnWuDDRYCusaGoru4GN9pQOmDXf84DK2_zw@mail.gmail.com> <PH0PR03MB6913CD2BA4AA0DDED58AB769F68B2@PH0PR03MB6913.namprd03.prod.outlook.com> <SA2PR08MB647407D9DA1BD7D785BA8309F78A2@SA2PR08MB6474.namprd08.prod.outlook.com>
In-Reply-To: <SA2PR08MB647407D9DA1BD7D785BA8309F78A2@SA2PR08MB6474.namprd08.prod.outlook.com>
Accept-Language: en-US
Content-Language: en-CA
X-MS-Has-Attach:
X-MS-Exchange-Organization-SCL: -1
X-MS-TNEF-Correlator:
X-MS-Exchange-Organization-RecordReviewCfmType: 0
x-ms-reactions: allow
Content-Type: multipart/alternative; boundary="_000_BL3PR19MB64449C3DA287729F2B602D3FAF962BL3PR19MB6444namp_"
MIME-Version: 1.0
X-Spamd-Bar: ---
Message-ID-Hash: J2FGI55I372ZESOPSL6N3WUL524KFTRJ
X-Message-ID-Hash: J2FGI55I372ZESOPSL6N3WUL524KFTRJ
X-MailFrom: laburdet.ietf@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-spring.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "spring@ietf.org" <spring@ietf.org>, BESS <bess@ietf.org>, "Pablo Camarillo (pcamaril)" <pcamaril@cisco.com>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS
List-Id: "Source Packet Routing in NetworkinG (SPRING)" <spring.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/spring/AHZvmi3uQaslV_Y7y3xJpxt85Bc>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spring>
List-Help: <mailto:spring-request@ietf.org?subject=help>
List-Owner: <mailto:spring-owner@ietf.org>
List-Post: <mailto:spring@ietf.org>
List-Subscribe: <mailto:spring-join@ietf.org>
List-Unsubscribe: <mailto:spring-leave@ietf.org>
Hi Jorge, Sasha, We discussed a flag and concluded it was not the best approach for service-layer protection: * as Jorge says we are defining several behaviours for when an interface goes Down * There was a concern over the ‘MUST be set to 0’ in rfc9252 which we didn’t want to ‘update’. (admittedly a weaker argument). The proposed use is intentionally different than Arg.FE2 for split-horizon. This is the goal - the FRR document defines explicitly the behaviour of Arg.FR2 and how to use it (avoiding a situation like rfc9819 where it needs to be clarified). I don't think they should be compared: Arg.FE2 and Arg.FR2 are different arguments to different SIDs / Routes ? Regards, Luc André Luc André Burdet | Cisco | laburdet.ietf@gmail.com | Tel: +1 613 254 4814 From: Jorge Rabadan (Nokia) <jorge.rabadan@nokia.com> Date: Thursday, October 1, 2026 at 04:08 To: Alexander Vainshtein <Alexander.Vainshtein=40rbbn.com@dmarc.ietf.org>; Gyan Mishra <hayabusagsm@gmail.com> Cc: spring@ietf.org <spring@ietf.org>; BESS <bess@ietf.org>; Pablo Camarillo (pcamaril) <pcamaril@cisco.com>; Luc André Burdet <laburdet.ietf@gmail.com> Subject: Re: [EXTERNAL] Re: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Hi Sasha, Luc can jump in too, but there was a discussion about using a flag or a new behavior. The decision was to define these new behaviors end.dt2u.reroute and end.dx2.reroute, because the semantics really didn’t match the existing behaviors. It is not only about “NRR” but also other procedures detailed in the draft, such us ignoring local bias, or bypassing non-DF blocking. Thanks. Jorge From: Alexander Vainshtein <Alexander.Vainshtein=40rbbn.com@dmarc.ietf.org> Date: Wednesday, September 30, 2026 at 3:42 AM To: Gyan Mishra <hayabusagsm@gmail.com> Cc: spring@ietf.org <spring@ietf.org>; BESS <bess@ietf.org>; Pablo Camarillo (pcamaril) <pcamaril@cisco.com>; Luc André Burdet <laburdet.ietf@gmail.com>; Jorge Rabadan (Nokia) <jorge.rabadan@nokia.com> Subject: RE: [EXTERNAL] Re: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS CAUTION: This is an external email. Please be very careful when clicking links or opening attachments. See the URL nok.it/ext for additional information. Gyan, ++ Luc and Jorge. Lots of thanks for your email and for your interest in the subject. I would like to bring to our attention the latest EVPN Fast Reroute draft<https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-fast-reroute-00> that addresses EVPN FRR over both IP/MPLS and SRv6 Underlay.\ In the case of EVPN-SRv6 it introduces new endpoint behaviors that are differentiated from already defined behaviors by using an advertised Argument Arg.FR2 that can be omitted or included in the Service SID depending on its intended usage. Proposed usage of Argument is quite different from the way Argument is used for Split Horizon Filtering in EVPN. IMHO the desired result could be provided in a much simpler way, e.g., by defining a No Reroute (NRR) flag in the Service SID Flags field of the SID Information Sub-TLV for SID with End.DX2 behavior. I will provide a detailed definition of my proposal in another email. Regards, Sasha From: Gyan Mishra <hayabusagsm@gmail.com> Sent: Wednesday, September 30, 2026 6:17 AM To: Pablo Camarillo (pcamaril) <pcamaril@cisco.com> Cc: Alexander Vainshtein <Alexander.Vainshtein@rbbn.com>; spring@ietf.org; BESS <bess@ietf.org> Subject: [EXTERNAL] Re: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Hi Sasha I have read through the thread and agree with Pablo that RFC 8986 specifies the SRv6 data plane and all endpoint behaviors and related pseudocode for each type of endpoint processing. From a L2 VPN control plane perspective all route types and functionality defined in RFC 7432bis update rem Hi Sasha I have read through the thread and agree with Pablo that RFC 8986 specifies the SRv6 data plane and all endpoint behaviors and related pseudocode for each type of endpoint processing. From a L2 VPN control plane perspective all route types and functionality defined in RFC 7432bis update remain applicable and encoded in the data plane per RFC 9252 BGP overlay services for SRv6 and RFC 9819 specifying the ARG field Arg.FE2 signaling over SRv6 data plane for ESI filtering. All FRR mechanisms from other L2 EVPN specification as well as TI-LFA FRR are all addressed in those specifications relevant to SRv6. Kind Regards Gyan On Tue, Sep 29, 2026 at 12:46 PM Pablo Camarillo (pcamaril) <pcamaril=40cisco.com@dmarc.ietf.org<mailto:40cisco.com@dmarc.ietf.org>> wrote: Hi Sasha, RFC 8986 specifies the fundamental data-plane pseudocode/primitive endpoint behaviors under nominal operation where the SID and outgoing interface I are active and valid. Interface Failure and Protection: RFC 8986 intentionally does not embed protection, fast reroute (FRR), or multi-homing state machines into the base endpoint definition. Instead, interface failure handling and protection mechanisms are governed by the relevant service layer and fast-convergence specifications (such as EVPN multi-homing in RFC 9252 / BESS SRv6 EVPN and TI-LFA / Egress Protection frameworks). Rerouting / Backup Encapsulation: In an EVPN VPWS or multi-homed active-standby/all-active scenario where interface I fails, an implementation that supports local egress protection / bypass may pre-program a backup path in the FIB. When I goes down, the node can encapsulate the decapsulated Ethernet frame into an SRv6 policy toward the backup PE's Service SID (or alternate interface) prior to control-plane reconvergence. This is an application of standard service-layer protection/FRR on top of the base behavior and is fully compliant with the architecture. Hope this clarifies it. Let us know if you have any further questions. Cheers, Pablo. From: Alexander Vainshtein <Alexander.Vainshtein=40rbbn.com@dmarc.ietf.org<mailto:40rbbn.com@dmarc.ietf.org>> Date: Tuesday, 15 September 2026 at 03:26 To: spring@ietf.org<mailto:spring@ietf.org> <spring@ietf.org<mailto:spring@ietf.org>> Cc: BESS <bess@ietf.org<mailto:bess@ietf.org>> Subject: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS Hi all, A gentle reminder: I have not received feedback from the SPRING WG on my email sent 3 months ago, The question in this email can be re-formulated differently: Suppose that an SID with endpoint with behavior End. DX2 has been defined and associated with the outgoing interface I. As long as I is operationally UP, packets received with this SID as the Destination IPv6 address in the IPv6 header shall be processed as defined in the standard, i.e.: • IPv6 header and all extension headers will be stripped • The resulting Ethernet frame shall be sent "as is: via I The question: How will packets received with this SID as the Destination IPv6 address in the IPv6 header be processed if I is operationally DOWN? Can we say that such packets MUST be discarded? Regards, and lots of thanks in advance, Sasha From: Alexander Vainshtein Sent: Thursday, June 11, 2026 7:10 PM To: spring@ietf.org<mailto:spring@ietf.org> Cc: BESS <bess@ietf.org<mailto:bess@ietf.org>> Subject: Usage of End.DX2 SID in EVPN-VPWS Importance: High Hi, I have a question about usage of End.DX2 SID (as defined in Section 4.9 of RFC 8986<https://datatracker.ietf.org/doc/html/rfc8986#section-4.9>in EVPN-VPWS. • The definition of this endpoint behavior says that "The End.DX2 SID MUST be the last segment in an SR Policy, and it is associated with one outgoing interface I" • If the upper-layer header type is Ethernet, the IPv6 header and all extension headers are stripped, and the resulting Ethernet frame is forwarded to the outgoing interface I. EVPN-VPWS as defined in RFC 8214 is explicitly mentioned as one of possible applications in this section, and Section 6.1.2 of RFC 9252<https://datatracker.ietf.org/doc/html/rfc9252#section-6.1.2> explicitly mentions End.DX2 as one of possible behaviors of the SID signaled in per-EVI Ethernet A-D routes (along with End.X2V and End.DT2U). I think that End.X2 behavior as defined above is not compatible with one of the advantageous features of EVPN-VPWS as described in the last para of Section 5 of RFC 8214<https://datatracker.ietf.org/doc/html/rfc8214#section-5>: <quote> Finally, EVPN may employ data-plane egress link protection mechanisms not available in VPWS. This can be done by the primary PE (on local AC down) using the label advertised in the per-EVI Ethernet A-D route by the backup PE to encapsulate the traffic and direct it to the backup PE. <end quote> (For the reference, implementing fast egress protection against AC failure in "classic" VPWS has been defined in RFC 8104). What, if anything, did I miss? Do you think that a new Endpoint behavior should be defined? Regards, and lots of thanks in advance, Sasha Disclaimer This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments. _______________________________________________ BESS mailing list -- bess@ietf.org<mailto:bess@ietf.org> To unsubscribe send an email to bess-leave@ietf.org<mailto:bess-leave@ietf.org>
- [spring] Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Luc André Burdet
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Pablo Camarillo (pcamaril)
- [spring] Re: [bess] Re: Usage of End.DX2 SID in E… Gyan Mishra
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Alexander Vainshtein
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Jorge Rabadan (Nokia)
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Luc André Burdet
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein