[spring] Usage of End.DX2 SID in EVPN-VPWS
Alexander Vainshtein <Alexander.Vainshtein@rbbn.com> Thu, 11 June 2026 16:12 UTC
Return-Path: <alexander.vainshtein@rbbn.com>
X-Original-To: spring@mail2.ietf.org
Delivered-To: spring@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 72F5CFF6C470 for <spring@mail2.ietf.org>; Thu, 11 Jun 2026 09:12:11 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1781194331; bh=JXCRrl12ocPe+r0uU6ZFp3ndueCPJK0Mo8J5DK6t1zk=; h=From:To:CC:Subject:Date; b=VU0MxOMmk9BlJfANQV+vI9Viij3rp9PeNORbg6DBNtUdKWltua5eeufoTzWrUhZZT /hBJSdQozhlBm2xPycCBR2ZjEPRVeAM0UoE3thnNl1m2vhagYix8BYRtfvig+iTIr8 jNzM0x387DVL7yCmn8tecIGHJu/QksRSLRRpRbA8=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.096
X-Spam-Level:
X-Spam-Status: No, score=-2.096 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, RCVD_IN_MSPIKE_H5=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=rbbn.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id UbliNG7oX39s for <spring@mail2.ietf.org>; Thu, 11 Jun 2026 09:12:11 -0700 (PDT)
Received: from usb-smtp-delivery-110.mimecast.com (usb-smtp-delivery-110.mimecast.com [170.10.151.110]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 5EB9BFF6C302 for <spring@ietf.org>; Thu, 11 Jun 2026 09:10:33 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=rbbn.com; s=mimecast20240522; t=1781194232; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:cc:mime-version:mime-version:content-type:content-type; bh=c0/viJDoEhlixFTYsRX1+7c1aI+oXz6XsI/VmZpLKNU=; b=WjMMvavQP93vk9W5mTenoIKOayf4aWnFCpniXHVG4qLiraKNIoHO15UznGdh8Gr1Gv5JZM WS/yjRMJ7b7qoerKZ2T0UpUOZBpOJCy9GL2OkSQlqnfJyDsoCMx6ozc36rcrTDN41HHHVF csJG5AJTOHBlU5LGJza9Nw689hgcubU5miUgJX9JL0SnpCKflQiP/fv6WYJJbEC62+kPe3 afNC46idfaUEKa2mQ+EQHO3/8dErE1p1KVXanwcMxSjq9LRWVGKLp+pSrXyhLkMHZklByN 2ziv/whpxwlAuOqbZd7n9gy6Jwg+iz0rfrFABhxffoMzQp6hIWwB7hNHId7VCw==
Received: from CO1PR03CU002.outbound.protection.outlook.com (mail-westus2azon11020130.outbound.protection.outlook.com [52.101.46.130]) by relay.mimecast.com with ESMTP with STARTTLS (version=TLSv1.3, cipher=TLS_AES_256_GCM_SHA384) id usb-mta-73-7jXWgJVTNFy6W5DGLROFqA-1; Thu, 11 Jun 2026 09:10:29 -0700
X-MC-Unique: 7jXWgJVTNFy6W5DGLROFqA-1
X-Mimecast-MFC-AGG-ID: 7jXWgJVTNFy6W5DGLROFqA_1781194228
Received: from PH0PR03MB6300.namprd03.prod.outlook.com (2603:10b6:510:e2::5) by DM6PR03MB5292.namprd03.prod.outlook.com (2603:10b6:5:240::19) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.113.11; Thu, 11 Jun 2026 16:10:27 +0000
Received: from PH0PR03MB6300.namprd03.prod.outlook.com ([fe80::6bff:3405:30e9:55d9]) by PH0PR03MB6300.namprd03.prod.outlook.com ([fe80::6bff:3405:30e9:55d9%5]) with mapi id 15.21.0092.014; Thu, 11 Jun 2026 16:10:26 +0000
From: Alexander Vainshtein <Alexander.Vainshtein@rbbn.com>
To: "spring@ietf.org" <spring@ietf.org>
Thread-Topic: Usage of End.DX2 SID in EVPN-VPWS
Thread-Index: Adz5uPR7fUL5tRVIRvCZZdadAMF0WQ==
Importance: high
X-Priority: 1
Date: Thu, 11 Jun 2026 16:10:26 +0000
Message-ID: <PH0PR03MB63003C7B2328118DE034A087F61B2@PH0PR03MB6300.namprd03.prod.outlook.com>
Accept-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PH0PR03MB6300:EE_|DM6PR03MB5292:EE_
x-ms-office365-filtering-correlation-id: 09985736-44ab-4a04-2b2f-08dec7d3f35d
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|23010399003|1800799024|366016|19092799006|376014|8096899003|3023799007|38070700021|11063799006|18002099003|56012099006
x-microsoft-antispam-message-info: bL37Nhrzo1jGMy2srkfVaDuBgcATmYpuN9LLmYhIC8O3B95uclvQmkh1nhg0cMUSmzzQ10yAyk9ASRauiYutKrsZ0K52puXgPGzKMwt3dOgw32yaqYW0p9ve3RQyXaeWb/ERBoa41V7HehHaLCxtA1fvapCbgYoT9q+T7HoujegMIDsu6cP0Q7WkT7QrSIJ14BgwRhQ6MhYNLtogG7nFouz0Xdasyo5TdbAYMnfjn9m7ELzd5rEHLE4NZrWWYCNIR5nZMf6zGmBz3vcctRtikT35vaSrM+Su8h1Ed8/ZhSdP9FTvXwsqkbcsyibTsDQ2Ht8zwRzba/WjrzOb3k5ZKef7u+85MCI6+ftDfMchvYprD00z+WHvJN/ehCI97CgDmGEO/ReKRC1yuX5Zl438XNd7xo/L/gFofyowU7WPEEwgBknS3AQxTMfC99OOK9AyAZGmjCce8WyppqXQC/jBfJd2W/HK6v2b5i2Wh12SIzlp8g2xJvtCHsNVRbBfOmMuggs5zL3ZCqEUsZOkjVdUGH8QeSA3q9u2vX0uA9/W9CXdnfd+S9QJ7x7F8k88xIPR2N/lQjRR4A645CU6DHeDFDF3MIRWozHgFOAj92hSoFNTs8VUlRvnnEGM29dE/Tj8S3ZUmIhyEkKRpnAPOZG5RnAm0e8s+LcsTSMng/3npPHw4lDcD/9pNCGc+18tEcU23yA4EvIjbKVUiqHq1Ykxa7AL3Bdrq9oaTPi9FWFnXzp+++JQBvhxL6lR6GYAVOUB
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PH0PR03MB6300.namprd03.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(23010399003)(1800799024)(366016)(19092799006)(376014)(8096899003)(3023799007)(38070700021)(11063799006)(18002099003)(56012099006);DIR:OUT;SFP:1102
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: FzmdjwzhD3Op0VOy3jzuntgkSx7e4FCAKD2+ylEQV1B/FgsZ6N+DAntVmd1X5hMlA0Xa8BJ1IZLGvr+boAVT3pJpGh0vrTYZtD0Od1e/FaGcqTzUe4w3QpZSCov2JtfZsHTGy7kJYvVFokpAM2nkyIkDW8PjSnuIHTuE0Afgl2Ypf/QMw6APCK2HHeBPym8+5U+FvTRol+Jv8HU9YxV9L/4bCrUBaaWIPbFhbvdjtOY3IIpYBRSxFke/y6gjqyt7yqkbRwM9o/XoV2E5kihwg0gPidazDNi9fbZtNBMf8eFmTBZX5kocurxWWXEUdhAyCjD6/IQFkF9Ya6d/MadBDfvliYjafOoncFo2QLTsJ0W0rdYZ9Ue2OCGOr8YdvAHV2WPDyhz2ADX7FgRvFcZwOL9A4twI34RpB8x/eNsUe7AtsAvPUoggiCvdvPvanA9boxExCpU5CoXMF4RisObG3lnjur0tFAYTuZMiQoENzOBBa0aokN4z2qGuhRUBSLUPucck0uCaod7vgiA4pntlqvPXkRKjHBPQR71doOluMElZH5WqAbiZs1RIRGMLccGiFlzkQkm0DGgaeKdydjvkZeSikOZZE/t38SAvcrjt/u7ycmLsvDOUdXHwlUZo4LIkkARq8/rzPikEZB7n6dbgENprI3z4Ed9+j+Ko1sf5FAQkwiayh0U39fZnUQxAwYNj4bFPGp0F++K3sa0btJFLmTOCJmgKNxXGlqw89N5U8s6Ll50L7qs+cpwN9s8HjA3dXU1cjbZ4ps9ahOwzuiUIg+XpQOEHs53rOJOoTfMOZ70Dq/53J4NLI/BABLqRH05Q1E7QYA163jzPDWgZIXOQu0ol4x5o+vpzC5jTsbhvC++jVd+73NLtfC3wWGwkZk/+gxbGxs9R13Cw84gMOAHk8Mp5G+nxlq1H1Ys4wi93X986MNfWjFdFJMBdFqhs7/NqHZJmI3JJTI1wF0xkHX6l/BxgzwL/VbqCXA+pk8zejva8lLv0S/EOsMiZ8S2AiaruSgUtzOwVdx6whgpFVOxgZ0uhn7Z1noIumYzAXJbtcxTHrnmx918Q2y2IqYRq3kcOf+3OVZZ81bSISOaIpS5bZ5tuZalZlRQ4sfiHYTrPtpiatgQ5HAyYZAgx4t+QYN+Hbs7XGTfs04aMHSQASJh506vqxmtIPDcQ4lappx1MGjCaSz+vJ8LrqORQIu5ttW5D19kAOwl7GedOVOZ0EOGFmGoDTrEFoNBEf9CUyBI3rTIxHRO18+0M4tjFo+N0Oj3MwKEia4Bfy9Yn1huQI08Beo24ZBT1lhWZ+YN0L19bi4vk6LEXcdtvWwsQjiVr1WUBIJGTSOsM6S82n0yzonJ5ME7/pGgVBd7z4jr3GIUJAA9ky9nFumAq179rvUP8e2gMO/s4iGWSFqvWa/aLjhEq2JbQI8UUxCi3y08xZ7GQ5eBOPUFYANPFiMyIa65f/kTYtbZM2RvHHXaQABbrSqoXC7RTneVONzsWxJnn5VuyIVDWlCjEe7PjdSV/lQ2Hk8B4nTYYFlMJxLOAxK0jtmaFUzzNImTyv7zPful/v0eKEuTKLf1T+IT3frZjJzhg6MGx7Wom0W5VjhCYrSV5E/fPNTLsDA6NuCqdlZIZVRvS8YZrAGZK5F3Vx9uZVvZqKtJzpTd8KCqfXnC+Tl22MmuJku/q6Iw0hEldXyS8SGjodUeDICiaeiVTSD7RY+vsVO5i
MIME-Version: 1.0
X-Exchange-RoutingPolicyChecked: H16GLGE9dN6TUoG2heg+cE+spYbA5jbbyAanmQVS/d4qUXKzcBI8Ug/h/NKLn2pUZhVF8f08JjcbGFZZkXzxbMy0LLoeQoy95P/zjQQpqWovs8KXkroJKmBGRLdwxZmk/rzeJeEbbkhBPymVgFF5INj2rK/aSkBR7aioJv2AaOI5fK7mkFy+VBJ0UzdFk4GEb8xYSpsgtuBk2X66i5/fO1fqEJzq+kupa53BZjmpL5iu6d+CFTXrrPBMF26QgQ3auOsw4NF1vIOdzdxfY8+Yk/1NnKFWfnrIcno8N+OFSM5AQrRbR6dhKnlCGtdT6ziUAbTSjsDSoFjzwstdXxd4fg==
X-OriginatorOrg: rbbn.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PH0PR03MB6300.namprd03.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 09985736-44ab-4a04-2b2f-08dec7d3f35d
X-MS-Exchange-CrossTenant-originalarrivaltime: 11 Jun 2026 16:10:26.7377 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 29a671dc-ed7e-4a54-b1e5-8da1eb495dc3
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: +oGH721Q2AbfKi+jXjURWbtcDQUAVXGCty/mXTyRQY0YlQ9uUMII2F15A3tGMTIdWu2kRo+TyAbzv/dp0SYWsg==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: DM6PR03MB5292
X-Mimecast-Spam-Score: 0
X-Mimecast-MFC-PROC-ID: AGTz6_bApczBRLdY6k2aWT_I2ttXNMlLPSPB3hiHTMc_1781194228
X-Mimecast-Originator: rbbn.com
Content-Language: en-US
Content-Type: multipart/alternative; boundary="_000_PH0PR03MB63003C7B2328118DE034A087F61B2PH0PR03MB6300namp_"
Message-ID-Hash: U5JISKNVCZPXIVAPIFEIPVSUZMQVQMLF
X-Message-ID-Hash: U5JISKNVCZPXIVAPIFEIPVSUZMQVQMLF
X-MailFrom: alexander.vainshtein@rbbn.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-spring.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: BESS <bess@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [spring] Usage of End.DX2 SID in EVPN-VPWS
List-Id: "Source Packet Routing in NetworkinG (SPRING)" <spring.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/spring/tdhbTdYaEsCjlbF5IlLlDoWgsuY>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spring>
List-Help: <mailto:spring-request@ietf.org?subject=help>
List-Owner: <mailto:spring-owner@ietf.org>
List-Post: <mailto:spring@ietf.org>
List-Subscribe: <mailto:spring-join@ietf.org>
List-Unsubscribe: <mailto:spring-leave@ietf.org>
Hi, I have a question about usage of End.DX2 SID (as defined in Section 4.9 of RFC 8986<https://datatracker.ietf.org/doc/html/rfc8986#section-4.9>in EVPN-VPWS. * The definition of this endpoint behavior says that "The End.DX2 SID MUST be the last segment in an SR Policy, and it is associated with one outgoing interface I" * If the upper-layer header type is Ethernet, the IPv6 header and all extension headers are stripped, and the resulting Ethernet frame is forwarded to the outgoing interface I. EVPN-VPWS as defined in RFC 8214 is explicitly mentioned as one of possible applications in this section, and Section 6.1.2 of RFC 9252<https://datatracker.ietf.org/doc/html/rfc9252#section-6.1.2> explicitly mentions End.DX2 as one of possible behaviors of the SID signaled in per-EVI Ethernet A-D routes (along with End.X2V and End.DT2U). I think that End.X2 behavior as defined above is not compatible with one of the advantageous features of EVPN-VPWS as described in the last para of Section 5 of RFC 8214<https://datatracker.ietf.org/doc/html/rfc8214#section-5>: <quote> Finally, EVPN may employ data-plane egress link protection mechanisms not available in VPWS. This can be done by the primary PE (on local AC down) using the label advertised in the per-EVI Ethernet A-D route by the backup PE to encapsulate the traffic and direct it to the backup PE. <end quote> (For the reference, implementing fast egress protection against AC failure in "classic" VPWS has been defined in RFC 8104). What, if anything, did I miss? Do you think that a new Endpoint behavior should be defined? Regards, and lots of thanks in advance, Sasha Disclaimer This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.
- [spring] Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Luc André Burdet
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Pablo Camarillo (pcamaril)
- [spring] Re: [bess] Re: Usage of End.DX2 SID in E… Gyan Mishra
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Alexander Vainshtein
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Jorge Rabadan (Nokia)
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Luc André Burdet
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein