[spring] Re: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS
Gyan Mishra <hayabusagsm@gmail.com> Wed, 30 September 2026 03:17 UTC
Received: from mail-oo2-x0d.google.com (mail-oo2-x0d.google.com [IPv6:2607:f8b0:4864:31::d]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange x25519 server-signature ECDSA (prime256v1) server-digest SHA256) (No client certificate requested) by mx.ietf.org (Postfix) with ESMTPS id 142AB42 for <spring@ietf.org>; Wed, 30 Sep 2026 03:17:10 +0000 (UTC)
Authentication-Results: mx.ietf.org; dkim=pass header.d=gmail.com header.s=20251104 header.b=tJDwMVyR; dmarc=pass (policy=none) header.from=gmail.com; arc=pass ("google.com:s=arc-20260327:i=1"); spf=pass (mx.ietf.org: domain of hayabusagsm@gmail.com designates 2607:f8b0:4864:31::d as permitted sender) smtp.mailfrom=hayabusagsm@gmail.com
Received: by mail-oo2-x0d.google.com with SMTP id 006d021491bc7-6d33d80855eso3337574eaf.1 for <spring@ietf.org>; Tue, 29 Sep 2026 20:17:10 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; t=1790738229; cv=none; d=google.com; s=arc-20260327; b=XTavjEoWtiyfkPzXrf8vsZDOh3ujkdUWzv3JvC9XtD4VITrFvuNaR5YXAMKdckjkHS 5A2kJaLl/rlczIO1rW5z4fl8PRUnGRrzM8ADpoNdXlwCQvPn+rwWvc+4WyRdc2uRcACL VvKQD39fTFAI5hjyF/e0UPLR2tBOhVgbB9kNW7uU2a6J9xOXS+/JEiyswwrU/2UUMWsY AwrEANEzJF5nGRg4vLvH+Le2pwI38Zg98zngbOARR+8HDexbtVeh8v13rgfKyJVhx60I GiQXMrc8wypGqfugVQ++JLT2VlzqsYqO+Y39kKmlViJOMTrrMoK0YxY5CwLgwdzUlsk1 qAxg==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20260327; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:dkim-signature; bh=yThc/CI3+GSbs+fBz6pwv6VbIPzV8Hy9mi9Aik2/L3A=; fh=TdLiaF0ykYhfC/1zoZnwPFjOlYqD15PG9NJWSqfG4rk=; b=BZpmD71niM9zM3NUifX5Rrwy6EOkL+zBCJLOwKerll3Mhdqg8KT4j5szLvYQY2ArlO S7OTAaIR2ycM8O/J0ASIz3Osw664dd/9OJf4YsRdehlOOmilgxdCD6wAxFXI7F+q7yuj 6PaLaioQPLOP25EYpvOGjBPdraFTL4TnBpXMTElnaH5QGre4Sis8+XwWpiPZEuNcjhlP 61w+5VImSPEoYM5UXlSY/+Kc0+8dcJwISEouw7PIlml9EB3RqzYUFi6ills9uYktg4u8 CRB8eW3o4cAJulzTUpBCdCmEr2mZqJdBI15l8FHOSUBY/y1aLFO/5BVBMEdLDzZhVJiQ CydQ==; darn=ietf.org
ARC-Authentication-Results: i=1; mx.google.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1790738229; x=1791343029; darn=ietf.org; h=content-type:cc:to:subject:message-id:date:from:in-reply-to :references:mime-version:from:to:cc:subject:date:message-id:reply-to :content-type; bh=yThc/CI3+GSbs+fBz6pwv6VbIPzV8Hy9mi9Aik2/L3A=; b=tJDwMVyRsYKdK+A4zwmWwa0GKxYWnnHYdtOZOZjH/dtrv5WKDL0ZaUol3Z6KLku4PN zpfEDnAKX6xXmlgBSh7lLUMSi1BWq/0ue3Ch0sksXNjLCyjatLARnlEFbNKvtnHUga9J g9SbctMHkOkAfKC6vGfoIEKO9p/XpQf8AZxGzUFmsq+5JN1A+IGUZwNuYHGAa3qlMGo9 oJ7bpozRhbZ3JuSalx7g+Wd3h33mJQgXa7E75d34GaPkpo4LtZeQvQFoDdjHhd73X1Zz Mf//bc2YkzZrWsZMFUne54n64vJObQXZpurxWo1ESbYsqxbKFnccueHfUrcH6eNCRJtO tG5Q==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20260707; t=1790738229; x=1791343029; h=content-type:cc:to:subject:message-id:date:from:in-reply-to :references:mime-version:x-gm-gg:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to:content-type; bh=yThc/CI3+GSbs+fBz6pwv6VbIPzV8Hy9mi9Aik2/L3A=; b=EmNxBHjqNEhFRJ0f3fVqYbVtwdPPkUFZUgetvpPNnyg6AWZkjKyjtnn1a9BWUjutGg Nilwtm+ESk/qVACNT+ADEsV0xnx0yXno/iT4bzWYuHr3GwgVxCV+zknhTx7k1Lzj9NAa KLsej30htKGQKq+y3hkvoWBC+2K69g+WIOnE4tmwBUEAyQBrG/QWps3MfrWVEXT+2xc9 rQn004gu9VsoB6RMjivnuObqJXv+FPLKyt82X0Fo3NEEfxsocZnh/brT8O3UR9Z9Rk36 JIQUwbx/9LLWFF71WPTHky5kEyQAkrYkg2kZbdJYdWdgl9juRRaizJQz59J9nuwo75sV ZZOQ==
X-Forwarded-Encrypted: i=1; AKwUvByF/IwHXzAnwEgmjPMDVvd/y5z0zV/G7G3fXhx3txRsquYXCZsJ007//Gx0iw9etJvcoGZVTSs=@ietf.org
X-Gm-Message-State: AFuF++maaTwlB+yrwHurGrnU75zeGUH076eE2oAgSseLsXj5U+NR6xSS DkrYlkHPdteKmjEFe8GBLmKFNI0+KWsfXBW/to4XJqaddJIDEipFl4U5s6gD22pIWydtS0hRHui CVdRlKqvk1MEJc1la2ivTiw/On8U5RDk=
X-Gm-Gg: AYBFou1dO0+MN2/0hUwA2IaMsWSCeuWucJL2ruej/r4H00MCQzAeO6OB8/UbA5ItDTG 7JspCo+3BkBEmaXIIgVAgbHSJTOm7lJ/WRYYDHxC0kQxufvAi3jMkJ7UaRAmR9GQFVgsxLbMQMS N44RvqdCiHZs/vGihO4knbJb3nljmpxleDdbZBy5h2JppCI/mA2TANTBYP9s9SFNocTaZuVnTva X9mbOU4R4rdCX9wxQQHeClqd4oH+H0ZfW61SyosH/JTUga86mmsNp3c6oHp0i3I65RuzzW7onM8 nbEX7yo/QCjihBgrTcnIuqU1RUmGPRw4OVcmzIbDehXWvz476j5TPQBwy37ZBnV4/KalBrN5UVz 3/fjOncg/aJj1YZYQgwXeIrqhd13hO+Xsn4vmERz5JxpfwtvNmnKXCQ==
X-Received: by 2002:a05:6820:f02b:b0:6cd:3fdc:6003 with SMTP id 006d021491bc7-6dcf75f7b63mr66056eaf.84.1790738229152; Tue, 29 Sep 2026 20:17:09 -0700 (PDT)
MIME-Version: 1.0
References: <PH0PR03MB63003C7B2328118DE034A087F61B2@PH0PR03MB6300.namprd03.prod.outlook.com> <PH0PR03MB630089DBBA00EF47AD6D9215F6BB2@PH0PR03MB6300.namprd03.prod.outlook.com> <DM8PR11MB5719B52E2804FF4CF38FB6A1C98C2@DM8PR11MB5719.namprd11.prod.outlook.com>
In-Reply-To: <DM8PR11MB5719B52E2804FF4CF38FB6A1C98C2@DM8PR11MB5719.namprd11.prod.outlook.com>
From: Gyan Mishra <hayabusagsm@gmail.com>
Date: Tue, 29 Sep 2026 23:16:57 -0400
X-Gm-Features: AclHuK-6pHhzg1mxOTEpPBRL3bCRzSSwjdGp4jVIJvTUQtYfNo2yeNYUX44B018
Message-ID: <CABNhwV0mSbz3uCkjnWuDDRYCusaGoru4GN9pQOmDXf84DK2_zw@mail.gmail.com>
To: "Pablo Camarillo (pcamaril)" <pcamaril=40cisco.com@dmarc.ietf.org>
Content-Type: multipart/alternative; boundary="00000000000008cf1e065caabcdd"
X-Spamd-Bar: --
Message-ID-Hash: AHX636TSGJYM4CFH55S5FUCP57BD5F6X
X-Message-ID-Hash: AHX636TSGJYM4CFH55S5FUCP57BD5F6X
X-MailFrom: hayabusagsm@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; loop; banned-address; header-match-spring.ietf.org-0; emergency; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Alexander Vainshtein <Alexander.Vainshtein=40rbbn.com@dmarc.ietf.org>, "spring@ietf.org" <spring@ietf.org>, BESS <bess@ietf.org>
X-Mailman-Version: 3.3.10
Precedence: list
Subject: [spring] Re: [bess] Re: Usage of End.DX2 SID in EVPN-VPWS
List-Id: "Source Packet Routing in NetworkinG (SPRING)" <spring.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/spring/dcuB2JjEvpLUTbTnBDICYTfoXR8>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spring>
List-Help: <mailto:spring-request@ietf.org?subject=help>
List-Owner: <mailto:spring-owner@ietf.org>
List-Post: <mailto:spring@ietf.org>
List-Subscribe: <mailto:spring-join@ietf.org>
List-Unsubscribe: <mailto:spring-leave@ietf.org>
Hi Sasha I have read through the thread and agree with Pablo that RFC 8986 specifies the SRv6 data plane and all endpoint behaviors and related pseudocode for each type of endpoint processing. From a L2 VPN control plane perspective all route types and functionality defined in RFC 7432bis update remain applicable and encoded in the data plane per RFC 9252 BGP overlay services for SRv6 and RFC 9819 specifying the ARG field Arg.FE2 signaling over SRv6 data plane for ESI filtering. All FRR mechanisms from other L2 EVPN specification as well as TI-LFA FRR are all addressed in those specifications relevant to SRv6. Kind Regards Gyan On Tue, Sep 29, 2026 at 12:46 PM Pablo Camarillo (pcamaril) <pcamaril= 40cisco.com@dmarc.ietf.org> wrote: > Hi Sasha, > > RFC 8986 specifies the fundamental data-plane pseudocode/primitive > endpoint behaviors under nominal operation where the SID and outgoing > interface I are active and valid. > > Interface Failure and Protection: RFC 8986 intentionally does not embed > protection, fast reroute (FRR), or multi-homing state machines into the > base endpoint definition. Instead, interface failure handling and > protection mechanisms are governed by the relevant service layer and > fast-convergence specifications (such as EVPN multi-homing in RFC 9252 / > BESS SRv6 EVPN and TI-LFA / Egress Protection frameworks). > > Rerouting / Backup Encapsulation: In an EVPN VPWS or multi-homed > active-standby/all-active scenario where interface I fails, an > implementation that supports local egress protection / bypass may > pre-program a backup path in the FIB. When I goes down, the node can > encapsulate the decapsulated Ethernet frame into an SRv6 policy toward the > backup PE's Service SID (or alternate interface) prior to control-plane > reconvergence. This is an application of standard service-layer > protection/FRR on top of the base behavior and is fully compliant with the > architecture. > > Hope this clarifies it. Let us know if you have any further questions. > > Cheers, > > Pablo. > *From: *Alexander Vainshtein <Alexander.Vainshtein= > 40rbbn.com@dmarc.ietf.org> > *Date: *Tuesday, 15 September 2026 at 03:26 > *To: *spring@ietf.org <spring@ietf.org> > *Cc: *BESS <bess@ietf.org> > *Subject: *[bess] Re: Usage of End.DX2 SID in EVPN-VPWS > > Hi all, > > A gentle reminder: I have not received feedback from the SPRING WG on my > email sent 3 months ago, > > > > The question in this email can be re-formulated differently: > > > > Suppose that an SID with endpoint with behavior End. DX2 has been defined > and associated with the outgoing interface I. > > As long as I is operationally UP, packets received with this SID as the > Destination IPv6 address in the IPv6 header shall be processed as defined > in the standard, i.e.: > > - IPv6 header and all extension headers will be stripped > - The resulting Ethernet frame shall be sent "as is: via I > > *The question*: > > How will packets received with this SID as the Destination IPv6 address in > the IPv6 header be processed if I is operationally DOWN? > > Can we say that such packets MUST be discarded? > > > > > > Regards, and lots of thanks in advance, > > Sasha > > > > *From:* Alexander Vainshtein > *Sent:* Thursday, June 11, 2026 7:10 PM > *To:* spring@ietf.org > *Cc:* BESS <bess@ietf.org> > *Subject:* Usage of End.DX2 SID in EVPN-VPWS > *Importance:* High > > > > Hi, > > I have a question about usage of End.DX2 SID (as defined in *Section 4.9 > of RFC 8986* <https://datatracker.ietf.org/doc/html/rfc8986#section-4.9>in > EVPN-VPWS. > > > > · The definition of this endpoint behavior says that "The End.DX2 > SID *MUST* be the last segment in an SR Policy, and it is associated with > one outgoing interface I" > > · If the upper-layer header type is Ethernet, the IPv6 header and > all extension headers are stripped, and the resulting Ethernet frame is > forwarded to the outgoing interface I. > > > > EVPN-VPWS as defined in RFC 8214 is explicitly mentioned as one of > possible applications in this section, and *Section 6.1.2 of RFC 9252* > <https://datatracker.ietf.org/doc/html/rfc9252#section-6.1.2> explicitly > mentions End.DX2 as one of possible behaviors of the SID signaled in > per-EVI Ethernet A-D routes (along with End.X2V and End.DT2U). > > > > > > I think that End.X2 behavior as defined above is not compatible with one > of the advantageous features of EVPN-VPWS as described in the last para of *Section > 5 of RFC 8214* <https://datatracker.ietf.org/doc/html/rfc8214#section-5>: > > <quote> > > Finally, EVPN may employ data-plane egress link protection mechanisms > > not available in VPWS. This can be done by the primary PE (on local > > AC down) using the label advertised in the per-EVI Ethernet A-D route > > by the backup PE to encapsulate the traffic and direct it to the > > backup PE. > > <end quote> > > > > (For the reference, implementing fast egress protection against AC failure > in "classic" VPWS has been defined in RFC 8104). > > > > What, if anything, did I miss? Do you think that a new Endpoint behavior > should be defined? > > > > Regards, and lots of thanks in advance, > > Sasha > > > > > *Disclaimer* > > This e-mail together with any attachments may contain information of > Ribbon Communications Inc. and its Affiliates that is confidential and/or > proprietary for the sole use of the intended recipient. Any review, > disclosure, reliance or distribution by others or forwarding without > express permission is strictly prohibited. If you are not the intended > recipient, please notify the sender immediately and then delete all copies, > including any attachments. > _______________________________________________ > BESS mailing list -- bess@ietf.org > To unsubscribe send an email to bess-leave@ietf.org >
- [spring] Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Luc André Burdet
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Pablo Camarillo (pcamaril)
- [spring] Re: [bess] Re: Usage of End.DX2 SID in E… Gyan Mishra
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Alexander Vainshtein
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Jorge Rabadan (Nokia)
- [spring] Re: [EXTERNAL] Re: [bess] Re: Usage of E… Luc André Burdet
- [spring] Re: Usage of End.DX2 SID in EVPN-VPWS Alexander Vainshtein