Re: [v6ops] Routers are hosts too!
t.petch <ietfc@btconnect.com> Tue, 12 January 2016 10:47 UTC
Return-Path: <ietfc@btconnect.com>
X-Original-To: v6ops@ietfa.amsl.com
Delivered-To: v6ops@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 071711A876E for <v6ops@ietfa.amsl.com>; Tue, 12 Jan 2016 02:47:00 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 0.799
X-Spam-Level:
X-Spam-Status: No, score=0.799 tagged_above=-999 required=5 tests=[BAYES_50=0.8, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, SPF_HELO_PASS=-0.001] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id OhViMmPusoM4 for <v6ops@ietfa.amsl.com>; Tue, 12 Jan 2016 02:46:57 -0800 (PST)
Received: from emea01-am1-obe.outbound.protection.outlook.com (mail-am1on0759.outbound.protection.outlook.com [IPv6:2a01:111:f400:fe00::759]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id EB83D1A876B for <v6ops@ietf.org>; Tue, 12 Jan 2016 02:46:56 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=btconnect.onmicrosoft.com; s=selector1-btconnect-com; h=From:To:Date:Subject:Message-ID:Content-Type:MIME-Version; bh=7ESOQaE5yRFWb0AAQYE5zGhi9haI7PtQur3JwAO6Mro=; b=j52CY6+SlAdrdXWsjkQQo7MYCzN9tZVCCa5I0iZwKf2Hce5JummGMJTyXZHc8I33khnsAViNhQDOLOK6l38HL/Tm8gCiux/pebt4I3LTzkblEvRU59i3KeHU9WcgLZ25o2dGi/YAQYci3DyW7HnEFNGoUqtrenSl+8Dej7vz0oc=
Authentication-Results: spf=none (sender IP is ) smtp.mailfrom=ietfc@btconnect.com;
Received: from pc6 (86.185.87.133) by DBXPR07MB061.eurprd07.prod.outlook.com (10.242.147.14) with Microsoft SMTP Server (TLS) id 15.1.361.13; Tue, 12 Jan 2016 10:46:33 +0000
Message-ID: <019a01d14d26$243f9de0$4001a8c0@gateway.2wire.net>
From: "t.petch" <ietfc@btconnect.com>
To: alexandre.petrescu@gmail.com, sthaug@nethelp.no
References: <5690A82F.5020007@isi.edu><03a301d14ade$57cb6e40$4001a8c0@gateway.2wire.net><56925425.4070502@gmail.com> <20160110.150704.74724334.sthaug@nethelp.no>
Date: Tue, 12 Jan 2016 10:43:48 +0000
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
X-Originating-IP: [86.185.87.133]
X-ClientProxiedBy: DB4PR05CA0020.eurprd05.prod.outlook.com (25.160.40.30) To DBXPR07MB061.eurprd07.prod.outlook.com (10.242.147.14)
X-Microsoft-Exchange-Diagnostics: 1; DBXPR07MB061; 2:hzBLm9rGw360XGl0A/0T8zpOmsqNv2ts+uZq2Oj4jBvJbNs9wpFv3yJ9hZKPPCksEMBoFYVkOruRo2X8d22HywoJ2rt2ndJMYtWmIWs2T40EIsQlBCr2Poxi38JM4J5dKSU1KefRHeCj2rmpHnypKg==; 3:FxqCqHPoHSI2xXkAeZECPctcvR0ZzvZ5mTy3xiWTtVxM2faspXgEIzrMAX4PrUQYSqJ2HiouIEESqYxOi8y3Rb92lwEcZAVFzg6f0QWumlLKG1C5kJe/aZTpx46uULfh; 25:UCHa66gnLvJPwogngghpq7hGzlx9w+C//rqckG/P8VBqmnHVVX6qK+ulIIKkkivFD9WqJ7NgZjG8zW4mN4PWTpJSEfOxftAdVmIxOzQipLEtiK8JrEQh3cudGu+cjhsrzhNtbnscCptYQhrtzoJnf6804Y05itjtOROHERiOQcOCGxOsM5/qCWbjU26c5COctNDQuGYK8hFn+iXjNpynnMtSbh6+v4KH9khTglF6AASh+jxiqCGARjxAnwf21X3z
X-Microsoft-Antispam: UriScan:;BCL:0;PCL:0;RULEID:;SRVR:DBXPR07MB061;
X-MS-Office365-Filtering-Correlation-Id: b0b9a7a7-2dc4-43c4-2528-08d31b3da336
X-Microsoft-Antispam-PRVS: <DBXPR07MB061A8ED2292170497B03CE7A0CA0@DBXPR07MB061.eurprd07.prod.outlook.com>
X-Exchange-Antispam-Report-Test: UriScan:(178726229863574);
X-Exchange-Antispam-Report-CFA-Test: BCL:0; PCL:0; RULEID:(601004)(2401047)(5005006)(520078)(8121501046)(10201501046)(3002001); SRVR:DBXPR07MB061; BCL:0; PCL:0; RULEID:; SRVR:DBXPR07MB061;
X-Microsoft-Exchange-Diagnostics: 1; DBXPR07MB061; 4:C0kTcjzRZLzo/HjZxcG09I13TIOyp029EznFZUVIJA1Ofge9UOFvdt890d7aa+hxiF1n1sHgcXa5KIVpHABbVICsp3pi/DOTRTqbxpQcLlwu9h3yJtPZzqpC20Iyvoz3HvT2Yygk0Jv/CRzLnbq+WWu8LpzfwiroHBvXMtUbCUJLPLSK+8Rmfz9WLElHInJT2Ck2qKROW/yjpBXyI3kMolinB5no+I/y9kcAgSrSER6+GB07Q2DR1plsmdx8qehcfpCWIdwM2n+w8kovkaI5cgj7duiZNd0C0mGbgrURCLso+NTzhYoOdk2ECfJnPRdytS2nlU504if5kVXcOSpiF2oMdj84xIByyakDqe2fZZYTifgh2Q2OkMriXztfS9Qq0+yTjbjS/Jn8+hPsA/DQqRS3JKxFCLmalRdrRftEkBa9Ytlp7g+KxEs7j1nKfeK6
X-Forefront-PRVS: 081904387B
X-Forefront-Antispam-Report: SFV:NSPM; SFS:(10019020)(6009001)(13464003)(377454003)(199003)(189002)(106356001)(5001960100002)(19580395003)(33646002)(47776003)(50466002)(19580405001)(230700001)(61296003)(76176999)(66066001)(1096002)(5008740100001)(81816999)(6116002)(77096005)(44736004)(1456003)(586003)(81686999)(44716002)(2906002)(15975445007)(3846002)(189998001)(50226001)(1556002)(226693001)(62236002)(105586002)(93886004)(97736004)(84392002)(5001770100001)(86362001)(81156007)(116806002)(40100003)(87976001)(14496001)(5004730100002)(92566002)(122386002)(42186005)(101416001)(4326007)(23756003)(50986999)(74416001)(7726001); DIR:OUT; SFP:1102; SCL:1; SRVR:DBXPR07MB061; H:pc6; FPR:; SPF:None; PTR:InfoNoRecords; A:0; MX:1; LANG:en;
Received-SPF: None (protection.outlook.com: btconnect.com does not designate permitted sender hosts)
X-Microsoft-Exchange-Diagnostics: 1; DBXPR07MB061; 23:qpdbG8Uv8jmBd38bH29CkQs2mZZZE6cTMAKAZ4dm9rcMDqytA7W/VDpzayZdDsNq9wH8ZmRWTcmBQFBOHw044MFx4dtkdh9u7nOWgrLXRBgehVBV0DVkFDuBGpgms31aVRyR6yFfh2hPZdn6It3DwuNiqBwUfMxB+VD8MVRMjqfausYiYTyYp/zdFuT6/Z/gE2a4ky89nvnL7uudDYuxgYmky79yMdJk5wcE7Fq6REzKv2Klc8IS1TPMJOLonnghIsnQHTv1fQSL0CzaHyCCjJP09YuuVo+8ON0stQw5B1vvo9OV5zG8EuP/XdQMRZagasPhGLpdBm+yEExi+C0OCNF+zRI69DEeBVwNu4jANUIa0xAIErH6mTBLBf2QXPn49B1xCARIj10523TBGKccmjLNplCKcvjYka+qfjPfq0wqWnHD2FrBSEYzXvHa0DHD7s7A9XQmdgRgOb9FCxW0D28tJbso7pFSNI2EpMdobKq9u6mPDNVqLXcxd6KZ54TlpvvLkHJegrrd5UhuJLELhCFOk6Fcg4g6Id4LOFc8j7do/uSRbqOqy/c2D9u3I5yma79E4OnNl2i1oHwSIInhyzmrwik7POkhT1HYz2ckoso/CIcb00okd0/Pksz6RCKlzdidip9UjLw/6KV63tba5q2Mv4IRt+p8t4kXXE36rgZ4lbT+a86EAqFDXKjnFJKMiepLq9+pslhurHdM3eg2tMSsARZwREAeMP7mKeuod2/8wWVjhNxoH1DM5JwLJcYztu0dzrEYaUynNitiqdLhNe7GoHzn0iE8UC6nK6ZAUb30HVIdFMn/5AKjkOpegCUAQvWJKFotEfMRzxtUTYN4dH7+BkXRm4Mz3J9H4ZudVwMAnUcYgRCocfXZPoJpyKz0hmP/luim/ymow5oeU4rE69K3IVP5lziqopgIHEw9PcpjDvxWtZTX4CdEwALkK4VIB2O5BmgnuE5iwy7Uirqn8dmnDd1fnv3G71TSQaHw1j4Y0jTkoSqRekuPo4FeminH8w7P6u8bcXZD3j+NNwMcgT4BU5YzXDgU7D8DhcCH8TlCSPNbtGJKbnMo1+1Rua4T7GgaFMV1sJQcB8TE/V8K3NJHqPSYnrThyzgL8yvSpCS8R+HR0WeCKWKE2FrPGltfuQMjU1MyJESwBITOzcgYd14xjE69wzGN24QwekpR/lvJ/jdxyUxSFFD+lhz/HrZ9KmtL1hk70+wZw9Yrm/MRNO0CsAtGu+33VZY6809BZ0B6/PuaEJnTSWPw96hyq3optWgGBSSQpQkOA/djUmbE34ClVsIByZnm2mOwvASBEKycczRDZnG7FBSml9EgLqGJte2gXB//BPcQilLGDuR8/voghuC3+ws24Bo8jrSil7M=
X-Microsoft-Exchange-Diagnostics: 1; DBXPR07MB061; 5:Ri6lUhZpbRZ1R/hMP1V5tMEjAvuoFRiBanzzydmI6gutHwXsoOBZ8vJ1uSsPpWOZ1N8ajGcPiaEcbvRY0OOuKCxdOYFXdrGLl91MwtUiD9zuLcfyWIiJG1FfUi8cRg78K8llJdfDGsKKi/yIfzkAcQ==; 24:QtpvxgV4PR1gy5QzwtmDqCQQxSCrfRLKzj3tHs9STXKNdw0/9mCBJ7l1GTDb06UePljreeEbbRPKwjw2BA+Sc8GuGliR7/VnabvLtIzwC1E=
SpamDiagnosticOutput: 1:23
SpamDiagnosticMetadata: NSPM
X-OriginatorOrg: btconnect.com
X-MS-Exchange-CrossTenant-OriginalArrivalTime: 12 Jan 2016 10:46:33.2377 (UTC)
X-MS-Exchange-CrossTenant-FromEntityHeader: Hosted
X-MS-Exchange-Transport-CrossTenantHeadersStamped: DBXPR07MB061
Archived-At: <http://mailarchive.ietf.org/arch/msg/v6ops/wryVpy50xAemFZ8xA5nRfamhRp8>
Cc: v6ops@ietf.org
Subject: Re: [v6ops] Routers are hosts too!
X-BeenThere: v6ops@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: v6ops discussion list <v6ops.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/v6ops>, <mailto:v6ops-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/v6ops/>
List-Post: <mailto:v6ops@ietf.org>
List-Help: <mailto:v6ops-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/v6ops>, <mailto:v6ops-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 12 Jan 2016 10:47:00 -0000
----- Original Message ----- From: <sthaug@nethelp.no> To: <alexandre.petrescu@gmail.com> Cc: <ietfc@btconnect.com>; <v6ops@ietf.org>; <touch@isi.edu> Sent: Sunday, January 10, 2016 2:07 PM > > > But then RFC1122 does not mention classless addressing or Variable > > > Length Subnet Masks - as I recall, they did not exist at that time. > > > Rather, RFC1122 deals with 32 bit Host addresses and Classful Networks, > > > ie 8 or 16 or 24 bit addresses, so while you might have more than one > > > entry in the cache for a given destination, they will all be the same > > > length so the concept of longest-prefix (and of course, the term prefix > > > has no meaning at that date) match does not come into consideration. > > > > DO you mean that the longest-prefix match operation was not there since > > the earliest days of Internet? > > Reading up on the history of the Internet is recommended. See for > instance > > https://en.wikipedia.org/wiki/Classless_Inter-Domain_Routing Well, may be:-) When I got involved with TCP/IP in 1992, subnets were fixed length across any one network and longest match does not figure in any description of routing at that time (Perlman, Interconnections, 1992; IBM, TCP/IP Tutorial, 1989). Before then, subnets did not exist - they first appeared in RFC in 1984 (RFC950, 1985) so routing was purely based on the network address, Class A, B, C. Even in 1992, commercial products may not have had subnet support so when designing an IP network, I had to check vendor literature for subnet support before using it in a design. Variable length subnets meant that the routing protocols had to carry the length of the mask with the advertisement and you see this in RIPv2 (RFC1388, 1993) and this, coupled with CIDR, introduced me to the idea of longest match in the forwarding algorithm. I know of that from RFC1349 (1992) and it will have been around earlier, but not by much - as I say, it would have been alien to most at that time, certainly in the commercial world, as opposed to the more academic/research oriented IETF. Does the history matter? Well yes, if you are citing documents such as RFC written at that time, ones which have not been superseded or updated in that regard, such as RFC1122. Host versus Router is one such, but another is gateway (the term router is relatively recent if you look at the RFC series as a whole) while the definition of the Network layer generates divergent opinions on some IETF list; and then, when did the Internet start? April 1995 is my date, but I recognise that that depends on your definition of Internet. Best practice is to put in, or cite, a definition so others are clear what you (think:-) you are talking about. Tom Petch > Steinar Haug, AS2116
- [v6ops] Routers are hosts too! (Re: I-D Action: d… Mark Smith
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Joe Touch
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Gert Doering
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Jared Mauch
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Gert Doering
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Gert Doering
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Eric Vyncke (evyncke)
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Tim Chown
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Lorenzo Colitti
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Mark Smith
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Joe Touch
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Michael H Lambert
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Joe Touch
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! sthaug
- Re: [v6ops] Routers are hosts too! Jared Mauch
- Re: [v6ops] Routers are hosts too! Jeff McAdams
- Re: [v6ops] Routers are hosts too! Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! Jeff McAdams
- Re: [v6ops] Routers are hosts too! Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! Jeff McAdams
- Re: [v6ops] Routers are hosts too! Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! Templin, Fred L
- Re: [v6ops] Routers are hosts too! Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! Jeff McAdams
- Re: [v6ops] Routers are hosts too! Templin, Fred L
- Re: [v6ops] Routers are hosts too! Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! Jeff McAdams
- Re: [v6ops] Routers are hosts too! Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! Gert Doering
- Re: [v6ops] Routers are hosts too! Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! Joe Touch
- Re: [v6ops] Routers are hosts too! Joe Touch
- Re: [v6ops] Routers are hosts too! t.petch
- Re: [v6ops] Routers are hosts too! Joe Touch
- Re: [v6ops] Routers are hosts too! Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! sthaug
- Re: [v6ops] Routers are hosts too! Joe Touch
- Re: [v6ops] Routers are hosts too! t.petch
- Re: [v6ops] Routers are hosts too! Mark Smith
- Re: [v6ops] Routers are hosts too! Mark Smith
- Re: [v6ops] Routers are hosts too! Warren Kumari
- Re: [v6ops] Routers are hosts too! Nick Hilliard
- Re: [v6ops] Routers are hosts too! sthaug
- Re: [v6ops] Routers are hosts too! t.petch
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Joe Touch
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… joel jaeggli
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Joe Touch
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Niall O'Reilly
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Gert Doering
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Eric Vyncke (evyncke)
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Lorenzo Colitti
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Eric Vyncke (evyncke)
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Lorenzo Colitti
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Gert Doering
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Lorenzo Colitti
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Tim Chown
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Templin, Fred L
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Gert Doering
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Templin, Fred L
- Re: [v6ops] Routers are hosts too! (Re: I-D Actio… Alexandre Petrescu