RE: IDR WG charter
"Abarbanel, Benjamin" <Benjamin.Abarbanel@Marconi.com> Wed, 04 September 2002 15:01 UTC
Received: from trapdoor.merit.edu (postfix@trapdoor.merit.edu [198.108.1.26]) by ietf.org (8.9.1a/8.9.1a) with ESMTP id LAA03627 for <idr-archive@ietf.org>; Wed, 4 Sep 2002 11:01:16 -0400 (EDT)
Received: by trapdoor.merit.edu (Postfix) id D73B991285; Wed, 4 Sep 2002 11:00:03 -0400 (EDT)
Delivered-To: idr-outgoing@trapdoor.merit.edu
Received: by trapdoor.merit.edu (Postfix, from userid 56) id 5244E91284; Wed, 4 Sep 2002 11:00:03 -0400 (EDT)
Delivered-To: idr@trapdoor.merit.edu
Received: from segue.merit.edu (segue.merit.edu [198.108.1.41]) by trapdoor.merit.edu (Postfix) with ESMTP id 6F22591285 for <idr@trapdoor.merit.edu>; Wed, 4 Sep 2002 11:00:00 -0400 (EDT)
Received: by segue.merit.edu (Postfix) id 5ED6D5DEF9; Wed, 4 Sep 2002 11:00:00 -0400 (EDT)
Delivered-To: idr@merit.edu
Received: from mailgate.pit.comms.marconi.com (mailgate.pit.comms.marconi.com [169.144.68.6]) by segue.merit.edu (Postfix) with ESMTP id DC85A5DD90 for <idr@merit.edu>; Wed, 4 Sep 2002 10:59:59 -0400 (EDT)
Received: from mailman.pit.comms.marconi.com (mailman.pit.comms.marconi.com [169.144.2.12]) by mailgate.pit.comms.marconi.com (8.9.3/8.9.3) with ESMTP id KAA29315; Wed, 4 Sep 2002 10:59:57 -0400 (EDT)
Received: from whq-msgrtr-01.pit.comms.marconi.com (whq-msgrtr-01.pit.comms.marconi.com [169.144.2.221]) by mailman.pit.comms.marconi.com (8.9.3/8.9.3) with ESMTP id KAA08755; Wed, 4 Sep 2002 10:59:58 -0400 (EDT)
Received: by whq-msgrtr-01.pit.comms.marconi.com with Internet Mail Service (5.5.2650.21) id <R68QLAZM>; Wed, 4 Sep 2002 10:59:57 -0400
Message-ID: <39469E08BD83D411A3D900204840EC55822831@vie-msgusr-01.dc.fore.com>
From: "Abarbanel, Benjamin" <Benjamin.Abarbanel@Marconi.com>
To: "'raszuk@cisco.com'" <raszuk@cisco.com>, Yakov Rekhter <yakov@juniper.net>
Cc: idr@merit.edu, skh@nexthop.com
Subject: RE: IDR WG charter
Date: Wed, 04 Sep 2002 10:59:55 -0400
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2650.21)
Content-Type: text/plain; charset="iso-8859-1"
Sender: owner-idr@merit.edu
Precedence: bulk
R: I no longer have a copy of that message, could you please quote it in another message? Thanks, Ben > -----Original Message----- > From: Robert Raszuk [mailto:raszuk@cisco.com] > Sent: Wednesday, September 04, 2002 10:55 AM > To: Yakov Rekhter > Cc: idr@merit.edu; skh@nexthop.com > Subject: Re: IDR WG charter > > > > Reject new IDR WG charter proposal. > > As a motivation I could only quote recent Pedro's mail listing very > valid points on Wed, 21 Aug 2002 in the mail to this list. > > R. > > > Yakov Rekhter wrote: > > > > Folks, > > > > So far we received just two e-mail on the subject of the IDR WG > > charter proposed by Bill and Alex. The WG chairs would like to get > > opinion of the WG members on whether the WG should accept the new > > charter, or stay with the existing one. With this in mind, please > > send me an e-mail with either "accept" (means accept the new > > charter), or "reject" (means stay with the existing charter). The > > deadline is Sep 17. > > > > Sue & Yakov. > > ------- Forwarded Message > > > > Date: Mon, 26 Aug 2002 07:18:00 -0700 > > From: Yakov Rekhter <yakov@juniper.net> > > To: idr@merit.edu > > cc: skh@nexthop.com > > Subject: IDR WG charter > > > > Folks, > > > > Please comment on the revised charter proposed by Bill and Alex > > (see below). The deadline for comments is Sep 10, 2002. > > > > Sue & Yakov > > - ------- Forwarded Message > > > > Date: Thu, 22 Aug 2002 16:11:10 -0700 > > From: Bill Fenner <fenner@research.att.com> > > To: idr@merit.edu > > Subject: BGP spec and IDR WG charter > > > > Dear IDR WG, > > > > After some consideration, the Routing Area Directors have decided > > not to forward any IDR documents for IESG consideration until the > > base BGP spec update is finished.[*] Despite the best > efforts of all > > involved, the spec update has been taking an incredible amount of > > time. We take this step in order to focus all possible resources > > of the WG community on the BGP spec update. > > > > This may seem like a negative action. On the contrary, it is > > meant to support the accomplishment of the working group's > goals.[**] > > The milestone for the submission of the BGP4 draft to the IESG > > was scheduled for January 2002. > > > > Attached is a proposed update for the IDR working group charter. > > Note that we just made up the dates in the goals and milestones, > > and the WG should come up with realistic ones. > > > > Bill and Alex > > > > [*] "finished" means, in this case, WG consensus, WG Last Call, > > AD Review, IETF Last Call, and IESG approval for publication. > > > > [**] In further support of the goal of having a quality > specification > > that reflects current reality, the ADs have been working on > assembling > > a team of reviewers that consists primarily of protocol > implementors, > > who have committed their time to examine the spec. We will be > > sending another message to this list explaining the details of how > > this team will do its work. > > > > - - - - - > > > > The Inter-Domain Routing Working Group is chartered to standardize > > and promote the Border Gateway Protocol Version 4 (BGP-4) [RFC > > 1771] capable of supporting policy based routing for TCP/IP > internets. > > The objective is to promote the use of BGP-4 to support IP version > > 4 and IP version 6. The working group will continue to work on > > improving the scalability of BGP. > > > > The current tasks of the WG are limited to: > > > > - - - Revise and clarify the base BGP4 document (RFC 1771). > Note that > > RFC 1771 no longer documents existing practice and one goal of the > > update is document existing practice. Determine whether the document > > can be advanced as full Standard or needs to recycle at Proposed > > or Draft Standard. > > > > - - - Submit updated MIBs to accompany the revised base > BGP4 document. > > > > Once these tasks are completed, work will progress on the following: > > > > - - - Review and Evaluate Existing RFCs on AS > Confederations and Route > > Reflection. If changes are needed, create and advance revisions. > > > > - - - Review RFC 2385 (Protection of BGP via TCP MD5 > signature) to see > > if any changes need to be made based on current Internet practice > > or based on the changes to the current bgp draft. If changes are > > needed, create an revision. Issue the WG Last Call on advancing > > the document to Draft Standard. > > > > - - - Produce an updated MIB for AS Confederations, Route > Reflection, > > Communities, Multi-Protocol BGP, etc.. > > > > - - - Review and evaluate Multiprotocol BGP (RFC 2858) for > advancement > > as Draft Standard. > > > > - - - Complete work on an Extended Community Attribute. Develop MIB > > for BGP Extended Communities. > > > > - - - Extend BGP to support a 4-byte AS number, develop plan for > > transitioning to usage of 4-byte AS numbers > > > > - - - Progress along the IETF standards track a BGP-based mechanism > > that allows a BGP speaker to send to its BGP peer a set of route > > filters that the peer would use to constrain/filter its outbound > > routing updates to the speaker. Currently defined in > > draft-ietf-idr-route-filter-03.txt. > > > > - - - Progress along standards track an Outbound Router Filter (ORF) > > type for BGP, that can be used to perform aspath based route > > filtering. The ORF-type will support aspath based route filtering > > as well as regular expression based matching for address groups. > > Currently defined in draft-ietf-idr-aspath-orf-00.txt. > > > > Tasks for this working group are limited to those listed above; > > new items to be added to the charter must be approved by the IESG. > > > > Goals and Milestones > > > > DONE Submit BGP Capability Advertisement to the IESG > > NOV 02 Submit BGP4 document to IESG. > > DEC 02 Submit updated base BGP4 MIB to IESG. > > MAR 03 Submit extensible BGP MIB to IESG. > > MAR 03 Submit Extended Communities draft to IESG. > > MAR 03 Submit 4-byte AS ID to IESG. > > MAR 03 Initial Draft for RFC2858 (if needed) > > MAR 03 BGP TCP MD5 signatures document to IESG. > > MAR 03 Outbound Route Filter, Prefix and ASpath ORF draft to IESG. > > > > - ------- End of Forwarded Message > > > > ------- End of Forwarded Message >
- IDR WG charter Yakov Rekhter
- Re: IDR WG charter Jeffrey Haas
- Re: IDR WG charter Danny McPherson
- RE: IDR WG charter Abarbanel, Benjamin
- IDR WG charter Yakov Rekhter
- Re: IDR WG charter Russ White
- Re: IDR WG charter Russ White
- accept Randy Bush
- Re: IDR WG charter Jeffrey Haas
- Re: IDR WG charter Robert Raszuk
- RE: IDR WG charter Abarbanel, Benjamin
- RE: IDR WG charter Natale, Jonathan
- RE: IDR WG charter Abarbanel, Benjamin
- Re: IDR WG charter Alex Zinin
- Re: IDR WG charter Jeffrey Haas
- Re: IDR WG charter Jeffrey Haas
- Re: IDR WG charter Tom Petch
- RE: IDR WG charter Bill Fenner
- Re: IDR WG charter andrewl
- RE: IDR WG charter Abarbanel, Benjamin
- RE: IDR WG charter Abarbanel, Benjamin
- Re: IDR WG charter Alex Zinin
- RE: IDR WG charter Abarbanel, Benjamin
- Re: IDR WG charter Alex Zinin
- RE: IDR WG charter Bill Fenner
- RE: IDR WG charter Abarbanel, Benjamin
- Re: IDR WG charter Robert Raszuk
- RE: IDR WG charter Abarbanel, Benjamin
- RE: IDR WG charter Randy Bush
- RE: IDR WG charter Abarbanel, Benjamin
- Re: IDR WG charter Jeffrey Haas
- RE: IDR WG charter Abarbanel, Benjamin
- IDR WG charter Yakov Rekhter
- Re: IDR WG charter Randy Bush
- RE: IDR WG charter Gray, Eric
- Re: IDR WG charter Yakov Rekhter
- Re: IDR WG charter Jeffrey Haas
- RE: IDR WG charter Gray, Eric
- Re: IDR WG charter Jeffrey Haas
- RE: IDR WG charter Sivananda Ramnath
- Re: IDR WG charter Mathew Richardson
- Re: IDR WG charter Jeffrey Haas