[OPSAWG]TACACS+ TLS Resumption and PSK.

"Douglas Gash (dcmgash)" <dcmgash@cisco.com> Mon, 28 October 2024 11:52 UTC

Return-Path: <dcmgash@cisco.com>
X-Original-To: opsawg@ietfa.amsl.com
Delivered-To: opsawg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 04512C14CE45 for <opsawg@ietfa.amsl.com>; Mon, 28 Oct 2024 04:52:03 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -12.042
X-Spam-Level:
X-Spam-Status: No, score=-12.042 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.148, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_NONE=0.001, T_SCC_BODY_TEXT_LINE=-0.01, T_SPF_HELO_PERMERROR=0.01, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=cisco.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id hU-lTG8wc5KF for <opsawg@ietfa.amsl.com>; Mon, 28 Oct 2024 04:51:59 -0700 (PDT)
Received: from rcdn-iport-1.cisco.com (rcdn-iport-1.cisco.com [173.37.86.72]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 1DEA1C14F5EE for <opsawg@ietf.org>; Mon, 28 Oct 2024 04:51:59 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=38622; q=dns/txt; s=iport; t=1730116319; x=1731325919; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=9qw6qHdFj/NMojTQXT8pimwOTEKL2m3eS9FR/bWkDrc=; b=b9z7Uqebzg3phNLQ/RcWPLiYGPc7Luj3j563nWtdnlIwvUTwSD61yzIs L3610CEGmsppTphpxtxj+K9zipgGAOb3jXGYJTo1luFfMfkDR2ieN6lw5 Ts60SLrEBn9M7LMVqYVjRyhihYfpxz1JFtOMWNQtS53JHv1VOYPUVsF0J Y=;
X-CSE-ConnectionGUID: S7GcBk3rQEiM506NFWm5Hg==
X-CSE-MsgGUID: 0M2uCVtsTgOD9xVi//irng==
X-IPAS-Result: A0ArAADeeR9n/47/Ja1RCRwBAQEBAQEHAQESAQEEBAEBQCWBGgcBAQsBgUAxKigHdAKBHEiIIQOETl+IcgOLYoVmjE0UgREDVg8BAQENAQE7CQQBAYIqAYJcAoomAiY0CQ4BAgQBAQEBAwIDAQEBAQEBAQEBDQEBBQEBAQIBBwWBDhOFew2GWgEBAQECAQ4EGzgUBQsCARkDAQIWCwENIBEdCAIEAQ0FCBqCWgQCJYF3FAMOIwMBEAaiDgGBQAKKKniBNIEB3ToDCoJYgUgBhH+DLh4BKoEyhEiEPCcbgg2BFUKFRUICAoEXDQ4SAgYUBQcSGAYBg1aCLwSCLSRHVIJKDhOCX3olgRqDS4IigQuBDYQBgygYigKBRyIDJjMhARABVRMXCwcFgT5BA4FagidtgVqBO4FTR4EWgVAvGyELXIFAgRwUBhUEgRGBATmCFGlLOgINAjaCJCRZglCHHh1AAwttPTUGDhsFBIE1BZkgATZ5AUaBdAUgSwECLBAmAQMNIgMRDgIgAmMLPR5BETqSUCSDFYwGR44QlB5xCoQaijWBYY80hisXhASBVqQMZAGYdyKCNI8tkVIZBYUEAgQCBAUCDwEBBoFnPA2BTHAVgyIJSRkPji4Vg1iFFMcueAI5AgcLAQEDCY9bKnNgAQE
IronPort-PHdr: A9a23:qeNXfBIXuC7yA0BOw9mcuVQyDhhOgF28FhQe5pxijKpBbeH5uZ/jJ 0fYo/5qiQyBUYba7qdcgvHN++D7WGMG6Iqcqn1KbpFWVhEEhMlX1wwtCcKIEwv6edbhbjcxG 4JJU1oNwg==
IronPort-Data: A9a23:n0hQYq0CSYDWj9gJZfbD5ZJwkn2cJEfYwER7XKvMYLTBsI5bp2EOn zceWGDQM62OYDH2fI1yOdy18xgEvsKEmIdiHlNp3Hw8FHgiRegpqji6wuYcGwvIc6UvmWo+t 512huHodZ1yEzmG4E/0YtANlFEkvYmQXL3wFeXYDS54QA5gWU8JhAlq8wIDqtYAbeORXUXU4 Lsen+WFYAX5gmYuYjpOg06+gEoHUMra6WtwUmMWPZinjHeG/1EJAZQWI72GLneQauF8Au6gS u/f+6qy92Xf8g1FIovNfmHTKxBirhb6ZGBiu1IOM0SQqkEqSh8ajs7XAMEhhXJ/0F1lqTzeJ OJl7vRcQS9xVkHFdX90vxNwS0mSNoUekFPLzOTWXcG7lyX7n3XQL/pGNx4ZNqcbofxOLGBrq KRGDh4ya02jiLfjqF67YrEEasULNsLnOsYb/3pn1zycVatgSpHYSKKM7thdtNsyrpkRRrCFO IxDNGcpNUiaC/FMEg9/5JYWkOytiXDkcxVTqUmeouw85G27IAlZiue8b4SIJI3VLSlTth69/ H/twXjiPh49GI2P9zvCtXO2gOCayEsXX6pXTtVU7MVCh0WIz3McIBwbSVX9puO24nNSQPpFI EASvy5rpq8o+QnzE5/2XgazpziPuRt0t8dsLtDWITqlk8L8yw2YHWMDCDVGbbQbWAUeHFTGC nfhcwvVOAFS
IronPort-HdrOrdr: A9a23:BSret6lc3x7zd2woTidke1TRD7LpDfNRiWdD5ihNYBxZY6Wkfp +V7ZcmPE7P6Ar5BktApTnZAtj/fZq9z/JICYl4B8bFYOCUghrYEGgC1/qs/9SOIVyFygcw79 YFT0E6MqyOMbEYt7e13ODbKadc/DDvysnB7omurQYJcegpUdAd0+4TMHfjLqQCfng8OXNPLu vl2iMonUvGRV0nKu6AKj0uWe/Fq9fXlJTgTyInKnccgjWmvHeD0pK/NwKX8Cs/flp0rIvK91 KrryXJooGY992rwB7V0GHeq75MnsH699dFDMuQzuAINzTFkG+TFcRccozHmApwjPCk6V4snt WJiQwnJd5P53TYeXzwiQfx2jPnzC0l5xbZuBylaDrY0I7ErQABeo58bLFiA1zkAo0bzZdBOZ dwriekXlxsfEr9dWrGloD1vlpR5zqJSDIZ4J0uZjpkIMojgHs7l/1EwKuTe61wRx7S+cQpFv JjA9rb4+sTeVSGb2rBtm0q29C0WG8vdy32CHTql/blmwS+pkoJhHcw1YgahDMN5Zg9Q55L66 DNNblpjqhHSosTYbhmDOkMTMOrAiiVKCi8fF66MBDiDuUKKnjNo5n47PE84/yrYoUByN83lI 7aWF1VuGYucwblCNGI3pdM7hfRKV/NEAjF24Vb/dx0q7f8TL3kPWmKT00vidKpp7EFDsjSS5 +ISdtr6j/YXB3T8KpyrnrDssNpWAwjedxQvsx+QF6HqN/KLIrx39arAso7DICdZQoZZg==
X-Talos-CUID: 9a23:2+AJm2mBJOruDimxgfNd4fklSV/XOUaC43z6IBSiMEtobeDNF3m+x6Y5s8U7zg==
X-Talos-MUID: 9a23:N53kQwSfC1VSk3VTRXS0oWt/H/l0+JihL2xcgasH/I6FLyp/bmI=
X-IronPort-Anti-Spam-Filtered: true
Received: from rcdn-l-core-05.cisco.com ([173.37.255.142]) by rcdn-iport-1.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 28 Oct 2024 11:51:57 +0000
Received: from rcdn-opgw-2.cisco.com (rcdn-opgw-2.cisco.com [72.163.7.163]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by rcdn-l-core-05.cisco.com (Postfix) with ESMTPS id D0DA61800021A for <opsawg@ietf.org>; Mon, 28 Oct 2024 11:51:57 +0000 (GMT)
X-CSE-ConnectionGUID: 29UOf5vnSTa12Zkbj7EZLw==
X-CSE-MsgGUID: EuEcuv5kTCy0mjH0E4aQdw==
Authentication-Results: rcdn-opgw-2.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.11,239,1725321600"; d="scan'208,217";a="23640699"
Received: from mail-dm6nam11lp2175.outbound.protection.outlook.com (HELO NAM11-DM6-obe.outbound.protection.outlook.com) ([104.47.57.175]) by rcdn-opgw-2.cisco.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 28 Oct 2024 11:51:57 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=XPNoXUnbuBWTaTsHtB4MNMyst7DMC8abRBQL74uYXlHsvNXztXhNoN/gStb5B9Itbk8uTwBHdR7v/cQNL+XVxqcObUc7Y/qC8m3KWc3VNk1ppjer/lluNcr8hLDU+GB5t4pcHSQfzxXSTJpwaBG2V23jdbvwhtGZ/yIb3cIhHvX0LQb72v9M6zUiLs8+y5aIg+k7w9YjBtP2mZNcc6L+sxjN8eDwIry+5fJsRnB3Tzlc8UzMZ8hjbfDcPBK4cote4o84ibsHG1F0sH/ej+uoyNoUxYcxmPMmyaCiQ60o2YbRqvaD9FRnkMZnpPe9gtloJnhyygHb92rudVNs+rQ6OQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=9qw6qHdFj/NMojTQXT8pimwOTEKL2m3eS9FR/bWkDrc=; b=XKTz9cZFVg6mmeaQVxE4HkaYDVbUIN0XIo8u45DHh8UgUPCIwR6s5WkPTf3kCfGg+OZLsCL0RGXkODHhWpJKDbi0KCtPCrTddMa0qcC+dhhRktxeYv5QxVNHiGe8HMpGKeX8LzRDECJaNlJ44lgcTsqWEjd1reV20LSO+gSj3UJ3jksRMFJZZKxfAiHPZUhpU3AstsH26Q/0Y7lpiBIA5DRD2Ob8nD5NDCm2Of78cORKrSQupt228OJ7lQFPUfb3VifWpTNbupi8fFy0jFk48xazlMKurG1fzdnPBFS2x/6rBJ5xLbhoqe6lDa9hhgfAB9h5eUlUHJ/jTTLELRp4/g==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from DM4PR11MB6384.namprd11.prod.outlook.com (2603:10b6:8:8a::11) by PH0PR11MB7445.namprd11.prod.outlook.com (2603:10b6:510:26e::13) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.8093.24; Mon, 28 Oct 2024 11:51:53 +0000
Received: from DM4PR11MB6384.namprd11.prod.outlook.com ([fe80::4991:900e:34ae:148e]) by DM4PR11MB6384.namprd11.prod.outlook.com ([fe80::4991:900e:34ae:148e%5]) with mapi id 15.20.8093.024; Mon, 28 Oct 2024 11:51:53 +0000
From: "Douglas Gash (dcmgash)" <dcmgash@cisco.com>
To: "mohamed.boucadair@orange.com" <mohamed.boucadair@orange.com>, "Joe Clarke (jclarke)" <jclarke@cisco.com>, Alan DeKok <aland@deployingradius.com>, "opsawg@ietf.org" <opsawg@ietf.org>
Thread-Topic: TACACS+ TLS Resumption and PSK.
Thread-Index: AQHbKS/Hp7tzzB0CBkKzlOyK3bZdow==
Date: Mon, 28 Oct 2024 11:51:53 +0000
Message-ID: <DM4PR11MB63847CDF57DDB71FA34B1A64B74A2@DM4PR11MB6384.namprd11.prod.outlook.com>
References: <171958741031.6614.6192371628253402915@ietfa.amsl.com> <BL3PR11MB636498065CA94698B937E5CCB7DF2@BL3PR11MB6364.namprd11.prod.outlook.com> <BL3PR11MB63647995AABAED8113F9DDBFB7DA2@BL3PR11MB6364.namprd11.prod.outlook.com>
In-Reply-To: <BL3PR11MB63647995AABAED8113F9DDBFB7DA2@BL3PR11MB6364.namprd11.prod.outlook.com>
Accept-Language: en-GB, en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: DM4PR11MB6384:EE_|PH0PR11MB7445:EE_
x-ms-office365-filtering-correlation-id: 9a9b5ef0-4daf-45a5-c923-08dcf746ea6a
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|376014|366016|10070799003|8096899003|38070700018;
x-microsoft-antispam-message-info: XISTeeD0WPXeMIFH0nxGfnwfKjJQm68xkXw9tySYqaYYRASizk5gveaJkNGVFDjHfSOnGh8fCTox63Ck+joUKsTSNMO/J/wVwcvsF+wtRhn0DaJKprjWYRNTWJRULpmWIN74xyr5CuaFCNW8ODuAWb8UeGRqUZc4kt5kiiSmGD5B3GnaRhCMHsizmGvyoEfDrZgSNER2wqRhPdi0BgK10tecN92lDpSWpAUOj+rDvICVclRIAwEVdbywuvQBCF39Sz8mbxmKLQBvwfPugr25LEpC6114SBRILrovA40vhWQvIRjZZvcnws3by8PcwraFd/xj9JhuwaJ2XkJ4kp66MwFz5R+jej7TLv1mHFXV8k1cMyYXd7qYGJrfeowqArTH2DEh5Yn7Qgm4CpZjbeorx01vpGBX4E2JPK6/XyB2EJJDVJnseOU6FYLN831TGebcQfEkRoZBoARgULZ5cQ8z+6z5HPgUhPLGeep1rWGD4d77W8wRp76BwBfQ9hwX161jP/ofYCBvHFjrfSS1WV7SnvVLQyHg0+77PJBeN+obXI0EQ/uBBYu42i4+CcEIUqmLvidGotlulL/DZlCdKzsLaaLUFAucmbCF5ymXtUkqSB855fQADSyLkmWO55BjFaKxpn9k2Y0tClru47g/2C9FQe5X2cII3WGivo9fEo74SwZXP8DHtQn5z9FhD9klKAEfUl6QhncqCyybZpsw3E1azrTBdy88fjtCTn7VXuJzHxccl7Q66F3BnjOAjxnx+XRYjK6rtCtmuRKnGdhFJ9tvdrP09oVb18gPfRn1VHu7AScf4Gm5YPsP3za5FbqrsmawM4TB+kP79cYTziPw/pj2Lhd5dOIKLmp2m/Mf4X4MgL1ZvN+7pHPhJ65wdgn+6zkPxDaKMCVC6pGcIjvIjXj0scF96WpUohDdcpAz8I+0bcmTg8i6sfRyoC700ZzRq2wDix/Qqj43ryk3HpDNxMqGao0jZAGbH14i3jNI//+TUkdqWoP/rkEtYWqJHW+UfWoHIiBbeNrOuIy7EyBDBjLcvAgSAVrwiaBCXFzA9fr0/T0SnOgK42K0QOzaDg6HGB5N76KpQZHZZpGAhvc/QQEOOBaRAfAAXWuVWBshp6oap1J+mKMBs2/zu+bw1Dokg/IA4NG/jd3naWb3EyXAmtjEuc5TvXHolplDItUO+8Gq2BTntehskL6dyVb3jU2FbYzpoFEygwxbN0iAa4EytkBHkBU5KJSLwNkFsuGIB73kdASKy/8lEQrozBgIDENfrg1y04dLEN+g44tq/jFJ4o841iZN5x6U31BvygrQkVHp33SLiulBZ6VL/XCJwSEX9QOhbNWEHcpl0CR+vRgpzj13FHV7EVAJxdY2UjLQ68dkFv2lAkOKSsS/9G/t9au3yX4z
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:DM4PR11MB6384.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(376014)(366016)(10070799003)(8096899003)(38070700018);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: HqaqzPcDos9Xho7/QnPRWlizIdkLKxySg0akfh/ipUM6O5801q1hHLlGfslzEW6+Tt2MeMvq2H7owonlToVtJrUeM4Lr60eky1vkCqnKR0awaNu69r0/vXdfGa44KQyqQVQ9DjD5DNPgV//6OZhHJWnzXkgWzm3uD43e8Dw/SDEt2HIfaG+uhHyy0ZOkzQWo8QqXXysHbstRCGq96Al+ke518EMx4TsiF03Oz91wr0CgsmZup6lddaxPpmYaWeq1JyrHCA0JWY7wJCkK2dUZTU1w5snrTQGnb1Y2XWWv36+SGjizgcQpmJKJ2FQ3gVI5U+lgkEjLDasVYtqtZx+UxaewM9GaEoPdE2pw4GBW35kikWqGyqdE63PbGNOHYO4Lf9Z3UhfhKevDhRsVv4rcx+OlOAU1fxLW/7PhfnIyiZIaQSVR7rKhgwLhGqWwzQ2QYvKYT1fb28V44K7cKA4LdYUcYBtQj3mvnMCL5rHsCAdzL3dydSJAsbVStXsY0wzUPlZuq0T+b+wX1vi6e6JeuQciLNjCAcGYeFm6IsMTbC2Qx7YBdFkxRp9ahs0VDQxt0MBB4+CkqPJxQGj00vtSvaPO7gVCjB0PqiaMvRfl3Nva1T7MerqydWhs+nwPNCQhcNdofKFEQDM7ndwsy9zSoUXme4Ab0lQoyWXFLwTRxHc/+OOxPdJkSjsvZjYB16SF0X/o+xHUAVLEj8r81cMOyXHkxUjobxBAw5+RXkt8KZkJkFX/a523LNLKLru8u0e1v55bLGBtBd90xYEQ3VqhdnEFshUxNXGlJpp8feBkpKcHZOZ4/h11tEv0lcpJlZSLUQmE93L6O90CzbnS8yF7xaSAv4cCfZVP3n2IVrAGW+SIKWrjSBsx+Kh5GB+i/YdDbxfqwOXhK6wUnpE8Ci4qocaAllFJhK7un/LpwUz8Rk4sEHzMKaEEG99Jy1y0AfK3wGAMY8YS+Pm8gGmV98MI6TbgNmgXbm1E20yLAF434GA0s3Cxoi23RCLuREbU+Le8LCO9/IUW3DpsozHJ1UmGeCxy/Iwyd3GhyVkMZWURA4tD5poFg5Mc3/8YK826wlMXatHBUrdp9yLTS9O0oIlF6yKtrYRLB5+OtuIAfCHbqWNEnIXYbzkDEtp1nZLr6W8UAlfRRjpaLQ5Esad6uslL2lR3yq5YPEKnl2aJ7s/jxN+JtwxXgV+AwvZ7kULsmP07PfYJ44nRDPf6GYAyA3ff4WBA0/nwdM4VFYuTbZ5eZupToiB5bA9jMzivW2BWHHjyZYMn4MP3cTPDe+lT5c1PIeNShiI4V+PQPAV5GVun/NXk90oRhCaiCRCS9LWmJyFcFbJwJXrWmHrowTThrtUpfAjOKHwhGcVK/4bTBgAjJbTBli6l0gmiOdiWm/t8/rb6F/BSlIHraeiAdEjw43h3y4D9R7FTi2+gnT7TrtXx+92GcKiYz1MqiR8cJhuo/7alB0swvMYtUyOTkw2upbcWvNERv5fXWqToBf90DRnXuK6j/BLQpdqC2u/Dsa+UUes3n8MnhdfjqsQy3GXnmTEU7jBr3m39am+J8I8ft99GHpJ99JhE5l1J1G4n02IDSnRHCUPSrx4bnnomMi4RLKHmkMrU4LavTknJdGyk1lS7pd+Vurs2WjaZWNADTMlDDsSxi+CxkhoeWQ49Ip65buQhyQ==
Content-Type: multipart/alternative; boundary="_000_DM4PR11MB63847CDF57DDB71FA34B1A64B74A2DM4PR11MB6384namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: DM4PR11MB6384.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 9a9b5ef0-4daf-45a5-c923-08dcf746ea6a
X-MS-Exchange-CrossTenant-originalarrivaltime: 28 Oct 2024 11:51:53.2099 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: mhMiDrJvpMVPuFP699KW/TQp1dZIKmEU7c2vf8QssPwFLunTgM6+ySQOLF4KwNdHEE+q19YvwWFEzpQNQng24w==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: PH0PR11MB7445
X-Outbound-SMTP-Client: 72.163.7.163, rcdn-opgw-2.cisco.com
X-Outbound-Node: rcdn-l-core-05.cisco.com
Message-ID-Hash: DZKM6G333GS7INGCVCO2U4KESHSNX5ON
X-Message-ID-Hash: DZKM6G333GS7INGCVCO2U4KESHSNX5ON
X-MailFrom: dcmgash@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-opsawg.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: John Heasly <heas@shrubbery.net>, Andrej Ota <andrej@ota.si>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [OPSAWG]TACACS+ TLS Resumption and PSK.
List-Id: OPSA Working Group Mail List <opsawg.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/opsawg/Z9M-dLojfMjmX1n29Ri1EYYWP4w>
List-Archive: <https://mailarchive.ietf.org/arch/browse/opsawg>
List-Help: <mailto:opsawg-request@ietf.org?subject=help>
List-Owner: <mailto:opsawg-owner@ietf.org>
List-Post: <mailto:opsawg@ietf.org>
List-Subscribe: <mailto:opsawg-join@ietf.org>
List-Unsubscribe: <mailto:opsawg-leave@ietf.org>

Dear Alan, Opsawg et al,

Rev 11 of the T+ TLS doc had new sections for PSK and resumption, with a slight restructure to accommodate PKI and PSK in regular hierarchy in the contents.

We are currently preparing another rev of the doc, so would be very grateful for any feedback to ensure the previous paucity of coverage of these subjects was sufficiently remedied. If not, now would be ideal time for us to address any remaining concerns in this (or any other) area.

Many thanks!

From: Douglas Gash (dcmgash) <dcmgash@cisco.com>
Date: Monday, 8 July 2024 at 09:48
To: mohamed.boucadair@orange.com <mohamed.boucadair@orange.com>, Joe Clarke (jclarke) <jclarke@cisco.com>, Alan DeKok <aland@deployingradius.com>, opsawg@ietf.org <opsawg@ietf.org>
Cc: Thorsten Dahm <thorsten.dahm@gmail.com>, John Heasly <heas@shrubbery.net>, Andrej Ota <andrej@ota.si>
Subject: Re: OPSAWG Digest, Vol 205, Issue 20
Dear Opsawg et al,

1) Discussion on External  PSK (Related to part of Mohamed’s point 2 below).

Our distillation of the thrust of Alan’s main advice is: The doc needs to either commit to fully documenting external PSK and its ramifications or preclude it. The truth is, our doc merely  says: TLS T+ implementations may support External PSK, and leaves it there.

Background: as this doc has evolved, we have temporized on the topic for the first TLS version of T+. On one side: we were not convinced External PSKs are quite established in TLS 1.3. On the other side they would be very useful for operators. But now  It seems that PSKs have become better established, through the work of Alan et al, so we may consider to document use of External for this initial doc, rather than adding later supplement to cover external PSK. It does mean through that there may be another round or two to bring in the needed details.

So now would be a good point to gauge the opinion of the group. Based upon where the doc is in the process, and what changes should be applied to it at this time::

1) Should we revert the doc to say:  “External PSK should not be used now.  A supplement will follow to address how PSK can be used properly”
Or
2) Keep the option for External PSKs to be used as now, and Commit to a few rounds of revisions to document to fully flesh out its support.

Authors would be happy either way, probably on balance we would prefer second option,



If we went for option 2), then below is an outline of the responses which we believe would cover External PSK:



Note: “RADIUS and TLS-PSK” Provides a wealth of recommendations on PSKs.



1.      a new section will be added specific to PSKs  include the following items, mainly  gleaned from “RADIUS and TLS-PSK”, (note that TLS 1.2 related issues have been filtered out)

General:

It is RECOMMENDED that systems follow the directions of [RFC9257<https://www.ietf.org/archive/id/draft-dekok-radext-tls-psk-01.html#RFC9257>] Section 4

PSK length recommendations for both implementation and operations

Fortunately, as we have already removed the MD5 obfuscation,  we do not have issues in sharing Shared secrets and PSKs
PSK Identity:

RFC9257<https://www.ietf.org/archive/id/draft-dekok-radext-tls-psk-01.html#RFC9257> 6.1 to be used for PSK  identities

PSK Identity length recommendations for both implementations and operations.
Per Client Sharing

PSK must be unique per client as configured on server

PSK Identities must be unique per client as configured on server

(Of course references will be updated to acknowledge this doc)


2.      The Tacacss draft doc mentions identity specifically in the context of Certificates. This will be clarified that it applies only to certificate based, and for PSK it has its own guidance as above.


The following changes are not directly related to External PSK and will be resolved anyway:

2) Resumption elements from RFC9190 (Related to the balance of Mohamed’s point 2 below).

References from RFC9190. The doc primarily adresses the use of TLS as an EAP option, which has extra concerns as it is used for authorization information. The concerns that were apprehended form the text are listed below with our  evaluation of relevance when used for the tacacss security wrapper.


Authorization on resumption mased on cached data rather than the data in the resumption:

Regarded: Not Relevant as the data is not used for authorization for tacacss

Verification of certificates revoked during the period since the last “New Session Ticket Message”

Regarded: Relevant, and we will update. RFC 8446 is not silent on this topic, so we will prefer to cover this by  refererence to section 4.6.1 which says:

         Note that in principle it is possible to continue issuing new tickets
               which indefinitely extend the lifetime of the keying material
               originally derived from an initial non-PSK handshake (which was most
               likely tied to the peer's certificate).  It is RECOMMENDED that
               implementations place limits on the total lifetime of such keying

         material; these limits should take into account the lifetime of the
               peer's certificate, the likelihood of intervening revocation, and the
               time since the peer's online CertificateVerify signature.


Maximum lifetime:

Regarded Relevant, we will update by reference to its coveragein RFC 8446

“time-of-check time-of-use” issues

Regarded: Not Relevant as the data is not used for authorization for tacacss

Re evaluation of authorization on resumption:

Regarded: Not Relevant as the data is not used for authorization for tacacss


3) Regarding 3) below, thanks for the catch, We’re proposing the following change:

Current:

   To ensure separation of TACACS+ traffic that uses TLS from that which
   does not (Section 5.3), they will be deployed on different ports.
   Due to the widespread use of default port number settings in numerous
   existing TACACS+ client configurations, a well-known system TCP/IP
   port number will be requested from IANA.  Client implementations can
   ensure traffic is kept separate.  The designated port number is [TBD]
   (Section 7) with the service name [TBDN] (Section 7).

Proposal:

   To ensure separation of TACACS+ traffic that uses TLS from that which
   does not (Section 5.3), they must be deployed on different server ports.
   Further, because of the widespread use of default port number
   settings in numerous existing TACACS+ client configurations, a well-
   known system TCP/IP port number is assigned: the designated port
   number is [TBD] (Section 7) with the service name [TBDN] (Section 7).
   This way the client can ensure that TLS and non TLS traffic are
   separated even where default ports are omitted from its server connection
   configuration.




Date: Fri, 28 Jun 2024 13:36:42 +0000
From: mohamed.boucadair@orange.com
Subject: [OPSAWG]Re: WG LC: draft-ietf-opsawg-tacacs-tls13
To: Alan DeKok <aland@deployingradius.com>, "opsawg@ietf.org"
        <opsawg@ietf.org>
Cc: "uta@ietf.org" <uta@ietf.org>, "Joe Clarke (jclarke)"
        <jclarke=40cisco.com@dmarc.ietf.org>
Message-ID: <DU2PR02MB10160C69E1AF8E95168D5CC6A88D02@DU2PR02MB10160.eu
        rprd02.prod.outlook.com>
Content-Type: text/plain; charset="iso-8859-1"

Hi all,

FWIW, we had an offline discussion with Alan and the authors to clarify the concerns.

I'm reporting the main outcome of that discussion, fwiw:

(1) Alan  agreed that:

* It is good practice to leverage existing standards
* Repeating details isn't useful

(2) Still, the key comment from Alan is:

>   My point was that the RFCs I referenced had substantial text over
> and above 8446 / 9525.  I asked that the authors double- check the
> documents I mentioned, to see how these issues were addressed.  The
> result was a few minor changes.

The shepherd agrees that this is a reasonable comment that should be adequately addressed.

The authors engaged to have a look into the various RFCs cited by Alan and grab applicable items to tacacs+ context. It would be helpful to share the rationale for the items that they picked vs. those they considered as not relevant.

(3) As a bonus, Alan provided the following comments and summary

==
Some grammar / clarity comments:


Section 3.1:
...
To ensure separation of TACACS+ traffic that uses TLS from that which does not (Section 5.3), they will be deployed on different ports. Due to the widespread use of default port number settings in numerous existing TACACS+ client configurations, a well-known system TCP/IP port number will be requested from IANA ...

  The text is ambiguous: "will" be requested?  When?  Does this document allocate the port?

  The usual text is to say "port TBD has been assigned for this protocol".


 In short:  I'm not objecting to the publication of this document.  My concern is that it doesn't give a lot of guidance to implementing TACACS+ over TLS.  I can see basic implementations working, just by wrapping TACACS+ in TLS.  But the operational considerations outlined above will have to be discovered piece-meal by implementors.
==


Cheers,
Med
***************************************