[Tvr] Re: [iesg] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)

mohamed.boucadair@orange.com Wed, 10 June 2026 06:44 UTC

Return-Path: <mohamed.boucadair@orange.com>
X-Original-To: tvr@mail2.ietf.org
Delivered-To: tvr@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id A7F9BFE7F46D; Tue, 9 Jun 2026 23:44:18 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1781073858; bh=BK3fhou98DMsCcaFHYvo7H/eavJ+E4YUjlslJmaNN18=; h=From:To:CC:Subject:Date:References:In-Reply-To; b=Bth9aGYrq2flKu07Rg6gfEwYNfjAuUrzcOuI6czgQMTNbzqx8tV9SwmiKatiimnxe wrLlcM9D16wAdxJdpdTBhUjCY8CuUu+s05ZFWbGJeJl0b9d1KKRZny40+4a80HdHyd HzPrwIczJrpwOLF1CeX9qoU5MRUf6BSh2ChVOs7g=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.793
X-Spam-Level:
X-Spam-Status: No, score=-2.793 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_NONE=0.001, UNPARSEABLE_RELAY=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=orange.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id EWdYvS_wxqUm; Tue, 9 Jun 2026 23:44:15 -0700 (PDT)
Received: from smtp-out.orange.com (smtp-out.orange.com [80.12.210.124]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 18876FE7F460; Tue, 9 Jun 2026 23:44:14 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=orange.com; i=@orange.com; q=dns/txt; s=orange002; t=1781073854; x=1812609854; h=to:cc:subject:date:message-id:references:in-reply-to: mime-version:from; bh=BK3fhou98DMsCcaFHYvo7H/eavJ+E4YUjlslJmaNN18=; b=HTGbRkvdhsuF8USKQjPhzdpeu9cmsb80T8bePMXcOmhekZwuQPHV6oUq /pJPTBhlNwfaQE8hAH0gtXiLMX4gtSvMxaevq2PFK0dYeRDeFowb2bX5R oeQe3mTG+nNsyX43MpfRCmPDae3fWYB1IxSfOhtflg2UcArGfWhrabtKW 6/xYUQwclngxDlcAXxfqC7BRGafq3gPDORC/4RbaNhJtB69Ob4RDwNebC AB1XxHeDmv7KlTf3NTf/tyz3JsqNxfK/gWfoZ1k29/GHsJvgcYUvlmdEK YRv446dJYCy8MQZuEbEKDV99fhqp0xbvCIVSV3/SykR6qegHb2bhqgnJg g==;
X-CSE-ConnectionGUID: y+0M6GJQRniBu3cQ3mhy1Q==
X-CSE-MsgGUID: T2WVyxd5TCa+SQif6NVU+Q==
Received: from unknown (HELO opfedv3rlp0b.nor.fr.ftgroup) ([x.x.x.x]) by smtp-out.orange.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 10 Jun 2026 08:44:07 +0200
Received: from unknown (HELO opzinddimail15.si.fr.intraorange) ([x.x.x.x]) by opfedv3rlp0b.nor.fr.ftgroup with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 10 Jun 2026 08:44:07 +0200
Received: from opzinddimail15.si.fr.intraorange (unknown [127.0.0.1]) by DDEI (Postfix) with ESMTP id AEC561E41A0E; Wed, 10 Jun 2026 08:44:00 +0200 (CEST)
Received: from opzinddimail15.si.fr.intraorange (unknown [127.0.0.1]) by DDEI (Postfix) with ESMTP id 9D95F1E42A85; Wed, 10 Jun 2026 08:44:00 +0200 (CEST)
Received: from smtp-out365.orange.com (unknown [x.x.x.x]) by opzinddimail15.si.fr.intraorange (Postfix) with ESMTPS; Wed, 10 Jun 2026 08:44:00 +0200 (CEST)
Received: from mail-francecentralazlp17012049.outbound.protection.outlook.com (HELO PR0P264CU014.outbound.protection.outlook.com) ([40.93.76.49]) by smtp-out365.orange.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 10 Jun 2026 08:44:00 +0200
Received: from PATP264MB6765.FRAP264.PROD.OUTLOOK.COM (2603:10a6:102:533::11) by MRZP264MB3225.FRAP264.PROD.OUTLOOK.COM (2603:10a6:501:1a::18) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.113.11; Wed, 10 Jun 2026 06:43:57 +0000
Received: from PATP264MB6765.FRAP264.PROD.OUTLOOK.COM ([fe80::fcc8:341e:f80e:de16]) by PATP264MB6765.FRAP264.PROD.OUTLOOK.COM ([fe80::fcc8:341e:f80e:de16%4]) with mapi id 15.21.0092.011; Wed, 10 Jun 2026 06:43:56 +0000
From: mohamed.boucadair@orange.com
X-CSE-ConnectionGUID: pEjWAZkCTmSwm7S0ZpgBDg==
X-CSE-MsgGUID: BhhJ6a3jT4icSvfQKClQEw==
X-TM-AS-ERS: 10.106.160.156-127.5.254.253
X-TM-AS-SMTP: 1.0 c210cC1vdXQzNjUub3JhbmdlLmNvbQ== bW9oYW1lZC5ib3VjYWRhaXJAb 3JhbmdlLmNvbQ==
X-DDEI-TLS-USAGE: Used
X-CSE-ConnectionGUID: jbnmIMQcRGWnyzJtyc8Z/w==
X-CSE-MsgGUID: HWAjLAl+RWqPr0QERqSqRQ==
IronPort-Data: A9a23:IDp/qKO/5Y+MGHvvrR3okMFynXyQoLVcMsEvi/4bfWQNrUoh32MCm DQaDGCDOPuMa2HyeNl2aIu1/EIHvpaGztNlTQZtpSBmQkwRpJueD7x1DKtR0wB+jCHnZBg6h ynLQoCYdKjYdleF+FH1dOKn9CAmvU2xbuKUIPbePSxsThNTRi4kiBZy88Y0mYcAbeKRW2thg vus5ZeDULOZ82QsaDxMtfvb8EoHUMna41v0gHRvPJing3eOzxH5PLpHTYmtIn3xRJVjH+LSb 47r0LGj82rFyAwmA9Wjn6yTWhVirmn6ZFXmZtJ+AsBOszAazsAA+v9T2Mk0MC+7vw60c+VZk 72hg3ASpTABZcUgkMxFO/VR/roX0aduoNcrKlDn2SCfItGvn3bEm51T4E8K0YIw+OxxBEBrz PciBw8LfwKhm/O9kID8Vbw57igjBJGD0II3gks49WuHUd0bGcmfBaLX+dVfwTE8wNhUGurTb NYYbjwpawncZxpIOREcD5dWcOWA2iG5ImYe9wzT+ftfD2v7lGSd1JDoN9rcf9GGA89Sg02Rq mvH5Uz+GBgcO9HZwj2Amp6prraUxnyqB9lCT9VU8NZKv3SR4kUXSycpTGOh+cCUsFeFQuhmf hl8Fi0G9vNoqBPDosPGdwy5pnGWvhMaHdtdD+MS5wSEy66S6AGcbkANRTNMLt0rqMEeSjkj1 1vPlNTsbRRqsrCJSXub/7GYpDWzEScQJG4GIyQDSGMt7MTlvIwpyAzGSOFvHZmrg9n5FBn2x DOLpW41gLB7pc8GzKqT/F3bjXSrvJehZgIv7wvLG2Oo8g08eJC/Ipej6VXX8PJNaZeQSFapv XUYlY6Z9u9mJY2Kkj3LROQlALav9rCBMVX0nUB1WpIh/jW34FaicJxepjZkKy9BLtgeUT7kf EGVvhlejKK/J1OvZK5zJoyrAsIhwKPtE8j/X/TdfN5WO8cpLVXfoHAoYlOM1WfwlkRqibs4J ZqQbcerCzAdFLhjyz21Aewa1NfH2xzS20vRT5b+7jGe2oCxW3iEW5UZIVDeXKcmufbsTBruz zpJCyed4ztlONASjwHS+I8XaF4QJH4wCJv7rdBNf+qKMA5+QT55UqWJneJnfJF5laNIkOuO5 mu6RkJT1Fv4gzvANBmObXdgLrjoWP6TTE7X3wRzZz5EOFB6PO5DCZvzkbNrINHLE8Q/lpZJo wEtIZnoPxi2Ym2vF84hgWbBQHxKL0/x2V3m09uNZTk0ZZl7QALVstTjZBOHyRTi+hGf7JNky 5X5j1+zacRZG2xKUp2MANrxlAzZgJTosLkrN6c+CoIJIB20mGWrQgSt5sIKzzYkckqZnWXBh 1jPUH/1Z4Dl+ucIzTUAvojcx6/BLge0NhMy87XzhVpuCRTnww==
IronPort-HdrOrdr: A9a23:CDLVsKHPUp1QVfe/pLqE3MeALOsnbusQ8zAXPhZKOGRom62j5q WTdZEgv3LJYVkqNE3I9eruBED4ewK6yXcX2/hyAV7BZmnbUTCTXfhfBOLZqlWKJ8SZzIBgPM xbAstD4bPLbGSTIqzBkXKF+3pL+qjizEgI792uqUtQcQ==
X-Talos-CUID: 9a23:TQCQE22dnQL80T+kfxEvtrxfGMojd1z49XzqDHC+GHRLVKyeGW3X5/Yx
X-Talos-MUID: 9a23:A662swyJNpbe6/MWXYclCg+hG0yaqISRIUIpuJFFgfadDTYoAhqnlQ+ueLZyfw==
X-IronPort-AV: E=Sophos;i="6.24,197,1774306800"; d="scan'208,217";a="133797383"
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=vthRbYMXG4kiYpEurtWUnq5jTVTQeaGgRxYlWxn0a+dQ+4LluABXoebYvPE81KNnIL03vNsrsef3bQ8lVJJcRhPFk5vlf1265C5gAYfscY4bNJUynUxzgmptO0zUQTpVGpQw1BX5SGzJXdLoeHXjt4tBUnVri6mDO/FhHgfHwI4p94bhzdwGtWZiKZvzHIEB6Lh1av81B6cCXP8qkD8LmtMfFgChncxkW/DoJrT2ssY7JN37VrBFaMKJK4QUpSMXJbsdZAlL+wmasMVD7fNIWuz+xy9fmFSMSAZBSPWSWNKUQTYRc3CRQyzK+EY/JPltOAcN6j+HWQ6m4VYWokG4VA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=1xS42Ulk8DJ9xQHFRMMP+DG8eZn8AhyYlttov7xTUrY=; b=ZrO0ufqoMDTItQmGkQ35svlnzjCUrgyxEll/SpU8XiI2MNajlpz3o6D/dayYFjXgbXEz5sD/a2k3QOfIcf9O8u+skmp9VmFx81EM+y81kG0rMVB1dh1TnuyHBi5OH3qF5m2iNnLTd96cpiO07+gB5MCg0XlDZh3O74QAs/MXmdkwhMseYadpwTcOkc+TwPWjwmzlK8+0O0caG0LqpqzuJSgUlPB2vVL3Qx2KWFVVe0aaQ78hhm/B73dsq9D5S6iuVieXEQyEqn8uJBARs4x0aJDCllsh1+8V8LtCka64XlEGDUGdQ7aTEhmMO79KhQr4BebYQuw9aT3HWRhGSGoBmQ==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=orange.com; dmarc=pass action=none header.from=orange.com; dkim=pass header.d=orange.com; arc=none
To: Yingzhen Qu <yingzhen.ietf@gmail.com>
Thread-Topic: [iesg] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
Thread-Index: AQHc+GNFaKTI37rmX0GM7QB1o1yFJbY3VU7g
Date: Wed, 10 Jun 2026 06:43:56 +0000
Message-ID: <PATP264MB67650E886745C4A3885B0A39881A2@PATP264MB6765.FRAP264.PROD.OUTLOOK.COM>
References: <177556668194.1013163.7429659860508359426@dt-datatracker-9dc8fdd9f-qcdj9> <CABY-gOMPKUxuiY0RHUt77M8C2MjX11Pi0gY0Tq1J0112KQ8prg@mail.gmail.com> <AS1PR07MB8589FC36E3ABEF44C7B3315FE02A2@AS1PR07MB8589.eurprd07.prod.outlook.com> <C8E8A43E-0B91-46D8-B35D-1A156C3B0278@gmail.com> <59D6472A-D39A-42DC-A5C3-4FA66AA772F4@gmail.com> <PAUP264MB675652B3CD6FF155DD30B31C880E2@PAUP264MB6756.FRAP264.PROD.OUTLOOK.COM> <10DBD700-F219-4779-BF3D-51401D75D98F@gmail.com> <PAUP264MB675625D0CE1EA76F00DB91B2880E2@PAUP264MB6756.FRAP264.PROD.OUTLOOK.COM> <CABY-gOO0BsC0NQHEgadyew75vFVWgP0aNcPnkg-X4ixY+vrAZA@mail.gmail.com>
In-Reply-To: <CABY-gOO0BsC0NQHEgadyew75vFVWgP0aNcPnkg-X4ixY+vrAZA@mail.gmail.com>
Accept-Language: fr-FR, en-US
Content-Language: fr-FR
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
msip_labels: MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_ActionId=5d14813d-f2bc-4ee7-b695-5a5d8285fab0;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_ContentBits=0;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_Enabled=true;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_Method=Privileged;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_Name=unrestricted_parent.2;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_SetDate=2026-06-10T06:34:07Z;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_SiteId=90c7a20a-f34b-40bf-bc48-b9253b6f5d20;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_Tag=10, 0, 1, 1;MSIP_Label_f47c794b-e3ab-43f0-9e0f-29fc3e503192_ContentBits=0;MSIP_Label_f47c794b-e3ab-43f0-9e0f-29fc3e503192_Enabled=true;MSIP_Label_f47c794b-e3ab-43f0-9e0f-29fc3e503192_Method=Standard;
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=orange.com;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PATP264MB6765:EE_|MRZP264MB3225:EE_
x-ms-office365-filtering-correlation-id: 32c95154-2002-48cc-5276-08dec6bba565
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|23010399003|376014|366016|1800799024|6133799003|8096899003|4133799003|56012099006|3023799007|11063799006|4143699003|22082099003|38070700021|18002099003|13003099007;
x-microsoft-antispam-message-info: i+0PcCnP4tzlFmsNcYLByMHbnv779nzJMKgDYaEzzTjG4p2HalHgkUpCshnK3psEfjbpnmPmJpDWBAatY3SlluQSH59mrJfI0zu8DUujYgriIpV8PLT2W0O8dX09FfdCq1MAxLHmiSIFwByAsecbr1dW2qs022V1d4KtGn4z/rQdgPWLJr4E8iruQDsw87YiIL4p3LHbSGZE5qvzZv7Xe3VooqmR7FpXR9G5CwJaB5i4kaUpA7Rn6ZmQKyjRygO1nQHB8WLJeIj0WQlP4RHxwAHCL5LKDybeWkfGc+Ff9yh7jkUG9XabgjiQ2xGfKFz2i4mPZ2ys8IAtV52Jahe92gEnIKHnhh3nKNbfTw05AF2vzJYFRrmfVUvbYdtrunx52hfvanak+LqvhciQj0xzB6JJc2G7o6dfTMs5hgDph5Q6MXigtWd9449iZOuvEtpAc7iIKwclOn6bS5NqIXiUIBnTMRNYX7dPEP+VR4oNumPGiSQmlREiMdCrjtKqSpVEJIeYTkmfaJJYF0KuO2EmT0ATpnIRUqqt33eA6R1dJQXYdYefEbte6zE3O6n7cZRlDgL+4bCE2Pqpb0GSZpi/qJSE74pmttY81tDkAV/c6FEWH6DHV4kyQUpDQZh04zRjq8YS2J//rCai0yH1w/KBz64AO4P5XuMVPObYKGoQYvKpot9WRvQ9Ld99lkt7Yfr0uIzGa4/SZ3fiBOib+CS01g==
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PATP264MB6765.FRAP264.PROD.OUTLOOK.COM;PTR:;CAT:NONE;SFS:(13230040)(23010399003)(376014)(366016)(1800799024)(6133799003)(8096899003)(4133799003)(56012099006)(3023799007)(11063799006)(4143699003)(22082099003)(38070700021)(18002099003)(13003099007);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: jGw4uO5WBtkHFC71K1vfVWvjJVveSEknyRtHUw821G8zbxPDpLUgd6dfbaeKoN8d5w8D6z0gsMQqv34/Aghp8XQ6Fkpinjk+nyIxFS2Mznxgl540RwYdphN3AkUWm95qTTjUP3LPuTVTE+VOkc9FNMdfemXgm8DR25g+3INyboiWArFcGH/X6zt05TB6H/cyguxx9SzVNpXogdV3ugOSteCyACjnigfi60SJ8gZoZqXKwWD36SToevNxfOzHQ4DI5i0kS/bPmm13IltLgvUbfe2yDj1ZPYjImcgXOw2gJRjP+1x/bJV8H3DpB7RymBTc/Q/7ZWjIhrTwBBdixw0/020FLhacWLJg0OWPlK68TQf/Zna071y+F0wKLfRfkJW7MhAfPZKmPQVfLxd1WWus4vZjCtlnp/USMOyxI0rhrb9GZMtFStRh+D//WTEZH0pvLKXhj+muIHRdvD3xDe1x8YRkbAiGu/ySTpFVDtn7zHdTjoDrSfLnTNDU0n8KR//uKvDbI1Z/SHlO2Fb3BIhdNjst3dzL2gJXHr2EKW67thyd0jf4v4cpZAiy5SkItW2RD/amUkAxa5z3dOBnFAKqHPQ0EcUohEy3sLnN4uWcATOpCcOMnyDIb+EPfHuckpajMpjoAkjW6JYOcjuT4hAJJtodmwb+e9bz6mqLsBBp8MH35teACkqpqYk56C68fYfjCRKxgoooroiWuozzxMypMekDwwMgtjbA2yAWnfkIx1kbAoqUagUOGhbQ1H7NmSQ22CFnVky6iP++FmFRnasAI+2ooHrKDOrCZf6IovRxsBZETXv7oqG+CzjvPrhbFTx1Iroi6POffPIfPhrzpTKHRpc0CxwfjlXLJDEU4YnnUeJafg1ZOrfv3Eup0O7XJF/amONSifzkQmnC5uFUMOrv+iiPnzs4VtT8whpc+tEQ+n/SAbe7ho80B04hMAoo+hJddQ2Q27T0hfL8cG5itVmnD/fIhKMnvByf7nhS+IJGkIg7/99dCQpEHrVb3omIm4+8L+Q49x0Sre81xGX09ImXGlC++IlLRe05X72fKbenz3mtd3jTLtod6NaZO1YfO3by90DJWL7T/Y+SEggjXXCJMFDwykV16JkWTvAso0DUhM7TYxCr99ylzvdo0BNvon6bcCVUfXp3bUsczWmy/xZL4cMLMRnVpwFjQYpyfbX7Q36GzxMqJecp3iO3qZ8Sq10w/TiC9UXYib05Jrnjc6WrgSLw1qQTbElYJ8P7JVMZl+OKbD8eXumoaOMyhm1x8cTFioEotq4SqQTPjZPTvVfLqzmIDQ5CyTNMIf+oq3/k82xr3wB45bD4iycOdAf3nJKVFeawK/vFhpofcgHH7+38W0NkgeZvbOXg5P+MHa38dKLooZXx92opCJax3d14gBraMZnZOqO+TQO7FrYQGry1atRKqLTp6AhaPCiaHUp2gBhH3TohzhDA5Lpbn28kW5Bqv5h3yubP9aWtQDoolR3LekIta4qIE2Ubr8LVXT9JZzly+AmhO1oAe977s6OPqEfqvoSajZZzavgf5dUkEElJHdFLeEQo2+PHV5h2YWFLY5CY3cXnEfbRmv8UqNYQSA3Rik7JGvx7Ggd6WVDJ1hvQjMzRyCMjRANbBB5DFSVzcErtdGF2VdlkufI9v6ufBNjrkYDVC8o277EWbrg6Ibn8mIgMJvnoljjeqYPWOr3dPHhXJ4tEpZeVZTM1Amk7/A7UvBNmuWH0tluBa0Z3KRtS2g==
Content-Type: multipart/alternative; boundary="_000_PATP264MB67650E886745C4A3885B0A39881A2PATP264MB6765FRAP_"
MIME-Version: 1.0
X-Exchange-RoutingPolicyChecked: ZvgHeofDur4VmK2qfSSPgNaNWpC14RpOG2Z1/75nLQMZ1LLv1k9HdguXgVaDAFx7JLtX6pNxR8Yt0NzKBpGjhUPY+Ssy4wlQpN56X9jH/w9WZhshUbnJha271GRPt9dZu4eE063XqiZbLHFm+J2p03dHvk9Bcs5zi2NrMAf272HirmOatgXK/rXUX7mH2ST6XVZtt6/6OwOfMJrW6VJBUS2r9bDPHTNRg9kPMh0FJGjGNVAhSHJ9gbEEXiUeEGH3y1wIZVnz9awSL1Cn8lUJC5Bcsd9C8kQpOWDUjnZsLtGX26/ar4l/IwdV/XOGqHpLq8mfJavkjMW3TUKyGiJWfA==
X-OriginatorOrg: orange.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PATP264MB6765.FRAP264.PROD.OUTLOOK.COM
X-MS-Exchange-CrossTenant-Network-Message-Id: 32c95154-2002-48cc-5276-08dec6bba565
X-MS-Exchange-CrossTenant-originalarrivaltime: 10 Jun 2026 06:43:56.8930 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 90c7a20a-f34b-40bf-bc48-b9253b6f5d20
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: xBlPL+T9E7NSJ+QpAiDQqkjUX+ij9Rk7OAZEKHQFmB+OW8NYI4cxCNBb2o5Tm/ZPWo3LVDBqw120jej5LSGq8xMj8p2JekVx1Way0mlvPOo=
X-MS-Exchange-Transport-CrossTenantHeadersStamped: MRZP264MB3225
X-TM-AS-ERS: 10.106.160.156-127.5.254.253
X-TM-AS-SMTP: 1.0 c210cC1vdXQzNjUub3JhbmdlLmNvbQ== bW9oYW1lZC5ib3VjYWRhaXJAb 3JhbmdlLmNvbQ==
X-TMASE-Version: DDEI-5.1-9.2.1011-29998.005
X-TMASE-Result: 10--44.805600-10.000000
X-TMASE-MatchedRID: hxjxCVYNHl1e1gaK0wVnmSvJNX12HxYCEcprQILSqFoTM542Js9P5M6N WEzfFbasBT98R9Gd+U32Gfn2D+o1f9bbC2JkIlQ5TQMx6era2oHyAtJ4ZuMdZHh3e1VpW+JML8Q lbY+P4+oMfiba6PAK2wrGJyc18EaKLui0T5w9j+blNiA90QUbyb3KSrWAF4P5/VWlKHXnqGmgYo HQ1Yk0DwPsBsD5OFCTChJqth1sAepJFPBcgYmFIj7p8nVd5WwPymNnxQ9cfSGRjrnZyAE5bpcUb L/LX2ykJO58QVRaY2cs+D6KuyFlDNFwAooHujt8yxGZYkgoczvIR1ufLT2T334pRJAmgA+3jAFd ZME1dQzHwJYnpo0L6W8lDAHJQfo4eKnzndt922XuatNXK2ADAU/xvIYub+nNABgiBGCF65rsXxv ZTa7VAUYNeTPwDt2PRyG5SSR7mMEiMrtypJdxpHS/QRf/AeS4dBjoMEPmPfgJgo0aAbue97PDP8 0NOi3yE7GRMzU5kUTKIm5wTGbEAK3tRi3BwhSz8xwlpu6x9hS1BPN2XantFjoG8lLtomiyJSpRj 1majUNsBBK+dj8AxaCfX1AcCU7MzDsZdzq+x0OUKgypnDzriOf9xibXubjIP8gvTu0PsW3Vo/AD iRmcJcE4zxW+fMHit2WzBqt0OeWCffNSFqgaK82/Is8wUrugNmG22UKBfzbACi4qzvC7MMz74oE lhNRBVkHd5sq6oNksVMwMaBIvJ7wkxl+OYw2ziTGYBnwvRCOqHCb8VDmjZ5FlE0yjfYW7e4nSBx uVq3PPEeDcxvUDjGUDVvvI14PLlo85K6HuY6fRVaCKvzOY2+Sazff4fhF1ryBnsTzBtwTh+0R5I BKRsqlMDJeKqhNbu55PhDswmTXgiEouQePr9OXNtR6FKqU/WWSz4drjSLhimmowi1sSA7cK7nie nQpHl/GWuNxIn+p7+ppwg+NZlyDilljGyWFtDjSolFn3I1u2FEUBwKd8ypRMZUCEHkRt
X-TMASE-SNAP-Result: 1.821001.0001-0-1-22:0,28:1,33:0,34:0,42:1-0
X-TMASE-INERTIA: 0-0;;;;
X-TMASE-XGENCLOUD: 76b790e0-0214-4080-b93d-869f7c548265-0-0-200-0
X-TMASE-EurekaRID: visyO8uH6pSPMs8JdWGYR+4E2qfogjIxqP/+/8i2VFPUkpPXncb+SRmzH T7+2EmKUq43nlcer2o8sGVwngd79CHGRDYF3daCnl/+0pN/F0dcTWAJG/8/ItTmHWBdC0OkKi3Q x8QSHN1sKiNGsVFRyv1zEdJOsFCA4pdKZERf3GyTQ5O7OIwCncYwz/SsfE8uBhT9mG4vm3voRu2 oq2vfZEY3XUDRfat6rvT634V1lCS4u52Kz254f/AB5pibqWqyA8OGa97fRGPSoT1BU1GPfgm7/5 FMSlHG4/EQJ3Qq+htsFIBl1zwV5jMWk9t5RrzKw74Nx2neHZk8STn8ytD4IFnueIG2F+TK+cjYc 43iNVjIJQo63bQlnOnI9p1hU9NxPLw3VSJc78MH8DU+6lne1Wz3K0lcx50kRZt3tw9SExuDn0TT l8RaeGdQdyRYgZ8YgoGUDl4RUHos1i1Ae5m8TdAnfFHnYmO2u67WYvr3SsOwP4db9i3g2tyfjSA six5eew8biOurK0Hz3Da0RFcHiCLZDUFgSJOmi1VHpe3KU1kAViqV/M/gtkRQ52rW9BB3vqBpOE qbwnBq5bqauGwUzbxg8H2664nkg7X0kMaG1RNNm8As9ll9pnIsxm8cxbLexQcATwPqe9AHfXtrb xm2o8/++mjmD3BISLy9xFeupUO+oOGJ/hFaPRCfgphfmUhl47yooLlZ6qV49Ab5hjGg0w5SqM+o ht0CiU55L5PRIT+Jskpf2L4dU1dqRjlmdzKEVr2YgH0V4QNF9SQFsOnxhzBi0cue9OMBcOMkMkC ODX0MI8Pj8EdqD9aL1UA4Yaj0bAaiOoESfzC+d8UsOB4UhTKXEosPiOPbn8/RL0AN7OhdAcNOM0 +PrvCtXq991orrw6Et0D6s+DKSjlQPoFCnu/q8TX8DQKvycyYMJHr4/T/DjHaz5CT2C4G/r0Zda Osm
Message-ID-Hash: NRIFEGSZUZVHSBP6OF7YCSBAXFBCDE4G
X-Message-ID-Hash: NRIFEGSZUZVHSBP6OF7YCSBAXFBCDE4G
X-MailFrom: mohamed.boucadair@orange.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Acee Lindem <acee.ietf@gmail.com>, Mahesh Jethanandani <mjethanandani@gmail.com>, Gunter van de Velde <gunter.van_de_velde@nokia.com>, The IESG <iesg@ietf.org>, "draft-ietf-tvr-schedule-yang@ietf.org" <draft-ietf-tvr-schedule-yang@ietf.org>, "tony.li@tony.li" <tony.li@tony.li>, "tvr-chairs@ietf.org" <tvr-chairs@ietf.org>, "tvr@ietf.org" <tvr@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Tvr] Re: [iesg] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
List-Id: Time-Variant Routing <tvr.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tvr/MbfokiYelOZd-b4XH2Cd6uvmz5Q>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tvr>
List-Help: <mailto:tvr-request@ietf.org?subject=help>
List-Owner: <mailto:tvr-owner@ietf.org>
List-Post: <mailto:tvr@ietf.org>
List-Subscribe: <mailto:tvr-join@ietf.org>
List-Unsubscribe: <mailto:tvr-leave@ietf.org>

Hi Yingzhen, all,

Thank you for the follow-up, changes, and detailed explanations below. -10 looks good to me.

I will clear my DISUCSS right now.

Cheers,
Med

De : Yingzhen Qu <yingzhen.ietf@gmail.com>
Envoyé : mercredi 10 juin 2026 00:56
À : BOUCADAIR Mohamed INNOV/NET <mohamed.boucadair@orange.com>
Cc : Acee Lindem <acee.ietf@gmail.com>; Mahesh Jethanandani <mjethanandani@gmail.com>; Gunter van de Velde <gunter.van_de_velde@nokia.com>; The IESG <iesg@ietf.org>; draft-ietf-tvr-schedule-yang@ietf.org; tony.li@tony.li; tvr-chairs@ietf.org; tvr@ietf.org
Objet : Re: [iesg] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)


Hi Med and all,

Sorry for the delay.

The authors discussed how to address the IESG comments, especially regarding augmentations. We have modified the ietf-tvr-topology.yang module to augment ietf-network.yang and ietf-network-topology.yang defined in RFC 8345. We decided to keep the ietf-tvr-node.yang module as independent as it is, considering the ietf-logical-network-element.yang and ietf-interfaces.yang are not widely deployed, and there are either openconfig or proprietary interface modules in use.

Version -10 has been uploaded with the changes.

The following are other comments from Med with replies:

# Title



## Consider



OLD: YANG Data Model for Scheduled Attributes



NEW: A YANG Data Model for Scheduled Attributes



## I wonder whether you can include TVR in the title as well.



## Please update the title in the reference clauses of your YANG modules.

[YQ]: the title is changed to "A YANG Data Model for Scheduled Attributes", and the referce clauses in the modules are updated as well.



# Please follow the guidance in Section 2.5 of RFC9907<https://datatracker.ietf.org/doc/rfc9907/> about data model, model, etc.



## For example, please make this change in the abstract:



OLD: The YANG model



NEW: The YANG data model



## Idem in the Introduction;



OLD:    The YANG model in this document can



NEW:    The YANG data model in this document can



## Please make sure this is used in a consistent manner through the document



[YQ]: fixed.



# We don’t need to motivate the use of YANG!



I would delete this text:



CURRENT:

   YANG [RFC7950<https://datatracker.ietf.org/doc/rfc7950/>] is a data definition language used to define the

   contents of a conceptual data store that allows networked devices to

   be managed using NETCONF [RFC6241<https://datatracker.ietf.org/doc/rfc6241/>]  YANG is proving relevant beyond

   its initial confines, as bindings to other interfaces (e.g., ReST)

   and encodings other than XML (e.g., JSON) are being defined.

   Furthermore, YANG data models can be used as the basis for

   implementation of other interfaces, such as CLI and programmatic

   APIs.



If you keep it, then s/being defined/defined

[YQ]: this has been removed.


# (nit) Reference use cases



OLD:

please reference to

   TVR (Time-Variant Routing) Use Cases [RFC9657<https://datatracker.ietf.org/doc/rfc9657/>]



NEW:

please refer to

   TVR (Time-Variant Routing) Use Cases [RFC9657<https://datatracker.ietf.org/doc/rfc9657/>]



[YQ]: fixed.





# Please list the modules in the order they are defined in the document:



CURRENT:

   Module ietf-tvr-schedule.yang contains the schedule YANG definitions.

   Module ietf-tvr-topology.yang defines a network topology with time-

   variant availability.  Module ietf-tvr-node.yang is to be used to

   manage scheduled attributes of a single node.



[YQ]: fixed.





# NMDA: The new guidance is to highlight when we deviate from NMDA



Please delete this statement:



CURRENT:

   The YANG modules in this document conform to the Network Management

   Datastore Architecture (NMDA) [RFC8342<https://datatracker.ietf.org/doc/rfc8342/>]



[YQ]: removed.





# RFC9922<https://datatracker.ietf.org/doc/rfc9922/>



CURRENT:

   time" and "recurrence-utc" as defined in

   [I-D.ietf-netmod-schedule-yang<https://datatracker.ietf.org/doc/draft-ietf-netmod-schedule-yang/>]



Please update this reference to RFC9922<https://datatracker.ietf.org/doc/rfc9922/>.



[YQ]: fixed.





# Users: Not sure to get what is meant by users in this text. Please clarify that in the text.



CURRENT:

  Users can supply attributes or containers that augment the schedule.

[YQ]: changed to "The schedule in the grouping can be augmented with attributes or containers.".



# Escape clause for RFC9911<https://datatracker.ietf.org/doc/rfc9911/> and the like



CURRENT:

   The following RFC is not referenced in the document text but is

   referenced in the "ietf-tvr-schedule.yang" module and "ietf-tvr-

   topology.yang" module: [RFC9911<https://datatracker.ietf.org/doc/rfc9911/>]



You don’t need this text per RFC9907<https://datatracker.ietf.org/doc/rfc9907/>:



   If the module (or modules) defined by the specification imports

   definitions from other modules (except for those defined in [RFC7950<https://datatracker.ietf.org/doc/rfc7950/>]

   or [RFC9911<https://datatracker.ietf.org/doc/rfc9911/>] or is always implemented in conjunction with other

   modules, then those facts MUST be noted in the overview section;

[YQ]: removed.



# Please consider adding a tree with ietf-tvr-schedule grouping



NEW:

module: ietf-tvr-schedule



  grouping tvr-schedule:

    +-- schedule* [schedule-id]

       +-- schedule-id                     uint32

       +-- (schedule-type)?

          +--:(period)

          |  +-- period-description?       string

          |  +-- period-start?             yang:date-and-time

          |  +-- time-zone-identifier?     sys:timezone-name

          |  +-- (period-type)?

          |     +--:(explicit)

          |     |  +-- period-end?         yang:date-and-time

          |     +--:(duration)

          |        +-- duration?           duration

          +--:(recurrence)

             +-- recurrence-first

             |  +-- start-time-utc?   yang:date-and-time

             |  +-- duration?         uint32

             +-- (recurrence-end)?

             |  +--:(until)

             |  |  +-- utc-until?          yang:date-and-time

             |  +--:(count)

             |     +-- count?              uint32

             +-- recurrence-description?   string

             +-- frequency?                identityref

             +-- interval?                 uint32

[YQ]: added as suggested.



# Update reference clause



OLD:

     import ietf-schedule {

       prefix "schedule";

       reference

         "RFC XXXX: A Common YANG Data Model for Scheduling";

     }



NEW:

     import ietf-schedule {

       prefix "schedule";

       reference

         "RFC 9922<https://datatracker.ietf.org/doc/rfc9922/>: A Common YANG Data Model for Scheduling";

     }

[YQ]: fixed.



# Update TLP Date of ietf-tvr-schedule s/2025/2026

[YQ]: fixed.



# Update the description of your modules to follow the IET template in RFC9907<https://datatracker.ietf.org/doc/rfc9907/>, in particular:



OLD:

        This version of this YANG module is part of RFC XXXX

        (https://www.rfc-editor.org/info/rfcXXXX) see the RFC itself

        for full legal notices.";





NEW:

        All revisions of IETF and IANA published modules can be found

        at the YANG Parameters registry group

        (https://www.iana.org/assignments/yang-parameters)



        This version of this YANG module is part of RFC XXXX; see

        the RFC itself for full legal notices.";

[YQ]: fixed.



# Extra reference clause



OLD:

     reference

       "RFC XXXX: YANG Data Model for Scheduled Attributes";



     revision 2025-06-30 {

       description

         "Initial Version";

       reference

         "RFC XXXX: YANG Data Model for Scheduled Attributes.";

     }



NEW:



     revision 2025-06-30 {

       description

         "Initial Version";

       reference

         "RFC XXXX: A YANG Data Model for Scheduled Attributes.";

     }

[YQ]: fixed.



# NMDA Again: Please delete the following:



CURRENT:

        This YANG model conforms to the Network Management

        Datastore Architecture (NMDA) as described in RFC 8342<https://datatracker.ietf.org/doc/rfc8342/>.

[YQ]: removed.



# The module will live outside the RFC



OLD:

  import ietf-tvr-schedule {

    prefix "tvr-schd";

  }



NEW:

  import ietf-tvr-schedule {

    prefix "tvr-schd";

    reference

      "RFC XXXX: A YANG Data Model for Scheduled Attributes";

  }

[YQ]: fixed.


# Redundant descriptions



CURRENT:

          type boolean;

          default false;

          description

            "By default, the link is not available.";



        leaf default-bandwidth {

          type yang:gauge64;

          units "bits/second";

          default "0";

          description

            "The default interface bandwidth in bits



The description for both nodes is redundant with “default” clause. Please consider a more meaningful description of the node, without repeating the default clause.

[YQ]: removed "default" from the default-bandwidth description.



# use “units” statement



CURRENT:

          description

            "The default one-way delay in microseconds.";



Please use units statant rather than having this in the description.

[YQ]: added "units:.



# Explain the recommendation



CURRENT:

   recurrence.  The model defined in this document doesn't prevent a

   configuration to mix both styles.  However, it's not recommended.



I would use NOT RECOMMENDED here. Also, please consider motivate the recommendation.

[YQ]: changed this to "However, it's NOT RECOMMENDED for simplicity and easy readability."



# Help identify the relevant data nodes



CURRENT:

   The TVR schedule modules are meant to work together with other models

   that manage node or interface attributes.



You list in your modules some identifiers that might be common (node-id, etc.). I would call these here for awareness.

[YQ]: added "For example, the "node-id" in the ietf-tvr-node.yang module."



# Security Considerations



Consider updating to follow the template in RFC9907<https://datatracker.ietf.org/doc/rfc9907/>, Section 3.7.1

[YQ]: done.



# Reference



Please move the following from Normative to Informative



   [RFC6241<https://datatracker.ietf.org/doc/rfc6241/>]  Enns, R., Ed., Bjorklund, M., Ed., Schoenwaelder, J., Ed.,

              and A. Bierman, Ed., "Network Configuration Protocol

              (NETCONF)", RFC 6241<https://datatracker.ietf.org/doc/rfc6241/>, DOI 10.17487/RFC6241, June 2011,

              <https://www.rfc-editor.org/info/rfc6241><https://www.rfc-editor.org/info/rfc6241%3E>.



   [RFC6242<https://datatracker.ietf.org/doc/rfc6242/>]  Wasserman, M., "Using the NETCONF Protocol over Secure

              Shell (SSH)", RFC 6242<https://datatracker.ietf.org/doc/rfc6242/>, DOI 10.17487/RFC6242, June 2011,

              <https://www.rfc-editor.org/info/rfc6242><https://www.rfc-editor.org/info/rfc6242%3E>.



   [RFC8040<https://datatracker.ietf.org/doc/rfc8040/>]  Bierman, A., Bjorklund, M., and K. Watsen, "RESTCONF

              Protocol", RFC 8040<https://datatracker.ietf.org/doc/rfc8040/>, DOI 10.17487/RFC8040, January 2017,

              <https://www.rfc-editor.org/info/rfc8040><https://www.rfc-editor.org/info/rfc8040%3E>.



   [RFC8446<https://datatracker.ietf.org/doc/rfc8446/>]  Rescorla, E., "The Transport Layer Security (TLS) Protocol

              Version 1.3", RFC 8446<https://datatracker.ietf.org/doc/rfc8446/>, DOI 10.17487/RFC8446, August 2018,

              <https://www.rfc-editor.org/info/rfc8446><https://www.rfc-editor.org/info/rfc8446%3E>.

[YQ]: done.



# Appendix “Example: Add a scheduled cost to OSPF interface”



What is the purpose of this example? Please consider clarifying that in the text.



# Please add a reference to RFC9129<https://datatracker.ietf.org/doc/rfc9129/> in the following:



CURRENT:

By default, the OSPF interface cost is calculated

   based on the bandwidth of the interface, and it is also configurable.

[YQ]: Changed the text to
"
   This example demonstrates how an OSPF interface [RFC9129] can be
   extended with a cost that changes with a schedule using the grouping
   defined in ietf-tvr-schedule.yang.
"

Thanks,
Yingzhen (on behalf of co-authors)

On Thu, May 21, 2026 at 10:57 AM <mohamed.boucadair@orange.com<mailto:mohamed.boucadair@orange.com>> wrote:
Re-,

Yes, ietf-network-topology.

I fully agree that ietf-te-topology and ietf-network-inventory-topology are not relevant to this discussion.

Cheers,
Med

> -----Message d'origine-----
> De : Acee Lindem <acee.ietf@gmail.com<mailto:acee.ietf@gmail.com>>
> Envoyé : jeudi 21 mai 2026 19:48
> À : BOUCADAIR Mohamed INNOV/NET <mohamed.boucadair@orange.com<mailto:mohamed.boucadair@orange.com>>
> Cc : Mahesh Jethanandani <mjethanandani@gmail.com<mailto:mjethanandani@gmail.com>>; Gunter van de
> Velde <gunter.van_de_velde@nokia.com<mailto:gunter.van_de_velde@nokia.com>>; Yingzhen Qu
> <yingzhen.ietf@gmail.com<mailto:yingzhen.ietf@gmail.com>>; The IESG <iesg@ietf.org<mailto:iesg@ietf.org>>; draft-ietf-
> tvr-schedule-yang@ietf.org<mailto:tvr-schedule-yang@ietf.org>; tony.li@tony.li<mailto:tony.li@tony.li>; tvr-chairs@ietf.org<mailto:tvr-chairs@ietf.org>;
> tvr@ietf.org<mailto:tvr@ietf.org>
> Objet : [iesg] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-
> schedule-yang-08: (with DISCUSS and COMMENT)
>
>
> Hi Med,
>
> There were many different modules mentioned by either Mahesh and
> yourself including ietf-interface,  ietf-te-topology, and ietf-
> network-inventory-topology.
> So, the that is being proposed is ietf-network-topology.yang -
> correct?
>
> Acee
>
>
> > On May 21, 2026, at 1:12 PM, mohamed.boucadair@orange.com<mailto:mohamed.boucadair@orange.com> wrote:
> >
> > Hi Acee,
> >
> > Thank you for the follow-up.
> >
> > As far as I'm concerned (and I think Mahesh as well), I wasn't
> asking why TE model/RFC8795 isn't used.
> >
> > Our question was vs. RFC8345 which provides the minimal
> nodes/links you need. The design in draft-ietf-tvr-schedule-yang
> seems to duplicate what is already there (no need to restate the
> ops consistency issues shared in previous messages by both Mahesh
> and Myself), hence the DISCUSSion about building on 8345 unless
> there are good reasons.
> >
> > Cheers,
> > Med
> >
> >> -----Message d'origine-----
> >> De : Acee Lindem <acee.ietf@gmail.com<mailto:acee.ietf@gmail.com>> Envoyé : jeudi 21 mai
> 2026
> >> 18:18 À : Mahesh Jethanandani <mjethanandani@gmail.com<mailto:mjethanandani@gmail.com>>;
> BOUCADAIR
> >> Mohamed INNOV/NET <mohamed.boucadair@orange.com<mailto:mohamed.boucadair@orange.com>> Cc : Gunter
> van de
> >> Velde <gunter.van_de_velde@nokia.com<mailto:gunter.van_de_velde@nokia.com>>; Yingzhen Qu
> >> <yingzhen.ietf@gmail.com<mailto:yingzhen.ietf@gmail.com>>; The IESG <iesg@ietf.org<mailto:iesg@ietf.org>>; draft-
> >> ietf-tvr-schedule-yang@ietf.org<mailto:ietf-tvr-schedule-yang@ietf.org>; tony.li@tony.li<mailto:tony.li@tony.li>; tvr-
> >> chairs@ietf.org<mailto:chairs@ietf.org>; tvr@ietf.org<mailto:tvr@ietf.org> Objet : Re: [iesg] Mohamed
> Boucadair's
> >> Discuss on draft-ietf-tvr-
> >> schedule-yang-08: (with DISCUSS and COMMENT)
> >>
> >> Mahesh, Mohamed,
> >>
> >> While I don't agree with using DISCUS to propose a different
> YANG
> >> module for node/link scheduling, I'm going to add the following
> text
> >> to the draft to satisfy your request for justification of the
> >> ietf-tvr-topology.yang module. I've also refactored the module
> itself
> >> with reusable groupings which you or any other ADs can augment
> any of
> >> the modules you suggested (the list was all over the map).
> >>
> >> 3.3.1.  Relationship to the Traffic Engineering YANG Module
> >>
> >>   The ietf-te-topology YANG module is specified in [RFC8795].
> >> One
> >>   design option would have been to augment this module rather
> than
> >>   define a separate time-variant routing topology module.  This
> >> option
> >>   was not pursued due to concerns about modularity and the
> overall
> >>   scope of the ietf-te-topology module.  Defining a separate
> >> ietf-tvr-
> >>   topology module facilitates implementation and deployment
> >>   flexibility.
> >>
> >>   The ietf-te-topology module is defined as a single,
> relatively
> >> large
> >>   YANG module and does not make extensive use of YANG features
> to
> >> allow
> >>   selective implementation of subsets of functionality.
> >>
> >>   While ietf-te-topology provides a comprehensive model for
> traffic
> >>   engineering topologies, it is not necessarily intended to
> serve as
> >>   the base for all topology-related augmentations.  A more
> minimal
> >> base
> >>   topology model, containing only nodes and links, could
> provide a
> >> more
> >>   flexible foundation for augmentation by different
> applications.
> >>
> >>   Other IETF YANG modules have similarly defined separate
> topology
> >>   models rather than augmenting ietf-te-topology, for example,
> >>   [I-D.ietf-ivy-network-inventory-topology].
> >>
> >>   To promote modularity and reuse, the time-variant scheduling
> >>   definitions for nodes and links are specified as reusable
> YANG
> >>   groupings.  These groupings can be used to augment ietf-te-
> >> topology
> >>   or other IETF YANG modules, as needed.  The reusable
> groupings
> >>   include node-availability-schedule, link-availability-
> schedule, and
> >>   link-default-attributes.
> >>
> >> I hope this satisfies this aspect of your DISCUSS. As I stated
> >> previously, I feel that using DISCUSS to propose a different
> >> technical solution from the one advanced by the TVR WG exceeds
> the
> >> role of the the IESG.
> >>
> >> Acee
> >>
> >>
> >>
> >>
> >>> On Apr 23, 2026, at 5:46 PM, Mahesh Jethanandani
> >> <mjethanandani@gmail.com<mailto:mjethanandani@gmail.com>> wrote:
> >>>
> >>> Hi Yingzhe/Gunter,
> >>>
> >>> I have explained this a couple of times, but I guess that
> >> explanation is not coming across. I will repeat it one more
> time
> >> here, but if that still does not make sense, it might be
> helpful to
> >> get on a call to explain this. Yingzhen, you know how to get
> hold of
> >> me.
> >>>
> >>> See inline with [mj]
> >>>
> >>>> On Apr 23, 2026, at 2:11 AM, Gunter van de Velde (Nokia)
> >> <gunter.van_de_velde@nokia.com<mailto:gunter.van_de_velde@nokia.com>> wrote:
> >>>>
> >>>> Hi Med, Mahesh,
> >>>>
> >>>> The draft-ietf-tvr-schedule-yang authors provided additional
> >> context and clarified the WG’s consensus on the relationship
> with
> >> RFC8345, including supporting data and rationale.
> >>>>
> >>>> Does this address your RFC8345 DISCUSS on draft-ietf-tvr-
> >> schedule-yang?
> >>>>
> >>>> If not, the alternative is to return the document to the WG
> for
> >> further discussion on the same topic. I would prefer to avoid
> that,
> >> given the prior extensive discussion and limited new input
> likely to
> >> change the outcome.
> >>>>
> >>>> Brgds,
> >>>> G/
> >>>>
> >>>>
> >>>>
> >>>> From: Yingzhen Qu <yingzhen.ietf@gmail.com<mailto:yingzhen.ietf@gmail.com>>
> >>>> Sent: Tuesday, April 21, 2026 5:32 AM
> >>>> To: Mohamed Boucadair <mohamed.boucadair@orange.com<mailto:mohamed.boucadair@orange.com>>
> >>>> Cc: The IESG <iesg@ietf.org<mailto:iesg@ietf.org>>; draft-ietf-tvr-schedule-
> >> yang@ietf.org<mailto:yang@ietf.org>
> >>>> <draft-ietf-tvr-schedule-yang@ietf.org<mailto:draft-ietf-tvr-schedule-yang@ietf.org>>; tony.li@tony.li<mailto:tony.li@tony.li>
> >>>> <tony.li@tony.li<mailto:tony.li@tony.li>>; tvr-chairs@ietf.org<mailto:tvr-chairs@ietf.org> <tvr-chairs@ietf.org<mailto:tvr-chairs@ietf.org>>;
> >>>> tvr@ietf.org<mailto:tvr@ietf.org> <tvr@ietf.org<mailto:tvr@ietf.org>>
> >>>> Subject: [iesg] Re: Mohamed Boucadair's Discuss on
> >>>> draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
> >>>>
> >>>> CAUTION: This is an external email. Please be very careful
> >> when clicking links or opening attachments. See the URL
> nok.it/ext<http://nok.it/ext>
> >> for additional information.
> >>>>
> >>>> Hi Med and all,
> >>>>
> >>>> Thanks for the reviews and comments.
> >>>>
> >>>> The authors and the document shepherd (Tony Li) discussed the
> >> comments we received. The most important question we need to
> answer
> >> from the IESG DISCUSSes is why the model is not augmenting
> existing
> >> IETF modules, such as the network-topology module defined in
> RFC
> >> 8345, the interface and LNE modules.
> >>>>  We've watched the video recordings and confirmed with the
> >> TVR-chairs about the WG consensus. Here are our answers to the
> IESG.
> >>>>
> >>>> The draft was adopted by the WG in Apr 2024 after IETF 119,
> and
> >> there were discussions during the TVR sessions at both IETF 118
> and
> >> 119.
> >>>> Long discussions about whether to augment or be standalone at
> >> IETF 118:
> >>>> Minutes of TVR at IETF 118:
> >>>>
> >>
> https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> >> dat
> >>>> atracker.ietf.org<http://atracker.ietf.org/>%2Fdoc%2Fminutes-118-tvr-
> >> 202311090830%2F&data=05%7C0
> >>>>
> >>
> 2%7Cmohamed.boucadair%40orange.com<http://40orange.com/>%7C1c14b34df2614500b1c708deb7549
> >> 469
> >>>>
> >>
> %7C90c7a20af34b40bfbc48b9253b6f5d20%7C0%7C0%7C639149771067779960%7
> >> CUn
> >>>>
> >>
> known%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIl
> >> AiO
> >>>>
> >>
> iJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C0%7C%7C%7C&sdata=EEg
> >> HAo
> >>>> 7xzgfH5PTq2y4RxiqVUlkNgBCOejLeWp5kGdw%3D&reserved=0
> >>>> The discussion at IETF 119 was more about some model details:
> >>>>
> >>
> https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> >> dat
> >>>> atracker.ietf.org<http://atracker.ietf.org/>%2Fdoc%2Fminutes-119-tvr-
> >> 202403200300%2F&data=05%7C0
> >>>>
> >>
> 2%7Cmohamed.boucadair%40orange.com<http://40orange.com/>%7C1c14b34df2614500b1c708deb7549
> >> 469
> >>>>
> >>
> %7C90c7a20af34b40bfbc48b9253b6f5d20%7C0%7C0%7C639149771067825250%7
> >> CUn
> >>>>
> >>
> known%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIl
> >> AiO
> >>>>
> >>
> iJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C0%7C%7C%7C&sdata=8NF
> >> 5pT
> >>>> 4zHJjqHUfbMJxdMZes2%2Bh7rgft29bG3S3gxdU%3D&reserved=0
> >>>>
> >>>> The draft was adopted by the WG with standalone modules
> without
> >> any objections. The authors believe that we have achieved WG
> >> consensus that the modules should be standalone.
> >>>>
> >>>> If the IESG insists that augmentations should be used, then
> the
> >> draft needs to be sent back to the WG.
> >>>
> >>>
> >>> [mj] Here is what I said in my response on 4/15.
> >>>
> >>>>> However, we need to clarify one thing. When we started the
> >> work, we discussed whether to augment the network topology
> module
> >> defined in RFC 8345. The WG's consensus was to keep the TVR
> model
> >> independent for easier implementation and deployment. This also
> >> applies to the IVY model (ietf-network-inventory).
> >>>>
> >>>>
> >>>> Augmentation would have been ideal, but I can understand if
> >> there were design choices for not wanting to do it.
> >>>>
> >>>> When we think of networks and network topology in a holistic
> >> way, there is usually one network topology, or at least there
> is one
> >> way to refer to all the nodes in the network. The change below
> is the
> >> min way to refer to a node in the network the same way, Since
> the
> >> module referred to RFC 8345, I gave you an example of a RFC
> 8345
> >> definition of ne-id, so the two can be consistent.
> >>>
> >>>
> >>> and even suggested a simple solution:
> >>>
> >>>>> All I am asking is that, rather than augmenting it, it
> should
> >> have a
> >>>>> leafref to the node in RFC 8345. Something like
> >>>>>
> >>>>>      leaf node-id {
> >>>>>        type leafref {
> >>>>>          path "path "/nw:networks/nw:network[nw:network-
> >> id=current()/../"+
> >>>>>                            "network-ref]/nw:node/nw:node-
> id”;
> >>>>>        }
> >>>>>        description
> >>>>>          "Identifier for a node; uniquely identifies a
> >> node.";
> >>>>>      }
> >>>>>
> >>>>> where ‘nw’ is the prefix for ‘ietf-network’ module, so that
> >> implementations and users know we are talking about the same
> node-
> >> id.
> >>>
> >>> That way, you are not augmenting the RFC 8345 model, that your
> >> model is still standalone, but you are still using the same
> ’node-
> >> id’ consistently across all the models.
> >>>
> >>> Does that help explain the ask?
> >>>
> >>> Cheers.
> >>>
> >>>>
> >>>> The authors will be happy to address other comments after we
> >> resolve this issue.
> >>>>
> >>>> Thanks,
> >>>> Yingzhen (on behalf of co-authors)
> >>>>
> >>>>
> >>>> On Tue, Apr 7, 2026 at 5:58 AM Mohamed Boucadair via
> >> Datatracker <noreply@ietf.org<mailto:noreply@ietf.org>> wrote:
> >>>> Mohamed Boucadair has entered the following ballot position
> for
> >>>> draft-ietf-tvr-schedule-yang-08: Discuss
> >>>>
> >>>> When responding, please keep the subject line intact and
> reply
> >> to all
> >>>> email addresses included in the To and CC lines. (Feel free
> to
> >> cut
> >>>> this introductory paragraph, however.)
> >>>>
> >>>>
> >>>> Please refer to
> >>>>
> >>
> https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> >> www
> >>>> .ietf.org<http://ietf.org/>%2Fabout%2Fgroups%2Fiesg%2Fstatements%2Fhandling-
> >> ballot-posi
> >>>>
> >>
> tions%2F&data=05%7C02%7Cmohamed.boucadair%40orange.com<http://40orange.com/>%7C1c14b34df
> >> 261
> >>>>
> >>
> 4500b1c708deb7549469%7C90c7a20af34b40bfbc48b9253b6f5d20%7C0%7C0%7C
> >> 639
> >>>>
> >>
> 149771067855442%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIl
> >> YiO
> >>>>
> >>
> iIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C
> >> 0%7
> >>>>
> >>
> C%7C%7C&sdata=F4nWOWj%2F9H1pypO8J4vIuLh1YUq4ZgS5jh0n7GdiBo0%3D&res
> >> erv
> >>>> ed=0 for more information about how to handle DISCUSS and
> >> COMMENT
> >>>> positions.
> >>>>
> >>>>
> >>>> The document, along with other ballot positions, can be found
> >> here:
> >>>>
> >>
> https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> >> dat
> >>>> atracker.ietf.org<http://atracker.ietf.org/>%2Fdoc%2Fdraft-ietf-tvr-schedule-
> >> yang%2F&data=05%7C0
> >>>>
> >>
> 2%7Cmohamed.boucadair%40orange.com<http://40orange.com/>%7C1c14b34df2614500b1c708deb7549
> >> 469
> >>>>
> >>
> %7C90c7a20af34b40bfbc48b9253b6f5d20%7C0%7C0%7C639149771067881746%7
> >> CUn
> >>>>
> >>
> known%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIl
> >> AiO
> >>>>
> >>
> iJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C0%7C%7C%7C&sdata=fa4
> >> BfN
> >>>> PNRHO4l5kO8JVkBysY2vPVOpycU%2Babi4b%2FzIs%3D&reserved=0
> >>>>
> >>>>
> >>>>
> >>>> -------------------------------------------------------------
> --
> >> ------
> >>>> -
> >>>> DISCUSS:
> >>>> -------------------------------------------------------------
> --
> >> ------
> >>>> -
> >>>>
> >>>> Hi Yingzhen, Acee, Eric, Don, and Marc,
> >>>>
> >>>> Thank you for the effort put into this specification.
> >>>>
> >>>> Thanks to Chongfeng Xie for the OPSDIR review and to the
> >> authors for
> >>>> engaging and addressing his review.
> >>>>
> >>>> Please find below some points for DISCUSSion:
> >>>>
> >>>> # Design Rationale
> >>>>
> >>>> ## ietf-tvr-schedule
> >>>>
> >>>> This module is not TVR-sepcific but a generic one similar to
> >> the one
> >>>> defined in RFC9922. Please update the module name and prefix
> to
> >>>> follow a patter similar to RFC9922. The description should be
> >> updated
> >>>> as well to reflect the generic nature of the module.
> >>>>
> >>>> ## Node module
> >>>>
> >>>> CURRENT:
> >>>>   Module ietf-tvr-node.yang is a device model and designed to
> >> manage a
> >>>>   single node with scheduled attributes.
> >>>>
> >>>> It is not clear to me how this is anchored in NE? What isn’t
> >> this
> >>>> defined as an extension to ietf-logical-network-element?
> >>>>
> >>>> Please consider adding a rationale of this design and how
> this
> >> is
> >>>> supposed to work.
> >>>>
> >>>> ## Idem vs. interface
> >>>>
> >>>> CURRENT:
> >>>>   Each node has scheduled power at the node level.  At the
> >> interface
> >>>>   level, a node has a list of interfaces, and each interface
> >> has its
> >>>>   own schedule for availability/power up and down, scheduled
> >> bandwidth,
> >>>>   and scheduled neighbors.
> >>>>
> >>>> Idem why isn’t this defined as an augmentation of the
> interface
> >>>> module? How overall consistency will be ensured.
> >>>>
> >>>> # Idem for the topology
> >>>>
> >>>> CURRENT:
> >>>>   Module ietf-tvr-topology.yang describes a network topology
> >> with a
> >>>>   time-variant availability schedule.
> >>>>
> >>>> Why isn’t this defined as a new ietf-network type +
> >> augmentation to
> >>>> RFC 8345 - A YANG Data Model for Network Topologies?
> >>>>
> >>>> ## Some elaboration about the design adopted in the draft
> >> compared to
> >>>> the alternatives mentioned above is needed, IMO. Thanks.
> >>>>
> >>>> # Broken JSON Examples
> >>>>
> >>>> RF9907 requires the following:
> >>>>
> >>>>  Examples that are meant to illustrate a valid
> >>>>   data instance MUST be validated (Section 3.10).
> >>>>
> >>>> At least all your JSON Examples are broken: namespace issues,
> >> type
> >>>> mis-alignment, no quotes for duration, etc.
> >>>>
> >>>> Please fix all these (you can run yangson or yanglint to fix
> >> those).
> >>>>
> >>>>
> >>>> -------------------------------------------------------------
> --
> >> ------
> >>>> -
> >>>> COMMENT:
> >>>> -------------------------------------------------------------
> --
> >> ------
> >>>> -
> >>>>
> >>>> # Overall, consider adding a discussion how thsi spec meets
> the
> >>>> requirements of TVR Use Cases.
> >>>>
> >>>> # Title
> >>>>
> >>>> ## Consider
> >>>>
> >>>> OLD: YANG Data Model for Scheduled Attributes
> >>>>
> >>>> NEW: A YANG Data Model for Scheduled Attributes
> >>>>
> >>>> ## I wonder whether you can include TVR in the title as well.
> >>>>
> >>>> ## Please update the title in the reference clauses of your
> >> YANG modules.
> >>>>
> >>>> # Please follow the guidance in Section 2.5 of RFC9907 about
> >> data
> >>>> model, model, etc.
> >>>>
> >>>> ## For example, please make this change in the abstract:
> >>>>
> >>>> OLD: The YANG model
> >>>>
> >>>> NEW: The YANG data model
> >>>>
> >>>> ## Idem in the Introduction;
> >>>>
> >>>> OLD:    The YANG model in this document can
> >>>>
> >>>> NEW:    The YANG data model in this document can
> >>>>
> >>>> ## Please make sure this is used in a consistent manner
> through
> >> the
> >>>> document
> >>>>
> >>>> # We don’t need to motivate the use of YANG!
> >>>>
> >>>> I would delete this text:
> >>>>
> >>>> CURRENT:
> >>>>   YANG [RFC7950] is a data definition language used to define
> >> the
> >>>>   contents of a conceptual data store that allows networked
> >> devices to
> >>>>   be managed using NETCONF [RFC6241].  YANG is proving
> >> relevant beyond
> >>>>   its initial confines, as bindings to other interfaces
> (e.g.,
> >> ReST)
> >>>>   and encodings other than XML (e.g., JSON) are being
> defined.
> >>>>   Furthermore, YANG data models can be used as the basis for
> >>>>   implementation of other interfaces, such as CLI and
> >> programmatic
> >>>>   APIs.
> >>>>
> >>>> If you keep it, then s/being defined/defined
> >>>>
> >>>> # (nit) Reference use cases
> >>>>
> >>>> OLD:
> >>>> please reference to
> >>>>   TVR (Time-Variant Routing) Use Cases [RFC9657].
> >>>>
> >>>> NEW:
> >>>> please refer to
> >>>>   TVR (Time-Variant Routing) Use Cases [RFC9657].
> >>>>
> >>>> # Please list the modules in the order they are defined in
> the
> >> document:
> >>>>
> >>>> CURRENT:
> >>>>   Module ietf-tvr-schedule.yang contains the schedule YANG
> >> definitions.
> >>>>   Module ietf-tvr-topology.yang defines a network topology
> >> with time-
> >>>>   variant availability.  Module ietf-tvr-node.yang is to be
> >> used to
> >>>>   manage scheduled attributes of a single node.
> >>>>
> >>>> # NMDA: The new guidance is to highlight when we deviate from
> >> NMDA
> >>>>
> >>>> Please delete this statement:
> >>>>
> >>>> CURRENT:
> >>>>   The YANG modules in this document conform to the Network
> >> Management
> >>>>   Datastore Architecture (NMDA) [RFC8342].
> >>>>
> >>>> # RFC9922
> >>>>
> >>>> CURRENT:
> >>>>   time" and "recurrence-utc" as defined in
> >>>>   [I-D.ietf-netmod-schedule-yang].
> >>>>
> >>>> Please update this reference to RFC9922.
> >>>>
> >>>> # Users: Not sure to get what is meant by users in this text.
> >> Please
> >>>> clarify that in the text.
> >>>>
> >>>> CURRENT:
> >>>>  Users can supply attributes or containers that augment the
> >> schedule.
> >>>>
> >>>> # Escape clause for RFC9911 and the like
> >>>>
> >>>> CURRENT:
> >>>>   The following RFC is not referenced in the document text
> but
> >> is
> >>>>   referenced in the "ietf-tvr-schedule.yang" module and
> "ietf-
> >> tvr-
> >>>>   topology.yang" module: [RFC9911].
> >>>>
> >>>> You don’t need this text per RFC9907:
> >>>>
> >>>>   If the module (or modules) defined by the specification
> >> imports
> >>>>   definitions from other modules (except for those defined in
> >> [RFC7950]
> >>>>   or [RFC9911]) or is always implemented in conjunction with
> >> other
> >>>>   modules, then those facts MUST be noted in the overview
> >> section;
> >>>>
> >>>> # Please consider adding a tree with ietf-tvr-schedule
> grouping
> >>>>
> >>>> NEW:
> >>>> module: ietf-tvr-schedule
> >>>>
> >>>>  grouping tvr-schedule:
> >>>>    +-- schedule* [schedule-id]
> >>>>       +-- schedule-id                     uint32
> >>>>       +-- (schedule-type)?
> >>>>          +--:(period)
> >>>>          |  +-- period-description?       string
> >>>>          |  +-- period-start?             yang:date-and-time
> >>>>          |  +-- time-zone-identifier?     sys:timezone-name
> >>>>          |  +-- (period-type)?
> >>>>          |     +--:(explicit)
> >>>>          |     |  +-- period-end?         yang:date-and-time
> >>>>          |     +--:(duration)
> >>>>          |        +-- duration?           duration
> >>>>          +--:(recurrence)
> >>>>             +-- recurrence-first
> >>>>             |  +-- start-time-utc?   yang:date-and-time
> >>>>             |  +-- duration?         uint32
> >>>>             +-- (recurrence-end)?
> >>>>             |  +--:(until)
> >>>>             |  |  +-- utc-until?          yang:date-and-time
> >>>>             |  +--:(count)
> >>>>             |     +-- count?              uint32
> >>>>             +-- recurrence-description?   string
> >>>>             +-- frequency?                identityref
> >>>>             +-- interval?                 uint32
> >>>>
> >>>> # Update reference clause
> >>>>
> >>>> OLD:
> >>>>     import ietf-schedule {
> >>>>       prefix "schedule";
> >>>>       reference
> >>>>         "RFC XXXX: A Common YANG Data Model for Scheduling";
> >>>>     }
> >>>>
> >>>> NEW:
> >>>>     import ietf-schedule {
> >>>>       prefix "schedule";
> >>>>       reference
> >>>>         "RFC 9922: A Common YANG Data Model for Scheduling";
> >>>>     }
> >>>>
> >>>> # Update TLP Date of ietf-tvr-schedule s/2025/2026
> >>>>
> >>>> # Update the description of your modules to follow the IET
> >> template
> >>>> in RFC9907, in particular:
> >>>>
> >>>> OLD:
> >>>>        This version of this YANG module is part of RFC XXXX
> >>>>
> >>
> (https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2<https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%252>
> >> Fwww.rfc-
> >>
> editor.org<http://editor.org/>%2Finfo%2FrfcXXXX&data=05%7C02%7Cmohamed.boucadair%40ora
> >>
> nge.com<http://nge.com/>%7C1c14b34df2614500b1c708deb7549469%7C90c7a20af34b40bfbc48b
> >>
> 9253b6f5d20%7C0%7C0%7C639149771067903451%7CUnknown%7CTWFpbGZsb3d8e
> >>
> yJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjo
> >>
> iTWFpbCIsIldUIjoyfQ%3D%3D%7C0%7C%7C%7C&sdata=K6p8IFlQCxh4braIttccs
> >> Pbgv3bSy90zbpzkclsyfJg%3D&reserved=0); see the RFC itself
> >>>>        for full legal notices.";
> >>>>
> >>>> NEW:
> >>>>        All revisions of IETF and IANA published modules can
> be
> >> found
> >>>>        at the YANG Parameters registry group
> >>>>
> >>
> (https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2<https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%252>
> >> Fwww.iana.org<http://fwww.iana.org/>%2Fassignments%2Fyang-
> >>
> parameters&data=05%7C02%7Cmohamed.boucadair%40orange.com<http://40orange.com/>%7C1c14b34
> >>
> df2614500b1c708deb7549469%7C90c7a20af34b40bfbc48b9253b6f5d20%7C0%7
> >>
> C0%7C639149771067924300%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOn
> >>
> RydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoy
> >>
> fQ%3D%3D%7C0%7C%7C%7C&sdata=yMlcQIT7QkTSIcCZ4QwZVqLHe%2Bqi9GaMiadV
> >> RiVgjMI%3D&reserved=0).
> >>>>
> >>>>        This version of this YANG module is part of RFC XXXX;
> >> see
> >>>>        the RFC itself for full legal notices.";
> >>>>
> >>>> # Extra reference clause
> >>>>
> >>>> OLD:
> >>>>     reference
> >>>>       "RFC XXXX: YANG Data Model for Scheduled Attributes";
> >>>>
> >>>>     revision 2025-06-30 {
> >>>>       description
> >>>>         "Initial Version";
> >>>>       reference
> >>>>         "RFC XXXX: YANG Data Model for Scheduled
> Attributes.";
> >>>>     }
> >>>>
> >>>> NEW:
> >>>>
> >>>>     revision 2025-06-30 {
> >>>>       description
> >>>>         "Initial Version";
> >>>>       reference
> >>>>         "RFC XXXX: A YANG Data Model for Scheduled
> >> Attributes.";
> >>>>     }
> >>>>
> >>>> # NMDA Again: Please delete the following:
> >>>>
> >>>> CURRENT:
> >>>>        This YANG model conforms to the Network Management
> >>>>        Datastore Architecture (NMDA) as described in RFC
> 8342.
> >>>>
> >>>> # The module will live outside the RFC
> >>>>
> >>>> OLD:
> >>>>  import ietf-tvr-schedule {
> >>>>    prefix "tvr-schd";
> >>>>  }
> >>>>
> >>>> NEW:
> >>>>  import ietf-tvr-schedule {
> >>>>    prefix "tvr-schd";
> >>>>    reference
> >>>>      "RFC XXXX: A YANG Data Model for Scheduled Attributes";
> }
> >>>>
> >>>> # Redundant descriptions
> >>>>
> >>>> CURRENT:
> >>>>          type boolean;
> >>>>          default false;
> >>>>          description
> >>>>            "By default, the link is not available.";
> >>>>
> >>>>        leaf default-bandwidth {
> >>>>          type yang:gauge64;
> >>>>          units "bits/second";
> >>>>          default "0";
> >>>>          description
> >>>>            "The default interface bandwidth in bits
> >>>>
> >>>> The description for both nodes is redundant with “default”
> >> clause.
> >>>> Please consider a more meaningful description of the node,
> >> without
> >>>> repeating the default clause.
> >>>>
> >>>> # use “units” statement
> >>>>
> >>>> CURRENT:
> >>>>          description
> >>>>            "The default one-way delay in microseconds.";
> >>>>
> >>>> Please use units statant rather than having this in the
> >> description.
> >>>>
> >>>> # Explain the recommendation
> >>>>
> >>>> CURRENT:
> >>>>   recurrence.  The model defined in this document doesn't
> >> prevent a
> >>>>   configuration to mix both styles.  However, it's not
> >> recommended.
> >>>>
> >>>> I would use NOT RECOMMENDED here. Also, please consider
> >> motivate the
> >>>> recommendation.
> >>>>
> >>>> # Help identify the relevant data nodes
> >>>>
> >>>> CURRENT:
> >>>>   The TVR schedule modules are meant to work together with
> >> other models
> >>>>   that manage node or interface attributes.
> >>>>
> >>>> You list in your modules some identifiers that might be
> common
> >> (node-id, etc.).
> >>>> I would call these here for awareness.
> >>>>
> >>>> # Security Considerations
> >>>>
> >>>> Consider updating to follow the template in RFC9907, Section
> >> 3.7.1
> >>>>
> >>>> # Reference
> >>>>
> >>>> Please move the following from Normative to Informative
> >>>>
> >>>>   [RFC6241]  Enns, R., Ed., Bjorklund, M., Ed.,
> Schoenwaelder,
> >> J., Ed.,
> >>>>              and A. Bierman, Ed., "Network Configuration
> >> Protocol
> >>>>              (NETCONF)", RFC 6241, DOI 10.17487/RFC6241, June
> >> 2011,
> >>>>
> >>
> <https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2<https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%252>
> >> Fwww.rfc-
> >>
> editor.org<http://editor.org/>%2Finfo%2Frfc6241&data=05%7C02%7Cmohamed.boucadair%40ora
> >>
> nge.com<http://nge.com/>%7C1c14b34df2614500b1c708deb7549469%7C90c7a20af34b40bfbc48b
> >>
> 9253b6f5d20%7C0%7C0%7C639149771067960209%7CUnknown%7CTWFpbGZsb3d8e
> >>
> yJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjo
> >>
> iTWFpbCIsIldUIjoyfQ%3D%3D%7C0%7C%7C%7C&sdata=%2BSDq4WUjOUMpt9ds5vi
> >> PjYAmWl5QglFiW9PEWT0R1lw%3D&reserved=0>.
> >>>>
> >>>>   [RFC6242]  Wasserman, M., "Using the NETCONF Protocol over
> >> Secure
> >>>>              Shell (SSH)", RFC 6242, DOI 10.17487/RFC6242,
> >> June 2011,
> >>>>
> >>
> <https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2<https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%252>
> >> Fwww.rfc-
> >>
> editor.org<http://editor.org/>%2Finfo%2Frfc6242&data=05%7C02%7Cmohamed.boucadair%40ora
> >>
> nge.com<http://nge.com/>%7C1c14b34df2614500b1c708deb7549469%7C90c7a20af34b40bfbc48b
> >>
> 9253b6f5d20%7C0%7C0%7C639149771067979308%7CUnknown%7CTWFpbGZsb3d8e
> >>
> yJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjo
> >>
> iTWFpbCIsIldUIjoyfQ%3D%3D%7C0%7C%7C%7C&sdata=v0gTWzCIVkWuaE3r4xzU6
> >> HPbLFP6L%2Fti6NCvBCiXG9U%3D&reserved=0>.
> >>>>
> >>>>   [RFC8040]  Bierman, A., Bjorklund, M., and K. Watsen,
> >> "RESTCONF
> >>>>              Protocol", RFC 8040, DOI 10.17487/RFC8040,
> >> January 2017,
> >>>>
> >>
> <https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2<https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%252>
> >> Fwww.rfc-
> >>
> editor.org<http://editor.org/>%2Finfo%2Frfc8040&data=05%7C02%7Cmohamed.boucadair%40ora
> >>
> nge.com<http://nge.com/>%7C1c14b34df2614500b1c708deb7549469%7C90c7a20af34b40bfbc48b
> >>
> 9253b6f5d20%7C0%7C0%7C639149771067997721%7CUnknown%7CTWFpbGZsb3d8e
> >>
> yJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjo
> >>
> iTWFpbCIsIldUIjoyfQ%3D%3D%7C0%7C%7C%7C&sdata=8aAV0au5wrHzoNqM9njoy
> >> cJXTJ3m0evGM676YREKZPc%3D&reserved=0>.
> >>>>
> >>>>   [RFC8446]  Rescorla, E., "The Transport Layer Security
> (TLS)
> >> Protocol
> >>>>              Version 1.3", RFC 8446, DOI 10.17487/RFC8446,
> >> August 2018,
> >>>>
> >>
> <https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%2<https://fra01.safelinks.protection.outlook.com/?url=https%3A%2F%252>
> >> Fwww.rfc-
> >>
> editor.org<http://editor.org/>%2Finfo%2Frfc8446&data=05%7C02%7Cmohamed.boucadair%40ora
> >>
> nge.com<http://nge.com/>%7C1c14b34df2614500b1c708deb7549469%7C90c7a20af34b40bfbc48b
> >>
> 9253b6f5d20%7C0%7C0%7C639149771068018031%7CUnknown%7CTWFpbGZsb3d8e
> >>
> yJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjo
> >>
> iTWFpbCIsIldUIjoyfQ%3D%3D%7C0%7C%7C%7C&sdata=E6%2FK0Yw3855BVhx0uEp
> >> yxDabcXsxPaT9So6U9sch1Kc%3D&reserved=0>.
> >>>>
> >>>> # Appendix “Example: Add a scheduled cost to OSPF interface”
> >>>>
> >>>> What is the purpose of this example? Please consider
> clarifying
> >> that
> >>>> in the text.
> >>>>
> >>>> # Please add a reference to RFC9129 in the following:
> >>>>
> >>>> CURRENT:
> >>>> By default, the OSPF interface cost is calculated
> >>>>   based on the bandwidth of the interface, and it is also
> >> configurable.
> >>>>
> >>>> Cheers,
> >>>> Med
> >>>
> >>>
> >>>
> >>> Mahesh Jethanandani
> >>> mjethanandani@gmail.com<mailto:mjethanandani@gmail.com>
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> >
> >
> __________________________________________________________________
> ____
> > ______________________________________
> > Ce message et ses pieces jointes peuvent contenir des
> informations
> > confidentielles ou privilegiees et ne doivent donc pas etre
> diffuses,
> > exploites ou copies sans autorisation. Si vous avez recu ce
> message
> > par erreur, veuillez le signaler a l'expediteur et le detruire
> ainsi que les pieces jointes. Les messages electroniques etant
> susceptibles d'alteration, Orange decline toute responsabilite si
> ce message a ete altere, deforme ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or
> > privileged information that may be protected by law; they should
> not be distributed, used or copied without authorisation.
> > If you have received this email in error, please notify the
> sender and delete this message and its attachments.
> > As emails may be altered, Orange is not liable for messages that
> have been modified, changed or falsified.
> > Thank you.

____________________________________________________________________________________________________________
Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.
____________________________________________________________________________________________________________
Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.