[Tvr] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)

Yingzhen Qu <yingzhen.ietf@gmail.com> Thu, 09 April 2026 10:25 UTC

Return-Path: <yingzhen.ietf@gmail.com>
X-Original-To: tvr@mail2.ietf.org
Delivered-To: tvr@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 9D891D8A235E for <tvr@mail2.ietf.org>; Thu, 9 Apr 2026 03:25:29 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1775730329; bh=/UINVaDLzW5/P0PUfhLokqcdgrZR/RL3djOtqh97Otg=; h=References:In-Reply-To:From:Date:Subject:To:Cc; b=EuzFBgSlEY+X1NFmbm+CVv6vIsxmyqJmEJSzT7ZLC2hsZVgZtMdWokx4S1v0V4JWv IIOyWSl9lV+DmouafnkhO2C0LHGLaZ9uY7w8P/KsjVeP7+AEti3nmSpRM1a2UE7jaW h1KfgeKb5yUpLNFUNutvIfWmThFf8pqiilSh7gjY=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 0wg8HTW37JDz for <tvr@mail2.ietf.org>; Thu, 9 Apr 2026 03:25:27 -0700 (PDT)
Received: from mail-lj1-x22f.google.com (mail-lj1-x22f.google.com [IPv6:2a00:1450:4864:20::22f]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id B343ED8A234F for <tvr@ietf.org>; Thu, 9 Apr 2026 03:25:27 -0700 (PDT)
Received: by mail-lj1-x22f.google.com with SMTP id 38308e7fff4ca-38dd5f28a4cso6307951fa.2 for <tvr@ietf.org>; Thu, 09 Apr 2026 03:25:27 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; t=1775730321; cv=none; d=google.com; s=arc-20240605; b=hZ8z+qNnkL/envKy8O45hv75YyrAOfMbvOjv7Dd40WFY4HYofSEjsmoIhE6SOU4Ikv Dy5pQT9Gz+a2ygiz5yOEK+QDZCpbVOmnaODtUXLN/cQdELvMrs4qP3/DlgZIt7Js8cJj MqBW+ym1H+9//foQk7D0XR3oB7eFAtcBSVdAMBieZTCnlqF4EwSmNGo7+dwk3jUZXt7d WPQN+p/T+SS3NPK92dtA3bDtS8tzYkKTOdOMNxOK0IjNw32zOu8GYr/Ev4efPT2oq7SJ aHjkRtKGJzoPzqF06W0AVVnTneNvujlRDxWTg5GcUaHdAfxBCPGWvzPv8ZA9PfEq38n7 H02w==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20240605; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:dkim-signature; bh=A5KO9nIHtubZ1B0HhwZZ0pAbH8/F6MoLTnRj57XN7A0=; fh=x54BkUdXVKv8MHSsEt6SDmew74JNcqcs3NXDPw/CcQk=; b=RkCa7mtrIraR0o830Y4c+QFThW6FJYFlUQ1nvQQENbyIFgyLwmGy4z5ozQb7rgBOpU 3GokBI2ej9Nl5wpMuu5A8Ox6DctrezWkdlyU4uwnJBeYknDmrfyGkbQu9WMumheyYlXd a21msGe7VntWJ8mWEPAtro8Rqj7AHfJ35Axl4q1izkL7NV7Dgf1CVQiLC1T6STylif2v dlPsqDC52LfhbULNCU6BK+Ls1PCPNTZSOqbpWFEy+15yEZfPP6ismgqHnws8ZjaWJkqO ZgUW8VtgbkrQzRWVr4p+m3eWrWNmmL4cQbESMHA8VViXGKE9hjrlOU4UYgGN+6hc0yJH Rqhw==; darn=ietf.org
ARC-Authentication-Results: i=1; mx.google.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1775730321; x=1776335121; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=A5KO9nIHtubZ1B0HhwZZ0pAbH8/F6MoLTnRj57XN7A0=; b=fWQd9f5MA0NYruVU6UnF65KL54/MhJDPpfTk4gNJEcWwtftWVV5PanIH00fXICv5Pn gj6ygZlN1CONzuUDXojhqe30XDyhjYwsm22dynHyTFtzb9+lM8/it0jkA2o1Y8uQih++ tlsOPTM5G5ZtmvZ/XSnEV+aGeIA7Uujr4/WSBIuoHv+0CXh81rx9rA0ENxzzI3Cs3HgE R/HokqkCuUZhJBs4IDvqtAWNL6ITCh3lU4QQNJT49csyHmjZTg6iw0Dt2Unwk3klcbSk I5kGAzWCHgTEqD4SkJOj/aIHdhPYbZuRwslUyG2xAFYcp4z7a7H3LO+Y14R/GllXEo6G krGw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1775730321; x=1776335121; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-gg:x-gm-message-state:from:to:cc:subject:date :message-id:reply-to; bh=A5KO9nIHtubZ1B0HhwZZ0pAbH8/F6MoLTnRj57XN7A0=; b=aHhSsU5jx/cgM4hSt5u4KuY6OxK4Ll2X6g0PUBWwhVcHOeCxQHEe2dwSCE77EXWBD/ nf5EWfpkivBIc/EUO3xGSkaxta6uDDF2W89LEEkcZB9+6OFqTZJZ1WSlRS95+/aZYCX4 3JLp24sztMVO+/+ZymTjO8CCEoux1TKhbuC7GKIrDmRBko5yQotm5f6OEp6qU4tGGaaR YCz/m9r/qOXMm8hPop6MOPsjoEq4GbObBU8Fn5CA3eSJgdFSitqeoUeJ0Xd11H7UHX59 pSB8+LOPa/cL93SkXt95pUUA+zwnr8hf4nRMMpytUGEUb5wX0JBjVm85xnG/FhkwspSy I7cQ==
X-Forwarded-Encrypted: i=1; AJvYcCWXIRz8sAFszIZ6pPewr6YfnEbdzPWwZ4strNeXfozcLDBn/jMiT5yySy0px+I72ndo9oY=@ietf.org
X-Gm-Message-State: AOJu0YzVBb6XwIbwNQ5t09lGIWspldtyc63mLHkBp5Vmmulp4uXeFin+ 6/i2gRB5QnmkBBN2j6rib1glvYk1IjSjdOavWROx6u626hvGR8abJhQqd13AHMehQepnL2dj/3I m4FtGYUnytwVg+5h/DiOZYMXVW4glm7b6
X-Gm-Gg: AeBDiesCmbZRzToME/d+8O+h6oip1j7fwHEDSXBdWDZD5DJl2KCwdE8dj/qIo+wr8E+ ubLvSw4QPeCw18W1VYlbYzg0DKuwrBwc1p4m1CNibxYVtjAV0oppdpw38lIgt9PkvOFpeHHd7NB 3qWXT8BNEAn+43mJxxqY6FS5+qGes9qmS3k41x9FO1lo58C5939ujvP9K1zj32mzAaHiMsb07LI G5g5yXgVNSAd1SSc2XOf9+0meDLkSvqyS+0AXcsJuvwHronWzCMf/Vt0nxaBCky60F2Nc6FN0FR VQrdxC/rapP0HgX+sA==
X-Received: by 2002:a05:651c:3249:b0:385:dde5:1bf3 with SMTP id 38308e7fff4ca-38d8d37b1aamr71557161fa.6.1775730320798; Thu, 09 Apr 2026 03:25:20 -0700 (PDT)
MIME-Version: 1.0
References: <177556668194.1013163.7429659860508359426@dt-datatracker-9dc8fdd9f-qcdj9>
In-Reply-To: <177556668194.1013163.7429659860508359426@dt-datatracker-9dc8fdd9f-qcdj9>
From: Yingzhen Qu <yingzhen.ietf@gmail.com>
Date: Thu, 09 Apr 2026 18:25:05 +0800
X-Gm-Features: AQROBzDwcxw8Joskig99Y2f_qPAWAuXMrRc0QAz-aoEamoRH35cb_BzNX4AdYdU
Message-ID: <CABY-gONA3BwmdDMCcuGmq-SAwM8dYnA4VcWpF9LJwdYyOHhFJQ@mail.gmail.com>
To: Mohamed Boucadair <mohamed.boucadair@orange.com>
Content-Type: multipart/alternative; boundary="000000000000fcf618064f046ed5"
Message-ID-Hash: GU7NDPO7FLJAQ5CNVLVNYHSYHVQ2YA3U
X-Message-ID-Hash: GU7NDPO7FLJAQ5CNVLVNYHSYHVQ2YA3U
X-MailFrom: yingzhen.ietf@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: The IESG <iesg@ietf.org>, draft-ietf-tvr-schedule-yang@ietf.org, tony.li@tony.li, tvr-chairs@ietf.org, tvr@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Tvr] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
List-Id: Time-Variant Routing <tvr.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tvr/xlO3Sv0m5lszDbusElKcXoGSvrI>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tvr>
List-Help: <mailto:tvr-request@ietf.org?subject=help>
List-Owner: <mailto:tvr-owner@ietf.org>
List-Post: <mailto:tvr@ietf.org>
List-Subscribe: <mailto:tvr-join@ietf.org>
List-Unsubscribe: <mailto:tvr-leave@ietf.org>

Hi Med,

Thanks for your review and comments. The authors will discuss the issues
and get back to you soon.

Thanks,
Yingzhen

On Tue, Apr 7, 2026 at 8:58 PM Mohamed Boucadair via Datatracker <
noreply@ietf.org> wrote:

> Mohamed Boucadair has entered the following ballot position for
> draft-ietf-tvr-schedule-yang-08: Discuss
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to
> https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/
> for more information about how to handle DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-tvr-schedule-yang/
>
>
>
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
>
> Hi Yingzhen, Acee, Eric, Don, and Marc,
>
> Thank you for the effort put into this specification.
>
> Thanks to Chongfeng Xie for the OPSDIR review and to the authors for
> engaging
> and addressing his review.
>
> Please find below some points for DISCUSSion:
>
> # Design Rationale
>
> ## ietf-tvr-schedule
>
> This module is not TVR-sepcific but a generic one similar to the one
> defined in
> RFC9922. Please update the module name and prefix to follow a patter
> similar to
> RFC9922. The description should be updated as well to reflect the generic
> nature of the module.
>
> ## Node module
>
> CURRENT:
>    Module ietf-tvr-node.yang is a device model and designed to manage a
>    single node with scheduled attributes.
>
> It is not clear to me how this is anchored in NE? What isn’t this defined
> as an
> extension to ietf-logical-network-element?
>
> Please consider adding a rationale of this design and how this is supposed
> to
> work.
>
> ## Idem vs. interface
>
> CURRENT:
>    Each node has scheduled power at the node level.  At the interface
>    level, a node has a list of interfaces, and each interface has its
>    own schedule for availability/power up and down, scheduled bandwidth,
>    and scheduled neighbors.
>
> Idem why isn’t this defined as an augmentation of the interface module? How
> overall consistency will be ensured.
>
> # Idem for the topology
>
> CURRENT:
>    Module ietf-tvr-topology.yang describes a network topology with a
>    time-variant availability schedule.
>
> Why isn’t this defined as a new ietf-network type + augmentation to RFC
> 8345 -
> A YANG Data Model for Network Topologies?
>
> ## Some elaboration about the design adopted in the draft compared to the
> alternatives mentioned above is needed, IMO. Thanks.
>
> # Broken JSON Examples
>
> RF9907 requires the following:
>
>   Examples that are meant to illustrate a valid
>    data instance MUST be validated (Section 3.10).
>
> At least all your JSON Examples are broken: namespace issues, type
> mis-alignment, no quotes for duration, etc.
>
> Please fix all these (you can run yangson or yanglint to fix those).
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> # Overall, consider adding a discussion how thsi spec meets the
> requirements of
> TVR Use Cases.
>
> # Title
>
> ## Consider
>
> OLD: YANG Data Model for Scheduled Attributes
>
> NEW: A YANG Data Model for Scheduled Attributes
>
> ## I wonder whether you can include TVR in the title as well.
>
> ## Please update the title in the reference clauses of your YANG modules.
>
> # Please follow the guidance in Section 2.5 of RFC9907 about data model,
> model,
> etc.
>
> ## For example, please make this change in the abstract:
>
> OLD: The YANG model
>
> NEW: The YANG data model
>
> ## Idem in the Introduction;
>
> OLD:    The YANG model in this document can
>
> NEW:    The YANG data model in this document can
>
> ## Please make sure this is used in a consistent manner through the
> document
>
> # We don’t need to motivate the use of YANG!
>
> I would delete this text:
>
> CURRENT:
>    YANG [RFC7950] is a data definition language used to define the
>    contents of a conceptual data store that allows networked devices to
>    be managed using NETCONF [RFC6241].  YANG is proving relevant beyond
>    its initial confines, as bindings to other interfaces (e.g., ReST)
>    and encodings other than XML (e.g., JSON) are being defined.
>    Furthermore, YANG data models can be used as the basis for
>    implementation of other interfaces, such as CLI and programmatic
>    APIs.
>
> If you keep it, then s/being defined/defined
>
> # (nit) Reference use cases
>
> OLD:
> please reference to
>    TVR (Time-Variant Routing) Use Cases [RFC9657].
>
> NEW:
> please refer to
>    TVR (Time-Variant Routing) Use Cases [RFC9657].
>
> # Please list the modules in the order they are defined in the document:
>
> CURRENT:
>    Module ietf-tvr-schedule.yang contains the schedule YANG definitions.
>    Module ietf-tvr-topology.yang defines a network topology with time-
>    variant availability.  Module ietf-tvr-node.yang is to be used to
>    manage scheduled attributes of a single node.
>
> # NMDA: The new guidance is to highlight when we deviate from NMDA
>
> Please delete this statement:
>
> CURRENT:
>    The YANG modules in this document conform to the Network Management
>    Datastore Architecture (NMDA) [RFC8342].
>
> # RFC9922
>
> CURRENT:
>    time" and "recurrence-utc" as defined in
>    [I-D.ietf-netmod-schedule-yang].
>
> Please update this reference to RFC9922.
>
> # Users: Not sure to get what is meant by users in this text. Please
> clarify
> that in the text.
>
> CURRENT:
>   Users can supply attributes or containers that augment the schedule.
>
> # Escape clause for RFC9911 and the like
>
> CURRENT:
>    The following RFC is not referenced in the document text but is
>    referenced in the "ietf-tvr-schedule.yang" module and "ietf-tvr-
>    topology.yang" module: [RFC9911].
>
> You don’t need this text per RFC9907:
>
>    If the module (or modules) defined by the specification imports
>    definitions from other modules (except for those defined in [RFC7950]
>    or [RFC9911]) or is always implemented in conjunction with other
>    modules, then those facts MUST be noted in the overview section;
>
> # Please consider adding a tree with ietf-tvr-schedule grouping
>
> NEW:
> module: ietf-tvr-schedule
>
>   grouping tvr-schedule:
>     +-- schedule* [schedule-id]
>        +-- schedule-id                     uint32
>        +-- (schedule-type)?
>           +--:(period)
>           |  +-- period-description?       string
>           |  +-- period-start?             yang:date-and-time
>           |  +-- time-zone-identifier?     sys:timezone-name
>           |  +-- (period-type)?
>           |     +--:(explicit)
>           |     |  +-- period-end?         yang:date-and-time
>           |     +--:(duration)
>           |        +-- duration?           duration
>           +--:(recurrence)
>              +-- recurrence-first
>              |  +-- start-time-utc?   yang:date-and-time
>              |  +-- duration?         uint32
>              +-- (recurrence-end)?
>              |  +--:(until)
>              |  |  +-- utc-until?          yang:date-and-time
>              |  +--:(count)
>              |     +-- count?              uint32
>              +-- recurrence-description?   string
>              +-- frequency?                identityref
>              +-- interval?                 uint32
>
> # Update reference clause
>
> OLD:
>      import ietf-schedule {
>        prefix "schedule";
>        reference
>          "RFC XXXX: A Common YANG Data Model for Scheduling";
>      }
>
> NEW:
>      import ietf-schedule {
>        prefix "schedule";
>        reference
>          "RFC 9922: A Common YANG Data Model for Scheduling";
>      }
>
> # Update TLP Date of ietf-tvr-schedule s/2025/2026
>
> # Update the description of your modules to follow the IET template in
> RFC9907,
> in particular:
>
> OLD:
>         This version of this YANG module is part of RFC XXXX
>         (https://www.rfc-editor.org/info/rfcXXXX) see the RFC itself
>         for full legal notices.";
>
> NEW:
>         All revisions of IETF and IANA published modules can be found
>         at the YANG Parameters registry group
>         (https://www.iana.org/assignments/yang-parameters)
>
>         This version of this YANG module is part of RFC XXXX; see
>         the RFC itself for full legal notices.";
>
> # Extra reference clause
>
> OLD:
>      reference
>        "RFC XXXX: YANG Data Model for Scheduled Attributes";
>
>      revision 2025-06-30 {
>        description
>          "Initial Version";
>        reference
>          "RFC XXXX: YANG Data Model for Scheduled Attributes.";
>      }
>
> NEW:
>
>      revision 2025-06-30 {
>        description
>          "Initial Version";
>        reference
>          "RFC XXXX: A YANG Data Model for Scheduled Attributes.";
>      }
>
> # NMDA Again: Please delete the following:
>
> CURRENT:
>         This YANG model conforms to the Network Management
>         Datastore Architecture (NMDA) as described in RFC 8342.
>
> # The module will live outside the RFC
>
> OLD:
>   import ietf-tvr-schedule {
>     prefix "tvr-schd";
>   }
>
> NEW:
>   import ietf-tvr-schedule {
>     prefix "tvr-schd";
>     reference
>       "RFC XXXX: A YANG Data Model for Scheduled Attributes";
>   }
>
> # Redundant descriptions
>
> CURRENT:
>           type boolean;
>           default false;
>           description
>             "By default, the link is not available.";
>
>         leaf default-bandwidth {
>           type yang:gauge64;
>           units "bits/second";
>           default "0";
>           description
>             "The default interface bandwidth in bits
>
> The description for both nodes is redundant with “default” clause. Please
> consider a more meaningful description of the node, without repeating the
> default clause.
>
> # use “units” statement
>
> CURRENT:
>           description
>             "The default one-way delay in microseconds.";
>
> Please use units statant rather than having this in the description.
>
> # Explain the recommendation
>
> CURRENT:
>    recurrence.  The model defined in this document doesn't prevent a
>    configuration to mix both styles.  However, it's not recommended.
>
> I would use NOT RECOMMENDED here. Also, please consider motivate the
> recommendation.
>
> # Help identify the relevant data nodes
>
> CURRENT:
>    The TVR schedule modules are meant to work together with other models
>    that manage node or interface attributes.
>
> You list in your modules some identifiers that might be common (node-id,
> etc.).
> I would call these here for awareness.
>
> # Security Considerations
>
> Consider updating to follow the template in RFC9907, Section 3.7.1
>
> # Reference
>
> Please move the following from Normative to Informative
>
>    [RFC6241]  Enns, R., Ed., Bjorklund, M., Ed., Schoenwaelder, J., Ed.,
>               and A. Bierman, Ed., "Network Configuration Protocol
>               (NETCONF)", RFC 6241, DOI 10.17487/RFC6241, June 2011,
>               <https://www.rfc-editor.org/info/rfc6241>.
>
>    [RFC6242]  Wasserman, M., "Using the NETCONF Protocol over Secure
>               Shell (SSH)", RFC 6242, DOI 10.17487/RFC6242, June 2011,
>               <https://www.rfc-editor.org/info/rfc6242>.
>
>    [RFC8040]  Bierman, A., Bjorklund, M., and K. Watsen, "RESTCONF
>               Protocol", RFC 8040, DOI 10.17487/RFC8040, January 2017,
>               <https://www.rfc-editor.org/info/rfc8040>.
>
>    [RFC8446]  Rescorla, E., "The Transport Layer Security (TLS) Protocol
>               Version 1.3", RFC 8446, DOI 10.17487/RFC8446, August 2018,
>               <https://www.rfc-editor.org/info/rfc8446>.
>
> # Appendix “Example: Add a scheduled cost to OSPF interface”
>
> What is the purpose of this example? Please consider clarifying that in the
> text.
>
> # Please add a reference to RFC9129 in the following:
>
> CURRENT:
> By default, the OSPF interface cost is calculated
>    based on the bandwidth of the interface, and it is also configurable.
>
> Cheers,
> Med
>
>
>
>