[Tvr] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
mohamed.boucadair@orange.com Fri, 24 April 2026 06:18 UTC
Return-Path: <mohamed.boucadair@orange.com>
X-Original-To: tvr@mail2.ietf.org
Delivered-To: tvr@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 0F514E227FE4; Thu, 23 Apr 2026 23:18:16 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1777011496; bh=ufDZrVuK0ACO5XrPYIYOqxZUMo3oKW9qjrHH79ZlLmE=; h=From:To:CC:Subject:Date:References:In-Reply-To; b=mwe9+IX5+TUjlo1+uQzmmvkbqfiIWFr/hwKQl050ieG4kernMX3Ppxg3IoeGWX0in fopV3sbmTchHWzbUvt5vAlpiXzHq4G+0Kv8FmtA4zV+QSTKv5COu2FY8qBjaFqiLW1 SHL3GcfRLwjtS1tTBzkoK+iRhefb9Mm621ItqimY=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.793
X-Spam-Level:
X-Spam-Status: No, score=-2.793 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7, RCVD_IN_MSPIKE_H5=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_NONE=0.001, UNPARSEABLE_RELAY=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=orange.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id eKYVKNvgUsBJ; Thu, 23 Apr 2026 23:18:14 -0700 (PDT)
Received: from smtp-out.orange.com (smtp-out.orange.com [80.12.210.124]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 072E6E227FD7; Thu, 23 Apr 2026 23:18:13 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=orange.com; i=@orange.com; q=dns/txt; s=orange002; t=1777011494; x=1808547494; h=to:cc:subject:date:message-id:references:in-reply-to: mime-version:from; bh=ufDZrVuK0ACO5XrPYIYOqxZUMo3oKW9qjrHH79ZlLmE=; b=DCETgjXX8wX/KISvY6oGz21N0T9+uSFGiBtTR6YwmrTC/+0vTGn1d357 KMInXWPoXbjOhT83NZMF1S2d3fsQmW1BDC22/QMpNvHBdxi+/5llFc1im pT1SVuk97CaxpEQiFnJzuLVhxgiIew4nrJ0n5Qoni2ayq82MhJ9T3fUzx X77VCHu2pVGVjzeuAxNgTOdBpLMt1YcUoMsR3h4Je9tX6uyMBTPe/8utm Nb+jt9CrbQDjysLhHfUX2O37yuqFur9J/yNuiew66MBO7ka7bUL++cmdC 9VXkc6MD7oHOvUUBpFKnvOMfQqsasayhAPmQHb31vIJjIRBn91eAsrS9T w==;
X-CSE-ConnectionGUID: v62cqOMiRVigwR8J+9uJDw==
X-CSE-MsgGUID: lEg18YZAQDiEx6TQ1AN1WA==
Received: from unknown (HELO opfedv1rlp0h.nor.fr.ftgroup) ([x.x.x.x]) by smtp-out.orange.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 24 Apr 2026 08:18:12 +0200
Received: from unknown (HELO opzinddimail21.si.fr.intraorange) ([x.x.x.x]) by opfedv1rlp0h.nor.fr.ftgroup with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 24 Apr 2026 08:18:12 +0200
Received: from opzinddimail21.si.fr.intraorange (unknown [127.0.0.1]) by DDEI (Postfix) with ESMTP id 8DE9DDEA049; Fri, 24 Apr 2026 08:18:01 +0200 (CEST)
Received: from opzinddimail21.si.fr.intraorange (unknown [127.0.0.1]) by DDEI (Postfix) with ESMTP id 7E9FADE9FB8; Fri, 24 Apr 2026 08:18:01 +0200 (CEST)
Received: from smtp-out365.orange.com (unknown [x.x.x.x]) by opzinddimail21.si.fr.intraorange (Postfix) with ESMTPS; Fri, 24 Apr 2026 08:18:01 +0200 (CEST)
Received: from mail-francecentralazlp17012054.outbound.protection.outlook.com (HELO PR0P264CU014.outbound.protection.outlook.com) ([40.93.76.54]) by smtp-out365.orange.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 24 Apr 2026 08:18:01 +0200
Received: from PATP264MB6765.FRAP264.PROD.OUTLOOK.COM (2603:10a6:102:533::11) by PARP264MB6866.FRAP264.PROD.OUTLOOK.COM (2603:10a6:102:55b::21) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9818.32; Fri, 24 Apr 2026 06:18:00 +0000
Received: from PATP264MB6765.FRAP264.PROD.OUTLOOK.COM ([fe80::fcc8:341e:f80e:de16]) by PATP264MB6765.FRAP264.PROD.OUTLOOK.COM ([fe80::fcc8:341e:f80e:de16%4]) with mapi id 15.20.9846.021; Fri, 24 Apr 2026 06:18:00 +0000
From: mohamed.boucadair@orange.com
X-CSE-ConnectionGUID: qDxEzBCsQwWyC6qhI0s7JA==
X-CSE-MsgGUID: dDUBpiaYRPeAIm7S+TyzdA==
X-TM-AS-ERS: 10.106.160.159-127.9.0.1
X-TM-AS-SMTP: 1.0 c210cC1vdXQzNjUub3JhbmdlLmNvbQ== bW9oYW1lZC5ib3VjYWRhaXJAb 3JhbmdlLmNvbQ==
X-DDEI-TLS-USAGE: Used
X-CSE-ConnectionGUID: 3oonsiIFTQaYj8enEdlwIg==
X-CSE-MsgGUID: RmTzRccSRCyjF55bVSHPtw==
IronPort-Data: A9a23:SXqlfakO2YPz7+5EKrIr4Dzo5gwEJkRdPkR7XQ2eYbSJt1+Wr1Gzt xJOXm6GbPbcMGenct91PITn/UsPuJGAn9BrGlQ9qi88Ei4T+ZvOCOrCIxarNUt+DCFioGGLT Sk6QoOdRCzhZiaE/n9BCpC48z8kk/vOH+OmYAL9EngZbRd+Tys8gg5Ulec8g4p56fC0GArlV ena+6UzA3f7nWQtWo4ow/jb8k425q6r4GhwUmEWPpingnePzhH5M7pPfcldH1OgKqFIE+izQ fr0zb3R1gvx4xc3B9q5pa3we0sMT6S6FVDmZq1+AvXKbrBq/0Te445jXBYuQR4/Zwahxrid/ O5wWamYEm/FCEFudNM1CHG0GwkmVUFPFSSuzXKX6aR/xGWeG5fgLmkH4EweZeUlFuhL7W5mr vsfLisMTz6/vuuHwuK2TMRggtsCI5y+VG8fkikIITDxNcx+ecqdH473vYYEmjAtmspJAPDSI dIDbiZiZwjBZBsJPUoLDJU5n6GjgXyXnz9w9ArT9PFxvDaVkVAZPLvFaLI5fvSPQsVcm0uU4 GjB4m/wDhgbLvSY0zOD/X/qjejK9c/+cNtIS+Pmq6Mx2DV/wEQpDSEEb1CwmsOSm0yQBo9VF Xc0wjYx+P1aGEuDFYKnA0LQTGS/lg8dXdVCE+A8rgCA1qT87AOQB2xCRTlEAPQnudQ5bT0ny lHPmMnmbRRjqrSbVTec+6ua6C+sI20OJm8PaTIAQE4U6t/siIA+khyJScxseIapidvkXzXx6 yyNqjl4g7R7pdIVzeCw/VnGmSmEp5XVQEgy/Aq/dn679Ct4aZKrIYuy5jDmAe1oKY+YShyPp nECkMWV4eYSF5iJnT6JWLxSROjzv6vZdjrBnVRoAp8tsSy3/GKudpxR5zc4I1p1NsEDenniZ 0q7VR5tCIF7Z3yta7R2QqyNMs0bz/jtE/npUu/1YY8bCnRuTzNr6h2Ccma+5QjQfKUElKg+P dKVa8+qBnsRBKJ71jOyTvUZyeZ0nnlknT6PA5fm0x6gzLySImaPTqsIO0ePaeZ/676YpALS8 JBUMM7iJ/RjvA/WPXW/HW07dA5iwZ0H6Xbe9pI/mgmrflcOJY3ZI6WNqY7NgqQ890ivqgs3w p1NchQDkgag7ZE2AQCLYWpkc7ThQd50qmgjVRER0aKT8yF7O+6Htf5HH7NuJOVP3LI5kZZcE aJfE+3eWasnd9gy02hHBXULhNA4LEzz7e9PVgL5CAUCk2lIHVCXpY64IlOzrEHjzEOf7KMDn lFp7SuDKbJreuioJJ++hC6Hp79pgUUgpQ==
IronPort-HdrOrdr: A9a23:rbiFbqvYwKqPqU8QJ8CvECJq7skCgYMji2hC6mlwRA09TyXGra 2TdaUgvyMc1gx7ZJhBo7+90ci7MAvhHPtOjbX5Uo3DYOCLghrKEGgm1/qE/9SCIVyDygc+79 YFT0EWMrSZYzlHZITBkW+F+rAbsbu6GciT9JrjJhxWPHhXgs9bnmJE4lHxKDwNeOAKP+tMKL Osou584xawc3Ueacq2QlEDQuj4vtXO0LbrewQPCRIL4BSHyWrA0s+NLzGomjMlFx9fy7Yr9m bI1yT/+6WYqvm+jjvRzXXa4Zh6kMbojvFDGMuPoM4ILSiEsHfeWK1RH5m5+BwlquCm71gn1P HKvhcbJsx2r0jce2mkyCGdqDXI4XIL0TvP2FWYiXzsrYjSXzQhEfdMgopfb1/w91cglMsU6t MA40up875sST/QliX04NbFEztwkFCvnHYkmekPy1RCTIolbqNLp4B3xjIfLH45JlO31GkbKp ggMCmFj8wmP29yLkqp9lWH+ebcE0jaRXy9Mwk/Us/86UknoJk29TpZ+CUlpAZwyHsMceg62w 36CNUXqFhvdL5lUUsvPpZ1fSLwMB2FfTvcdHiVZVTrfZt3QE7wlw==
X-Talos-CUID: 9a23:/RuNpmww2ep9WFfKGgeOBgVPHccjaXz84kvpKn66WWtvZbGRVn6frfY=
X-Talos-MUID: 9a23:H/cNnAyOA9pA6sZwrj91sg4nFCiaqJ6rNFI3mp49geKVNwItZj2jtxSPXpByfw==
X-IronPort-AV: E=Sophos;i="6.21,167,1763420400"; d="scan'208,217";a="127665530"
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=cRaF1m4erwgscvhGPdOmS66W2l+DG3oyXqcmHMNWghwFLydozRM4C8Q5yG6JpDLLTFFJ+R7syzXU1iw68fNHQ+gT3+AeQQTa6r/G96RMUH04Qs8kqjHxkXWHXtrhGgnMd94YokzCfcEjU+j9IJDVd/gQjko+6F5e0lIDHECfbRAZ9HFSU6A9vgsbReluoeQutOw2dH9FyfVpakL3IbwqjXaYFni/6HuwzUnugxRnSVwgs76mMKbEBxPu/q7Co9B5Xa1WzjmOU9z8Gt4iHxRp1uzJySTs2IzwP7VDDOD0XsGlqDbAUbAUZMcwMIg2wg7nI2Risc/Ghc+eV8k2Z1SNXQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=xtoSliAGBWia8w3CUvtJmNjUx6mwZWot7n3NyOe+s1k=; b=TX0lz12NhSsIGWsVcFk/FzxYQqczUQOP8jbyyHH2ZPGb7XBgMe2GvG368mEf5Jj6rMpK9aVKY9E8o2znOBY0ySdZ0xUbe8MVAFPHkD3QnYy7tpbx10lNfCKWxTalM4hLUTHKLUEiffGDnZLCK7lseizx/Ils+37Nq1Trvai6r2Z/mnwEjs33Kp0ZzinZcfOzLW3r5/Pa2LLtTgTv23XyiT5eyAO54vSs1HiFZj19vecZALnnsn/ZwMccGPrZ5KJY5qNNCVgI/d69vcX3iXcOEcFLnvJRyR+Z/fvEXRY6gRth6O8NqyR1fCefxOc+KqFEa2J73RkxBpb8aHw+0cenRw==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=orange.com; dmarc=pass action=none header.from=orange.com; dkim=pass header.d=orange.com; arc=none
To: Yingzhen Qu <yingzhen.ietf@gmail.com>
Thread-Topic: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
Thread-Index: AQHc0T+EptWipu32w0Km6lpwZDN4U7Xtu9bQ
Date: Fri, 24 Apr 2026 06:17:59 +0000
Message-ID: <PATP264MB6765289577C0E7A309CC0792882B2@PATP264MB6765.FRAP264.PROD.OUTLOOK.COM>
References: <177556668194.1013163.7429659860508359426@dt-datatracker-9dc8fdd9f-qcdj9> <CABY-gOMPKUxuiY0RHUt77M8C2MjX11Pi0gY0Tq1J0112KQ8prg@mail.gmail.com>
In-Reply-To: <CABY-gOMPKUxuiY0RHUt77M8C2MjX11Pi0gY0Tq1J0112KQ8prg@mail.gmail.com>
Accept-Language: fr-FR, en-US
Content-Language: fr-FR
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
msip_labels: MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_ActionId=7e5c9de1-6ca8-4f67-a1b7-d0f6ae0bcc58;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_ContentBits=0;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_Enabled=true;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_Method=Privileged;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_Name=unrestricted_parent.2;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_SetDate=2026-04-24T05:58:04Z;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_SiteId=90c7a20a-f34b-40bf-bc48-b9253b6f5d20;MSIP_Label_07222825-62ea-40f3-96b5-5375c07996e2_Tag=10, 0, 1, 1;MSIP_Label_f47c794b-e3ab-43f0-9e0f-29fc3e503192_ContentBits=0;MSIP_Label_f47c794b-e3ab-43f0-9e0f-29fc3e503192_Enabled=true;MSIP_Label_f47c794b-e3ab-43f0-9e0f-29fc3e503192_Method=Standard;
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=orange.com;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PATP264MB6765:EE_|PARP264MB6866:EE_
x-ms-office365-filtering-correlation-id: e66472a9-8eb3-49a5-f253-08dea1c93bf7
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|366016|376014|8096899003|22082099003|13003099007|38070700021|18002099003|56012099003;
x-microsoft-antispam-message-info: 9DjIXMCe6x96ns9YRMSR+al5LRR8ciiGWq8eSCro3AL4eb3zRBu5tlR3T5TUt4jv3goGEEoLBd1zQzGPZXQMXlcCB2y7D1ChG0QB7M/w0cLBZry4o5SjMJjj3Im5SEYV53lq+f8KQ3lhWeuz+0Snd28X+7xoi9nW5NXRpTAFrlanOrmPw/W6VnPdIBCrBIOBN0sjMUyqFWEIhMEmMuO+si0IF37wzls77QkMflFujEwjbvD6iV1vwEvkkG3Q7Pp5HL5EKLpRsPqm70ZxAMWhcVznTQW+HBJJzDql00XfY1ELmNYNg6wO6rdH6CIdsRdw5QYXr66urJUlG6EV1mHD8xvbttSW9P7DMaPbZhfEWh71Q4EtdpUxMiyU8frfASkmc8oVLB3UWx/2pOTbE2yFaCv8dcjt3RKH9AXhtweKh7bkH+dAgoybld2WXj4+lL0IsB7uzpgdodc+zGToo7k2zjKT1Hi1fsSrpR0SaWcbcC3ZRA9UOR8iMS5u09jr7Xk+1Sek6LGsXH+CFq7eZWbSjF+mDjQPkus9TT59jUx8Qi5f48PsFehg8Hh2nB/BgBr4zhLEtry3VzUr9hf8ym2LG+FXImVHiT7+zE/Wa3Y+zVaLSVRhNbORA9HWgzkMFIaxrDDa4s9Tcfr5RXOD7KnUD+EcQammN3u15pw/VUFCNrg+flfeBZ2MfxtUZVgQiXruT8qMqsKCm9kFBzJMUSXHzMdgL7vDA0TlmP1yk5iY0Ao9bBu/m+iAV8U5Ek/48tJX
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PATP264MB6765.FRAP264.PROD.OUTLOOK.COM;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(366016)(376014)(8096899003)(22082099003)(13003099007)(38070700021)(18002099003)(56012099003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: xyOuvoCD0Sogyghu8am6COY/uIKKAxqNAW5iDQ8VW56snNiSQhb9zbG+41VeGG61YvVsrC/iNRrz7kdhQp39/m6oZ4rZ65qkQxrxb/UbTbp3ypBv9g+lmRlImWfUnUprROaiklFUHXndMPpuV7IdCuesPZqkspBKiqNiQihCu0xwy28IZ12jaT9HWgahWwtiBgEiq2Z3Uw20G8K5INa6eHSuZu2MS6cCNpC1N/7rdJ3QNaZPWuhBPnx4agDphu0iqc7+h7mH78d8y15xzZBKnWMRN0D3kZXn0Q8QVV8cevKFhZ+HrL1XCgo1Kc0y31JwlBHh+vQkYgBP1nkcjkdTo5HTj5SVfg6qivqFHVdHX0db4vy3IO/SuKdbWuKd3zXy0+0Cnk9d0d/ckAOv59cHSr9yPDMmH2biHao07BVvOYLqMGqFvR5IBIOdzfjWo/0UX/J5b7skzPNinnYt0GZXVLknamjg51Xx1dcUrItPtiIeqHLQu8pz5KesYZqW7NKe1RJCtUDwIhuFBXVOz2/Q+y9v1jWqwmME8wXTY1Psb1jR1140J4qEyudaMDJZ9fU7YWFlgv0YGVK1NMO6uQES7yp/LpbX/xZdzHqvSSspLQK3KF6sDEtcu5DbtEZ9h3nEv3ov0CBeuE+PvT5whdUU1bK65ko9uZeNdjfTVh35+rDlbF/pqOJq0U7ODDs2IdyFyurldHLaBDxtP9CUDfmYqSyyhFhPqA1r9rf7TuAqLaMLQWt8h1AhlN2zSwruSaHW6s+Ws2yFjtFj+rRn573I61ZkV/ef4oTevXOmUrRIppSCEg+VmkkZ0VxzG0kV+AEIdf7GfMQRlgHTuib59x1GcS9DUcw4HKaPTJ4BFXMoR8xBydcAExbLrSDNPYH3M9aJYJCZpPKpQty4cVE5d4zFiYymfSVUUXz5Wr/b63109MI2hU1tBm+3mR9zXnxDpcbNzYoODBIFLsbmKIsREOGr/uy1Npaaqi1sAeXQEaF6LOcfnryQU++oKk8B574x4TrT74h8e0c/7RMXMKXrtkyz2WJUatF0zufuufzyfpcBH7/cNWgVBGVnepoDvZlEc7fnkno9uMrdvKAACJANmNelGGi+wD7o+SQWTRIwXJmDYNxZ3yV2vesAN2Hm0vj9xswuRqrqsf4G2WGFzzkDxIS5pj68mq/M3k+EE+cC/Y07zLDaEik+b+0rqyMzcgq5kYyeGoJIAOvIYr3AF89zRVZX/KG5bQmi0FsQ77U2UruHEvHQ3TxVY+MTF8jxJ/wArjAk0DCzo//X0EAlgHI7K0MW7TMAdheTnqDrYHk6heCz6QGyPJXYIeEEHrp/M2g2R1bL//fc2W8F0WOlsW//uJA3qzio8nEQFgsVdFyCplyrEpExdHlqPHEMi7f+mz7CfR7LOOf/t2e9kLJ5ZkTB9dmch4DckUJVTNzrAuPUZku0faiko0TINQgDinTL0OgkRkY3pnwDNmWeZhmaI1DBloJ1VIN5mmYMRxWtmfx+AQYFVHD6kBvNi7xDEcOgpl3dE7J3MwDD6B5KECcW6al1Yn+XWyAsbhRRALs1bNIBXZmV2rteQRaasJHTW3t+eSQeWCzWS9FGtuw0gDajNy5P19E216vhy++yNNQVpeoU5tM0jc3KoRf1GGjjoFKtdiCLeI4TwGwrGknbrUeUPGbHV0o9zVWTyar8zQ/pw24y4ubKj3z/j4Uxk8negppLY+hikZBwVuglI/Own6I0LkOIFbKCJwf8lwwea2ttNLLCx5G0bj0=
Content-Type: multipart/alternative; boundary="_000_PATP264MB6765289577C0E7A309CC0792882B2PATP264MB6765FRAP_"
MIME-Version: 1.0
X-Exchange-RoutingPolicyChecked: dALUcUHHanjilhUfmVfVsGK/1vI/rneKWax4nzAUJZSl8cf0F5vP/LIsZgnutU6OOvzjAQFEZjyCtuPiAB+BfR+hihiMH9OJ4+AluiRx3nEviCidlVS6RtSfDmXXNcMMMGuPDwQO+KEQ+qsIupuokdcYoI54DufNAJCVf0DslLKaT00jOeFoQjSWKZOcc2WyaE6exzTicYpxo2c88BXrkyjm2gBejHcpyRZtJBLLPDogqYjpYWbjw02dnRiC3fYoy2aSRJ04i+b9SXE45j9ijTyD7ccu0xOgn+LCYewmyzZhPzrFr6xcpYGDwWCSaLhT1fHJImiHTNnfI/K7AsCA4g==
X-OriginatorOrg: orange.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PATP264MB6765.FRAP264.PROD.OUTLOOK.COM
X-MS-Exchange-CrossTenant-Network-Message-Id: e66472a9-8eb3-49a5-f253-08dea1c93bf7
X-MS-Exchange-CrossTenant-originalarrivaltime: 24 Apr 2026 06:17:59.9702 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 90c7a20a-f34b-40bf-bc48-b9253b6f5d20
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: /9Lfj78hVv2GvepIQA2vDw4CMkwx95pJv23FxY7m2DGeqe724LdHg7ovCzAeT5yPUfIs5yDAlW8EeiF+BGKCVZvYCFLk1/GGgp4Oc+InwsE=
X-MS-Exchange-Transport-CrossTenantHeadersStamped: PARP264MB6866
X-TM-AS-ERS: 10.106.160.159-127.9.0.1
X-TM-AS-SMTP: 1.0 c210cC1vdXQzNjUub3JhbmdlLmNvbQ== bW9oYW1lZC5ib3VjYWRhaXJAb 3JhbmdlLmNvbQ==
X-TMASE-Version: DDEI-5.1-9.1.1004-29902.005
X-TMASE-Result: 10--39.688300-10.000000
X-TMASE-MatchedRID: hFbMlnd2lLPyCZGzF+DOCcKCBCANPuMT36lQXQeyPFGPSNdj1JMyAV/8 lGqVstJX1IeckOrbKEzsTbavftkPi63HIwbjsszGjw3U5Sr2LsjY6EGR3k/uistrR4A0Ts3P5yE cDTjPPfOxAHDfblcOmUveIbrkQ/PUhyvU+W6q++tgrjeh0lt2oH2/y3jJprUQ1KDIlODIu+VdXe eZrNJbgl3w8qWNACoptfNXTrzsfrTIopq+iRbSYXN94JK30y2IEclbAMYYY6xPnKxAOPp4WbGxv DsmsUsI5wMPMqdPNSy80pLJ05MDCwQaa5Wpdq/VzlhhP4M79IgdZEkR8Y/meSH8kDR0dp2mdcfU 63y8xPByAu/UL6iDH7f8PrMZNcbjxLg1KTwRubGiEGgx8PtSIbU+IyHhkXf1Q95F2IiVUkQvldj gsR0hnLwAmz0iQUL1fAv9fPOPYKd/tlTnr5tIpflL4i9cjuYNxbAoZFyXeaEzNsXWBvGVBrBxKH mTK1j5eevydFaExT1YkE8hEisGyL9nk9YaLJ/gcM6eO8R5z1g4ZNXh8UPrIDvH5O5/sxwMhzldY l+vKikfF7U3vuk4U7dUzphAvWK/sEu/2jq52UJOVy8VDFWNASrLqyE6Ur/jgbNN0R684zPP2Lat tpg/+XkK0FnHivpUeUjslqRojmbyiqhwAyxWKFGkPFPB4CMJXTubK8QEAhnmtKQDaTOE7LXl40g TGJ5pf3B3inVRvoq0xgJ2yHF4ftMZAsUXTpOExBNI9kTkfyAIoonX8X+CmdDEMPvvoocv8/H7ae UWPQvnb/gCT7Rgr1pQEuphvAQe+GGV/qOROSEChP19SWWT9Z4CIKY/Hg3AbSvDOziLGuSvXSmSd lcYmvmS+aPr0Ve8SlnU38LCY8sSaLuaWYViyJFOlJCK/1fttEEZawRd3mVj8ogAYaRTijI8un5p huIWFvaZ9d6xO7+d3AnFdjifRNXGPiEj8Hwu
X-TMASE-SNAP-Result: 1.821001.0001-0-1-22:0,33:0,34:0-0
X-TMASE-INERTIA: 0-0;;;;
X-TMASE-XGENCLOUD: NULL-NULL-7-0-1
Message-ID-Hash: KEFDPUKX4P4Y72OZLWKJTLHPJKCEPK7A
X-Message-ID-Hash: KEFDPUKX4P4Y72OZLWKJTLHPJKCEPK7A
X-MailFrom: mohamed.boucadair@orange.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: The IESG <iesg@ietf.org>, "draft-ietf-tvr-schedule-yang@ietf.org" <draft-ietf-tvr-schedule-yang@ietf.org>, "tony.li@tony.li" <tony.li@tony.li>, "tvr-chairs@ietf.org" <tvr-chairs@ietf.org>, "tvr@ietf.org" <tvr@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Tvr] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
List-Id: Time-Variant Routing <tvr.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tvr/p0IpFwZzdx-xST1Y2KiU622_N1s>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tvr>
List-Help: <mailto:tvr-request@ietf.org?subject=help>
List-Owner: <mailto:tvr-owner@ietf.org>
List-Post: <mailto:tvr@ietf.org>
List-Subscribe: <mailto:tvr-join@ietf.org>
List-Unsubscribe: <mailto:tvr-leave@ietf.org>
Hi Yingzhen, all, Thank you for sharing these additional context. As indicated in my ballot, I think that we need the design rationale explained in the draft itself for the three parts (topo, LNE, interfaces). This covers also having a discussion on the expected interaction to prevent interference between some of these modules: for example, if a node also supports interface module, how to prevent contradicting instructions are being supplied? How to ensure that if/name is pointing to the interface to be managed, etc. Similar considerations apply for the node level as it seems that your design assumes that the control is not at the component level but system-wise, which precludes cases where several instances to be controlled are within the same node, etc. Likewise for the topology, you assume that a node belong to one and only one topology. Do you think that you can have such discussion in the spec? Cheers, Med De : Yingzhen Qu <yingzhen.ietf@gmail.com> Envoyé : mardi 21 avril 2026 05:32 À : BOUCADAIR Mohamed INNOV/NET <mohamed.boucadair@orange.com> Cc : The IESG <iesg@ietf.org>; draft-ietf-tvr-schedule-yang@ietf.org; tony.li@tony.li; tvr-chairs@ietf.org; tvr@ietf.org Objet : Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT) Hi Med and all, Thanks for the reviews and comments. The authors and the document shepherd (Tony Li) discussed the comments we received. The most important question we need to answer from the IESG DISCUSSes is why the model is not augmenting existing IETF modules, such as the network-topology module defined in RFC 8345, the interface and LNE modules. We've watched the video recordings and confirmed with the TVR-chairs about the WG consensus. Here are our answers to the IESG. The draft was adopted by the WG in Apr 2024 after IETF 119, and there were discussions during the TVR sessions at both IETF 118 and 119. Long discussions about whether to augment or be standalone at IETF 118: Minutes of TVR at IETF 118: https://datatracker.ietf.org/doc/minutes-118-tvr-202311090830/ The discussion at IETF 119 was more about some model details: https://datatracker.ietf.org/doc/minutes-119-tvr-202403200300/ The draft was adopted by the WG with standalone modules without any objections. The authors believe that we have achieved WG consensus that the modules should be standalone. If the IESG insists that augmentations should be used, then the draft needs to be sent back to the WG. The authors will be happy to address other comments after we resolve this issue. Thanks, Yingzhen (on behalf of co-authors) On Tue, Apr 7, 2026 at 5:58 AM Mohamed Boucadair via Datatracker <noreply@ietf.org<mailto:noreply@ietf.org>> wrote: Mohamed Boucadair has entered the following ballot position for draft-ietf-tvr-schedule-yang-08: Discuss When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.) Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ for more information about how to handle DISCUSS and COMMENT positions. The document, along with other ballot positions, can be found here: https://datatracker.ietf.org/doc/draft-ietf-tvr-schedule-yang/ ---------------------------------------------------------------------- DISCUSS: ---------------------------------------------------------------------- Hi Yingzhen, Acee, Eric, Don, and Marc, Thank you for the effort put into this specification. Thanks to Chongfeng Xie for the OPSDIR review and to the authors for engaging and addressing his review. Please find below some points for DISCUSSion: # Design Rationale ## ietf-tvr-schedule This module is not TVR-sepcific but a generic one similar to the one defined in RFC9922. Please update the module name and prefix to follow a patter similar to RFC9922. The description should be updated as well to reflect the generic nature of the module. ## Node module CURRENT: Module ietf-tvr-node.yang is a device model and designed to manage a single node with scheduled attributes. It is not clear to me how this is anchored in NE? What isn’t this defined as an extension to ietf-logical-network-element? Please consider adding a rationale of this design and how this is supposed to work. ## Idem vs. interface CURRENT: Each node has scheduled power at the node level. At the interface level, a node has a list of interfaces, and each interface has its own schedule for availability/power up and down, scheduled bandwidth, and scheduled neighbors. Idem why isn’t this defined as an augmentation of the interface module? How overall consistency will be ensured. # Idem for the topology CURRENT: Module ietf-tvr-topology.yang describes a network topology with a time-variant availability schedule. Why isn’t this defined as a new ietf-network type + augmentation to RFC 8345 - A YANG Data Model for Network Topologies? ## Some elaboration about the design adopted in the draft compared to the alternatives mentioned above is needed, IMO. Thanks. # Broken JSON Examples RF9907 requires the following: Examples that are meant to illustrate a valid data instance MUST be validated (Section 3.10). At least all your JSON Examples are broken: namespace issues, type mis-alignment, no quotes for duration, etc. Please fix all these (you can run yangson or yanglint to fix those). ---------------------------------------------------------------------- COMMENT: ---------------------------------------------------------------------- # Overall, consider adding a discussion how thsi spec meets the requirements of TVR Use Cases. # Title ## Consider OLD: YANG Data Model for Scheduled Attributes NEW: A YANG Data Model for Scheduled Attributes ## I wonder whether you can include TVR in the title as well. ## Please update the title in the reference clauses of your YANG modules. # Please follow the guidance in Section 2.5 of RFC9907 about data model, model, etc. ## For example, please make this change in the abstract: OLD: The YANG model NEW: The YANG data model ## Idem in the Introduction; OLD: The YANG model in this document can NEW: The YANG data model in this document can ## Please make sure this is used in a consistent manner through the document # We don’t need to motivate the use of YANG! I would delete this text: CURRENT: YANG [RFC7950] is a data definition language used to define the contents of a conceptual data store that allows networked devices to be managed using NETCONF [RFC6241]. YANG is proving relevant beyond its initial confines, as bindings to other interfaces (e.g., ReST) and encodings other than XML (e.g., JSON) are being defined. Furthermore, YANG data models can be used as the basis for implementation of other interfaces, such as CLI and programmatic APIs. If you keep it, then s/being defined/defined # (nit) Reference use cases OLD: please reference to TVR (Time-Variant Routing) Use Cases [RFC9657]. NEW: please refer to TVR (Time-Variant Routing) Use Cases [RFC9657]. # Please list the modules in the order they are defined in the document: CURRENT: Module ietf-tvr-schedule.yang contains the schedule YANG definitions. Module ietf-tvr-topology.yang defines a network topology with time- variant availability. Module ietf-tvr-node.yang is to be used to manage scheduled attributes of a single node. # NMDA: The new guidance is to highlight when we deviate from NMDA Please delete this statement: CURRENT: The YANG modules in this document conform to the Network Management Datastore Architecture (NMDA) [RFC8342]. # RFC9922 CURRENT: time" and "recurrence-utc" as defined in [I-D.ietf-netmod-schedule-yang]. Please update this reference to RFC9922. # Users: Not sure to get what is meant by users in this text. Please clarify that in the text. CURRENT: Users can supply attributes or containers that augment the schedule. # Escape clause for RFC9911 and the like CURRENT: The following RFC is not referenced in the document text but is referenced in the "ietf-tvr-schedule.yang" module and "ietf-tvr- topology.yang" module: [RFC9911]. You don’t need this text per RFC9907: If the module (or modules) defined by the specification imports definitions from other modules (except for those defined in [RFC7950] or [RFC9911]) or is always implemented in conjunction with other modules, then those facts MUST be noted in the overview section; # Please consider adding a tree with ietf-tvr-schedule grouping NEW: module: ietf-tvr-schedule grouping tvr-schedule: +-- schedule* [schedule-id] +-- schedule-id uint32 +-- (schedule-type)? +--:(period) | +-- period-description? string | +-- period-start? yang:date-and-time | +-- time-zone-identifier? sys:timezone-name | +-- (period-type)? | +--:(explicit) | | +-- period-end? yang:date-and-time | +--:(duration) | +-- duration? duration +--:(recurrence) +-- recurrence-first | +-- start-time-utc? yang:date-and-time | +-- duration? uint32 +-- (recurrence-end)? | +--:(until) | | +-- utc-until? yang:date-and-time | +--:(count) | +-- count? uint32 +-- recurrence-description? string +-- frequency? identityref +-- interval? uint32 # Update reference clause OLD: import ietf-schedule { prefix "schedule"; reference "RFC XXXX: A Common YANG Data Model for Scheduling"; } NEW: import ietf-schedule { prefix "schedule"; reference "RFC 9922: A Common YANG Data Model for Scheduling"; } # Update TLP Date of ietf-tvr-schedule s/2025/2026 # Update the description of your modules to follow the IET template in RFC9907, in particular: OLD: This version of this YANG module is part of RFC XXXX (https://www.rfc-editor.org/info/rfcXXXX) see the RFC itself for full legal notices."; NEW: All revisions of IETF and IANA published modules can be found at the YANG Parameters registry group (https://www.iana.org/assignments/yang-parameters) This version of this YANG module is part of RFC XXXX; see the RFC itself for full legal notices."; # Extra reference clause OLD: reference "RFC XXXX: YANG Data Model for Scheduled Attributes"; revision 2025-06-30 { description "Initial Version"; reference "RFC XXXX: YANG Data Model for Scheduled Attributes."; } NEW: revision 2025-06-30 { description "Initial Version"; reference "RFC XXXX: A YANG Data Model for Scheduled Attributes."; } # NMDA Again: Please delete the following: CURRENT: This YANG model conforms to the Network Management Datastore Architecture (NMDA) as described in RFC 8342. # The module will live outside the RFC OLD: import ietf-tvr-schedule { prefix "tvr-schd"; } NEW: import ietf-tvr-schedule { prefix "tvr-schd"; reference "RFC XXXX: A YANG Data Model for Scheduled Attributes"; } # Redundant descriptions CURRENT: type boolean; default false; description "By default, the link is not available."; leaf default-bandwidth { type yang:gauge64; units "bits/second"; default "0"; description "The default interface bandwidth in bits The description for both nodes is redundant with “default” clause. Please consider a more meaningful description of the node, without repeating the default clause. # use “units” statement CURRENT: description "The default one-way delay in microseconds."; Please use units statant rather than having this in the description. # Explain the recommendation CURRENT: recurrence. The model defined in this document doesn't prevent a configuration to mix both styles. However, it's not recommended. I would use NOT RECOMMENDED here. Also, please consider motivate the recommendation. # Help identify the relevant data nodes CURRENT: The TVR schedule modules are meant to work together with other models that manage node or interface attributes. You list in your modules some identifiers that might be common (node-id, etc.). I would call these here for awareness. # Security Considerations Consider updating to follow the template in RFC9907, Section 3.7.1 # Reference Please move the following from Normative to Informative [RFC6241] Enns, R., Ed., Bjorklund, M., Ed., Schoenwaelder, J., Ed., and A. Bierman, Ed., "Network Configuration Protocol (NETCONF)", RFC 6241, DOI 10.17487/RFC6241, June 2011, <https://www.rfc-editor.org/info/rfc6241>. [RFC6242] Wasserman, M., "Using the NETCONF Protocol over Secure Shell (SSH)", RFC 6242, DOI 10.17487/RFC6242, June 2011, <https://www.rfc-editor.org/info/rfc6242>. [RFC8040] Bierman, A., Bjorklund, M., and K. Watsen, "RESTCONF Protocol", RFC 8040, DOI 10.17487/RFC8040, January 2017, <https://www.rfc-editor.org/info/rfc8040>. [RFC8446] Rescorla, E., "The Transport Layer Security (TLS) Protocol Version 1.3", RFC 8446, DOI 10.17487/RFC8446, August 2018, <https://www.rfc-editor.org/info/rfc8446>. # Appendix “Example: Add a scheduled cost to OSPF interface” What is the purpose of this example? Please consider clarifying that in the text. # Please add a reference to RFC9129 in the following: CURRENT: By default, the OSPF interface cost is calculated based on the bandwidth of the interface, and it is also configurable. Cheers, Med ____________________________________________________________________________________________________________ Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci. This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation. If you have received this email in error, please notify the sender and delete this message and its attachments. As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified. Thank you.
- [Tvr] Mohamed Boucadair's Discuss on draft-ietf-t… Mohamed Boucadair via Datatracker
- [Tvr] Re: Mohamed Boucadair's Discuss on draft-ie… Yingzhen Qu
- [Tvr] Re: Mohamed Boucadair's Discuss on draft-ie… Yingzhen Qu
- [Tvr] Re: [iesg] Re: Mohamed Boucadair's Discuss … Gunter van de Velde (Nokia)
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… Mahesh Jethanandani
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… Yingzhen Qu
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… Mahesh Jethanandani
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… Acee Lindem
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… Tony Li
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… Acee Lindem
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… mohamed.boucadair
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… Acee Lindem
- [Tvr] Re: [iesg] Re: Mohamed Boucadair's Discuss … mohamed.boucadair
- [Tvr] Re: [iesg] Re: Mohamed Boucadair's Discuss … Yingzhen Qu
- [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on d… Mahesh Jethanandani
- [Tvr] Re: [iesg] Re: Mohamed Boucadair's Discuss … mohamed.boucadair
- [Tvr] Re: Mohamed Boucadair's Discuss on draft-ie… mohamed.boucadair