[Tvr] Re: [iesg] Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)

Tony Li <tony.li@tony.li> Fri, 24 April 2026 17:26 UTC

Return-Path: <tony1athome@gmail.com>
X-Original-To: tvr@mail2.ietf.org
Delivered-To: tvr@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id D0A47E289C6D for <tvr@mail2.ietf.org>; Fri, 24 Apr 2026 10:26:50 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1777051610; bh=QLS4dhrx+nYTcFHCFvAtC0s7BZdCFhCzAATzpoZ148s=; h=Subject:From:In-Reply-To:Date:Cc:References:To; b=ESHcgiiKVb7T/vPcTg22w+FDTGU4uQ+ftLBFV2TE5tVDm0Po4YyBVUFA2gHxrzQM+ Egq4MklHuHTzfI1Se1JrBFpT8Bl3//u+c710HN+Efban8tlhyZUBAYv4cUcgCS8Oyw AYphGgp/O7XbUQwyWJJYEV7v5IJc5fgAL5uaoEs8=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.997
X-Spam-Level:
X-Spam-Status: No, score=-1.997 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FORGED_FROMDOMAIN=0.001, FREEMAIL_FROM=0.001, HEADER_FROM_DIFFERENT_DOMAINS=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id nbPl-iqnrtip for <tvr@mail2.ietf.org>; Fri, 24 Apr 2026 10:26:50 -0700 (PDT)
Received: from mail-dl1-x1234.google.com (mail-dl1-x1234.google.com [IPv6:2607:f8b0:4864:20::1234]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 927FDE289AE9 for <tvr@ietf.org>; Fri, 24 Apr 2026 10:25:32 -0700 (PDT)
Received: by mail-dl1-x1234.google.com with SMTP id a92af1059eb24-12c7212836bso3880450c88.0 for <tvr@ietf.org>; Fri, 24 Apr 2026 10:25:32 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1777051526; x=1777656326; darn=ietf.org; h=to:references:message-id:content-transfer-encoding:cc:date :in-reply-to:from:subject:mime-version:sender:from:to:cc:subject :date:message-id:reply-to; bh=gKSMvwXqa6BuJoSjwQy4GZ5cJCVLRVvaXDnYiPlUvAg=; b=ZYBFPBvq9WlzCQjZbazIl3OkygXf8A3FJTKYEPjMPnf5g78xtkz2nDsFCNQYMqml1/ Vgdo5dE07owEwBbA37HIshesECeO68xrYMCy407UrxI4CxToRx7JAiuk8tSVg95UqvQp LWGO94wJAPOOrs19lqkUINCtIVZrsz/6jkHA94drRo3hTIkAc2ctJBY91yAz92geeE8K osjupV7AAGBC5hIC9M5NHB6ehJlrV6VYCu3kSA8Nume3egwyG6g8kzHArjO8Ky6GzVEG eSXvwYyHjYZvb/1wtLVDg7p60rAcR9Px9R9FHD0Qxd+ktNxUeb/Sd8zlmA7tAg7yrz94 81BA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1777051526; x=1777656326; h=to:references:message-id:content-transfer-encoding:cc:date :in-reply-to:from:subject:mime-version:sender:x-gm-gg :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to; bh=gKSMvwXqa6BuJoSjwQy4GZ5cJCVLRVvaXDnYiPlUvAg=; b=Y7tlnbOS0zCdP6G4NOXqBMMCOW5Cqu5Ca1KpTjHpw85NLzha9OeYBV6tLgUsPH7BZE N6mJgSoObIIyL34Pfo/L68s7jF/2RI9mfddKbO5Dp+MSEXegd1wbZeryRlwwK98n1ysB N1QkX8lhtluQx7mFs3/vBmxJAB+6qwIzvWYmHt30pA8oPtGeWp8rZdsqSzXxwwU5ZOcE jB3AfkzIeYbNM0Btpa8MZIXhLV25X+H1/UCcXwdaf0l1NIRVZutL0vHyM4Es6+t9+z4y hOTINXTx/Seg677DbIQbwxJl2ThZssc9fqtmqo9OT3XuxXvTZfpQDlJwSMbSmhxIvrb3 Rm7g==
X-Forwarded-Encrypted: i=1; AFNElJ8d4rEKe6BZlzfqH6R+3CvzeX79IlAW654bbwtLh2DQxi93KFOofnSHgY9UJHhFTr27O3o=@ietf.org
X-Gm-Message-State: AOJu0YydqCBVZb/OMcsGevo6+FYoQFt76acWqr+SDJXeoJPvCFb3m8YM gdAXaIHB7S5Lw+dLero/AwAW6RMx8OSXNPvrFqITvjN4jAL8qLlAXhfk
X-Gm-Gg: AeBDies6MFSTG/jy5SppYEUqg2sm7JxNmbKI5K1FcWvvvPfHaNMs0b46PLutcVo4DH5 Q1bbf8SthT4MEkRJEKpzGIyzsvXIi6oQIzzig79Ei6OFPrFNuOQilLn/TkSLZV9IRKzdMbt8uZN Vq51HK7xtB+LJIjw5pQlOhTmYbgiJAsmeZa+ck2h5zSYWpCgslNC+Xk0uP1/HPcGM7wX+LNfyiW woDnl+tbihAnsVNsT0j3w0Hl0ihz/2G4uO6187pWJaXpuRMzp4xmY1uId3iCVOxgNh/87CBElQw 6FPM4O9PWyiuf1g2PQF2+Qpe3ZUlsf0aLAsscj8bbGhjZCjJ8OsX4Dg90zdQv4uYyE3AeZJovwx Ieqhv9p0G1oQoXBU/GCca3mPk2pvxH85hq5qAs6vErKk5SsqTVPLIE2wvVCnLvq4PzbvYGJchh8 sfHEEuMqrBTqNvMBtZCy3OpGHnpNeEpoxZVbZLC3BEK+OzekbPkjoi6XIheiQgwcc/WQjOzoh8X W9u
X-Received: by 2002:a05:7300:2392:b0:2c1:6676:5ebd with SMTP id 5a478bee46e88-2e46557c7f0mr18768698eec.10.1777051526001; Fri, 24 Apr 2026 10:25:26 -0700 (PDT)
Received: from smtpclient.apple (c-73-93-167-4.hsd1.ca.comcast.net. [73.93.167.4]) by smtp.gmail.com with ESMTPSA id 5a478bee46e88-2e53ccce426sm33404265eec.16.2026.04.24.10.25.25 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Fri, 24 Apr 2026 10:25:25 -0700 (PDT)
Sender: Tony Li <tony1athome@gmail.com>
Content-Type: text/plain; charset="utf-8"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3826.700.81.1.4\))
From: Tony Li <tony.li@tony.li>
In-Reply-To: <C5AB23A0-6D45-4ACE-8561-588BA3CB1C5D@gmail.com>
Date: Fri, 24 Apr 2026 10:25:14 -0700
Content-Transfer-Encoding: quoted-printable
Message-Id: <6C45864A-B82B-4CFB-B89C-6E9CD5585880@tony.li>
References: <177556668194.1013163.7429659860508359426@dt-datatracker-9dc8fdd9f-qcdj9> <CABY-gOMPKUxuiY0RHUt77M8C2MjX11Pi0gY0Tq1J0112KQ8prg@mail.gmail.com> <AS1PR07MB8589FC36E3ABEF44C7B3315FE02A2@AS1PR07MB8589.eurprd07.prod.outlook.com> <C8E8A43E-0B91-46D8-B35D-1A156C3B0278@gmail.com> <C5AB23A0-6D45-4ACE-8561-588BA3CB1C5D@gmail.com>
To: Acee Lindem <acee.ietf@gmail.com>
X-Mailer: Apple Mail (2.3826.700.81.1.4)
Message-ID-Hash: DIRIWC54P7BXQDSY6PFCU3XOP2ZOKMN6
X-Message-ID-Hash: DIRIWC54P7BXQDSY6PFCU3XOP2ZOKMN6
X-MailFrom: tony1athome@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Mahesh Jethanandani <mjethanandani@gmail.com>, "Gunter Van De Velde (Nokia - BE/Antwerp)" <gunter.van_de_velde@nokia.com>, Yingzhen Qu <yingzhen.ietf@gmail.com>, Med Boucadair <mohamed.boucadair@orange.com>, The IESG <iesg@ietf.org>, "draft-ietf-tvr-schedule-yang@ietf.org" <draft-ietf-tvr-schedule-yang@ietf.org>, TVR WG Chairs <tvr-chairs@ietf.org>, "tvr@ietf.org" <tvr@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Tvr] Re: [iesg] Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
List-Id: Time-Variant Routing <tvr.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tvr/N3ZE_dWPP4BI_v4i0_XaXi4Gupo>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tvr>
List-Help: <mailto:tvr-request@ietf.org?subject=help>
List-Owner: <mailto:tvr-owner@ietf.org>
List-Post: <mailto:tvr@ietf.org>
List-Subscribe: <mailto:tvr-join@ietf.org>
List-Unsubscribe: <mailto:tvr-leave@ietf.org>

Hi all,

A call seems like a good idea to help make progress here.  I’d be happy to set it up.  Would the participants please unicast me with some possible times?

Thanks,
Tony


> On Apr 23, 2026, at 4:00 PM, Acee Lindem - acee.ietf at gmail.com <mailforwards@cloudmails.net> wrote:
> 
> Hi Mahesh, 
> 
> I would like to participate in the call as well. Note that the WG had considered augmenting the TE Topology model (https://datatracker.ietf.org/doc/rfc8795/) but decided against it to facilitate deployment and functional agility for TVR node and link scheduling. 
> 
> Your suggestion to augment the inventory YANG model is a bad one. I know you shepherded the inventory YANG model and are more familiar with itl,  but mixing inventory and time variant routing just doesn't make sense. 
> 
> Also, this DISCUSS is part of a more disturbing trend where ADs will make alternate technical proposals via draft DISCUSSes that have been advanced all the way to the IESG Telechat by their respective WGs. 
> 
> Thanks,
> Acee
> 
> 
> 
> 
>> On Apr 23, 2026, at 5:46 PM, Mahesh Jethanandani <mjethanandani@gmail.com> wrote:
>> 
>> Hi Yingzhe/Gunter,
>> 
>> I have explained this a couple of times, but I guess that explanation is not coming across. I will repeat it one more time here, but if that still does not make sense, it might be helpful to get on a call to explain this. Yingzhen, you know how to get hold of me.
>> 
>> See inline with [mj]
>> 
>>> On Apr 23, 2026, at 2:11 AM, Gunter van de Velde (Nokia) <gunter.van_de_velde@nokia.com> wrote:
>>> 
>>> Hi Med, Mahesh,
>>> 
>>> The draft-ietf-tvr-schedule-yang authors provided additional context and clarified the WG’s consensus on the relationship with RFC8345, including supporting data and rationale.
>>> 
>>> Does this address your RFC8345 DISCUSS on draft-ietf-tvr-schedule-yang?
>>> 
>>> If not, the alternative is to return the document to the WG for further discussion on the same topic. I would prefer to avoid that, given the prior extensive discussion and limited new input likely to change the outcome.
>>> 
>>> Brgds,
>>> G/
>>> 
>>> 
>>> 
>>> From: Yingzhen Qu <yingzhen.ietf@gmail.com>
>>> Sent: Tuesday, April 21, 2026 5:32 AM
>>> To: Mohamed Boucadair <mohamed.boucadair@orange.com>
>>> Cc: The IESG <iesg@ietf.org>; draft-ietf-tvr-schedule-yang@ietf.org <draft-ietf-tvr-schedule-yang@ietf.org>; tony.li@tony.li <tony.li@tony.li>; tvr-chairs@ietf.org <tvr-chairs@ietf.org>; tvr@ietf.org <tvr@ietf.org>
>>> Subject: [iesg] Re: Mohamed Boucadair's Discuss on draft-ietf-tvr-schedule-yang-08: (with DISCUSS and COMMENT)
>>> 
>>> CAUTION: This is an external email. Please be very careful when clicking links or opening attachments. See the URL nok.it/ext for additional information.
>>> 
>>> Hi Med and all,
>>> 
>>> Thanks for the reviews and comments.
>>> 
>>> The authors and the document shepherd (Tony Li) discussed the comments we received. The most important question we need to answer from the IESG DISCUSSes is why the model is not augmenting existing IETF modules, such as the network-topology module defined in RFC 8345, the interface and LNE modules.
>>>  We've watched the video recordings and confirmed with the TVR-chairs about the WG consensus. Here are our answers to the IESG.
>>> 
>>> The draft was adopted by the WG in Apr 2024 after IETF 119, and there were discussions during the TVR sessions at both IETF 118 and 119.  
>>> Long discussions about whether to augment or be standalone at IETF 118:
>>> Minutes of TVR at IETF 118: https://datatracker.ietf.org/doc/minutes-118-tvr-202311090830/
>>> The discussion at IETF 119 was more about some model details: https://datatracker.ietf.org/doc/minutes-119-tvr-202403200300/
>>> 
>>> The draft was adopted by the WG with standalone modules without any objections. The authors believe that we have achieved WG consensus that the modules should be standalone.
>>> 
>>> If the IESG insists that augmentations should be used, then the draft needs to be sent back to the WG.
>> 
>> 
>> [mj] Here is what I said in my response on 4/15.
>> 
>>>> However, we need to clarify one thing. When we started the work, we discussed whether to augment the network topology module defined in RFC 8345. The WG's consensus was to keep the TVR model independent for easier implementation and deployment. This also applies to the IVY model (ietf-network-inventory).
>>> 
>>> 
>>> Augmentation would have been ideal, but I can understand if there were design choices for not wanting to do it.
>>> 
>>> When we think of networks and network topology in a holistic way, there is usually one network topology, or at least there is one way to refer to all the nodes in the network. The change below is the min way to refer to a node in the network the same way, Since the module referred to RFC 8345, I gave you an example of a RFC 8345 definition of ne-id, so the two can be consistent.
>> 
>> 
>> and even suggested a simple solution:
>> 
>>>> All I am asking is that, rather than augmenting it, it should have a leafref to the node in RFC 8345. Something like
>>>> 
>>>>      leaf node-id {
>>>>        type leafref {
>>>>          path "path "/nw:networks/nw:network[nw:network-id=current()/../"+
>>>>                            "network-ref]/nw:node/nw:node-id”;
>>>>        }
>>>>        description
>>>>          "Identifier for a node; uniquely identifies a node.";
>>>>      }
>>>> 
>>>> where ‘nw’ is the prefix for ‘ietf-network’ module, so that implementations and users know we are talking about the same node-id.
>> 
>> That way, you are not augmenting the RFC 8345 model, that your model is still standalone, but you are still using the same ’node-id’ consistently across all the models.
>> 
>> Does that help explain the ask?
>> 
>> Cheers.
>> 
>>> 
>>> The authors will be happy to address other comments after we resolve this issue.
>>> 
>>> Thanks,
>>> Yingzhen (on behalf of co-authors)
>>> 
>>> 
>>> On Tue, Apr 7, 2026 at 5:58 AM Mohamed Boucadair via Datatracker <noreply@ietf.org> wrote:
>>> Mohamed Boucadair has entered the following ballot position for
>>> draft-ietf-tvr-schedule-yang-08: Discuss
>>> 
>>> When responding, please keep the subject line intact and reply to all
>>> email addresses included in the To and CC lines. (Feel free to cut this
>>> introductory paragraph, however.)
>>> 
>>> 
>>> Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/
>>> for more information about how to handle DISCUSS and COMMENT positions.
>>> 
>>> 
>>> The document, along with other ballot positions, can be found here:
>>> https://datatracker.ietf.org/doc/draft-ietf-tvr-schedule-yang/
>>> 
>>> 
>>> 
>>> ----------------------------------------------------------------------
>>> DISCUSS:
>>> ----------------------------------------------------------------------
>>> 
>>> Hi Yingzhen, Acee, Eric, Don, and Marc,
>>> 
>>> Thank you for the effort put into this specification.
>>> 
>>> Thanks to Chongfeng Xie for the OPSDIR review and to the authors for engaging
>>> and addressing his review.
>>> 
>>> Please find below some points for DISCUSSion:
>>> 
>>> # Design Rationale
>>> 
>>> ## ietf-tvr-schedule
>>> 
>>> This module is not TVR-sepcific but a generic one similar to the one defined in
>>> RFC9922. Please update the module name and prefix to follow a patter similar to
>>> RFC9922. The description should be updated as well to reflect the generic
>>> nature of the module.
>>> 
>>> ## Node module
>>> 
>>> CURRENT:
>>>   Module ietf-tvr-node.yang is a device model and designed to manage a
>>>   single node with scheduled attributes.
>>> 
>>> It is not clear to me how this is anchored in NE? What isn’t this defined as an
>>> extension to ietf-logical-network-element?
>>> 
>>> Please consider adding a rationale of this design and how this is supposed to
>>> work.
>>> 
>>> ## Idem vs. interface
>>> 
>>> CURRENT:
>>>   Each node has scheduled power at the node level.  At the interface
>>>   level, a node has a list of interfaces, and each interface has its
>>>   own schedule for availability/power up and down, scheduled bandwidth,
>>>   and scheduled neighbors.
>>> 
>>> Idem why isn’t this defined as an augmentation of the interface module? How
>>> overall consistency will be ensured.
>>> 
>>> # Idem for the topology
>>> 
>>> CURRENT:
>>>   Module ietf-tvr-topology.yang describes a network topology with a
>>>   time-variant availability schedule.
>>> 
>>> Why isn’t this defined as a new ietf-network type + augmentation to RFC 8345 -
>>> A YANG Data Model for Network Topologies?
>>> 
>>> ## Some elaboration about the design adopted in the draft compared to the
>>> alternatives mentioned above is needed, IMO. Thanks.
>>> 
>>> # Broken JSON Examples
>>> 
>>> RF9907 requires the following:
>>> 
>>>  Examples that are meant to illustrate a valid
>>>   data instance MUST be validated (Section 3.10).
>>> 
>>> At least all your JSON Examples are broken: namespace issues, type
>>> mis-alignment, no quotes for duration, etc.
>>> 
>>> Please fix all these (you can run yangson or yanglint to fix those).
>>> 
>>> 
>>> ----------------------------------------------------------------------
>>> COMMENT:
>>> ----------------------------------------------------------------------
>>> 
>>> # Overall, consider adding a discussion how thsi spec meets the requirements of
>>> TVR Use Cases.
>>> 
>>> # Title
>>> 
>>> ## Consider
>>> 
>>> OLD: YANG Data Model for Scheduled Attributes
>>> 
>>> NEW: A YANG Data Model for Scheduled Attributes
>>> 
>>> ## I wonder whether you can include TVR in the title as well.
>>> 
>>> ## Please update the title in the reference clauses of your YANG modules.
>>> 
>>> # Please follow the guidance in Section 2.5 of RFC9907 about data model, model,
>>> etc.
>>> 
>>> ## For example, please make this change in the abstract:
>>> 
>>> OLD: The YANG model
>>> 
>>> NEW: The YANG data model
>>> 
>>> ## Idem in the Introduction;
>>> 
>>> OLD:    The YANG model in this document can
>>> 
>>> NEW:    The YANG data model in this document can
>>> 
>>> ## Please make sure this is used in a consistent manner through the document
>>> 
>>> # We don’t need to motivate the use of YANG!
>>> 
>>> I would delete this text:
>>> 
>>> CURRENT:
>>>   YANG [RFC7950] is a data definition language used to define the
>>>   contents of a conceptual data store that allows networked devices to
>>>   be managed using NETCONF [RFC6241].  YANG is proving relevant beyond
>>>   its initial confines, as bindings to other interfaces (e.g., ReST)
>>>   and encodings other than XML (e.g., JSON) are being defined.
>>>   Furthermore, YANG data models can be used as the basis for
>>>   implementation of other interfaces, such as CLI and programmatic
>>>   APIs.
>>> 
>>> If you keep it, then s/being defined/defined
>>> 
>>> # (nit) Reference use cases
>>> 
>>> OLD:
>>> please reference to
>>>   TVR (Time-Variant Routing) Use Cases [RFC9657].
>>> 
>>> NEW:
>>> please refer to
>>>   TVR (Time-Variant Routing) Use Cases [RFC9657].
>>> 
>>> # Please list the modules in the order they are defined in the document:
>>> 
>>> CURRENT:
>>>   Module ietf-tvr-schedule.yang contains the schedule YANG definitions.
>>>   Module ietf-tvr-topology.yang defines a network topology with time-
>>>   variant availability.  Module ietf-tvr-node.yang is to be used to
>>>   manage scheduled attributes of a single node.
>>> 
>>> # NMDA: The new guidance is to highlight when we deviate from NMDA
>>> 
>>> Please delete this statement:
>>> 
>>> CURRENT:
>>>   The YANG modules in this document conform to the Network Management
>>>   Datastore Architecture (NMDA) [RFC8342].
>>> 
>>> # RFC9922
>>> 
>>> CURRENT:
>>>   time" and "recurrence-utc" as defined in
>>>   [I-D.ietf-netmod-schedule-yang].
>>> 
>>> Please update this reference to RFC9922.
>>> 
>>> # Users: Not sure to get what is meant by users in this text. Please clarify
>>> that in the text.
>>> 
>>> CURRENT:
>>>  Users can supply attributes or containers that augment the schedule.
>>> 
>>> # Escape clause for RFC9911 and the like
>>> 
>>> CURRENT:
>>>   The following RFC is not referenced in the document text but is
>>>   referenced in the "ietf-tvr-schedule.yang" module and "ietf-tvr-
>>>   topology.yang" module: [RFC9911].
>>> 
>>> You don’t need this text per RFC9907:
>>> 
>>>   If the module (or modules) defined by the specification imports
>>>   definitions from other modules (except for those defined in [RFC7950]
>>>   or [RFC9911]) or is always implemented in conjunction with other
>>>   modules, then those facts MUST be noted in the overview section;
>>> 
>>> # Please consider adding a tree with ietf-tvr-schedule grouping
>>> 
>>> NEW:
>>> module: ietf-tvr-schedule
>>> 
>>>  grouping tvr-schedule:
>>>    +-- schedule* [schedule-id]
>>>       +-- schedule-id                     uint32
>>>       +-- (schedule-type)?
>>>          +--:(period)
>>>          |  +-- period-description?       string
>>>          |  +-- period-start?             yang:date-and-time
>>>          |  +-- time-zone-identifier?     sys:timezone-name
>>>          |  +-- (period-type)?
>>>          |     +--:(explicit)
>>>          |     |  +-- period-end?         yang:date-and-time
>>>          |     +--:(duration)
>>>          |        +-- duration?           duration
>>>          +--:(recurrence)
>>>             +-- recurrence-first
>>>             |  +-- start-time-utc?   yang:date-and-time
>>>             |  +-- duration?         uint32
>>>             +-- (recurrence-end)?
>>>             |  +--:(until)
>>>             |  |  +-- utc-until?          yang:date-and-time
>>>             |  +--:(count)
>>>             |     +-- count?              uint32
>>>             +-- recurrence-description?   string
>>>             +-- frequency?                identityref
>>>             +-- interval?                 uint32
>>> 
>>> # Update reference clause
>>> 
>>> OLD:
>>>     import ietf-schedule {
>>>       prefix "schedule";
>>>       reference
>>>         "RFC XXXX: A Common YANG Data Model for Scheduling";
>>>     }
>>> 
>>> NEW:
>>>     import ietf-schedule {
>>>       prefix "schedule";
>>>       reference
>>>         "RFC 9922: A Common YANG Data Model for Scheduling";
>>>     }
>>> 
>>> # Update TLP Date of ietf-tvr-schedule s/2025/2026
>>> 
>>> # Update the description of your modules to follow the IET template in RFC9907,
>>> in particular:
>>> 
>>> OLD:
>>>        This version of this YANG module is part of RFC XXXX
>>>        (https://www.rfc-editor.org/info/rfcXXXX) see the RFC itself
>>>        for full legal notices.";
>>> 
>>> NEW:
>>>        All revisions of IETF and IANA published modules can be found
>>>        at the YANG Parameters registry group
>>>        (https://www.iana.org/assignments/yang-parameters)
>>> 
>>>        This version of this YANG module is part of RFC XXXX; see
>>>        the RFC itself for full legal notices.";
>>> 
>>> # Extra reference clause
>>> 
>>> OLD:
>>>     reference
>>>       "RFC XXXX: YANG Data Model for Scheduled Attributes";
>>> 
>>>     revision 2025-06-30 {
>>>       description
>>>         "Initial Version";
>>>       reference
>>>         "RFC XXXX: YANG Data Model for Scheduled Attributes.";
>>>     }
>>> 
>>> NEW:
>>> 
>>>     revision 2025-06-30 {
>>>       description
>>>         "Initial Version";
>>>       reference
>>>         "RFC XXXX: A YANG Data Model for Scheduled Attributes.";
>>>     }
>>> 
>>> # NMDA Again: Please delete the following:
>>> 
>>> CURRENT:
>>>        This YANG model conforms to the Network Management
>>>        Datastore Architecture (NMDA) as described in RFC 8342.
>>> 
>>> # The module will live outside the RFC
>>> 
>>> OLD:
>>>  import ietf-tvr-schedule {
>>>    prefix "tvr-schd";
>>>  }
>>> 
>>> NEW:
>>>  import ietf-tvr-schedule {
>>>    prefix "tvr-schd";
>>>    reference
>>>      "RFC XXXX: A YANG Data Model for Scheduled Attributes";
>>>  }
>>> 
>>> # Redundant descriptions
>>> 
>>> CURRENT:
>>>          type boolean;
>>>          default false;
>>>          description
>>>            "By default, the link is not available.";
>>> 
>>>        leaf default-bandwidth {
>>>          type yang:gauge64;
>>>          units "bits/second";
>>>          default "0";
>>>          description
>>>            "The default interface bandwidth in bits
>>> 
>>> The description for both nodes is redundant with “default” clause. Please
>>> consider a more meaningful description of the node, without repeating the
>>> default clause.
>>> 
>>> # use “units” statement
>>> 
>>> CURRENT:
>>>          description
>>>            "The default one-way delay in microseconds.";
>>> 
>>> Please use units statant rather than having this in the description.
>>> 
>>> # Explain the recommendation
>>> 
>>> CURRENT:
>>>   recurrence.  The model defined in this document doesn't prevent a
>>>   configuration to mix both styles.  However, it's not recommended.
>>> 
>>> I would use NOT RECOMMENDED here. Also, please consider motivate the
>>> recommendation.
>>> 
>>> # Help identify the relevant data nodes
>>> 
>>> CURRENT:
>>>   The TVR schedule modules are meant to work together with other models
>>>   that manage node or interface attributes.
>>> 
>>> You list in your modules some identifiers that might be common (node-id, etc.).
>>> I would call these here for awareness.
>>> 
>>> # Security Considerations
>>> 
>>> Consider updating to follow the template in RFC9907, Section 3.7.1
>>> 
>>> # Reference
>>> 
>>> Please move the following from Normative to Informative
>>> 
>>>   [RFC6241]  Enns, R., Ed., Bjorklund, M., Ed., Schoenwaelder, J., Ed.,
>>>              and A. Bierman, Ed., "Network Configuration Protocol
>>>              (NETCONF)", RFC 6241, DOI 10.17487/RFC6241, June 2011,
>>>              <https://www.rfc-editor.org/info/rfc6241>.
>>> 
>>>   [RFC6242]  Wasserman, M., "Using the NETCONF Protocol over Secure
>>>              Shell (SSH)", RFC 6242, DOI 10.17487/RFC6242, June 2011,
>>>              <https://www.rfc-editor.org/info/rfc6242>.
>>> 
>>>   [RFC8040]  Bierman, A., Bjorklund, M., and K. Watsen, "RESTCONF
>>>              Protocol", RFC 8040, DOI 10.17487/RFC8040, January 2017,
>>>              <https://www.rfc-editor.org/info/rfc8040>.
>>> 
>>>   [RFC8446]  Rescorla, E., "The Transport Layer Security (TLS) Protocol
>>>              Version 1.3", RFC 8446, DOI 10.17487/RFC8446, August 2018,
>>>              <https://www.rfc-editor.org/info/rfc8446>.
>>> 
>>> # Appendix “Example: Add a scheduled cost to OSPF interface”
>>> 
>>> What is the purpose of this example? Please consider clarifying that in the
>>> text.
>>> 
>>> # Please add a reference to RFC9129 in the following:
>>> 
>>> CURRENT:
>>> By default, the OSPF interface cost is calculated
>>>   based on the bandwidth of the interface, and it is also configurable.
>>> 
>>> Cheers,
>>> Med
>> 
>> 
>> 
>> Mahesh Jethanandani
>> mjethanandani@gmail.com
>> 
>> 
>> 
>> 
>> 
>> 
>