RE: Proposed response to OIF on OSPF ENNI

"Brungard, Deborah A, ALABS" <dbrungard@att.com> Tue, 25 July 2006 20:47 UTC

Received: from [10.91.34.44] (helo=ietf-mx.ietf.org) by megatron.ietf.org with esmtp (Exim 4.43) id 1G5To6-0005Tr-Oo for ccamp-archive@ietf.org; Tue, 25 Jul 2006 16:47:10 -0400
Received: from stsc1260-eth-s1-s1p1-vip.va.neustar.com ([156.154.16.129] helo=chiedprmail1.ietf.org) by ietf-mx.ietf.org with esmtp (Exim 4.43) id 1G5TBI-0003vs-1B for ccamp-archive@ietf.org; Tue, 25 Jul 2006 16:07:04 -0400
Received: from psg.com ([147.28.0.62]) by chiedprmail1.ietf.org with esmtp (Exim 4.43) id 1G5T89-0005Db-Ht for ccamp-archive@ietf.org; Tue, 25 Jul 2006 16:03:53 -0400
Received: from majordom by psg.com with local (Exim 4.60 (FreeBSD)) (envelope-from <owner-ccamp@ops.ietf.org>) id 1G5T39-0005Ks-K6 for ccamp-data@psg.com; Tue, 25 Jul 2006 19:58:39 +0000
X-Spam-Checker-Version: SpamAssassin 3.1.1 (2006-03-10) on psg.com
X-Spam-Level:
X-Spam-Status: No, score=-2.2 required=5.0 tests=AWL,BAYES_00 autolearn=ham version=3.1.1
Received: from [216.82.241.195] (helo=mail121.messagelabs.com) by psg.com with smtp (Exim 4.60 (FreeBSD)) (envelope-from <dbrungard@att.com>) id 1G5T38-0005JP-CM for ccamp@ops.ietf.org; Tue, 25 Jul 2006 19:58:38 +0000
X-VirusChecked: Checked
X-Env-Sender: dbrungard@att.com
X-Msg-Ref: server-10.tower-121.messagelabs.com!1153857516!13228420!1
X-StarScan-Version: 5.5.10.7; banners=-,-,-
X-Originating-IP: [134.24.146.4]
Received: (qmail 28797 invoked from network); 25 Jul 2006 19:58:36 -0000
Received: from unknown (HELO attrh3i.attrh.att.com) (134.24.146.4) by server-10.tower-121.messagelabs.com with SMTP; 25 Jul 2006 19:58:36 -0000
Received: from OCCLUST04EVS1.ugd.att.com (135.38.164.12) by attrh3i.attrh.att.com (7.2.052) id 44C39E850004F11F; Tue, 25 Jul 2006 15:58:35 -0400
X-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
Subject: RE: Proposed response to OIF on OSPF ENNI
Date: Tue, 25 Jul 2006 14:58:34 -0500
Message-ID: <449B2580D802A443A923DABF3EAB82AF0C7756E4@OCCLUST04EVS1.ugd.att.com>
In-Reply-To: <44C550D7.90104@kddilabs.jp>
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
Thread-Topic: Proposed response to OIF on OSPF ENNI
Thread-Index: AcavdNm23DacerUoR2eeOhvtB9cVwQAqe5Vw
From: "Brungard, Deborah A, ALABS" <dbrungard@att.com>
To: Tomohiro Otani <otani@kddilabs.jp>
Cc: ccamp@ops.ietf.org, Adrian Farrel <adrian@olddog.co.uk>
Sender: owner-ccamp@ops.ietf.org
Precedence: bulk
X-Spam-Score: -2.6 (--)
X-Scan-Signature: 1449ead51a2ff026dcb23465f5379250

Hi Tomo,

Much thanks for the reply. I think this modification to remove the
limitation to intra-carrier was done in version -03. It has been
difficult to follow the different versions.

(CCAMP-Chair hat off/AT&T hat on)
I also have concern with use of a link state routing protocol as an
inter-carrier interface. 

Regards,
Deborah
 

-----Original Message-----
From: Tomohiro Otani [mailto:otani@kddilabs.jp] 
Sent: Monday, July 24, 2006 7:00 PM
To: Brungard, Deborah A, ALABS
Cc: ccamp@ops.ietf.org; Adrian Farrel
Subject: Re: Proposed response to OIF on OSPF ENNI

Hi Deborah,

In terms of 3, I agree with the description.  As far as I understand,
OIF is looking at intra-domain inter-vendor specification as
their E-NNI signaling & routing.  I have not caught up with the
modification. I think it is not appropriate for us to use the link
state based protocol as an inter-carrier interface of optical networks.

Regards,

tomo





Brungard, Deborah A, ALABS wrote:
> Hi,
>  
> We had a communication from OIF on their OSPF ENNI specification. You 
> can see the original files on _http://www.olddog.co.uk/ccamp.htm_. 
> Having assembled comments from several people and our discussions in 
> Montreal, we have put together the following response.
>  
> Please comment on the list in the next week.
>  
> Thanks,
> Adrian and Deborah
>  
> 
> = = = = = = = = = =
> 
> Dear Jim,
> 
>  
> 
> We thank you for sending us the OIF ENNI document in response to our 
> request. While we appreciate the document being provided for 
> information, it is concerning that this document has not been
previously 
> shared with CCAMP or the OSPF WG considering the document contains 
> significant modifications to the operation of OSPF and reflects OIF
work 
> over the last several years. CCAMP has been working on GMPLS ASON for 
> several years and our Design Teams include OIF participants. Even
though 
> a reply was not requested, we are replying, as we strongly recommend 
> that the document not be published for public information in its
current 
> form.
> 
>  
> 
> Of most concern to CCAMP is that it is not aligned with RFC 4258 
> (Requirements for Generalized Multi-Protocol Label Switching (GMPLS) 
> Routing for the Automatically Switched Optical Network (ASON)) or the 
> to-be-published: 
>
ftp://ftp.isi.edu/internet-drafts/draft-ietf-ccamp-gmpls-ason-routing-ev
al-03.txt. 
> Considering notable OIF participants are authors of both these IETF 
> documents (and the same participants are contributors and the Editor
for 
> the OIF document), the non-alignment is perplexing. Considering the
IETF 
> document is ready for publication, we suggest in the interests of
time, 
> that you align your document with the IETF document. If any questions
on 
> the interpretation of the IETF's work, we recommend that you either 
> utilize the CCAMP mail exploder or send a communication.
> 
>  
> 
> Specific comments include:
> 
> 1.      What is the intent of this document? Will it be published as
an 
> Implementation Agreement (IA)?
> The title indicates it will be an Implementation Agreement on GMPLS
OSPF 
> extensions, but the main body of the document is a list of issues with

> GMPLS OSPF. Further, your communication to us stated the document was 
> requirements on and use of OSPF-TE at the ENNI. These three views seem

> to be inconsistent.
> 
> /2.      /The list of changes from the previous version (listed under 
> the Table of Contents) includes "/removed "intra-carrier" limitation/"

> and the inclusion of Figure 1 showing the OSPF ENNI for use between 
> vendor domains and between carrier domains. GMPLS OSPF-TE already 
> supports inter-vendor operations.
> The IETF's GMPLS ASON routing focus has been on the use of a
link-state 
> based protocol to support a hierarchical routing architecture
(G.7715.1) 
> within a carrier's domain. Requirements for using a link state
protocol 
> as an inter-domain protocol between carriers are significantly 
> different. We strongly disagree if you intend to publish this document

> as an inter-carrier OSPF ENNI Implementation Agreement claiming 
> alignment with IETF RFCs without review (or agreement) by any of the 
> IETF Working Groups.//
> 
> 3.      Section 4.1/Table 1 and the statement under the table 
> identifying issues with GMPLS identifier namespaces are not correct. 
> GMPLS identifier namespaces do meet ASON requirements for namespace 
> separation of the transport plane and control plane (Section 5.2 and 
> 5.3/Evaluation). Perhaps you are confusing OSPF and GMPLS OSPF? As you

> also identified in your liaison that the key area needing review was
the 
> support of independence of functional component to physical location, 
> this appears to be a key area of misunderstanding on GMPLS. We
recommend 
> reviewing RFC3945 (GMPLS Architecture) to understand that the key 
> architecture difference between GMPLS and MPLS is the decoupling of
the 
> transport plane and control plane. Additionally, RFC4394, RFC4397, and

> RFC4258, provide a mapping to ITU terminology which may be helpful
reading.
> 
>  
> 
> We request an additional round of communication of this document to
the 
> IETF before approval to allow us to work with you to produce
convergence 
> between OIF and IETF work which, we believe, will be in the best 
> interests of the industry.
> 
>  
> 
> Best regards,
> 
> Adrian Farrel and Deborah Brungard,
> 
> CCAMP co-chairs
>