[Mod-discuss] Re: Is there a problem? [was Keith Moore's response to WGLC (was Re: WG Last call...)]
"D. J. Bernstein" <djb@cr.yp.to> Sun, 14 September 2025 08:45 UTC
Return-Path: <djb-dsn2-1406711340.7506@cr.yp.to>
X-Original-To: mod-discuss@mail2.ietf.org
Delivered-To: mod-discuss@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id A34F4626FC53 for <mod-discuss@mail2.ietf.org>; Sun, 14 Sep 2025 01:45:17 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -4.197
X-Spam-Level:
X-Spam-Status: No, score=-4.197 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, UNPARSEABLE_RELAY=0.001] autolearn=ham autolearn_force=no
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id BGyr3oDGPI5m for <mod-discuss@mail2.ietf.org>; Sun, 14 Sep 2025 01:45:17 -0700 (PDT)
Received: from salsa.cs.uic.edu (salsa.cs.uic.edu [131.193.32.108]) by mail2.ietf.org (Postfix) with SMTP id 16132626FC4E for <mod-discuss@ietf.org>; Sun, 14 Sep 2025 01:45:17 -0700 (PDT)
Received: (qmail 1351278 invoked by uid 1010); 14 Sep 2025 08:45:16 -0000
Received: from unknown (unknown) by unknown with QMTP; 14 Sep 2025 08:45:16 -0000
Received: (qmail 420450 invoked by uid 1000); 14 Sep 2025 08:45:10 -0000
Date: Sun, 14 Sep 2025 08:45:10 -0000
Message-ID: <20250914084510.420448.qmail@cr.yp.to>
From: "D. J. Bernstein" <djb@cr.yp.to>
To: mod-discuss@ietf.org
Mail-Followup-To: mod-discuss@ietf.org
In-Reply-To: <B9249DE0-B415-4BC1-AF51-24373D99516F@episteme.net>
Message-ID-Hash: R7XE2Y5PIC5C5WKGBIOTQMZ3EG4E4WNT
X-Message-ID-Hash: R7XE2Y5PIC5C5WKGBIOTQMZ3EG4E4WNT
X-MailFrom: djb-dsn2-1406711340.7506@cr.yp.to
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-mod-discuss.ietf.org-0; header-match-mod-discuss.ietf.org-1; header-match-mod-discuss.ietf.org-2; header-match-mod-discuss.ietf.org-3; header-match-mod-discuss.ietf.org-4; header-match-mod-discuss.ietf.org-5; header-match-mod-discuss.ietf.org-6; header-match-mod-discuss.ietf.org-7; header-match-mod-discuss.ietf.org-8; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Mod-discuss] Re: Is there a problem? [was Keith Moore's response to WGLC (was Re: WG Last call...)]
List-Id: Discussion list for IETF moderation policies and practices <mod-discuss.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/mod-discuss/4offkMkcnblj93TX3qXVz9Ln97w>
List-Archive: <https://mailarchive.ietf.org/arch/browse/mod-discuss>
List-Help: <mailto:mod-discuss-request@ietf.org?subject=help>
List-Owner: <mailto:mod-discuss-owner@ietf.org>
List-Post: <mailto:mod-discuss@ietf.org>
List-Subscribe: <mailto:mod-discuss-join@ietf.org>
List-Unsubscribe: <mailto:mod-discuss-leave@ietf.org>
> To the contrary, this document gets us out of the current procedure of
> "banning" people (as per RFC 3683 and RFC 3934) and instead will encourage
> the chairs (and the IETF overall) to use far less problematic measures. With
> a very small handful of exceptions, I think even the most extreme cases can
> generally be dealt with by an "approve-before-posting" moderation
If RFC 3934 allows only all-or-nothing bans, then how do we explain the
fact that WG chairs have already been, under the purported authority of
RFC 3934, (1) locking threads and (2) applying "approve-before-posting"
censorship?
Here's a concrete example of the MODPOD chairs locking a thread:
https://web.archive.org/web/20250914052134/https://mailarchive.ietf.org/arch/msg/antitrust-policy/JV2QB6dbt5JI8DuHz0YrYt4QviY/
The rest of this message gives a concrete example of censorship by the
MODPOD chairs. This example also illustrates the ineffectiveness of time
limits and of IETF's appeal processes.
As background: The MODPOD milestones say "Nov 2025 - WGLC". The chairs
suddenly announced a limited-time WGLC in August, despite the draft
still being a moving target with unanswered objections. In the week
after WGLC was announced, I sent a few dozen messages raising further
objections to the draft and to the claimed justification for the draft.
I received email from the MODPOD chairs dated 3 Sep 2025 05:44:41 -0700
claiming that my "volume of posting" had a "disruptive effect" and
saying that they had placed an "administrative hold" on my messages.
I complained to the chairs about this. They didn't address the content
of my complaint. I then filed a complaint with the AD, cc'ing
ietf@ietf.org for transparency:
https://cr.yp.to/2025/20250904-modpod.pdf
So far the AD also has not addressed the content of my complaint. RFC
2026 authorizes appeals to IESG only when a dispute "cannot be resolved"
by the AD; it doesn't create an expedited appeals process when there's a
limited-time WGLC. (The content of my appeal on 27 August to IESG
regarding the thread lock also hasn't received a response.)
My understanding is that an "administrative hold" is classic censorship:
each message is sent to the chairs, who will eventually decide whether
to post the message or to suppress it.
When such censorship is in place, I can't try simply sending each
message I have in mind and seeing whether the censors allow it through.
If I send a message and it _does_ get through, then I'm risking that a
more important subsequent message will be deleted by the censors on the
grounds of "volume".
So I was forced to self-censor. For example, you can see that my PDF
linked above points out that the current MODPOD draft no longer has the
"WG process" constraint from the RFC 3934 text "disruptive to the WG
process"; but I couldn't take the risk of pointing this out on list
while the censorship was in place. I think it's an important point, but
the bigger picture is that it's just one of (at least) five ways that
the MODPOD draft allows censorship that RFC 3934 doesn't allow.
The "administrative hold" lasted for the rest of the announced WGLC
period (through 11 September---evidently AoE since no time zone was
announced, although I gather that the chairs have now improperly
extended the WGLC to allow late votes). I received email from the chairs
dated 12 Sep 2025 08:58:16 -0700 saying this "was only a hold, not a
block", and email dated 13 Sep 2025 14:55:42 -0700 saying they turned
off the "administrative hold".
I'm not saying that what happened here complied with RFC 3934: on the
contrary, RFC 3934 has some guardrails around its power to (temporarily)
"suspend" someone's "posting privileges", and my PDF linked above spells
out some clear violations of those guardrails in this case.
But I don't see how can argue that this power is an all-or-nothing
power: allowing _only_ bans, nothing short of bans. If it _is_ an
all-or-nothing power then it's systematically violated by any WG chairs
pushing the existing lock/censor/... buttons in IETF's mail system.
---D. J. Bernstein
- [Mod-discuss] WG Last call for draft-ietf-modpod-… Lisa Dusseault
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Pete Resnick
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Jeffrey Haas
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Joel Halpern
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Lisa Dusseault
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Russ Housley
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Jay Daley
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… John Levine
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Jay Daley
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Jay Daley
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Jay Daley
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Colin Perkins
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Stephen Farrell
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Stephen Farrell
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… D. J. Bernstein
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Wilton (rwilton)
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… D. J. Bernstein
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Wilton (rwilton)
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… D. J. Bernstein
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Eliot Lear
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Stephen Farrell
- [Mod-discuss] Terms? Re: WG Last call for draft-i… Brian E Carpenter
- [Mod-discuss] Re: Terms? Re: WG Last call for dra… Lars Eggert
- [Mod-discuss] Re: Terms? Re: WG Last call for dra… Brian E Carpenter
- [Mod-discuss] Re: Terms? Re: WG Last call for dra… Stephen Farrell
- [Mod-discuss] Re: Terms? Re: WG Last call for dra… Lars Eggert
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Salz, Rich
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Wilton (rwilton)
- [Mod-discuss] Keith Moore's response to WGLC (was… Keith Moore
- [Mod-discuss] Re: Keith Moore's response to WGLC … Rob Sayre
- [Mod-discuss] Re: Keith Moore's response to WGLC … Michael De Roover
- [Mod-discuss] Re: Keith Moore's response to WGLC … Rob Sayre
- [Mod-discuss] Re: Keith Moore's response to WGLC … Michael De Roover
- [Mod-discuss] Re: Keith Moore's response to WGLC … Rob Sayre
- [Mod-discuss] Re: Keith Moore's response to WGLC … Michael De Roover
- [Mod-discuss] Re: Keith Moore's response to WGLC … Brian E Carpenter
- [Mod-discuss] Re: Keith Moore's response to WGLC … Michael De Roover
- [Mod-discuss] Re: Keith Moore's response to WGLC … Simon Josefsson
- [Mod-discuss] Is there a problem? [was Keith Moor… Brian E Carpenter
- [Mod-discuss] Re: Is there a problem? Ted Lemon
- [Mod-discuss] Re: Is there a problem? D. J. Bernstein
- [Mod-discuss] Re: Is there a problem? Ted Lemon
- [Mod-discuss] Re: Is there a problem? Nick Hilliard
- [Mod-discuss] Re: Is there a problem? D. J. Bernstein
- [Mod-discuss] Re: Is there a problem? Ted Lemon
- [Mod-discuss] Re: Is there a problem? Lisa Dusseault
- [Mod-discuss] Re: Is there a problem? [was Keith … Simon Josefsson
- [Mod-discuss] Re: Is there a problem? [was Keith … Pete Resnick
- [Mod-discuss] Re: Is there a problem? [was Keith … D. J. Bernstein
- [Mod-discuss] Re: Is there a problem? [was Keith … Pete Resnick
- [Mod-discuss] Re: Is there a problem? [was Keith … Simon Josefsson
- [Mod-discuss] Re: Is there a problem? [was Keith … Pete Resnick
- [Mod-discuss] Re: Is there a problem? [was Keith … Simon Josefsson
- [Mod-discuss] Re: Is there a problem? [was Keith … Ted Lemon
- [Mod-discuss] Re: Is there a problem? [was Keith … Simon Josefsson
- [Mod-discuss] Re: Is there a problem? [was Keith … Pete Resnick
- [Mod-discuss] Re: Is there a problem? [was Keith … Simon Josefsson
- [Mod-discuss] Re: Is there a problem? [was Keith … Ted Lemon
- [Mod-discuss] Re: Is there a problem? [was Keith … Simon Josefsson
- [Mod-discuss] Re: Is there a problem? [was Keith … Ted Lemon
- [Mod-discuss] Re: Is there a problem? [was Keith … Eliot Lear
- [Mod-discuss] Re: Is there a problem? [was Keith … Brian E Carpenter
- [Mod-discuss] Re: Is there a problem? [was Keith … Brian E Carpenter
- [Mod-discuss] Re: Is there a problem? [was Keith … Watson Ladd
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Simon Josefsson
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … John C Klensin
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … John C Klensin
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … John C Klensin
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … John C Klensin
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Brian E Carpenter
- [Mod-discuss] Re: Keith Moore's response to WGLC … Simon Josefsson
- [Mod-discuss] Re: Keith Moore's response to WGLC … Brian E Carpenter
- [Mod-discuss] Re: Keith Moore's response to WGLC … Nick Hilliard
- [Mod-discuss] Re: Keith Moore's response to WGLC … D. J. Bernstein
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Ted Lemon
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Ted Lemon
- [Mod-discuss] RFC7282 relevant? [Re: Keith Moore'… Brian E Carpenter
- [Mod-discuss] Re: RFC7282 relevant? [Re: Keith Mo… Rob Sayre
- [Mod-discuss] Re: RFC7282 relevant? [Re: Keith Mo… Michael De Roover
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Nick Hilliard
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Keith Moore
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Rob Sayre
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Rob Sayre
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Rob Sayre
- [Mod-discuss] Re: Keith Moore's response to WGLC … Brian E Carpenter
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Nick Hilliard
- [Mod-discuss] Re: Keith Moore's response to WGLC … Lars Eggert
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Rob Sayre
- [Mod-discuss] Re: Keith Moore's response to WGLC … Pete Resnick
- [Mod-discuss] Re: Keith Moore's response to WGLC … Eliot Lear
- [Mod-discuss] Re: Keith Moore's response to WGLC … Nick Hilliard
- [Mod-discuss] Admin overriding moderator [was Kei… Brian E Carpenter
- [Mod-discuss] Re: Admin overriding moderator [was… Rob Sayre
- [Mod-discuss] Re: Admin overriding moderator [was… John C Klensin
- [Mod-discuss] Re: Admin overriding moderator [was… Rob Sayre
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Sean Turner
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Sayre
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Sayre
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Sayre
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Sayre
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Jay Daley
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Sayre
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Christopher Wood
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Sayre
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Sean Turner
- [Mod-discuss] Re: WG Last call for draft-ietf-mod… Rob Sayre