[v6ops] 6rd and draft-ietf-v6ops-6to4-to-historic

Brian E Carpenter <brian.e.carpenter@gmail.com> Wed, 27 April 2011 21:02 UTC

Return-Path: <brian.e.carpenter@gmail.com>
X-Original-To: v6ops@ietfa.amsl.com
Delivered-To: v6ops@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id DD302E07A0 for <v6ops@ietfa.amsl.com>; Wed, 27 Apr 2011 14:02:45 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -102.957
X-Spam-Level:
X-Spam-Status: No, score=-102.957 tagged_above=-999 required=5 tests=[AWL=0.042, BAYES_00=-2.599, J_CHICKENPOX_13=0.6, RCVD_IN_DNSWL_LOW=-1, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([64.170.98.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 8tV6FCqPdpuD for <v6ops@ietfa.amsl.com>; Wed, 27 Apr 2011 14:02:45 -0700 (PDT)
Received: from mail-pz0-f44.google.com (mail-pz0-f44.google.com [209.85.210.44]) by ietfa.amsl.com (Postfix) with ESMTP id 577CDE062B for <v6ops@ietf.org>; Wed, 27 Apr 2011 14:02:45 -0700 (PDT)
Received: by pzk5 with SMTP id 5so1543843pzk.31 for <v6ops@ietf.org>; Wed, 27 Apr 2011 14:02:45 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:message-id:date:from:organization:user-agent :mime-version:to:cc:subject:references:in-reply-to:content-type :content-transfer-encoding; bh=n/zMC8oZe2BEvK/a2cNEm8AccU1vCoqXzI/0q0PfnBQ=; b=uLm3WA3Gs+2CpnKjH94VaLq77Y+yK64+FhwrxjrJDUC4IVESAr9GGPEkSJXXCxOK44 guyOcpGTuH/+bW5chcfhT+ddiW2JAM0FZT+ge+zVRMR5O3CwHUPpXeVlV5UnYjH3k6WS ppuaOpI50BF518O1OPhZbfbuS2qvf6Pq9Fp5I=
DomainKey-Signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:organization:user-agent:mime-version:to:cc :subject:references:in-reply-to:content-type :content-transfer-encoding; b=LXJ6w7rlbQd/Z35oI86C5Lnd9QOo6BVzOPARxqSxCqPmy4sSTxMEnxrZVYo7tdJG8z NSFbgDfqaNk9fbN20UE00boFWLVxpTswJRTsmig9EMVQY7mX3x0j5y7hwOlVCRmdTuEV BPrUdMVo3x4wDhuzS4Db5O84v5hrldF3WFww8=
Received: by 10.68.38.131 with SMTP id g3mr2662226pbk.516.1303938163088; Wed, 27 Apr 2011 14:02:43 -0700 (PDT)
Received: from [130.216.38.124] (stf-brian.sfac.auckland.ac.nz [130.216.38.124]) by mx.google.com with ESMTPS id x4sm764788pbr.71.2011.04.27.14.02.40 (version=SSLv3 cipher=OTHER); Wed, 27 Apr 2011 14:02:42 -0700 (PDT)
Message-ID: <4DB8846B.4010004@gmail.com>
Date: Thu, 28 Apr 2011 09:02:35 +1200
From: Brian E Carpenter <brian.e.carpenter@gmail.com>
Organization: University of Auckland
User-Agent: Thunderbird 2.0.0.6 (Windows/20070728)
MIME-Version: 1.0
To: Ole Troan <otroan@employees.org>
References: <mailman.26.1303844404.3511.v6ops@ietf.org> <4DB723C7.1090905@globis.net> <BANLkTi=w2FYksAu6fnTScAsR3EqCbPmPdA@mail.gmail.com> <4DB7BC9F.9000604@globis.net> <124BB081-7D4C-4C73-94F0-8E5C67A5B737@employees.org> <4DB86A2F.2040201@globis.net> <CD3C01C7-FBCE-4150-9522-A5529B1408FB@employees.org>
In-Reply-To: <CD3C01C7-FBCE-4150-9522-A5529B1408FB@employees.org>
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: 7bit
Cc: Ray Hunter <v6ops@globis.net>, v6ops@ietf.org
Subject: [v6ops] 6rd and draft-ietf-v6ops-6to4-to-historic
X-BeenThere: v6ops@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: v6ops discussion list <v6ops.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/v6ops>, <mailto:v6ops-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/v6ops>
List-Post: <mailto:v6ops@ietf.org>
List-Help: <mailto:v6ops-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/v6ops>, <mailto:v6ops-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 27 Apr 2011 21:02:46 -0000

On 2011-04-28 07:27, Ole Troan wrote:
> Ray,
> 
>> I obviously defer to you as the co-author of RFC5969.
>>
>> Would it be possible to include some text in your proposal to clarify and encapsulate this view?
>>
>>  e.g.
>>
>> "Historic Links between 6rd and 6to4
>>
>> Although 6rd has significant historic links with 6to4 (especially because 6to4 invented the underlying method of creating an IPv6 prefix based on an IPv4 address), 6rd was defined and improved in such ways that it does not share the same shortcomings for which the 6to4 transition mechanism is being moved to historic status. Furthermore, the definition of 6rd in RFC5969 is sufficiently decoupled from RFC3056 and RFC3068 that 6rd may be considered as a stand alone protocol in and of itself, independent of 6to4."
> 
> revision 01 now has the following:
> http://tools.ietf.org/html/draft-ietf-v6ops-6to4-to-historic-01
> 
>    6rd [RFC5969] utilizes the same encapsulation and base mechanism as
>    6to4, and could be viewed as a superset of 6to4 (6to4 could be
>    achieved by setting the 6rd prefix to 2002::/16).  However, the
>    deployment model is such that 6rd can avoid the problems described
>    here.  In this sense, 6rd can be viewed as superseding 6to4 as
>    described in section 4.2.4 of [RFC2026]
> 
> is that better?

Works for me. Also, there is no formal problem with RFC 5969 citing RFC 3056
even if the latter is made Historic. (It would be a wordsmithing problem if
RFC 5969 was to be updated.)

BTW, Section 5 of draft-ietf-v6ops-6to4-advisory also mentions this
topic briefly.

   Brian


> 
> cheers,
> Ole
> 
> _______________________________________________
> v6ops mailing list
> v6ops@ietf.org
> https://www.ietf.org/mailman/listinfo/v6ops
>